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Safety Information
NOTICE Read these instructions carefully, and look at the equipment to become familiar with 
the device before trying to install, operate, or maintain it. The following special 
messages may appear throughout this documentation or on the equipment to warn 
of potential hazards or to call attention to information that clarifies or simplifies a 
procedure.

The addition of this symbol to a Danger or Warning safety label indicates
that an electrical hazard exists, which will result in personal injury if the
instructions are not followed.

This is the safety alert symbol. It is used to alert you to potential personal
injury hazards. Obey all safety messages that follow this symbol to avoid
possible injury or death.

DANGER indicates an imminently hazardous situation, which, if not avoided, will 
result in death or serious injury.

DANGER

WARNING indicates a potentially hazardous situation, which, if not avoided, can result 
in death, serious injury, or equipment damage.

WARNING

CAUTION indicates a potentially hazardous situation, which, if not avoided, can result 
in injury or equipment damage.

CAUTION
31003882 12/2006 9



Safety Information
PLEASE NOTE Electrical equipment should be installed, operated, serviced, and maintained only by 
qualified personnel. No responsibility is assumed by Schneider Electric for any 
consequences arising out of the use of this material.

© 2006 Schneider Electric. All Rights Reserved.
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About the Book
At a Glance

Document Scope This manual describes how to install, configure, and use ProWORX 32 and all of its 
components.

To find out about any changes to the manual after this version was published, 
consult our web site at www.telemecanique.com.

Terms and Abbreviations

Numbers are written according to international practice as well as The International 
System of Units (SI); each thousand is separated by a space, along with the use of 
the decimal point, e.g., 12 345.67

Validity Note The data and illustrations found in this book are not binding. We reserve the right to 
modify our products in line with our policy of continuous product development. The 
information in this document is subject to change without notice and should not be 
construed as a commitment by Schneider Electric.

This document applies to the installation and use of ProWORX 32 client in the 
following environments.

Windows 98SE
Windows NT (V4.0, SP6a or higher)
Windows 2000 (SP3 or higher)
Windows XP Professional (not Home), SP1 & 2

This document applies to the installation and use of ProWORX 32 Server in the 
following environments.

Windows NT (V4.0, SP6a or higher)
Windows 2000 (SP3 or higher)
Windows XP Professional (not Home), SP1 & 2
31003882 12/2006 11



About the Book
Related 
Documents

Product Related 
Warnings

Schneider Electric assumes no responsibility for any errors that may appear in this 
document. If you have any suggestions for improvements or amendments or have 
found errors in this publication, please notify us.

No part of this document may be reproduced in any form or by any means, electronic 
or mechanical, including photocopying, without express written permission of 
Schneider Electric. All rights reserved.

All pertinent state, regional, and local safety regulations must be observed when 
installing and using this product. For reasons of safety and to ensure compliance 
with documented system data, only the manufacturer should perform repairs to 
components.

When controllers are used for applications with technical safety requirements, 
please follow the relevant instructions.

Failure to use Schneider Electric software or approved software with our hardware 
products may result in improper operating results.

Failure to observe this product related warning can result in injury or equipment 
damage.

User Comments We welcome your comments about this document. You can reach us by e-mail at 
techpub@schneider-electric.com

Title of Documentation Reference 
Number

Ladder Logic Block Library 840 USE 101

Modbus Plus PCI-85 Interface Adapter 890 USE 162

Modicon Quantum Hot Standby System Planning and Installation Guide 840 USE 106

Modicon Quantum Automation Series Hardware Reference Guide 840 USE 100

Modicon Momentum I/O Base User Guide 870 USE 002

A120 Series I/O Modules User Guide 890 USE 109

BM85 Bridge Multiplexer User’s Guide 890 USE 103
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Getting Started
Welcome to ProWORX 32

Overview This manual is a guide for operating ProWORX 32. It does not contain information 
about specific controllers, I/O cards, or ladder logic instructions. For further 
hardware and ladder logic information, go to the ProWORX 32 online help system.

What's in this 
Chapter?

This chapter contains the following topics:

Topic Page

System Requirements 14

Installing ProWORX 32 15

Logging in to ProWORX 32 16

Authorizing ProWORX 32 20

ProWORX 32 Client Security 22

Contacting Schneider Electric 24
13



Getting Started
System Requirements

Hardware 
Requirements

 

Software 
Requirements

 

Language 
Availabilty

The ProWORX 32 Software only supports English, French, German, and Spanish.

Hardware Client Requirement Server Requirement Client/Server 
Requirement

Processor 650 MHz (Pentium III) 1 GHz (Pentium III) 1.8 GHz (Pentium 4)

Memory 256 MB 512 MB 512 MB

Hard Disk Space 
(Available)*

200 MB

Installation Media 
Type

CD

Display 256 color VGA or 
higher

Note: To Print Preview a project with 5000 networks, 1GB of available hard disk 
space is required.

Software Requirement

ProWORX 32 Client - 
Operating Systems

Windows 98
Windows NT (V4.0, SP6a or higher)
Windows 2000 (SP3 or higher)
Windows XP Professional (not Home), SP1 & 2

ProWORX 32 Server - 
Operating Systems

Windows NT (V4.0, SP6a or higher)
Windows 2000 (SP3 or higher)
Windows XP Professional (not Home), SP1 & 2

Microsoft Internet Explorer Version 5.0 or higher

Microsoft MDac Version 2.5 or higher
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Getting Started
Installing ProWORX 32

Installing 
ProWORX 32

ProWORX 32 requires the installation of MDAC version 2.5 or later and Internet 
Explorer 5.0 or later. Install the MDAC software from the ProWORX 32 installation 
CD, and ensure that you have a compatible version of Internet Explorer prior to 
installing ProWORX 32. Then, to install ProWORX 32:

Modifying or 
Repairing the 
ProWORX 32 
Installation

If you have already installed ProWORX 32:

Uninstalling 
(Removing) 
ProWORX 32

If you have already installed ProWORX 32:

Step Action

1 Insert the ProWORX 32 CD into your CD-ROM drive.

2 In Windows Explorer, open the installation from the CD-ROM drive at 
ProWORX_32 → disk1 → setup.exe.

3 Select the language of ProWORX 32 you want to install (English, French, 
German, Spanish).

4 Follow the on-screen instructions to complete the installation of ProWORX 32.

Step Action

1 Insert the ProWORX 32 CD into your CD-ROM drive.

2 Click Modify to add new components or remove already installed components.

3 Click Next, and follow the on-screen instructions.

4 Click Repair to reinstall all components installed by the previous setup.

5 Click Next, and follow the on-screen instructions.

Step Action

1 Insert the ProWORX 32 CD into your CD-ROM drive.

2 Click Remove to uninstall all installed components.

3 Click Next, and follow the on-screen instructions.
31003882 12/2006 15



Getting Started
Logging in to ProWORX 32

The ProWORX 32 
Login Screen

When you open ProWORX 32, the login dialog box appears. If you are using 
projects that reside on a server or you want to communicate through the server, 
enter the login information and click Login. If you are using projects that reside on 
the client, click Bypass.

Logging in to 
Windows as a 
Non-
Administrator

If you try to log in to Windows locally with a non-administrative account, using 
Windows NT, Windows 2000, or Windows XP, a Runtime Error 70 Permission 
Denied appears on the screen.

To log in to Windows as a non-administrator, follow the steps below.

Note: If you consistently use projects that reside on the client, you can clear the 
Display dialog on startup check box in the login dialog box, so that it does not 
appear every time you open ProWORX 32.

Note: ProWORX 32 servers, version 1.x and 2.x, are not compatible. Both the 
client and server must be at the same major revision for the client to log in to the 
server.

Note: The Bypass button is changed to the Close button when the Enforce Client 
Login checkbox is checked in the Environment Properties display. 

Step Action

1 Log in to Windows as an administrator.
Note: Make sure you have a user or group defined with power user privileges.

2 Open Windows Explorer.

3 Right-click the ProWORX → 32 folder.

4 Click Properties.

5 Click the Security tab.
Note: In Windows XP, if you do not see the Security tab, follow the instructions 
below to enable Security features.

Click Start → Settings → Control Panel.
Double-click Folder Options.
Click the View tab.
Clear the Use simple file sharing (Recommended) checkbox.
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Getting Started
 

Logging in to the 
Server with 
TCP/IP

To log in to the server with TCP/IP:

6 In the Group or user names field, click the group or user to whom you want to 
grant power user permission.

Note: If you want to create a new group or user, click Add. Type the name of the 
group or user and click OK. Then, continue with Step 6 above.

Step Action

7 Select all permission check boxes in the Allow column (except Full Control).

8 Click Advanced.
For Windows 2000, select the Reset permissions... check box.
For Windows XP, select the Replace permissions... check box.

9 Click OK. Click Yes in the warning dialog box.

10 Click OK.

11 Log off Windows as an administrator. You can now log in to Windows as a non-
administrator.

Step Action

Note: If your computer is configured for a ProWORX Server connection, you must 
set the server communications type (see p. 284) for TCP/IP before you log in.

Step Action

1 From the ProWORX 32 menu, click Server → Login, or click the Login toolbar 
icon.

2 Enter the user name and password that your system administrator has given you 
in the Name and Password fields.

3 Click the TCP/IP button.

4 Click either the Server Address button or the Server Name button.

5 If you click the Server Address button, select or type the appropriate Ethernet 
address from the address field list, which shows the 10 most recently used 
Ethernet addresses.

6 If you click the Server Name button, select a server name from the list of the 10 
most recently used server names, or enter the host name of the computer on 
which ProWORX Server is installed.
31003882 12/2006 17



Getting Started
Logging in to the 
Server with 
Modbus Plus

To log in to the server with Modbus Plus:

7 Click Browse to search for a specific computer host name. A dialog box opens, 
which displays a list of domains currently accessible from the user’s computer. 
Double click on a domain name to view the computers within that domain.

8 Click Rescan to reexamine the network for domains. Click a computer name and 
click Select, or double click the computer name to enter the name into the 
Server Name text field.
Note: If you click Cancel Scan, the scan stops, and it may take several minutes.

9 Enter the server communications timeout (seconds) in the Timeout field.

10 Enter the port number in the Port Number field. The port number entered must 
match the port number on which the ProWORX 32 Server is listening.

11 Click Login.

Step Action

Note: If your computer is configured for a ProWORX Server connection, you must 
set the server communications type (see p. 284) for Modbus Plus before you log in.

Step Action

1 From the ProWORX 32 menu, click Server → Login, or click the Login toolbar 
icon.

2 Enter the user name and password that your system administrator has given you 
in the Name and Password fields.

3 Click the Modbus Plus button.

4 Click the Server Address button. Select a server address from the list of 10 most 
recently used server addresses. Or, type the Modbus Plus address of the server.

5 Enter the server communications timeout (seconds) in the Timeout field.

6 Enter the Modbus Plus adapter number in the Adapter Number field.

7 Click Login.

Note: If the client and server are installed on the same computer, a second 
Modbus Plus adapter card is required for the client to connect to the server.
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Getting Started
Logging out of 
the ProWORX 32 
Server

Closing the ProWORX 32 client automatically logs you out of the server. To log out 
of the server, while remaining in ProWORX 32:

Step Action

1 From the ProWORX 32 menu, click Server → Logout, or click the Logout 
toolbar icon.
31003882 12/2006 19



Getting Started
Authorizing ProWORX 32

Opening the 
Authorization 
Program

Click Start → Programs → ProWORX 32 → Authorization.

Using the 
Authorization 
Wizard

 

Step Action

1 The authorization wizard welcome screen appears. Click Next.

2 Click the Client or Server button to authorize.

3 Click one of the following buttons, and click Next.
Authorize this PC: Sets up the PC you are currently using to run ProWORX 
32.
Transfer Authorization: Transfers authorization (see p. 21) from one PC to 
another.
Enter received code: If already registered, you are taken directly to the 
Enter Received Code (see p. 21) screen.

4 If you selected Authorize this PC, click one of the following methods to 
authorize ProWORX 32, and click Next.

By Phone: A message box is displayed containing a customer support phone 
number and the customer support hours of operation. Click OK to return to 
the authorization application.
By Fax: A fax page is printed containing the information you have entered 
and a phone number to which to send the fax.
By Multi-User License Diskette: This option is used strictly for 
uncopyprotected versions in which a diskette has been provided by 
Schneider Electric. The contents of the diskette will be transferred onto your 
machine.
By Email: An email is sent to customer support containing the information 
you have entered.
By Web: You will be directed to a web page at the Schneider Electric web 
site where the information that you have entered will be displayed and an 
authorization number will be generated for you.

5 Click one of the following buttons to authorize, and click Next.
Online Only Client: Access to online only portions of ProWORX 32.
Lite Client: Access to Momentum, Compact, and Micro controllers only.
Full Development Client: Full access to all features of ProWORX 32.

6 Enter your personal information in the User Information screen, and click Next. 
If you would like to view our privacy policy, click Privacy Policy.
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Getting Started
Transferring 
Authorization

If you selected Transfer Authorization in Step 3 in the table above, follow the steps 
below.

Entering the 
Authorization 
Code

Follow the steps below to enter your authorization number.

Step Action

1 Insert a diskette into your PC diskette drive, or select any medium (network drive, 
USB, etc.) to which you want to move authorization from another PC.

2 Click one of the following buttons, and click Next.
Transfer authorization from computer to diskette/medium.
Transfer authorization from diskette/medium to computer.

Step Action

1 A Code Entry Number and a Computer ID are created automatically.

2 Enter the authorization number provided to you by customer support in the 
Received Authorization Code field, and click Next.

3 To complete your ProWORX 32 authorization, click Finish.
31003882 12/2006 21



Getting Started
ProWORX 32 Client Security

Overview Security allows an administrator to disable features of ProWORX 32.

Setting Security 
for a Client

 

Step Action

1 Right-click Workspace in the project navigation panel, and click Security 
Settings.
- or -
Click File → Security Settings.

2 To set and confirm the administrative password, enter the password into the 
Password and Confirm Password fields.

3 To set the rights that users have (see p. 23) while running ProWORX 32 on this 
specific PC, select rights from the Enabled Functionality group of rights.

4 Click OK to confirm changes. Click Close to exit.
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Getting Started
User Rights User rights descriptions:

User Right Description

Controller Configuration The ability to change the controller configuration or change 
controller type.

Traffic Cop The ability to edit in the traffic cop.

Communications The ability to change the communications setup, including the 
controller’s address.

Logic The ability to edit logic.

Forcing The ability to force contacts and coils on or off. This feature is 
allowed without online editing enabled.

Insert The ability to insert cells, rows, columns, and networks.

Delete The ability to delete cells, rows, columns, and networks.

Sweep The ability to enter sweep mode.

Data Editors The ability to enter any of the data editors. If deselected, the 
user is unable to change register data.

Extended Memory The ability to edit 6x extended memory registers.

Protected Registers The ability to set ranges of 4xxxx addresses that are 
uneditable. See p. 68 for more information.

Configuration Extensions The ability to edit the configuration extensions.

ASCII Messages The ability to edit the ASCII messages.

Search The ability to use the search feature.

Read The ability to read from the controller.

Write The ability to write to the controller.

Start/Stop The ability to start or stop the controller.

Clear Audit Trails The ability to remove all audit trail and logbook entries.
31003882 12/2006 23



Getting Started
Contacting Schneider Electric

Customer 
Support

Customer support is available to registered Schneider Electric users.

If you have a question about ProWORX 32 and can't find the answer in the 
ProWORX 32 help system or the user guide, contact customer support.

Please find the nearest Schneider Electric sales office by visiting http://
www.schneider-electric.com. In the Select a country list, click the country closest 
to you for customer support. 

Customer 
Support 
Guidelines

To help us assist you quickly, please have the following information ready.

The version and serial number of your copy of ProWORX 32. To find this 
information, click Help → About.
What you were doing when the problem occurred, whether you can repeat it, and 
any error messages you received.
Your version of Windows. To find this information in Windows 98, Windows NT 
4.x, Windows 2000 Professional (not Home), or Windows XP Professional (not 
Home), click Start → Settings. Select Control Panel and double-click System. 
Select the General tab. Your version of Windows is listed under the System 
heading.
Information about your computer, including its processor type, memory, hard 
drive size, video card type, and I/O boards.

Select a country

Schneider Electric in your
country:

Select a country
Argentina
Australia
Austria
Belgium
Brazil
Bulgaria
Canada
Chile
China
Colombia
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Working with ProWORX 32
At a Glance

Overview This chapter explains the ProWORX 32 environment, including setting the 
ProWORX 32 environment and using the toolbar. This chapter also discusses the 
features of the My Projects, My Computer, Utilities, Plant, and Documents tabs.

What's in this 
Chapter?

This chapter contains the following topics:

Topic Page

ProWORX 32 Environment 26

ProWORX 32 Toolbar 29

Navigating in ProWORX 32 34

Tracking Help 39

Message Central 40
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Working with ProWORX 32
ProWORX 32 Environment

Setting 
ProWORX 32 
Environment 
Properties

The following table describes the different options that you can set in the 
Environment properties. 

Step Action

1 Click View → Properties.
- or -
Right-click Workspace or a project name in the project navigation panel, and click 
Properties.

2 Click the Environment tab. Set the following ProWORX 32 Environment parameters.

3 Auto Monitor/Logout: When you select the Auto Monitor/Logout check box, the Online 
Network Editor closes after the specified amount of inactivity, and the user mode changes 
from program to monitor. You will see the message Auto Device Logout has taken all 
projects offline in the Message Central window.

4 Instruction Toolbar: See p. 30) for detailed information on modifying the toolbar.

5 Under Online, select one or more of the following check boxes.
Prompt for Read when Exiting Online: Displays a prompt to perform a read after switching 
out of online mode.
Compare to Project on Attach: Displays a prompt to perform a compare when switching 
to online mode.
Automatically Update Used Tables Online: When going online, the used address tables 
are automatically updated. This feature requires additional time to go online.
Verify Device: When you switch between online and offline/combined, this option prompts 
you to toggle the memory protect switch to verify that you are connected to the intended 
device.

6 Under Environment, select one or more of the following check boxes.
Enable Audit Trails: See p. 293) and the log book are viewable.
Enable Scrolling Navigation Panel: The navigation panel shrinks, enabling the horizontal 
scroll bar.
Save Project Mode on Exit: Saves the project mode, offline or online, when you exit. The 
next time the project is opened, it will attempt to enter the mode that was saved. If the project 
was online when you exited, it will attempt to connect to the PLC the next time the project is 
opened.
Enable Client-Server Integration on Same Machine: The next time ProWORX 32 starts, 
the server installed on this machine also starts. This process allows other clients continued 
access to the server after the ProWORX 32 client closes.
Start in Monitor Mode: Starts ProWORX 32 in monitor mode. You must switch to program 
mode to make changes to a project.
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Note: The difference between monitor mode and program mode:
In monitor mode, the controller program is read only. The Monitor display box 
in the status bar at the bottom of the screen is yellow.
In program mode, the control program allows you read/write privileges. The 
Program display box in the status bar at the bottom of the screen is gray.
To switch between modes, choose one of the following:

Toggle the display box in the status bar at the bottom of the screen.
Click Edit → Program Mode. When checked, program mode is active. When 
unchecked, monitor mode is active.
Press Alt+P.

Step Action

7 Under Server Security, select one or more of the following check boxes.
Auto Deletion of Project after Put to Server: This feature when checked 
ensures that the ProWORX 32 Client software deletes a project, not only from 
the workspace, but also from the projects directory. The default setting is 
unchecked which causes the project if open in the workspace to be closed and 
removed from the workspace but maintained in the projects directory
Enforce Client Login: When this checkbox is checked, the Bypase button 
changes to the Close button in the Environment properties display.
The Server Security properties are only enabled when the user is logged into the 
Server via the Administrator server login.

Note: The 'Warning: The selected option closes and deletes the project after it has 
been Put to the server.' dialog is displayed to warn the user that projects ‘Put’ onto 
the Server will be deleted. This message is displayed only once after the ‘Auto 
Deletion of Project after Put to Server’ checkbox is initially checked in the 
Environment Properties window.
Also, a warning message dialog box: 'If project changes are not saved, changes 
will be lost and cannot be recovered, Continue with Put without saving? OK/Cancel 
is displayed when putting a project to the Server and the project has changed and 
hasn't been saved in the Client, ProWORX 32 asks the user to save the changes 
before the Put. If the user replies ‘Yes’ the ‘Put’ is done and the project is deleted 
from the Workspace and the Client projects directory, if ‘No’ is selected the 
following warning is provided: Pressing ‘OK’ puts the project, without changes, on 
the Server and then deletes the project from both the Workspace and the Client 
projects directory. Pressing ‘Cancel’ cancels the ‘Put’ operation.
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Step Action

8 Under Message Central, select one or more of the following check boxes.
Auto Display Message Central: Automatically displays Message Central when 
a message is generated by ProWORX 32.
Auto Switch to Tabs in Message Central: If the Tracking tab is active, 
ProWORX 32 will switch tabs to Message Central when a new message 
appears.
Alert User of Critical Messages: Displays critical messages in Message 
Central and a message dialog box.
Alert User of Non-Critical Messages: Displays non-critical messages in 
Message Central and a message dialog box.

Note: The Message Central and Tracking Help windows default to remaining open. 
If you want the windows to be closed continuously:
Clear these 2 check boxes:

Auto Display Message Central
Auto Switch to Tabs in Message Central

Select these 2 check boxes:
Alert User of Critical Messages
Alert User of Non-Critical Messages

Step Action

9 Under Traffic Cop, select one or more of the following check boxes.
Prompt when Inserting Drops: Displays a prompt when the user inserts a drop.
Prompt when Deleting Drops: Displays a prompt when the user deletes a drop.
Prompt when Inserting Racks: Displays a prompt when the user inserts a rack.
Prompt when Deleting Racks: Displays a prompt when the user deletes a rack.
Prompt when Inserting Slots: Displays a prompt when the user inserts a slot.
Prompt when Deleting Slots: Displays a prompt when the user deletes a slot.
Paste Duplicate Traffic Cop Warning: Displays a prompt when the user pastes 
a duplicate traffic cop.
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ProWORX 32 Toolbar

Overview The ProWORX 32 toolbar contains all the icons that can be used to access features, 
utilities, and tools. 

Using the 
Toolbar

 

Customizing the 
Toolbar

 

ProWORX 32 ToolbarHandle

Step Action

1 Click  View → Toolbars, or right-click any toolbar.

2 To add a toolbar, select a toolbar from the list. A toolbar that is displayed is 

denoted by a check .

3 To remove a toolbar, select the checked toolbar from the list.

4 To move a selected toolbar within the ProWORX 32 toolbar area, select the 
toolbar handle, and drag and drop the toolbar to its desired location.

Step Action

1 Right-click any toolbar. Click Customize.

2 Click the Toolbars tab to add and/or remove toolbars.
To add a toolbar, select any of the toolbar check boxes.
To remove a toolbar, clear any of the toolbar check boxes.
To create a toolbar, click New. Type the new name of the toolbar, and click 
OK.

3 Click the Commands tab to add and/or remove icons to/from a toolbar.
Click a menu item in the Categories field.
To add an icon, click the icon in the Commands field, and drag and drop the 
icon to its desired location on the toolbar.
To remove an icon, click the icon on the toolbar, and drag and drop it 
anywhere inside the Customize dialog box.
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Customizing the 
Instruction 
Toolbar

 

4 Click the Options tab to personalize your menus and toolbars. Select or clear 
any of the following check boxes, depending on your preferences.

Menu show recently used tools first (defaults to checked)
Show full menus after a short delay

Large Icons
Show ScreenTips on Toolbars (defaults to checked)

Show shortcut Keys in ScreenTips
Menu animation
Choose one of the following animation styles:

(None)
Random
Unfold
Slide

5 Click Keyboard to assign keyboard shortcut keys to respective toolbar icons.

6 Click Close to confirm all changes.

Note: There is no warning if the key that you wish to assign as a shortcut key is 
already in use. The old shortcut key will be replaced. For more information on 
customizing toolbars, click Start → Help to view the Windows help file.

Step Action

Step Action

1 Right-click a project or Workspace, and click Properties.
- or -
Click View → Properties.

2 Click the Environment tab.

3 Scroll to the number of the button (1-14) you would like to change in the Button 
Number field (1 = the leftmost button, 14 = the rightmost button).

4 Enter the name of the instruction to be placed on the toolbar in the Button Text 
field.

5 Click OK.
30 31003882 12/2006



Working with ProWORX 32
Toolbar Listing Default toolbars and icon.

Toolbar Icon

Standard Toolbar

 - Create a new project

 - Open a project

 - Close the active project

 - Save the active project

 - Save all projects

 - Change the report layout

 - Print preview

 - Print the active project

 - Reverse the last action

 - Repeat the last action

 - Cut the current selection and copy to the system clipboard

 - Copy the current selection to the system clipboard

 - Paste data from system clipboard to selected area

 - Change the view of the current Network

 - Activate 7 x 11 full screen mode

 - Zoom in

 - Zoom out

 - Global replace

 - Search

 - Find and replace

 - Help
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Control Toolbar
 - Take a project offline

 - Take a project to emulation

 - Take a project online

 - Take a project to combined mode

DWW Toolbar
 - First record

 - Previous record

 - Next record

 - Last record

 - Pause/resume

 - Record

 - Toggle between logging real-time data from a controller and logging 
stored

Online Controls Toolbar
 - Start/stop controller (see p. 117)

 - Initialize logic (see p. 106)

 - Read from controller (see p. 107)
read
read extended memory

 - Write to controller (see p. 109)
write logic
relocate logic and data
relocate logic only
write extended memory

Instruction Toolbar

A user-defined set of instructions. Click an instruction to add it to the logic 
editor at the cursor.

Toolbar Icon
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Project Toolbar

 - Project menu

 - Configuration

 - Traffic Cop

 - Communications

 - Logic

 - Data Watch Window

 - Configuration extensions

 - ASCII messages

 - PLC status

 - Analyze device

 - Knowledge base

 - Change controller type

Server Toolbar

 - Login to server

 - Logout of server

 - Unlock a project

 - Update lock status

 - Get from server

 - Get from server with lock

 - Put to server

Toolbar Icon
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Navigating in ProWORX 32

Overview The navigation panel in ProWORX 32 includes the following tabs:

My Projects
My Computer
Utilities
Plant
Documents

My Projects The following features are available under the My Projects tab.

Feature Description

Configuration Use Configuration to edit controller configuration and 
properties, ports, and loadables. 

Traffic Cop Use the Traffic Cop to visualize and configure I/O series, drops, 
cards, and slots.

Communications Use Communications to configure ProWORX for common 
types of network connections.

Logic Use the Logic editor to edit ladder logic in online, offline, or 
emulation mode.

Data Editors Data Editors includes the following windows, which are used to 
view and edit register data values for a selected project.

Data Watch Window
Register Editor
PID Summary
Drum/ICMP Summary
HMI View

Configuration Extensions Configuration Extensions provides you with utilities that can be 
loaded into a controller.

ASCII Messages Use ASCII Messages to enter or edit messages that you want 
your controller or project to send.

PLC Status PLC Status allows you to monitor PLC status words. You can 
monitor multiple projects at the same time.

Analyze Device Analyze Device performs a checklist of predetermined tasks to 
find specific problems relating to an I/O sub-system’s health 
and general PLC status.

Knowledge Base Knowledge Base is a user-defined library of accumulated 
process experience relating to a specific project that allows you 
to identify solutions to problems that have occurred in the past.
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My Computer The My Computer tab displays the same features as the My Projects tab. Difference 
between these 2 tabs:

My Projects displays a list of projects that were opened or created in the 
installation projects directory. The display contains the project’s controller type 
communications setting and address. Projects in this list can be opened and get 
from or put to the server.
My Computer displays a list of projects that were opened or created outside of 
the projects directory. The display contains the project name and path. The status 
bar at the bottom of the list contains the current projects and their respective 
paths. You can use projects located anywhere on your computer.

Utilities The following features are available under the Utilities tab.

Feature Description

MBP Stat Use MBP Stat to access device status and diagnostic tools. 

BootP Use the BOOTP server to listen for IP address requests. The 
response includes an IP address for the client.

Ping Use Ping to test for a given IP address. Ping helps diagnose problems 
with the TCP/IP communications as well as determine a device’s 
existence.

Network Explorer Use Network Explorer to find controllers, bridges, bridge multiplexers, 
and other devices attached to networks.

BM85 Configuration Use BM85 Configuration to configure a BM85 device.

Compare Use Compare to discover differences in logic and configuration 
between a project and a controller or between two projects or between 
two controllers.

I/O Drawing Viewer Use pan and zoom features of I/O Drawing Viewer to view drawings. 
These drawings are in a .DXF format that is supported by most CAD 
programs.

Loadable Library Use Loadable Library to hold sets of loadables so you only have to 
translate them to ProWORX 32 format once. 

Exec Loader Use Exec Loader to transfer the flash RAM executive, read a 
controller’s flash RAM executive into a disk file, or write a device’s 
flash RAM executive from a disk file.

WebLoader Use WebLoader to transfer Web content between a PC and a M1E 
Processor's FLASH memory over the Modbus TCP/IP communication 
network.
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Plant The Plant Layout is a powerful means of organizing ProWORX 32 projects and 
documents into a logical arrangement. The Plant Layout is a tree that looks like a 
folder list in Windows Explorer. The files in the tree are projects and documents. 
Each folder in the tree may contain several items. This allows you to group your 
projects and documents together in any order that you like.

Example

You have a plant with 3 production lines. Each line has two machines and a 
schematic wiring diagram. Each machine has a ProWORX 32 project used for 
programming it. Now, you can create a Plant Layout that mimics this physical reality. 
Your Plant Layout will have 3 folders in the tree, 1 for each line. Inside each folder 
will be 2 projects and 1 document. In this way, you can easily tell what project 
belongs to what physical machine and how they are related to each other. The Plant 
Layout also includes any documents that may be related to the projects, lines, or the 
plant itself.

The following features are available from the right-click menu in Plant Layout.

Note: If you are logged into a server, files that are locked out by a user are denoted 
with a red check mark. The Plant Layout itself may be locked out and modified.

Command Function

Add New Plant Item Returns an input prompt that asks for a new Plant Item. If an 
item is entered, it will appear as a Group root node in the Plant 
Layout list.

Delete Plant Item Asks the user if he wants to delete the Plant Item. If the user 
selects Yes, the Item, all associated Projects, and Related 
Docs are removed from the Plant Layout tree. If the user 
selects No, no changes are made.

Add Project Adds an existing project to the current Plant Item group. The 
Select Project dialog appears for this operation.

Remove Project Removes the project from the Plant Layout tree. The project 
will remain in the Projects tree. Only available if a Project is 
selected.

Add File Opens a dialog for file selection. If a file is selected, it is added 
to the Documents list. Files are placed into a ...\RelatedDocs\ 
folder in the applications path.

Remove File Deletes a file from both the tree and from the ...\RelatedDocs\ 
folder. Available only if a file is selected.

Get Plant Layout from 
Server

Retrieves the PlantLayout.INI file from the server and updates 
the Plant Layout tree. Only available if logged into a server.
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Get Plant Layout with Lock Retrieves the PlantLayout.INI file from the server and updates 
the Plant Layout tree. The Root Node of the Plant Layout tree 
displays a locked status and the PlantLayout.INI file is checked 
out to the current user.

Put Plant Layout to Server Sends the PlantLayout.INI file to the server. The file now exists 
on the Server, and is available for checkout or to other clients. 
Only available if logged into a Server.

Unlock Plant Layout Unlocks the PlantLayout.INI file on the server without making 
any changes to the server’s copy of the file. Other clients may 
access it normally. Only available if logged into a server.

Get Project from Server Retrieves the selected project from those listed under the 
Server node and places it in the ...\Projects\ folder. Project 
also appears in the tree. Only available if logged into a server.

Get Project with Lock Retrieves the selected project from those listed under the 
Server node and places it in the ...\Projects\ folder. Project 
also appears in the tree. Projects displays a locked status, and 
is checked out to the current user.

Put Project to Server Sends the selected project to the server and adds it to those 
listed under the Server node. Project is not on the Server, and 
is available for checkout to other clients. If the project already 
exists on the Server, the user will not be allowed to put it to the 
server unless he checks out the project.

Unlock Project Unlocks the selected project on the server without making any 
changes to the server’s copy of the project. Other clients may 
access it normally.

Get File from Server Retrieves the selected file from those listed under the Server 
node and places it in the ...\RelatedDocs\ folder and in the 
tree.

Get File with Lock Retrieves the selected file from those listed under the Server 
node and places it in the ...\RelatedDocs\ folder and in the 
tree. File displays a locked status, and will be checked out to 
the current user.

Put File to Server Sends the selected file from the ...\RelatedDocs\ folder and 
adds it to those listed under the Server node. The file now 
exists on the Server, and is available for checkout or to the 
other clients. If the file already exists on the Server, the user 
will not be allowed to put it to the server unless she checks out 
the file.

Unlock File Unlocks the selected file on the server without making any 
changes to the server’s copy of the file. Other clients may 
access it normally.

Command Function
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Documents The Documents tab displays an alphabetical list of all documents that have been 
added.

Double clicking any file launches the file in its associated editor.

The following features are available from the right-click menu in the Documents tab.

Note: If you are logged into a server, an additional Server root node will appear 
with a list of all documents stored on the server. Files that are locked out by the 
user are denoted with a red check mark.

Command Function

Add File Opens a command dialog for the selection. If a file is selected, it is 
added to the Documents list.

Remove File Deletes a file from the document’s tree and from the 
...\RelatedDocs\ folder.

Get File from Server Retrieves selected file from list under Server node, places it in the 
...\RelatedDocs\ folder, and displays it in the document tree. Only 
available if logged into a server.

Get File with Lock Retrieves the selected file from those listed under Server node, 
places it in the ...\RelatedDocs\ folder, and displays it in the tree. 
File will display a locked status and will be checked out to current 
user. Only available if logged into a server.

Put File to Server Sends the selected file to the ...\RelatedDocs\ folder, and lists it 
under Server node. File can now be checked out or is available to 
other clients. Only available if logged into a server.

Unlock File Unlocks the selected file on the server without making any changes 
to the server’s copy of the file. Other clients may access it normally. 
Only available if logged into a server.
38 31003882 12/2006



Working with ProWORX 32
Tracking Help

Overview Tracking Help is a brief description of the editor, instructions, or I/O card that is 
currently selected in ProWORX 32.

Using Tracking 
Help

To open the Tracking Help window:

Step Action

1 Click View → Tracking Help.

2 To see more information about the current tracking help topic, press F1.

Note: The Message Central and Tracking Help windows default to remaining open. 
If you want the windows to be closed continuously, click View → Properties or 
right-click Workspace or a project name and click Properties. Click the 
Environment tab. Under Message Central:
Clear these 2 check boxes:

Auto Display Message Central
Auto Switch to Tabs in Message Central

Select these 2 check boxes:
Alert User of Critical Messages
Alert User of Non-Critical Messages
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Message Central

Overview Message Central displays messages from ProWORX 32 related to the project in 
which you are working.

Message Central has the following fields.

Setting 
Properties

To set properties for Message Central, click View → Properties or right-click 
Workspace or a project name. Click Properties, and then click the Environment 
tab. Properties related to Message Central include:

Auto Display Message Central
Auto Switch to Tabs in Message Central
Alert User of Critical Messages
Alert User of Non-Critical Messages

See p. 26 for detailed information on setting properties related to Message Central.

Field Description

Time Time of message

Project Name of project related to message

Area Area of project related to message

Message Text of message

Note: The Message Central and Tracking Help windows default to remaining open. 
If you want the windows to be closed continuously, click View → Properties or 
right-click Workspace or a project name and click Properties. Click the 
Environment tab. Under Message Central:
Clear these 2 check boxes:

Auto Display Message Central
Auto Switch to Tabs in Message Central

Select these 2 check boxes:
Alert User of Critical Messages
Alert User of Non-Critical Messages
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At a Glance

Overview ProWORX 32 holds information about each of your controllers in a project. The 
project stores:

controller's configuration
ladder logic
descriptors of the controller and ladder logic
project properties
data trends
results comparison

What's in this 
Chapter?

This chapter contains the following topics:

Topic Page

Creating a New Project 42

Converting Ladder Logic Databases 45

Using the ProWORX Server to Manage ProWORX 32 Projects 47

Working with a ProWORX 32 Project 49

Using Emulation Mode 53

Instructions Supported in Emulation Mode 57

Adding Emulation Instruction Solve Support 58

Documentation Editor 61

Using the Documentation Editor 62

Symbolic Addressing 64

Importing and Exporting ProWORX 32 Documentation 66

Protected Registers 68

Using Search 69

Address Used 75

The Knowledge Base 77
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Creating a New Project

Overview The Project Configuration Wizard takes you through creating new default projects 
and modify existing projects in ProWORX 32. The configuration wizard guides you 
through a series of simple steps to set up a project.

Each dialog box in the wizard has a caption stating which step you are currently 
completing. Also, each dialog box has a diagram and description detailing what the 
current step involves.

The standard wizard buttons are:

Creating a New 
Project

 

Button Function

Help Displays context-sensitive help pertaining to the current step.

Cancel Exits the wizard, and no new project is created or no changes are saved.

Back Returns the wizard to the previous step.

Next Advances the wizard to the next step.

Finish Completes the wizard, and creates a new project or saves the changes.

Step Action

1 Click File → New.

2 Enter a project name in the New Project Name field.

3 Click OK. The New Project Wizard appears.

4 Select a method to create the new project.
Online to Controller
Offline to Controller

Select Controller Type
Base on Existing Project
Read from Controller

Note: If you choose Select Controller Type, you can also select the Use as a 
Macro check box.
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Creation Method 
Details

The creation methods include:

Selecting a 
Controller Type

This step includes 2 lists to select a controller. Below the lists are detailed 
descriptions of the currently selected controller. Displayed below the controller 
selection list are pictures of the I/O types supported by the current controller.

To select a controller:

Path Description

Online to Controller This option connects directly to a controller in the 
online mode. The next step configures the parameters 
used to communicate (see p. 44) with the desired 
controller.

Offline to Controller

Select Controller Type This step allows you to set up the controller type (see 
p. 43).

Base on Existing Project This option creates a project based on an existing 
project. First, select an existing project from the list of 
projects on the local computer. ProWORX 32 creates 
a copy of the project and uses it as the base for the 
new project. ProWORX 32 initializes the logic and 
clears the traffic cop of the new project. See p. 44 to 
configure communications to the desired controller.

Read from Controller This option creates a project based on a read of the 
program from an existing controller. See p. 44 to 
configure communications to the desired controller.

Use as a Macro With the Select the Controller Type option, you can 
select the Use as Macro (see p. 250) checkbox to 
create a macro-enabled database.

Step Action

1 Select a controller family from the Pick a Controller Family list: Compact, Micro, 
Momentum, 38x/48x, 484 Replacement, 68x/78x, 984ABX, Atrium, Other, 
Quantum, or VME.

2 Select the desired controller from the Pick a Controller list. The list of controllers 
depends on which controller family you selected in step 1 above.

3 Click Next to continue.
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Controller 
Details

The controller details available depend on the controller you have selected in the 
previous step. Set the available controller details:

Click Next when you have set the controller details.

Communications 
Setup

To select a communications mode:

Completing a 
New Project

Click Finish to complete the creation of your new project. When the progress 
number reaches 100%, the wizard closes. The newly created project appears in the 
project navigation tree.

Controller Detail Description

Executive Cartridge Cartridges that determine the controller’s instruction set. Select the one 
installed in your controller. The Executive Cartridge is available for the 38x, 
48x, 68x, and legacy 984 slot-mount controllers.

Memory Pack The amount of both Extended and User Logic memory in the controller. Select 
the amount installed in your controller. Available on a variety of x80 and 984 
A/B controllers.

Extended Memory Additional memory providing 6xxxx registers. Select the amount installed in 
your controller. Available on a variety of x80 and 984 A/B controllers.

Built-in XMRD/XMWT Select Yes or No. The built-in extended memory functions option is only 
available for the 984AS908.

User Logic Memory available for ladder logic. Select the amount of memory you want to 
use for ladder logic from the total amount available in your controller. 
Available on a variety of x80 and 984 A/B controllers.

S908 Size Select either 512 or 1024 (1k) input and output points per drop. Available for 
most 68x and 78x controllers.

Micro I/O Mode Micro controllers only. Select:
Single: The controller is independent, not in a parent/child relationship.
Parent: The controller is the parent in a parent/child relationship.
Child: The controller is the child in a parent/child relationship.

Available for Brick controllers from the Micro 311/0 to the Micro 612/4.

Step Action

1 Select a communications tab: Modbus, Modbus Plus, Gateway, or TCP/IP.

2 Set the communications-specific properties as desired. For more information, see p. 80.

3 If your project will communicate with a controller via the ProWORX server, click the Use 
server to communicate check box.

4 Click Next to continue.
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Converting Ladder Logic Databases

Overview Old ladder logic databases created in 484, 584, 884, ProWORX, ProWORX Plus, 
ProWORX NxT, Modsoft, and Concept can be imported into the new format of 
ProWORX 32. By importing a database using the ProWORX 32 convert function, 
your logic, documentation, configuration, and other relevant areas of your project 
are converted directly into ProWORX 32.

Converting a 
Database

 

Step Action

1 Click File → Import → Database. The Select Database to Convert dialog box 
appears.

2 Select a database to convert from the following database types:
ProWORX 484 (*.cf4)
ProWORX 884 (*.cf8)
ProWORX NxT Macro (*.wns)
ProWORX 984 (*.cf9, *.dcf)
Modsoft (*.cfg)
Concept 984 (*.asc)
ProWORX Plus/ProWORX NxT (*.dcf)

3 When you have selected a database, click Open to start the conversion process.

4 To cancel the conversion, click Cancel in the Conversion Status dialog box.

5 Click OK in the Conversion Complete dialog box to return to ProWORX 32.

Note: ProWORX 32 does not support Modsoft  SFC.
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Note: For 584 databases, after importing/opening the Nxt or Modsoft 584 project 
with ProWORX 32 version 2.1 the project can be read, written, edited and saved 
with the following limitations:

Loadables cannot be added to 584 projects.
The Loadable library for 584 is not supported. If the 584 project imported has 
loadables, those will still be part of the imported project.
Undo/Redo is not available in the Ladder Logic editor online, because the 
PRWX loadable cannot be written to the 584.
Modbus is the only communication mode available.
No access to Segment Scheduler (584 does not support this).
Cannot ‘Change PLC Type’ from a 584 to another PLC type.
The following ProWORX 32 features are not supported for the 584 projects:

Configuration Extensions
Loadables
Segment Scheduler
PRWX Ladder Logic block
Undo/Redo online in Ladder Logic editor
584 is not available under the Select Controller Type in the New Project 
wizard
Change PLC Type
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Using the ProWORX Server to Manage ProWORX 32 Projects

Overview The ProWORX server is an application used to store and manage ProWORX 32 
projects. The following project transactions can occur between a ProWORX 32 client 
and the ProWORX server (see p. 283).

The following options are available by clicking Server, right-clicking the project in the 
navigation panel, or clicking the client toolbar icons of the ProWORX 32 client.

When Service Can Be 
Accessed

Transaction Result

Client’s Server pull down 
menu, client toolbar

Login Allows access to the ProWORX 32 Server

Client’s Server pull down 
menu, client toolbar

Logout Removes access to the ProWORX 32 Server

Client’s Server pull down 
menu, client toolbar, right-
clicking the project name in 
the navigation panel 

Get from 
Server

The project is copied to your local PC. If you 
plan to make changes to a project, you should 
get the project from the server with a lock.

Client’s Server pull down 
menu, client toolbar, right-
clicking the project name in 
the navigation panel 

Get from 
Server with 
Lock

The project is copied to your local PC. You 
have sole access and editing capabilities for a 
project when it is locked out to your PC.

Client’s Server pull down 
menu, client toolbar, right-
clicking the project name in 
the navigation panel 

Put to Server When you have finished making changes or 
you want to add a project to the server, use this 
function, which creates a copy of the project on 
the server.

Client’s Server pull down 
menu, client toolbar, right-
clicking the project name in 
the navigation panel 

Unlock 
Project

The project is unlocked so that other clients 
can check it out of the server.

Client’s Server pull down 
menu, right-clicking the 
project name in the 
navigation panel 

Get Previous 
Version

A Version Selection window is opened, which 
allows you to select a previous version of your 
project from the server to overwrite your 
current project.
Note: Click View Audit Trail in the Version 
Selection window to display the audit trail for 
the selected version. The audit trail provides a 
record of each project transaction between the 
ProWORX 32 client and server.

Client’s Server pull down 
menu, right-clicking the 
project name in the 
navigation panel 

Get Backup 
Version

A Version Selection window is opened. It 
allows you to select the backup version of your 
project from the server to overwrite your 
current project.
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Client’s Server pull down 
menu, right-clicking the 
project name in the 
navigation panel 

Get Previous 
Compare

A Version Selection window is opened. It 
allows you to select a previously compared 
version of your project from the server. Click 
OK to display the results of the comparison.

Client’s Server pull down 
menu, client toolbar

Update Lock 
Status

The status of files on the server you are 
connected to is displayed by selecting Update 
Lock Status in The ProWORX 32 Client's 
project navigation panel. A Red checkmark 
indicates checked out by you and Yellow, 
checked out by someone else. The Update 
Lock Status feature queries the Server to 
update the lock status of the files and it is 
appropriately displayed in the project 
navigation panel.

Note: You must be logged into the Server to make the Server transactions 
available. Transaction icons on the client toolbar, transaction items in the Server 
pull down menu, and transaction items displayed when right-clicking the project 
name in the navigation panel are either not available or greyed out when not logged 
into the Server.

Note: If the ProWORX 32 Client Security permission settings are set to be higher 
than the ProWORX 32 Server security settings for a project, the Server security 
settings will override the local ProWORX 32 Client Security when the project is 
retreived from the server and the user remains logged into the server. When the 
user logs out of the server, the Client Security settings are not restored until 
ProWORX 32 is closed and restarted. The security feature works as designed. And 
it is up to the end user to ensure that the proper access rights are invoked and 
controlled.

When Service Can Be 
Accessed

Transaction Result
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Working with a ProWORX 32 Project

Projects in 
Offline Mode

To work with a controller offline, you must create a project for it. This project stores 
the controller's traffic cop and configuration information, its ladder logic, and 
descriptors of the controller and ladder logic. As you work in offline mode, editors 
modify this data. Because the offline editors are not connected directly to the 
controller, changes made in it do not take effect immediately. Instead, when you 
have finished programming, you can write all your changes to the controller at once.

Taking a Project 
Offline

Right-click the project name in the navigation panel, and click Project State → 
Offline.

- or -

Click Controller → Offline.

- or -

Click the Offline toolbar button.

Projects in 
Online Mode

To work with a controller online, select a project, and change its mode to online. 
ProWORX 32 then attaches the communications settings provided to that controller. 
The online editors read ladder logic, traffic cop information, register contents, and 
the controller's configuration directly from the controller, and ProWORX 32 writes 
back to it. Changes made in the online mode take effect in the controller 
immediately, but don't appear in its project until you read from the controller.

Note: When you are in online mode, and you want to copy/paste logic between 2 
projects, the register contents do not paste. The register contents can be copied 
and pasted in offline mode only (see p. 274)).

Note: When printing in online mode, the contents of the offline database is printed.

Note: When in online mode the Documentation Editor is read only.
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Taking a Project 
Online

Right-click the project in the navigation panel, and click Project State → Online.

- or -

Click Controller → Online.

- or -

Click the Online toolbar button.

Direct to Online 
Mode

To use the Direct to Online mode, double-click Direct to Online in the project 
navigation panel.

The Direct to Online mode allows you to work with a controller online without using 
an associated project. It is for online operations only.

Direct to Online is useful if you want to connect to a random controller quickly for 
simple maintenance or if you do not have access to the required projects.

Since no project is required for Direct to Online, any project-based data can not be 
accessed, including various Traffic Cop card information and all Documentation 
(including symbols).

Furthermore, you must rebuild the Address Used tables each time you connect to a 
controller using Direct to Online because the data is not directly stored in the 
controller.

To exit Direct to Online, click File → Close.

Note: Before you use Direct to Online, you must configure your communications 
(see p. 80) for a valid controller. Then, you may open any editor to view or edit 
online data.

Note: The following functions are not available when using Direct to Online.
Global Replace
Compare
Documentation Utilities
Change Controller Type
Offline editing
Emulation mode
Combined mode
Read data from a project
Write data to a project

With the exception of the above functions, all online editors perform in the same 
manner as the project-based online mode.
50 31003882 12/2006



Working with Projects
Projects in 
Emulation Mode

To work with a controller in emulation mode (see p. 53), first make sure that the 
project is in offline mode. Bringing a project into emulation mode allows you to 
emulate the solving of logic without a controller. From emulation mode, you can view 
the solving of logic and the changing of register data. Use the online controls to start 
and stop the emulator.

Taking a Project 
to Emulation

Right-click the project in the navigation panel, and click Project State → Emulation.

- or -

Click Controller → Emulation.

- or -

Click the Emulation toolbar button.

Projects in 
Combined Mode

Combined mode is a combination of offline and online modes. When a project is in 
combined mode, it attaches to the controller specified by the communication 
settings. All work done in the editors is made directly to the controller. Work done in 
the logic editor, traffic cop, and register editors is also saved back to the project file. 
So, there is no immediate need to read from the controller to update the project file 
with all the changes.

Taking a Project 
to Combined 
Mode

Right-click the project in the navigation panel, and click Project State → Combined.

- or -

Click Controller → Combined.

- or -

Click the Combined toolbar button.

Setting the 
Project 
Properties

 

Step Action

1 Ensure that the project is selected in the navigation panel. The currently selected 
project is appended to the ProWORX screen’s title bar.
Right-click the project.

2 Click Properties.

3 Click the Project tab.

4 Configure the project properties (see p. 52).

5 Click OK to save changes.
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Project 
Properties 
Description

Property descriptions:

Property Description

Detailed Project Name Enter the detailed description of the current project.
Note: 64-character maximum

Project Enter a name (brief description) for the current project.
Note: 64-character maximum

Client Enter the name of the project’s client if applicable.
Note: 64-character maximum

Author Enter the name of the project author.
Note: 64-character maximum

Page Title Enter a title that you want to appear at the top of the page when 
you use the print command.
Note: 64-character maximum

6 Digit Addressing Auto: Sets addressing to five digits unless the controller has 
addresses configured that require six. The Auto button is the 
default.
On: Sets all addressing to six digits, allowing ProWORX 32 to 
enter and display constants greater than 9999.
The display of 6 digit addressing is dependent upon the 
controller type that is configured.

Maximum Decimal Value Restricts registers to a decimal value of either 9999 (default) or 
65535.

Start Network Configures the logic editor to go to the network/row/column 
entered by the user when the logic editor is started.

Save to Flash on Exit If the controller supports flash memory, selecting this check box 
will save the controller’s contents to flash memory on exit of 
online.

Enable Symbols Enables or disables symbolic addressing (see p. 64).
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Using Emulation Mode

Overview The emulation function is used to test the integrity of the logic in a project without the 
need of a PLC. Emulation mode allows you to check discrete states and register 
contents, and test your logic in a safe environment.

Taking a Project 
to Emulation

Right-click your project in the project navigation panel, and click Project State → 
Emulation.

- or -

Click Controller → Emulation.

- or -

Click the Emulation toolbar button.

Setting up 
Emulation

Before you test your logic, set the default states or values into the emulator. Thus, 
when you use the Load command, you can debug your database file using the 
states you have preset. Discretes may be set to OFF, ON, Enabled, Disabled OFF, 
or Disabled ON. Register values may be set to Decimal, Hexadecimal, Binary, 
ASCII, or Floating Point.

Setting 
Emulation 
Properties

 

Setting the 
Default Address 
Data Values

You can toggle discretes or transfer values to arrays of registers during emulation 
when setting states or register contents on a state or value. To edit the Default 
Address Data Values table in the Emulation tab:

Note: ProWORX 32 emulation mode does not have the capability of a controller 
simulator.

Step Action

1 Right-click your project in the project navigation panel, and click Properties.

2 Click the Emulation tab.

Step Action

1 Enter an address or a range of addresses in the format (axxxx-axxxx) in the 
Address Range field.

2 If you have entered a 3x/4x analog address range, enter a value in the Data 
Value field. If you have entered a discrete address range, select a data value 
(Off, On, Enables, Disabled Off, Disabled On) from the Data Value list.
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Setting 
Instructions with 
Loopback

You can toggle discretes or transfer values to arrays of registers during emulation 
when setting states or register contents based on a state or value. To edit the 
LoopBack Control table in the Emulation tab:

Adjusting Scan 
Time

To adjust scan time in the Emulation tab:

3 If you have entered a 3x/4x analog address range, select a radix for the address 
range from the Radix list.
Note: Floating point only works with two registers. All others can be set to work 
on ranges of addresses.

4 Click OK to save the changes.

5 To load the default address values while in Emulation mode, click Emulation → 
Load Default Address Values from the logic editor right-click menu.

Step Action

Step Action

1 Enter the address where you want the loopback in the Ctrl Address field.

2 Enter the state or value of the address in the Condition field.

3 Select the radix you want to enter your condition in from the Radix list.

4 Enter the number of scans you want the Condition to be monitored by before 
being updated (0 to 65535) in the Scan Delay field.

5 Enter the address range by typing the start and end addresses, separated by a 
dash, in the Destination field. If there is only one Destination for that control 
condition, enter only one address.

6 For discrete addresses, select On or Off from the Data Value list.

7 Select the numeric system you want to enter your Destination in from the Radix 
list.

8 Click OK to save the changes.

9 To load the loopback table while in Emulation mode, click Emulation → Load 
Loopback Table from the logic editor right-click menu.

10 To enable or disable loopback while in Emulation mode, click Emulation → 
Loopback Enabled from the logic editor right-click menu.

Step Action

1 Enter a scan time rate between 1 and 999 in the Timer increment per scan of 
logic (ms) field.
Note: This option does not speed up or slow down the emulator’s solving time. 
It only affects how fast the timers increment.

2 Click OK to save the changes.
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Starting 
Emulation

To start emulation:

Setting the Solve 
Mode

Several solve modes are available to assist in emulating logic. You can set 
emulation to stop solving following any number of full sweeps, after a particular 
network is solved, when a breakpoint is reached, or when certain logical conditions 
are true or not true.

You can change the solve mode by:
Right-clicking your project, and clicking Online Commands → Start/Stop.
- or -
Clicking Controller → Start/Stop.

Select a solve mode button any time when emulation is in a stopped state.

Solving by 
Sweep

In the start/stop dialog box:

Solving by 
Network

In the start/stop dialog box:

Solving by 
Instruction

In the start/stop dialog box:

Step Action

1 Right-click your project, and click Online Commands → Start/Stop.
- or -
Click Controller → Start/Stop.
- or -
Click the Start Controller toolbar button.

2 Set the emulator’s solve mode (see p. 55) in the Start/Stop dialog box.

3 Click Start to start emulation in continuous solve mode.

Step Action

1 Click the Sweep button.

2 Enter the number of times you want the logic to be solved before stopping.

3 Click Start.

Step Action

1 Click the Network button.

2 Logic is solved network-by-network in order of networks, starting at segment 
one, network one.

3 Click Start.

Step Action

1 Click the Instruction button.
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Solving to a 
Breakpoint

In the start/stop dialog box:

Setting Emulator 
Breakpoints

To set a breakpoint at the cursor in the logic editor:

Stopping 
Emulation

To stop emulation:

2 Logic is solved instruction-by-instruction in order of instructions, starting at 
segment one, network one, cell (1,1).

3 Click Start.

Step Action

Step Action

1 Click the Breakpoint button. Select one of the following break types.

2 To set a break when a particular value is reached in a register, click Register 
from the list. Enter the address in the Address field and a data value in the Value 
field.

3 To set a break when a discrete value turns on or off, click Discrete from the list. 
Enter the address in the Address field and select Off or On from the Value list.

4 To set a break when the solve reaches a certain instruction type in logic, click 
Instruction from the list. Select the instruction to break at from the Instruction 
list.

5 To set a break when a specific address is reached in logic, click Address from 
the list. Enter the address to break at in the Address field.

6 To break at the breakpoints set (see p. 56) in the breakpoint table, click 
Breakpoint from the list.

7 Logic is solved in order until it comes to the first breakpoint, at which point it 
stops. To continue solving logic until the next breakpoint, click Start.

Step Action

1 Click Emulation → Breakpoint from the right-click menu.

2 To delete a breakpoint, click Emulation → Breakpoint Table from the right-click 
menu.

3 Select the row of the breakpoint that you want to delete and click Delete.

4 Click Close to exit the breakpoint table.

Step Action

1 Right-click your project, and click Online Commands → Start/Stop.
- or -
Click Controller → Start/Stop.

2 Click Stop.
56 31003882 12/2006



Working with Projects
Instructions Supported in Emulation Mode

Overview Following is an alphabetical list of instructions supported in emulation mode.

Instruction Instruction Instruction Instruction

AD16 DV16 NBIT SKP

ADD EMTH (1-37) NC SRCH

AND FIN NCBT SU16

BCD FOUT NO SUB

BLKM FTOI NOBT T.01

BLKT IBKR NTC T->R

BROT IBKW OR T->T

CMPR ICMP PTC T0.1

CNR ITOF R->T T1.0

COMP JSR RBIT TBLK

CONV LAB RET TEST

CR MATH RTTI TTR

DCTR MBIT RTTO UCTR

DIV MSTR (reg read/write SBIT XOR

DMTH MU16 SCIF

DRUM MULT SENS
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Adding Emulation Instruction Solve Support

Overview ProWORX 32 has the capability of allowing advanced users to add instruction solve 
support for the ProWORX emulator.

Creating an 
Emulation Solve 
File

Using a text editor:

Instruction Solve 
File Function 
Parameters

Parameter descriptions:

Step Action

1 Create a folder, named EmulatorInst, in the ProWORX → 32 directory.

2 Create a blank .ESF file in the ProWORX → 32 → EmulatorInst directory.

3 Name your .ESF file the same as the instruction that is to be solved.
Example: The ADD instruction’s emulation solve file would be named ADD.ESF.
Note: Do not use spaces in your emulation solve file name.

Variable Description

Network The network number where instruction is located.

Row The row in logic where instruction is located.

Col The column in logic where instruction is located.

TopTyp The address type of the top node of the instruction (valid values: 0, 1, 3, 4, 8 for 
constants).

TopVal The address offset of the top node of the instruction (valid values: 0 - 65535).

TopLen The number of addresses the top node uses.

MidTyp The address type of the middle node of the instruction (valid values: 0, 1, 3, 4, 
8 for constants).

MidVal The address offset of the middle node of the instruction (valid values: 0 - 65535).

MidLen The number of addresses the middle node uses.

BotTyp The address type of the bottom node of the instruction (valid values: 0, 1, 3, 4, 
8 for constants).

BotVal The address offset of the bottom node of the instruction (valid values: 0 - 65535).

BotLen The number of addresses the bottom node uses.

UctrNum Used only for UCTR instructions.

DctrNum Used only for DCTR instructions.

Spare3 Spare parameter.

Note: All parameters must appear in the instruction subroutine declaration.
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Emulation Solve 
File API Calls

 

API Call Description

Power Flow Calls
GetPowerFlow(Network, Row, Col, PowerState)
SetPowerFlow(Network, Row, Col, 1)

Power flow calls are used to:
Determine whether an instruction should be solved 
(using GetPowerFlow)
To pass along powerflow to the next cell (using 
SetPowerFlow)
To activate an error condition (using SetPowerFlow)

Power flow calls can be used to either get or set a particular 
cell in logic. Depending on the instruction being solved, the 
row and col variables are used to access a particular cell 
within the 7 row x 11 column matrix.

Single Discrete State Calls
GetSingleDiscreteState(RefTyp, RefVal, State)
SetSingleDiscreteState(RefTyp, RefVal, 1)

Single discrete state calls are used to get or set the state of 
a 0xxxx or 1xxxx address. The State will return with 0 for Off 
or 1 for On. When calling the Set, use either 0 for Off or 1 for 
On.

Single Discrete History Calls
GetSingleDiscreteHistory(RefTyp, RefVal, History)
SetSingleDiscreteHistory(RefTyp, RefVal, State)

Single discrete history calls are used to get or set the history 
of a 0xxxx or 1xxxx address. The history will return with 0 for 
Off or 1 for On. When calling the Set, use either 0 for Off or 
1 for On.

Single Discrete Disabled Calls
GetSingleDiscreteDisabled(RefTyp, RefVal, Disabled)
SetSingleDisabledState(RefTyp, RefVal, Disabled)

Single discrete disabled calls are used to get or set the 
disabled status of a 0xxxx or 1xxxx address. The disabled 
status will return with 0 for Enabled or 1 for Disabled. When 
calling the Set, use either 0 for Enabled or 1 for Disabled.

Single Register Data Calls
GetSingleRegisterData(RefTyp, RefVal, Data)
SetSingleRegisterData(RefTyp, RefVal, Data)

Single register data calls are used to get or set the data 
value of a 3xxxx or 4xxxx address. Valid range for data is 0 
to 65535.

Group Discrete Calls
GetGroupDiscreteState(RefTyp, RefVal, NumGroups, 
State(), Disabled())
SetGroupDiscreteState(RefTyp, RefVal, NumGroups, 
State())
SetGroupDisabledState(RefTyp, RefVal, NumGroups, 
Disabled())

Group discrete calls are similar to the single calls except 16 
discretes per group are received or set at one time. The 
arrays must contain data for as many groups as are 
specified.

Group Register Calls
GetGroupRegisterData(RefTyp, RefVal, NumGroups, 
Data())
SetGroupRegisterData(RefTyp, RefVal, NumGroups, 
Data())

Group register calls are similar to the single calls except that 
a group of registers are received or set at one time. The Data 
array must contain data for as many groups as are specified.
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Emulation Solve 
File Content 
Example

ADD.ESF file content example:

Sub ADDINST (Network, Row, Col, TopTyp, TopVal, TopLen, 
MidTyp, MidVal, MidLen, BotTyp, BotVal, BotLen, Spare1, 
Spare2, Spare3)

 

dim State,TData,MData,Bdata

'is top input powered?

call LLEmulator.GetPowerFlow(Network,Row,Col-1,State)

If State<>0 then

' get the value of top node

 If (TopTyp=3) or (TopTyp=4) then

 call LLEmulator.GetSingleRegisterData(TopTyp,TopVal,TData)

 Else

  TData=TopVal

 End if

'get the value of middle node

 If (MidTyp=3) or (MidTyp=4) then

 call LLEmulator.GetSingleRegisterData(MidTyp,MidVal,MData)

 Else

  MData=MidVal

 End if

 BData=TData+Mdata 

'overflow

 If BData>9999 then

  BData=BData-10000

  call LLEmulator.SetPowerFlow(Network,Row,Col,1)

 End if

'set value into bottom node

 call LLEmulator.SetSingleRegisterData(BotTyp,BotVal,BData)

 End if

End Sub

Note: Only emulation solve files for instructions currently not supported by the 
emulator are checked for by ProWORX 32. You cannot edit built-in instructions.
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Documentation Editor

Overview The documentation editor, the default bottom-left editor, allows you to see and edit 
documentation for addresses and traffic cop items. It hot-tracks items that are 
selected in the many of the editors, including the data watch window and traffic cop. 
To open the documentation editor, click View → Documentation.

There are three sections of the documentation editor.
Edit
Summary
Traffic Cop

To switch between sections, click the respective button at the top of the 
documentation editor.

Opening the 
Documentation 
Editor Properties 
Window

 

Documentation 
Editor Properties

The following properties are listed under the Documentation tab:

Step Action

1 Right-click your project or Workspacein the project navigation panel, and click 
Properties.
- or -
Click View → Properties.

2 Click the Documentation tab.

Property To Set: Function

Display One Line 
Documentation 
Window

Select the Display One 
Documentation Window check box.

If the box is checked, the documentation editor will appear in 
one-line mode, and the address descriptors are not editable.
If the box is cleared, the documentation editor will appear in 
edit mode, and the user can edit address descriptors.

Total Number of 
Descriptor Lines

In the Total Number of Descriptor 
Lines list, select a number between 3 
and 9.

The descriptor field is a multi-line field that can be set from 3 
to 9 lines of documentation. This preference forces the editor 
to edit only the set number of lines of the descriptor.

Number of Visible 
Descriptor Lines

In the Number of Visible Descriptor 
Lines list, select a number between 1 
and the value of the total number of 
descriptor lines.

The descriptor field is a multi-line field that can be set from 1 
to 9 lines of documentation.

Supported Fields In the Supported Fields box, select 
the check boxes of the items that you 
want displayed.

If a box is cleared, the corresponding field will never be 
displayed. If a box is checked, the field will be displayed as 
long as dependent properties are set correctly.
Example: If symbols are disabled for the project, the symbol 
field will not be displayed even though the box is selected.
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Using the Documentation Editor

Edit Mode 
Overview

Edit mode is a completely customizable and editable visual representation of the 
current project documentation. Edit mode highlights items when the mouse passes 
over them, which are currently selected in ProWORX 32, including instructions, I/O 
cards, and addresses in the Data Watch Window.

Customizing the 
Edit Mode Fields

In the documentation editor:

Using the Edit 
Mode

Enter an address in the Reference field to view the address’ documentation. To 
navigate through documented addresses, click

the previous documented address

and the next documented address buttons.

To navigate sequentially through addresses, click the previous address

and the next address buttons.

To: Function

Move a field Click the field’s handle, and drag it to the area of the 
window that you would like the field moved to.

Resize a field Click and drag the field’s handle.

Minimize or maximize a field Click the field’s handle.
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Using the Single-
line Mode

The single-line documentation editor displays the currently selected address’ 
descriptors. This mode is uneditable. To view the single-line documentation editor, 
click the 1 Line button at the top right corner of the documentation editor, or:

To switch back to Edit mode:
Click the Edit button at the top right corner of the documentation editor

- or -
Clear the Display One Line Documentation Window check box in step 4 
above.

Summary Mode Summary mode shows the most common information for documented addresses. 
Click the address type list to select the type of address (Symbol, 0x, 1x, 3x, 4x, 
Xmem, or ‘All addresses’) you want to view. To edit the documentation of any 
address, double-click the appropriate row, and the documentation editor will switch 
to edit mode showing the selected address.

Using the 
Symbol Filter

In summary mode, when symbol has been selected in the address type list box, the 
filter box will be visible. The symbol filter is a simple query that filters the symbol 
summary based on what criteria is entered into the filter. To view all symbols, leave 
the filter empty, and press Enter.

The content of the filter is the LIKE statement of an SQL SELECT statement. 
Therefore, rules for entering text into the filter box are the same as composing an 
SQL query. Some filter examples:

Traffic Cop Mode Using traffic cop mode, you can edit short comments for head, drop, rack and slot 
addresses.

Step Action

1 Right-click your project.

2 Click Properties.

3 Click the Documentation tab.

4 Select the Display One Line Documentation Window check box.

Filter Text Results

S* All symbols that start with an ‘S’ are displayed.

*Switch All symbols ending with ‘Switch’ are displayed.

[A-D]* All symbols starting with ‘A’, ‘B’, ‘C’, or ‘D’ are displayed.

*Switch* All symbols with the letter sequence ‘Switch’ are displayed.

Disk? All symbols named ‘Disk(x)’ will be displayed. e.g. Disk1, Disk2, DiskA, etc.
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Symbolic Addressing

Overview Symbolic addressing allows you to replace numerical addresses for customized 
text, which provide more meaning for you. 0x, 1x, 3x, 4x, or constant addresses may 
have symbols.

Documentation 
Symbols

Symbols, which are 32 characters long, represent numerical addresses. Symbols 
are displayed in upper and lower case.

Adding Symbols 
to the 
Documentation 
Editor

 

Note: Before using symbolic addressing, ensure that you selected the Symbols 
check box (see p. 52) in the Project tab of the Properties dialog box. Otherwise, the 
field will not appear in the documentation editor.

Note: While you can use upper and lower case when creating symbols, you cannot 
use the same word with different capitalization.
Example: You cannot use PUMP1 and Pump1 as two different symbols.
To move text between other fields, use Cut (Ctrl+X), Copy (Ctrl+C), and Paste 
(Ctrl+V).

Step Action

1 In the Reference field, type the address to be associated with this symbol. You 
can either type the address in directly, or use the left and right arrow keys to scroll 
through the address. 0x, 1x, 3x, 4x, or constant addresses may have symbols.

2 In the Symbol field, type the associated symbol text.
Result: The symbol is saved for its associated address.
Note: Do not confuse the Symbol field with the ISA Symbol field. If you did not 
select the Symbols check box (see p. 52) in the Project tab of the Properties 
dialog box, the Symbol field will not appear in the documentation editor.
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Adding Symbols 
in the Logic 
Editor

 

Placing an 
Address or 
Symbol in the 
Network Logic

 

Step Action

1 Open the logic editor (see p. 159).

2 Double-click an instruction with the address for which you want to assign a 
symbol.
Result: The Address Edit dialog box opens.

3 In the address field, type the associated symbol text.

4 Click OK.
Result: The Add Symbol dialog box opens.

5 In the address field, type the numerical address to associate with this symbol.

6 Click OK.
Result: The symbol and its associated address are added to the documentation 
for the selected address.

Step Action

1 Open the logic editor (see p. 159).

2 Double-click an instruction with the address for which you want to assign a 
symbol.
Result: The Address Edit dialog box opens.

3 In the address field, type the symbol text.
Result: The symbol and its associated address will be set for the selected 
instruction.
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Importing and Exporting ProWORX 32 Documentation

Overview ProWORX 32 imports and exports database documentation in several formats. The 
Documentation Import feature lets you bring documentation from existing files or 
databases into ProWORX 32 without having to re-enter information. Documentation 
Export lets you edit documentation in a separate word processing or spreadsheet 
program.

Importing 
Documentation

To import documentation:

Exporting 
Documentation

To export documentation:

Note: This function does not import controller logic.

Step Action

1 To append the documentation to the existing project documentation, right-click 
the project and click Import Documentation → Append.

2 To merge or overlay the documentation with existing project documentation, 
right-click the project and click Import Documentation → Overlay.

3 To delete all current documentation and import new documentation, right-click 
the project and click Import Documentation → Create New.

4 Select a file (.csv, .mdb, .doc, .xls) to import from the Select Documentation File 
dialog box, and click Open.

Step Action

1 Right-click the project, and click Export Documentation.

2 In the Select Destination File dialog box, select a file type from the Save as type 
list (.csv, .mdb, .doc, .xls).

3 Enter the export file name in the File name field.

4 Navigate to the folder where you want to save the exported file.

5 Click Save.
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Import/Export 
Formats

Import/Export format descriptions:

Format Description

MS Word (.doc) Documentation is exported directly into an MS Word document. Each address type is displayed on a 
separate table.

MS Excel (.xls) Documentation is exported directly into an MS Excel workbook. Each address type is displayed on a 
separate MS Excel worksheet. When importing documentation, ProWORX 32 expects these sheets to 
be in the same order with the same name.

MS Access 
(.mdb)

Documentation is exported directly into an MS Access database. Each address type is in its own table.
Note: It is important that you do not move or rename fields within the database if you are going to import 
your data.

.CSV File The text file (.csv) is a comma-delimited file. This file can be edited using any standard text editor 
(Notepad, Wordpad, etc.).
The comma-delimited line is different depending on the address type.

0xxxx/1xxxx - Address, Desc1, Desc2,...,Desc9, Short Comment 1,...,Short Comment 4, Symbol, 
ISA Symbol, Page Title, Long Comment ID
3xxxx/4xxxx - Address, Desc1, Desc2,...,Desc9, Short Comment 1,...,Short Comment 4, Symbol
6xxxx/Networks/Segments - Address, Desc1, Desc2,...,Desc9, Short Comment 1,...,Short 
Comment 4, Page Title, Long Comment ID
Traffic Cop - Address (HxxDxxRxxSxxx), Desc1, Desc2,...,Desc9, Short Comment 1,...,Short 
Comment 4

ProWORX 
ASCII (.fil)

Files for exchanging data easily. By default, ProWORX 32 creates this type of file for documentation.

ProWORX 
Symbol (.fis)

Files for exchanging symbols.

Spreadsheet 
Data 
Interchange 
Format (.dif)

ProWORX 32 creates standard .DIF files. Most spreadsheet programs can import this format without 
difficulty. However, you must take special care when transferring data to and from Microsoft Excel in 
.DIF files.

dBaseIV 
Database (.dbf)

ProWORX 32 creates standard .DBF files for use with Ashton-Tate’s data management program 
dBaseIV. Most other data management and spreadsheet programs (including Microsoft Excel) can read 
this format without difficulty.

Traffic Cop (.tef) Importing a .TEF file overwrites the existing traffic cop data. Exporting creates a .TEF file of the current 
traffic cop data. ProWORX 32 requires both the .TEF and .DEF files to successfully import the 
documentation.

Concept (.txt) When exporting, ProWORX 32 creates a .TXT file of the current descriptors and symbols for 0x, 1x, 3x, 
4x and symbols for constants to be used in Concept.

Note: In order to import and export using .doc (MS Word) and .xls (MS Excel) files, you must 
have MS Word and/or MS Excel installed on your PC.

Note: Documentation files of type .fil, .fis, .dif, .dbf, .tef, and .txt are compatible across these 
ProWORX applications: ProWORX NxT, ProWORXPLUS, and ProWORX 32.
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Protected Registers

Overview Ranges of output registers added to the Protected Registers table are protected. 
Their data values are uneditable by users who do not have administrative access to 
ProWORX 32. To use registers in the protected registers table, ensure that the 
Protected Registers check box is selected in the security settings (see p. 22). You 
can access the security settings by right-clicking Workspace in the project 
navigation panel.

Setting 
Protected 
Registers

Follow the steps below to set protected registers.

Step Action

1 Right-click your project, and click Properties.

2 Click the Protected Registers tab.

3 Enter 4xxxx addresses in the From and To fields.

4 Click Add to add the range of addresses to the Protected Registers table.

5 To delete a range of addresses from the Protected Registers table, select the 
row to be deleted and then click Delete.

6 Click OK to save your changes.
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Using Search

Overview The search dialog box is used to find, replace, or go to addresses or symbols in 
ProWORX 32.

You may search for several items in your project. These include:

addresses
symbols
functions
disabled contacts and coils
duplicate coils

Additionally, you can search in a number of different areas of your project. These 
include:

entire project
logic
configuration
traffic cop
peer cop
I/O scanner

Using Find/
Replace - Simple 
Search

 

Note: After you perform a search, you must save your project before you rebuild 
the address used tables so that the tables will be accurate.

Step Action

1 Click Edit → Find (Ctrl+F) or Edit → Replace (Ctrl+H).
- or -
Click the Find or Replace toolbar buttons.
- or -
Right click in the logic editor, and click Search → Find or Search → Replace.

2 In the Find What box, enter the value you want to find in the Address field.
Note: Addresses must be within the valid range of addresses for the current project. 
Symbols must be a valid symbols format.
Note: The default value type is Address.

3 If you clicked Replace in step 1, enter the replacement value in the Replace With 
field.

4 Enter values in the Start and End fields in the Network Range box to define a range 
of networks to search. A value of 1 to the maximum network number is allowed.
Example: You can search for address 40001 in networks 10-20 only.
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Using Find/
Replace - 
Advanced 
Search

5 Click Find or Replace to complete the operation.
If you click Find, the search results are displayed in the search panel.
If you click Replace, the dialog box remains open, and a message indicating that 
a search has been completed appears in the Message Center window.

Step Action

Step Action

1 Click Edit → Find (Ctrl+F).
- or -
Click the Find toolbar button.
- or -
Right click in the logic editor, and click Search → Find.

2 Click Advanced.

3 In the Search Where box, click one of the following areas from the list.
Entire Project
Logic
Traffic Cop
Peer Cop
I/O Scanner
Configuration

4 In the Search For box, click one of the following value type buttons.
Address
Symbol
Function/Address
Function
Disabled
Duplicate Coils

Note: The fields available in the Find What box are dependent on the value type 
button you click.
Note: The Symbol button is unavailable by default. To search for symbols (see 
p. 64), make sure you select the Enable Symbols (see p. 51) check box in the 
Project tab of the Properties dialog box.

5 Enter the value you want to search for in the Find What field.
Note: If you clicked the Disabled or Duplicate Coils button in step 4, no fields will 
appear in the Find What box.

6 If you clicked the Function/Address or Function button as the value type in the 
Search For box, a second field called Instruction will appear under the Find What 
box. Select an instruction from the Instruction list.

7 Enter values in the Start and End fields in the Network Range box to define a range 
of networks to search. A value of 1 to the maximum network number is allowed.

8 Click Find or Replace to complete the operation.
If you click Find, the search results are displayed in the search panel.
If you click Replace, the dialog box remains open, and a message indicating that 
a search has been completed appears in the Message Center window.
70 31003882 12/2006



Working with Projects
Using Step 
Search

You can only use the Step Search function in an advanced search (see p. 70).

Using Goto 
Search

The Goto feature allows you to navigate to a specified item in your logic. You can 
specify any coil, network, or segment. If the specified item is found, your logic editor 
will automatically display the item.

Using 
Documentation 
Search

The Documentation feature allows you to search for a specific text item in the current 
project. These items may be found in descriptors, symbols, short comments, long 
comments, or page titles.

Step Action

1 Follow steps 1-7 in the table above.

2 Select the Step Search check box, and click Find.

3 When the search finds the first source address, click one of the following from the 
Step Search dialog box.

Find Next: Continues the search for the next source address.
Mark: Marks the current search result and adds it to the Mark table (see p. 175).
Find All: Finds all results without displaying the Step Search prompt.
Stay: Cancels the search, and remains at the current position.
Cancel: Cancels the search, and returns to the position where the search 
started.

Step Action

1 Click Edit → Find (Ctrl+F).
- or -
Click the Find toolbar button.
- or -
Right click in the logic editor, and click Search → Find.

2 Click the Goto tab.

3 Click one of the following buttons:
Coil
Network
Segment

4 Enter a coil address, network number, or segment number depending on the choice 
you made in the previous step.

5 Click Goto.
Note: If the specified location does not exist, a message will be displayed stating 
that the item was not found.

Step Action

1 Click Edit → Find (Ctrl+F).
- or -
Click the Find toolbar button.
- or -
Right click in the logic editor, and click Search → Find.
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Using the Search 
Results Panel

 

2 Click the Documentation tab.

3 Enter a text string in the Find What field.
Note: Text strings can contain any combination of alphanumeric characters 
including punctuation. Note that *, ?, and # are reserved characters, and will be 
treated as wild cards if they exist in the string. (The text strings search similarly to 
Microsoft Word searches.)
The wild cards have the following properties.

* - searches for any combination of characters
? - searches for any single character
# - searches for any number

4 Select one or more of the following check boxes in the Search Where field.
Descriptors
Short Comments
Long Comments
Symbols
Page Title

Note: The search will find symbol matches even if Symbolic Addressing is turned 
off.
Note: Short comments and descriptors include documentation for traffic cop. Traffic 
cop descriptors are not displayed or editable in the document editor; however, the 
search will find results in this documentation. Documentation search, therefore, can 
be used to find locations of traffic cop cards based on their names, which are stored 
in the descriptors.

5 Click Find to conduct a search based on the specified settings. The All tab of the 
Search Results panel appears.

6 Click Close.

Step Action

Step Action

1 Click View → Search.

2 In the Search Results panel, select one of the following tabs.
All - Shows all search results, preceded by the first letter of the area in which the 
results were found.
Example: A peer cop result might be P.L1,SO,Dev:01. See p. 73 below for more 
information on the format of the search results.
Logic - Shows only logic search results.
TCop - Shows only traffic cop search results.
Peer Cop - Shows only peer cop search results.
I/O Scan - Sows only I/O scan search results.
Config - Shows only configuration search results.

Note: Documentation search results always appear in the All tab.

3 Double-click the cell that contains the location of the address that you want to go to.

4 To close the Search Results panel, click x in the top, right-hand corner.
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Search Results 
Information

Search results information are presented in one of the following formats:

Logic Search Results

Logic search results are in the format of INST.nnnn.r.cc. The following table shows 
the notation used:

Traffic Cop Search Results

Traffic Cop search results are in the format of Hhh,Ddd,Rr,Sss. The following table 
shows the notation used:

Peer Cop Search Results

Peer Cop search results are in the format of L1,XX,Dev:dd. The following table 
shows the notation used.

I/O Scan Search Results

I/O Scan search results are in the format of Card:c,T:ttt. The following table shows 
the notation used.

Notation Description

n network number

r row number

c column number

Notation Description

h head

d drop

r rack

s slot

Notation Description

L link number

XX link area

D device number

Notation Description

C card number

ttt transaction number
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Documentation Search Results

Documentation search results are presented in a three-part notation such as D-
000009-Y. In this example, the D denotes that this is a documentation search result. 
The second part of the notation, 000009 in this example, is a reference. The 
reference may be a normal address, a traffic cop location, a network number, or any 
other reference type that allows documentation. The third part, Y, represents the 
location where the text was found. In this case, Y refers to a symbol location (see 
the table below).

The following table shows types of references.

The following table shows types of locations. Multiple locations may exist for each 
reference.

Addresses 0xxxxx, 1xxxxx, 3xxxxx, 4xxxxx

XMem 6ff,xxxx

Networks Nxxxxx

Segments Sxxxxx

Processor Pxxxxx

Labels Lxxxxx

TCop Head Hxx

TCop Drop HxxDxx

TCop Rack HxxDxxRxx

TCop Slot HxxDxxRxxSxx

D Descriptor

S Short Comment

L Long Comment

P Page Title

Y Symbol
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Working with Projects
Address Used

Overview The Address Used tables keep track of what addresses are used in logic, traffic cop, 
peer cop, and the I/O scanner. Each address has its own cell in the address used 
grid.

The Address Used tables are updated every time an address is changed in one of 
the above areas. The changes are reflected in the Used Table panel. The Used 
tables are useful for determining what addresses are used, how they are used, and 
how many times they are used. 0xxxx, 1xxxx, 3xxxx, and 4xxxx address types are 
tracked. The tables reflect the content of the currently selected project; switching 
projects updates the used tables.

If the project is in online mode, there is a separate set of used tables for the online 
device. This is due to the fact that the online device may have different contents than 
the project database.

Using the 
Address Used 
Tables

  

Note: If the project is in either offline or combined mode and you need to switch to 
online mode while the Address Used table is displayed, you must rebuild the 
Address Used table (see p. 76) before you can view the results.

Note: If you are using the Direct to Online (see p. 50) mode, you must rebuild the 
Address Used tables (see p. 76) each time you connect to a controller using Direct 
to Online because the data is not directly stored in the controller.

Step Action

1 Click View → Address Used.

2 To view an address type, click the corresponding tab.
0xxxxx
1xxxxx
3xxxxx
4xxxxx

3 To select an address for logic, click the address from the used table and drag 
and drop it into the instruction that you want to use the address. 

4 To display the address used legend, select the Legend check box.
To hide the address used legend, clear the Legend check box.
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Address Used 
Legend 
Descriptions

The Address Used table displays the following information, as noted in the legend.

Finding a Free 
Address

 

Rebuilding the 
Address Used 
Tables

To rebuild the Address Used table, click Rebuild.

Display Description

Top-left purple square Address is used in logic.

Top-right blue square Address is used in the traffic cop.

Bottom-left green square Address is used in the Peer Cop.

Bottom-right yellow square Address is used in the I/O Scanner.

An overlaid C Coil is used in logic.

An overlaid D Duplicate coil is used in logic.

Step Action

1 Click the tab of the address type you wish to find.

2 Click Find Free.

3 Enter an address where the search begins in the Start Address field.

4 Enter the number of free addresses in a row that you need in the Length field.

5 Click Find to search for the free address(es).

6 Click Close.

Note: If you are in online mode, rebuilding the address used table requires a read 
from a PLC. The used tables are unavailable while being rebuilt.
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The Knowledge Base

Overview The Knowledge Base is a user-defined library of accumulated process experience 
relating to a specific project. It is used to identify solutions to problems that have 
occurred in the past. It is also used to keep maintenance records of fixes.

Opening the 
Knowledge Base

Double-click Knowledge Base in the project navigation panel.

- or -

Click Project → Knowledge Base.

- or -

Click the Knowledge Base toolbar button.

Searching for 
Keywords in the 
Knowledge Base

In the Knowledge Base dialog box:

Note: Each project has its own knowledge base, i.e., the knowledge base is 
specific to the project.

Step Action

1 Enter a word in the Keyword field.

2 Click Search.
Result: All fields in the knowledge base are searched for the keyword.
Note: After you click Search the first time, the button changes to a Find Next 
button.

3 To find the next instance of the keyword, click Find Next. The search starts from 
the first record in the grid.
Note: You may also search for partial word matches.

Note: 
If you click a different record while the search is processing, the search will 
continue from that location.
If you click Add, Delete, Edit, or Print while the search is processing, the search 
will reset itself and the button will change from Find Next to Search.
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Adding a Record 
to the Knowledge 
Base

In the Knowledge Base dialog box:

Deleting a 
Record from the 
Knowledge Base

In the Knowledge Base dialog box, select the record you want to delete and click 
Delete.

Printing the 
Knowledge Base

In the Knowledge Base dialog box, click Print. The ProWORX 32 print setup 
appears.

Step Action Comment

1 Click Add. The Knowledge Base Entry dialog box 
opens.

2 Enter a name in the Author field. Maximum: 55 characters.

3 Enter the problem description in the 
Problem field.

Maximum: 275 characters.

4 Enter the solution description into the 
Solution field.

Maximum: 440 characters.

5 Enter the name of an image that may 
be associated with the problem or 
solution in the Image field.
The image name must be entered in 
full including the file extension.
Example: Image1.bmp is correct; 
whereas Image1 is not.

Valid image types are .bmp and .jpg.
The image must reside in 
ProWORX\32\Projects\KBImages.
Maximum image name length: 255 
characters.

6 Click OK to save the record. The Date/Time are added automatically 
after clicking OK.
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Communications Setup
At a Glance

Overview ProWORX 32 can communicate with controllers in several ways. This chapter 
explains how to configure ProWORX for several common types of network 
connections. This chapter also describes how to select and attach to a controller, 
both directly and by scanning your entire network for devices.

What's in this 
Chapter?

This chapter contains the following topics:

Topic Page

Communications Overview 80

Configuring Modbus Communications 81

Modbus Communications by Modem 82

Configuring Modbus Plus Communications 86

Configuring Ethernet Gateway Communications 87

Configuring TCP/IP Communications 88

Network Explorer 89
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Communications Setup
Communications Overview

Overview Before your computer can connect to a controller (or, for some systems, the 
gateway, which relays information to and from the controller), you must configure 
ProWORX 32 for your communication protocol and settings.

Opening the 
Communications 
Setup

Double-click Communications in the project navigation panel.

- or -

Click Project → Communications.

- or -

Click the Communications toolbar button.

Setting the 
Default 
Communications 
Type

Click the tab of your communications protocol.
Modbus
Modbus Plus
Gateway
TCP/IP

Editing 
Communications 
Parameters

To edit a communications parameter:

Communicating 
Using the Server

 

Note: To connect with each other, your computer and controller must be 
configured for the same communication protocol and settings.

Step Action

1 Double-click the parameter.
- or -
Click the parameter, and click Change Setting.

2 Make the desired changes in the Edit dialog box, and click OK to save changes.

Step Action

1 Ensure that you are logged on to the ProWORX Server.

2 To communicate with PLCs through the server’s communications portal, select 
the Use server to communicate check box in the lower, left-hand corner.
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Communications Setup
Configuring Modbus Communications

Overview Modicon’s master/slave protocol is standard on 984 and many other controllers. In 
the Communications Setup dialog box, click the Modbus tab if your computer is 
connected to a controller’s Modbus port, either directly or through a modem.

Setting Modbus 
Parameters

Click the Modbus tab and set the following communications parameters.

When you finish configuring the parameters, click OK.

Note: The controller must have the same Modbus settings as the computer. Set 
Modbus parameters for your PLC with the Ports tab of the Controller Configuration 
window or with its DIP switches.

Parameter Description

Modbus Address The Modbus address of the PLC.

Port Identifies which serial port on your PC is connected to the controller 
or modem (if you are connecting to the controller through one). 
Default is COM1.

Baud Rate Defines the data transfer speed of your PC’s serial port in bits per 
second. The PC and controller must be set to the same baud. 
Default is 9600.

Parity Adds a check bit to a packet to make the number of binary ones 
always either odd (odd parity) or even (even parity). If parity is set 
to none, the check bit is not added. The PC and controller must use 
the same parity. Default is even.

Stop Bits Sets the number of bits at the end of a packet and prepares the 
receiving device for the next packet. The PC and controller must 
use the same number of stop bits. Default is 1.

Data Mode defines the data protocol (RTU or ASCII) for this communications 
mode. Both the PC and controller must use the same data protocol. 
Default is RTU.

Timeout Specifies the length of time the PC will wait for successful 
communication with a controller before displaying an error 
message. Default is three seconds.

Modem Type If your computer is connected directly to the controller, set the 
modem type to none. If your computer is directed to the controller 
through a modem, it must be configured (see Modbus 
Communications by Modem, p. 82).
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Modbus Communications by Modem

Overview Controllers in remote locations can be equipped with RS-232 modems. Your 
computer can connect to the controller (by telephone, radio, or microwave systems) 
using its own modem. Once the connection is established, the computer and 
controller behave as if they were connected directly through a Modbus network.

You can easily configure ProWORX 32 to connect to controllers through dial-up and 
dedicated-line modems. Before you begin, confirm that

the controller is properly connected to its RS-232 modem
your computer is properly connected to its modem
the modems’ DIP switches, if applicable, are set as follows

DIP switch settings:

After you configure ProWORX 32 to use a modem, it checks to see whether there is 
an active connection each time you select a device on your network.

If it cannot find one, ProWORX 32 asks you for a phone number to dial or, if your 
modem uses a dedicated line, opens a connection automatically.
If it finds a connection (or after opening one), you can choose to select a Modbus 
device or close the connection and open a new one.

Use a modem connection to a controller just like a direct Modbus link. You can scan 
for and attach to Modbus devices (and Modbus Plus devices, if the controller 
supports Bridge Mode to allow you to connect to a Modbus Plus network) just as you 
normally would.

Modem DIP Switch Setting Example: US Robotics Modem DIP 
Switches (seen from back)

Data Terminal Ready Always On Switch 1 (on left): Down

Verbal Word Results Switch 2: Up

Result Code Display Enabled Switch 3: Down

Command mode local echo Switch 4: Up

Auto Answer Switch 5: Up

Carrier Detect Normal Switch 6: Up

Load Non-Volatile RAM Defaults Switch 7: Up

Use AT Command Set (Smart Mode) Switch 8 (on right): Down
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Setting the 
Modbus Modem 
Parameters

In the Communications Setup dialog box: 

Step Action

1 Click the Modbus tab, and set the communications parameters (see Configuring 
Modbus Communications, p. 81).
Note: The controller must have the same Modbus settings as the computer. 
Open Configuration in the project navigation panel. Click the Ports tab to set 
Modbus parameters for your PLC.

2 Double-click Port.
- or -
Click Port, then click Change Setting.

From the Value list, select the computer port connected to the modem; 
otherwise, ProWORX 32 won’t be able to locate it.
Click OK.

3 The Modbus configuration (see Modbus 10-bit Configurations, p. 84) must send 
exactly 10 bits per data package to your modem.
Modems generally expect 10 bits in a data package; however, the Modbus 
defaults (even parity, RTU mode, and one stop bit) send 11 bits per package.
Change the Modbus settings to provide 10 bits per data package, or ProWORX 
32 will not be able to communicate with the modem. Alternatively, if your modem 
supports large data packages, you can set its DIP switches to allow 11 bits per 
data package (see your modem’s manual).

4 Double-click Modem Type.
- or -
Click Modem Type, then click Change Setting.

From the Value list, select the type of modem (see Modbus Modem Type 
Descriptions, p. 84).
Click OK.

5 To edit the modem parameters (see Modbus Modem Parameter Descriptions, 
p. 85), click Modem Setup. Edit the following fields as necessary.

Phone Number
Initialization
Dial Command
Command Suffix
Hangup Command

Click OK.
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Modbus 10-bit 
Configurations

These Modbus configurations provide 10 bits per data package:

Modbus Modem 
Type 
Descriptions

Modem Type specifies the kind of modem connected to your computer.

Parameters ASCII Mode ASCII Mode RTU Mode

Start Bit 1 bit 1 bit 1 bit

Data 7 bits 7 bits 8 bits

Stop Bits: 1 1 bit 1 bit

Stop Bits: 2 2 bits

Parity: None 0 bits 0 bits

Parity: Odd or Even 1 bit

Total 10 bits 10 bits 10 bits

Modem Type Description

None (Default) For direct Modbus connections between the PC and controller without a 
modem. This setting disables the other modem options.

Dial-Up For standard modems that do not require a password. If you are unsure, 
try this setting first. When you select a device, ProWORX 32 asks you 
for a number to dial.

Dial-Chat For password-protected modems. After the connection is established, a 
terminal window opens so you can enter text. When you select a device, 
ProWORX 32 asks you for a number to dial.

Line/J478 For modems with a dedicated telephone line to the controller. You do 
not have to type a number to dial. This setting disables the other modem 
options.

LineRTS For radio or microwave modems with a dedicated link to the controller. 
You don’t have to type a number to dial. This setting disables the other 
modem options.
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Modbus Modem 
Parameter 
Descriptions

Set the following modem parameters.

When you finish configuring the parameters, click OK.

Parameter Description

Phone Number The phone number of the modem to which the PLC is attached.

Initialization Some modems require special initialization commands such as ATZ 
before they can be used. Type a sequence of Hayes modem 
commands in this field for ProWORX 32 to send to your modem. 
Check your modem’s manual for the commands to turn off error 
correction, compression, and software flow control and turn on verbal 
word results.

Dial Command Type ATDT for tone dialing (default) or ATD for pulse dialing. This 
prefix is sent to the modem along with the phone number you type in 
the Select Device dialog. To instruct the modem to pause for half a 
second, type a comma (,).

Command Suffix Characters appended to every command you send to the modem, 
including the Initialization string and Hangup command. The default is 
a carriage return and a line feed.

Hangup Command To hang up your modem, ProWORX 32 sends the standard Hayes 
modem command ATH. If your modem uses a different command, 
enter it here. This command is prefixed with ,,,+++,,,. Hanging up can 
take up to three seconds.
31003882 12/2006 85



Communications Setup
Configuring Modbus Plus Communications

Overview In the Communications Setup dialog box, select the Modbus Plus tab if your 
computer is connected to a Modbus Plus network through a network adapter card 
such as an SA85.

Setting Modbus 
Plus Parameters

Click the Modbus Plus tab, and set the following communications parameters.

When you finish configuring the parameters, click OK.

Parameter Description

Modbus Plus Address The Modbus Plus address of the PLC.

Adapter Sets an identifying number for an SA85 network card. Up to two 
SA85 cards, numbered 0 or 1, can be installed. A card’s identifying 
number in ProWORX 32 must be the same as in the device 
command in the PC’s CONFIG.SYS file. Default is 0.

Timeout Specifies the length of time the PC will wait for successful 
communication with a controller before displaying an error 
message. Default is 3 seconds.
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Communications Setup
Configuring Ethernet Gateway Communications

Overview A gateway connects two networks that would not normally be able to communicate 
with each other. ProWORX 32 supports Modicon’s Ethernet to Modbus Plus 
gateway, which bridges your computer’s TCP/IP Ethernet to the controller’s Modbus 
Plus network.

Setting Ethernet 
Gateway 
Parameters

In the Communications Setup dialog box, click the Gateway tab, and set the 
following communications parameters.

When you finish configuring the parameters, click OK.

Note: Your computer’s Ethernet address is set in Windows by your network 
administrator (as is its sub-network mask address, if necessary).

Parameter Description

Gateway Type Double click Gateway Type.
- or -
Click Gateway Type, then click Change Setting.

From the Value list, select one of the following gateways.
SGATE (CEV200)
NR&D MEB
GATEWAY?
CEV300

Index Double click Index.
- or -
Click Index, then click Change Setting.

In the Value field, enter the destination index of the PLC.

IP Address Double click IP Address.
- or -
Click IP Address, then click Change Setting.

In the Value field, enter the TCP/IP address of the gateway.

Timeout Specifies the length of time the PC will wait for successful 
communication with a controller before displaying an error 
message. Default is 3 seconds.

Double click Timeout.
- or -
Click Timeout, then click Change Setting.

In the Value field, enter the timeout.
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Configuring TCP/IP Communications

Overview Some controllers can be equipped with Ethernet TCP/IP modules. In the 
Communications Setup dialog box, click the TCP/IP tab if both your computer and 
controller use TCP/IP networking, regardless of whether they are on the same 
network or are connected by a gateway.

Setting TCP/IP 
Parameters

Select the TCP/IP tab, and set the following communications parameters.

When you finish configuring the parameters, click OK.

Note: Your PC’s TCP/IP address is set in Windows by your network administrator 
(as are the gateway and sub-network mask addresses, if necessary).

Parameter Description

IP Address Double click IP Address.
- or -
Click IP Address, then click Change Setting.

In the Value field, enter a PLC’s Ethernet address in standard TCP/IP format: 
four numbers ranging from 0 to 255, separated by periods.
Example: 10.0.254.68 is a valid IP address.

Timeout Double click Timeout.
- or -
Click Timeout, then click Change Setting.

In the Value field, enter a value that specifies the length of time the PC will 
wait for successful communication with a controller before displaying an error 
message. Default is 3 seconds.

Starting IP 
Address

Double click Starting IP Address.
- or -
Click Starting IP Address, then click Change Setting.

In the Value field, enter the starting IP address in standard TCP/IP format: 
four numbers ranging from 0 to 255, separated by periods.

Ending IP 
Address

Double click Ending IP Address.
- or -
Click Ending IP Address, then click Change Setting.

In the Value field, enter the ending IP address in standard TCP/IP format: 
four numbers ranging from 0 to 255, separated by periods.
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Network Explorer

Overview The Network Explorer finds controllers, bridges, bridge multiplexers, and other 
devices attached to networks. ProWORX 32 displays the devices it finds by their 
address number, and also shows their type, mode, and status.

The results of a network scan are displayed in the panel tree on the left of the 
display. If any PLCs are found, they are displayed on the right panel. The right panel 
has two different views, the graphical, and the list view. The graphical view displays 
a picture of the series of controller found, along with all of its data. The list view 
displays the data in a spreadsheet format.

Using the 
Network 
Explorer

Step Action

1 Click Utilities → Network Explorer.
- or -
Click the Utilities tab in the project navigation panel, then double-click 
Network Explorer.
- or -
Double-click Communications in the project navigation panel, then click 
Network Explorer at the bottom right of any tab in the Communications 
Setup dialog box.

2 The Communications Setup dialog box opens. Select the default 
communications type (see Communications Overview, p. 80).

Click OK if you opened Network Explorer through the Utilities menu.
- or -
Click Network Explorer if you are running this function through the 
Communications Setup dialog box.

3 To return to the Communications Setup dialog box at any time, click 
Communications Setup.

4 To switch between views, click either the Graphical View button or the List 
View button.

5 The following information is provided for each controller.
Address
Controller Type
PLC State: Running, Optimized, Stopped (the Stopcode is displayed). For 
more information, see Stopcode Error Analysis, p. 329.
Battery State: Good or Bad.
Memory Protect: On or Off.
PLC Name: In certain controllers, you can save the project name inside of a 
loadable. The project name will be retrieved if the controller is running and the 
loadable is in logic.
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Configuring a Controller
At a Glance

Overview The configuration editor is used to edit and view the current controller configuration 
of the project. The configuration editor displays configuration options (properties) 
within several tabs. Each tab contains one or more property lists used to display and/
or edit items relating to controller configuration. Properties that are displayed 
depend on the controller that is being configured.

What's in this 
Chapter?

This chapter contains the following topics:

Topic Page

Controller Configuration 92

Controller Details for Online DIM Awareness Controllers 93

General Tab 94

Ports Tab 97

Loadables Tab 99

Loadable Library Wizard 101

Smart Configuration 103
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Configuring a Controller
Controller Configuration

Overview Before you begin, use the New Project Wizard (see p. 42) to select the right type of 
controller. The options that appear in the configuration editor depend on the 
controller type, so select only those that your controller supports.

Configuring a 
Controller

 

Step Action

1 Double-click Configuration in the project navigation panel.
- or -
Right-click Configuration in the project navigation panel, and click Open 
Editor.
- or -
Click the Configuration toolbar button.

2 Click the tab for the options you want to configure.
General: Configures a controller’s memory, including the number of coils and 
registers, I/O cards and drops, the amount of memory set aside for 
Configuration Extensions, and the number and size of the ASCII messages 
you want to use.
Ports: Configures the controller’s serial and ASCII ports.
Loadables: Extensions to a controller's capabilities. When they appear as 
instructions (most of the time), they are represented as 3 node instructions.

3 Click the parameter rows to update.
Press Enter to accept the changes.
- or -
Press Esc to decline the changes.

4 When you close the configuration editor, a prompt appears asking if you want to 
Save project changes.

Click Yes to save the changes.
Click No to cancel the changes.
Click Cancel to stay in the configuration editor.
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Controller Details for Online DIM Awareness Controllers

Overview You may configure a controller that is in DIM awareness when you are in online 
mode with the controller. Some controllers may allow different executive details. You 
must provide the details of the current executive for your controller before you can 
successfully finish configuring it. 

Configuring the 
Controller

Follow the steps below to configure the controller in online DIM awareness.

Step Action

1 Open the configuration editor (see p. 92).

2 Review and edit the details for your controller by clicking them in the details list.

3 Click OK to configure your controller with these settings.
- or -
Click Cancel to abort the operation and leave your controller in DIM 
awareness.
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General Tab

Overview The general tab in the configuration editor allows you to configure a controller’s 
memory. It contains many important options, including the number of coils, registers, 
segments of logic, I/O cards the controller will use, the amount of memory it sets 
aside for configuration extensions, and the number and size of its ASCII messages.

General Tab 
Parameters

The following parameters are editable.

Parameter Description

Registers For each of the 0xxxx, 1xxxx, 3xxxx, and 4xxxx register fields, type the 
number of registers the controller will use. The controller polls all of 
these registers for each scan. So, to keep your controller scanning 
quickly, set up only as many registers as you need.

Segments Type the number of logic segments the controller will use.

I/O Drops Different controllers use different I/O drops.
If you have a controller that uses channels instead of I/O drops, type 
the number of channels the controller I/O will use. Channels always 
come in pairs, so the number must be even.
If you have a Micro series controller in parent mode, type the 
number of children (0 to 4) associated with it.
If you have a Micro series controller in child mode, type the child ID 
(1 to 4).

I/O Words Quantum, Atrium, 785E, Momentum, Compact (E258, E265, E275, 
E258) controllers only: Type the maximum number of I/O words that 
will be available for programming in the traffic cop. Check your 
controller documentation for the appropriate values.

DCP Drop ID 680, 685, 685E, 780, 785, 785E or 785L controllers only: If another 
computer uses this controller for distributed control, type the 
controller’s Distributed Control Processor ID number (0 to 32).

I/O Time Slice Type the amount of time the controller will devote to peripheral port 
communication, from 1 to 100 milliseconds. The default is 10 ms for 
984A, B, and X controllers and 20 ms for Quantum controllers.

Duplicate Coil Start Set the starting address to a non-zero value to enable the duplicate coil 
range (i.e., allow coil addresses within this range to be assigned to 
more than 1 coil).
Set the range to 0 to disable the duplicate coil address range. The 
starting address of the duplicate coil range is part of the configuration, 
and defines the entire range of coils that will be treated as duplicate 
coils. The range is from the starting address to the configured number 
of coils. Therefore, to enable the entire range of coils, set the starting 
address to 1.
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Remote Channels 984A-S901, 984B-S901, and 584 controllers only: Select from 2 to 
32 remote I/O channels. Channels always come in pairs, so this setting 
must be an even number.

Total Messages Controllers that support ASCII messaging only: Type the total 
number of ASCII messages the controller will use.

Message Words Controllers that support ASCII messaging only: Type the length (in 
machine words) of your controller’s ASCII messages. One machine 
word is equal to two ASCII characters.

ASCII Ports Type the number of ASCII ports on the controller. This setting must be 
an even number.

B984 Controller Select the type of B984 controller you have: B884 or B886.

Input Latched Select this option if you want the controller to maintain the input state 
on power-down. Inputs remain frozen for one scan when the controller 
is powered back up.

Settling Time Group Settling Time allows you to set parameters for input digital 
filtering.

Each input value is polled through a filter based on a time window. 
You can set the duration of the time window between 200 
microseconds and 19.8 ms (in 200 microsecond increments).
The module samples each input every 200 microseconds, and uses 
the time window associated with the input to determine the input 
state. If the scanned input state is OFF, the input state is set OFF. 
If the scanned input state is ON, the input state is set based on a 
history queue. If the input was ON one time window ago, the input 
is set ON; if the input was OFF, the input state is set OFF.
The inputs are divided into four groups. The Settling Time of each 
can be configured separately.

Group 1: Inputs 1-4
Group 2: Inputs 5-8
Group 3: Inputs 9-12
Group 4: Inputs 13-16

Battery Coil Type the control address for the controller’s battery.

Timer Register Type the register offset used to store the controller’s timer value.

Time of Day Clock Type the register offset used to store the controller’s clock (see p. 176) 
value.

Config Extension 
Used

Displays the amount of config extension space used. This field is not 
editable.

Parameter Description
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Config Extension 
Size

Type the amount of memory (in machine words) to be set aside for 
Configuration Extensions. Use the following information to calculate the 
minimum Configuration Extension size.

Configuration Overhead: 1 word
Extension Overhead:

TCP/IP: 100 words, for M1E controllers: 20 words
Data Protect: 8 words
S980 Address: 8 words
Quantum Hot Standby: 17 words
VME Bus: 9 words
Profibus: approximately 4096 words; check your Profibus 
manual for details
Peer Cop: 5 words
Links: 3 words per link, plus:
-) Global Output: 4 words per link
-) Global Input: 2 words overhead plus, for each of up to 64 
devices, 1 + twice the number of up to 8 sub-entries (max. 8). 
The maximum is 2 + (64*(1+2*8)) = 1090 words.
-) Specific Output: 2 words overhead plus 2 words for each of up 
to 64 devices. The maximum is 2+(2*64) = 130 words.
-) Specific Input: 2 words overhead plus 2 words for each of up 
to 64 devices. The maximum is 2+(2*64) = 130 words.
SY/MAX: 52 words
I/O Scanner: 4 M1E controllers; 10 words of overhead; 40 words 
of overhead for anything other than M1Es; 12 words/transaction.

Enable Skips Click True to enable skips (segments can be skipped during solves).

Watch Dog Time Type the time-out delay for the Watch Dog Timer, in tens of 
milliseconds. The controller adds 250 ms to the value you enter. The 
default is 0000, which represents 250 ms.

Bridge Mode Click True to enable Bridge Mode. Some controllers support Bridge 
Mode, which allows you to connect to a Modbus Plus network through 
their Modbus port 1.
Note: To use Bridge Mode, your controller’s MEM/DIP switch must be 
in the MEM position.

Parameter Description
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Ports Tab

Overview From this tab in the configuration editor, you configure the controller’s Modbus and 
ASCII ports. These settings do not affect the communications setup of your PC in 
any way — only the controller’s.

Modbus Ports The following parameters are editable.

Simple ASCII 
Ports

Some Modicon controllers have RS-232 ports as part of remote I/O drops. Advanced 
programmers can use these ports (called simple ASCII or ASCII/DAP ports) for 
serial communications between controllers and data terminal equipment. In ladder 
logic, use the Block Move (BLKM) instruction to send and receive simple ASCII 
messages. Configure the number of ASCII ports for a controller by setting the ASCII 
ports parameter in the general tab.

Parameter Description

Mode Defines the data protocol (RTU or ASCII) for this communications mode. 
Both the PC and controller must use the same data protocol. Default is RTU.
If you select ASCII protocol for a port, you can only configure its parity, stop/
data bits, and baud settings.

Parity Adds a check bit to a packet to make the number of binary ones always either 
odd (odd parity) or even (even parity). If parity is set to none, the check bit is 
not added. The PC and controller must use the same parity. Default is even.

Stop/Data Sets the number of bits at the end of a packet, which prepares the receiving 
device for the next packet. The PC and controller must use the same number 
of stop bits. Default is 1.

Baud Defines the data transfer speed of the controller’s Modbus port in bits per 
second. The PC and controller must be set to the same baud rate. Default is 
9600.

Head Quantum controllers only: Sets the slot number on the local drop 
backplane where the CPU resides.

Address Assigns the Modbus address for the port. Default is 1.

Delay Sets the amount of time in tens of milliseconds the controller waits after 
receiving a message before sending an acknowledgment. Default is 1 (10); 
max. is 20 (200).

Modbus Port 
2 Type

Momentum M1 controllers only: Sets the port type of Modbus Port 2, to 
either RS232 or RS485.
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The 984A, 984B, and Micro 311, 411, 512, 612 controllers have simple ASCII ports 
with fewer properties than Modbus ports.

ASCII Ports This table allows the user to set each port to be compatible with the device to which 
it is connected.

There are five properties that can be set.

Micro Ports If you are using a Micro 311, 411, 512, or 612 controller, assign its ports using the 
Micro port list. The assignments in the list are combinations of the controller’s 
COM1, COM2, and I/O expansion link port. The assignments available depend on 
which Micro I/O mode you set in the controller details section of the general tab in 
the controller configuration editor.

Parameters Description

Parity Adds a check bit to a packet to make the number of binary ones always 
either odd (odd parity) or even (even parity). If parity is set to none, the 
check bit is not added. The PC and controller must use the same parity 
setting. Default is even.

Stop/Data Sets the number of bits at the end of a packet which prepare the receiving 
device for the next packet. The PC and controller must use the same 
number of stop bits. Default is 1.

Baud Sets the data transfer speed of the controller’s Modbus port in bits per 
second. The PC and controller must be set to the same baud. Default is 
9600.

Property Description

Parity Select Even, Odd, or None.

Baud Rate The communication speed is set to one of the following baud rates: 50, 75, 110, 
134.5, 150, 300, 600, 1200, 1800, 2000, 2400, 3600, 4800, 7200, 9600, and 
19200.

Number of 
Stop Bits

Select the number of stop bits for each data byte (1 or 2). A system with NO 
PARITY generally uses 2 stop bits, while a system with PARITY uses 1 stop bit.

Number of 
Data Bits

Select the number of data bits issued from the ASCII port (a number from 5 to 
8). The choice of 7 data bits is standard for most ASCII devices.

Keyboard/
Non-
Keyboard

Select a keyboard or non-keyboard device. This function allows you to modify 
the response of the ASCII port to match the type of device to which it is 
connected. In keyboard mode, the port echoes back the input character and 
requires delimiters to move to the next data field and to terminate the message. 
Editing input data is possible from a terminal. In non-keyboard mode, no data is 
echoed back. As a data field is completed, the next available data field is entered 
or the message automatically terminates. No editing capabilities are supported.
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Loadables Tab

Overview User loadables are instructions that do not come with a controller. Instead, they are 
supplied by Modicon or third-party vendors, and must be copied into a controller or 
project to be used.

Loadables are extensions to a controller's capabilities. When they appear as logic 
function blocks (most of the time), they are represented as three node instructions.

The display shows a table of loadables and related information. A check mark is 
shown beside loadables that are present in the project. Loadables with no check 
mark are present in the loadable library, but are not currently available in the project. 
To add or delete a loadable from a project, select or de-select the associated 
checkbox.

Loadable 
Parameter

The following parameters are editable.

Updating 
Loadables 
Overview

Two possible scenarios that require you to update a loadable:

Periodically, new versions of loadables become available. If you try to delete an 
old loadable from the configuration, the configurator alerts you that it is already 
used in logic, and prevents the loadable’s deletion. Since adding a loadable can 
be an extensive task, update loadable conveniently allows you to replace a 
loadable without first deleting it from logic. 
You may have read a controller’s data into a project where the controller data 
contained an .MSL loadable (i.e. an .EXE file from Schneider Electric or a third 
party vendor). If the controller had been run prior to performing the read, the MSL 
loadable in the project is unusable if written back to the controller. Use update 
loadable to get the MSL loadable back to a state where it can be written to the 
controller. Update loadable asks you for the original .EXE loadable. It places it into 
the project, and the project may then be rewritten successfully to the controller.

Note: You can only add loadables that are already part of a loadable library. Using a loadable 
is a two-step process: transferring it into a loadable library (see p. 101), then selecting it from 
the library into the controller or project by selecting the loadables’ check box in the loadables 
tab and saving changes.

Parameter Description

Name User loadable name

Opcode A unique two-digit hexadecimal number used to identify an instruction in the 
programmable controller logic

Version The version number of the installed loadable

Type Either MSL or USL
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Updating 
Loadables

To update a loadable in a project, right-click the loadable and click Update.

Copying a 
Loadable to a 
Controller

To copy a loadable to a controller or project:

Deleting 
Loadables

To delete a loadable from a controller or project, clear the loadable’s check box.

Step Action

1 Select the loadable’s checkbox.
Result:The Select Opcode dialog appears if no opcode has been set for the 
loadable.

2 Select an available opcode from the list, and click OK.

3 If you are offline, selected (checked) loadables are included in the project. Any 
new loadables you select will be added to the project when the configuration 
changes are saved. To use the loadables in a controller, write to the controller 
(see p. 109).

4 If you are in online mode, changes are not made to the current project. If you add 
loadables and close the configurator while online, the configurator makes the 
changes directly to the controller.
Note: The controller must be stopped.

5 If you are in online combined mode, any changes that you save are saved to the 
current project and then written to the controller.
Note: The controller must be stopped.

Note: You cannot delete a loadable if it is used in logic.
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Loadable Library Wizard

Overview Before you can place a user loadable into a controller or project, it must be read into 
the loadable library. A loadable library holds a set of loadables for you so that you 
only have to translate them to ProWORX 32 format once.

In the Loadable Library, you can read a loadable from disk, translate it to ProWORX 
32 format, and move it into a library. You can read loadables from an existing project, 
a Schneider Electric (.exe or .dat) or third party disk (.exe or .dat) or a ProWORX 
.TLD library file.

Using the 
Loadable Library

 

Note: Reading a user loadable into a loadable library does not copy it into your 
controller or project.
Using a loadable is a two-step process:
1. reading it into a loadable library
2. reading it into a controller or project (see p. 99)

Note: You can not open the loadable library wizard while the configuration editor 
is open.

Step Action

1 Click the Utilities tab in the project navigation panel, and double-click 
Loadable Library.
- or -
Click Utilities → Loadable Library.

2 Click one of the following buttons:
Edit opcode: (see p. 102) below.
View text: Displays the manufacturer’s notes for a loadable (if available).
Rebuild library: On rare occasions, a library of loadables can become 
damaged (for example, when a computer crashes and files are corrupted). 
ProWORX 32 allows you to recreate a library from its .USL and .MSL files.
Transfer loadable into loadable library: Transfer loadables from a project, 
an old ProWORX.tld file, Schneider Electric (.dat), or an .exe into the 
loadables library. Also use this option to update the version of existing 
loadables in the loadable library.

3 Click Finish to complete the wizard.
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Editing Opcodes An opcode is a unique number identifying a loadable in the controller or project. 
Because each opcode must be different, they may need changing.

When a loadable is added to a project or controller, the configurator will compare the 
new loadable's opcode with the opcodes already used in the controller by built-in 
instructions and previously loaded loadables. If it sees that the new loadable opcode 
will conflict, the Select Opcode window appears.

However, if you happen to know an opcode that won't conflict with the loadables 
already in your controller you can use the Edit opcode option in the wizard to make 
the change. Then when you add the loadable in configuration, you won't be 
prompted to provide a new opcode.
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Smart Configuration

Overview The Online Smart Configurator lets you make configuration changes without losing 
logic or traffic cop information stored in the controller.

The configurator will not let you save changes to the controller if:
a reduction in controller memory for a particular setting reduces it below the 
amount used by logic
modules, which are used in logic, are deleted

Example: The controller might contain logic addresses up to 10160, but you tried to 
reconfigure the number of 1x addresses to 32.

If this happens, you can either:
Make changes to your new configuration so that the addresses currently used in 
the controller fall within the appropriate address ranges.
- or -
Send configuration changes to the controller without attempting a smart 
configuration. You will lose all logic and traffic cop information stored in the 
controller.

Changing your 
Configuration 
Online without a 
Loss of 
Information

 

Step Action

1 Open the configuration editor (see p. 92).

2 In the configuration editor, select the required address ranges for your 
configuration.

3 To save the changes:
Click Apply.
- or -
Close the configuration editor.

Result: A dialog box opens, asking if you want to do a smart configuration.

4 Click Yes to proceed with a smart configuration, without losing logic or traffic cop 
information.

5 The smart configuration proceeds and requires a read from (see p. 107) and a 
write to (see p. 109) the controller.
Note: This may take some time.

6 If the smart configuration encounters problems, like newly configured address 
ranges that are too small for the current logic, you will be notified and returned 
to the configuration editor.
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Changing your 
Configuration 
Online with a 
Loss of 
Information

 

Step Action

1 Open the configuration editor (see p. 92).

2 In the configuration editor, select the required address ranges for your 
configuration.

3 To save the changes:
Click Apply.
- or -
Close the configuration editor.

Result: A dialog box opens, asking if you want to do a smart configuration.

4 Click No to proceed with a normal configuration.
Result: Logic and traffic cop information will be cleared.
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Working with Controllers
At a Glance

Overview This chapter explains how to use ProWORX 32 with a controller.

What's in this 
Chapter?

This chapter contains the following topics:

Topic Page

Initializing Logic in a Controller 106

Reading From a Controller 107

Writing to a Controller 109

Transferring Memory Contents to Controller EEPROM 112

Transferring the Flash RAM Executive 113

Transferring Memory Contents to Micro Flash RAM 114

Transferring Internal Flash or PCMCIA to Controller Flash 115

Starting and Stopping Controllers 117

PLC Status Viewer 118

Analyze Device 120
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Initializing Logic in a Controller

Overview Initializing logic erases the networks, register contents and ASCII messages in a 
programmable controller. The controller must be stopped before you can initialize 
logic.

It is strongly recommended that you read the contents of the controller to a backup 
database before initializing logic.

Initializing Logic Right-click your project in the project navigation panel, and click Online Commands 
→ Initialize Controller Logic.

- or -

Click Controller → Initialize Controller Logic.

- or -

Click the Initialize Logic in Controller toolbar button.

Note: A prompt appears to inform you that this action cannot be undone.
Click Yes to continue.
Click No to cancel.
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Reading From a Controller

Overview The Read from Controller function transfers memory contents from a programmable 
controller into a designated database. It is strongly recommended that you use this 
function to backup the contents of a controller before working with it online.

Reading from a 
Controller

  

Partial Reading 
from a Controller

You may read a partial component of a PLC program separately, including the 
following.

configuration, including configuration extensions
network logic, included used tables

Note: Ensure that you have selected the correct controller to read from and that 
the project you are reading into is backed up if necessary. Also, verify the 
communications settings for the correct address.

Step Action

1 To read the logic, traffic cop, configuration, loadables, ASCII, state and disabled 
tables:

Right-click your project in the project navigation panel, and click Online 
Commands → Read → Read.
- or -
Click Controller → Read.
- or -
Click Read from the Read from Controller toolbar button list.

2 To read only the extended memory registers:
Right-click your project in the project navigation panel, and click Online 
Commands → Read → Read Extended Memory.
- or -
Click Controller → Read Extended Memory.
- or -
Click Read Extended Memory from the Read from Controller toolbar 
button list.

3 A dialog box prompts you to confirm that you want to read the selected controller. 
Click Read to read all PLC components.
Note: If you wish to automatically rebuild the Address Used tables when the read 
is complete, select the Rebuild Address Used Tables after Read check box.

Note: To read a partial component of a PLC program separately, see p. 107 below. 

4 When the read is complete, click OK to return to ProWORX 32.
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data states and values
ASCII messages

When you select the Enable Partial Read check box, the following conditions apply.

Based on the above conditions, the required check boxes are selected in the dialog 
box, and you cannot clear them. In addition, a message is appended to the text label 
explaining why an option is unavailable. For example, if your controller and project 
match but the ASCII messages have changed, the screen message states that the 
ASCII and configuration sections must be read.

To perform a partial read:

If... Then...

the ASCII messages have changed between 
the PLC and the database,

both ASCII messages and configuration must 
be read.

the configuration has changed between the 
PLC and the database,

the logic and configuration must be read.

both ASCII and configuration have changed, only the state RAM option is available. The 
configuration and ASCII message check 
boxes are selected by default and cannot be 
cleared.

no changes have been made to the 
configuration or ASCII,

all options are available.

Step Action

1 Follow steps 1-3 in the table above (see p. 107).

2 You are prompted to confirm that you want to read the selected controller. Select 
the Enable Partial Read check box.
If the check box is selected, the four partial read options (configuration, logic, 
state RAM, and ASCII messages) are enabled based on the allowable conditions 
determined from the database vs. PLC changes. If the check box is cleared, all 
partial read options are checked and disabled, and a full read will be performed.

3 Select the Configuration check box to read this component.

4 Select the Logic check box to read this component.

5 Select the State RAM check box to read this component.

6 Select the ASCII Messages check box to read this component.

7 Click Read.
Note: If you do not click any components for partial read, you will see an error 
message, and no read is performed.
Note: If you wish to automatically rebuild the Address Used tables when the read 
is complete, select the Rebuild Address Used Tables after Read check box.

8 Click OK when the read is complete.
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Writing to a Controller

Overview The Write to Controller function writes the contents of a database to a controller. The 
controller must be stopped before you can write to it.

Writing to a 
Controller

 

Note: Ensure that you have selected the correct controller to write to and that the 
controller you are writing to is backed up if necessary. Also, verify the 
communications settings for the correct address.

Step Action

1 Follow this step to write the logic, traffic cop, configuration, loadables, ASCII, 
state and disabled tables. This command overwrites all existing PLC data.

Right-click your project in the project navigation panel, and click Online 
Commands → Write → Write All.
- or -
Click Controller → Write All.
- or -
Click Write All from the Write to Controller toolbar button list.

2 Follow this step to write the contents of the controller as long as addresses and 
function blocks in logic are supported in the destination controller. You can 
choose to update either the Logic, Coils Used, ASCII, and State/Disabled tables, 
or just the Logic and Coils Used):

Right-click your project in the project navigation panel, and click Online 
Commands → Write → Relocate Logic and Data.
- or -
Click Controller → Relocate Logic and Data.
- or -
Click Relocate Logic and Data from the Write to Controller toolbar button 
list.

3 Follow this step to write only the extended memory registers. Select all extended 
memory files or a specific extended memory file and click OK.

Right-click your project in the project navigation panel, and click Online 
Commands → Write → Write Extended Memory.
- or -
Click Controller → Write Extended Memory.
- or -
Click Write Extended Memory from the Write to Controller toolbar button 
list.
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Partial Writing to 
a Controller

You may write to a partial component of a PLC program separately, including the 
following.

configuration, including configuration extensions
network logic, included used tables
data states and values
ASCII messages

4 ProWORX 32 verifies that the controller and database match and the results are 
stated in the Project/Controller Validation dialog box. If the controller and 
database match, click Write. Potential reasons that the controller and database 
would not match include:

The controller being written to may not have enough memory for the logic 
being written.
The controller address ranges may not be large enough.
The controller instruction set may not match the database.
The database may use duplicate coils, which most controllers do not support.

Note: To write a partial component of a PLC program separately, see p. 110 below.

5 Click OK when the write is complete.

6 If the write command was cancelled at any time, go back to step 1.

Unintended System Operation
Canceling the write operation while downloading default register values will result 
in partially written data and the PLC can be placed into run mode. If your 
application relies on default register values (coil states, disabled states, register 
values, history tables, etc.), you must complete a full write operation prior to 
placing the PLC into run mode.

Failure to follow this instruction can result in injury or equipment damage.

Step Action

CAUTION
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When you select the Enable Partial Write check box, the following conditions apply.

Based on the above conditions, the required options are checked and disabled in 
the dialog box. In addition, a message is appended to the text label explaining why 
an option is disabled. For example, if your controller and project match but the ASCII 
messages have changed, the screen message would state that the ASCII and 
configuration sections must be written.

To perform a partial write:

If... Then...

the ASCII messages have changed between 
the PLC and the database,

both ASCII messages and configuration must 
be written.

the configuration has changed between the 
PLC and the database,

the logic and configuration must be written.

both ASCII and configuration have changed, only the state RAM option is available. The 
configuration and ASCII message boxes will 
be checked and disabled.

no changes have been made to the 
configuration or ASCII,

all options are available.

Step Action

1 Follow steps 1-4 in the table above (see p. 109).

2 You are prompted to confirm that you want to write to the selected controller. 
Select the Enable Partial Write check box.
If the check box is selected, the four partial write options (configuration, logic, 
state RAM, and ASCII messages) are enabled based on the allowable conditions 
determined from the database vs. PLC changes. If the check box is cleared, all 
partial write options are checked and disabled, and a full write will be performed.

3 Select the Configuration check box to write this component.

4 Select the Logic check box to write this component.

5 Select the State RAM check box to write this component.

6 Select the ASCII Messages check box to write this component.

7 Click Write.
Note: If you do not click any components for partial write, you will see an error 
message, and no write is performed.

8 Click OK when the write is complete.
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Transferring Memory Contents to Controller EEPROM

Overview This function works only with Compact controllers. This function cannot be 
performed while the controller is running. You must stop the controller first.

Tip: Memory Protect is a switch on your controller that stops you from altering the 
controller’s contents. The Memory Protect switch should be on, or the card 
overwrites memory on power up.

Transferring 
Controller 
Memory to 
EEPROM

 

Note: Do not attempt the transfer operation if the controller’s battery is low because 
the processor contents may be lost.

Step Action

1 Right-click your project in the project navigation panel, and click Online 
Commands → Write → Transfer to Flash/EEPROM.
- or -
Click Controller → Transfer to Flash/EEPROM.
- or -
Click Transfer to Flash/EEPROM from the Write to Controller toolbar 
button list.

2 A-series Compact controllers have four enhanced EEPROM options which may 
be set prior to transferring:

After power down, restore PLC to previous Run/Stop state.
Start PLC after download from EEPROM.
Save 4xxxx registers to EEPROM.
Optimized Mode - When selected, the controller can’t be edited while online.

3 Click Transfer. You are prompted to stop the controller if it is running.
112 31003882 12/2006



Working with Controllers
Transferring the Flash RAM Executive

Using Exec 
Loader

To transfer the flash RAM executive, read a controller’s flash RAM executive into a 
disk file, or write a device’s flash RAM executive from a disk file, use the third-party 
Exec Loader application. The Exec Loader is a Windows based 32-bit program that 
allows you to update the executive firmware in a variety of Schneider Electric PLC 
modules.

To open Exec Loader:
Click the Utilities tab in the project navigation panel, then double-click Exec 
Loader.
- or -
Click Utilities → Exec Loader.
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Transferring Memory Contents to Micro Flash RAM

Overview This function works only with Micro controllers. This function copies the memory 
contents of a Micro controller to the controller’s flash RAM.

When the Micro controller receives power, it first checks to see if a valid 
configuration is present in the data memory. If not, the contents of the flash RAM are 
re-loaded into the controller memory.

Flash RAM may be used as an alternative to the optional battery backup, or as an 
extra backup of the logic and configuration.

Transferring to 
Micro Controller 
Flash RAM

 

Step Action

1 Right-click your project in the project navigation panel, and click Online 
Commands → Write → Transfer to Flash/EEPROM.
- or -
Click Controller → Transfer to Flash/EEPROM.
- or -
Click Transfer to Flash/EEPROM from the Write to Controller toolbar 
button list.

2 Click Transfer. You are asked whether or not you want ProWORX 32 to start the 
controller after loading to Flash RAM.

Click Yes to have ProWORX 32 automatically start the controller after 
transferring memory contents to Flash RAM.
Click No to keep the controller stopped after transferring memory contents to 
Flash RAM.

3 If the controller is currently running, you are prompted to stop it. You must do so 
to continue.
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Transferring Internal Flash or PCMCIA to Controller Flash

Overview This function copies the memory contents of a Compact TSX, Quantum 434, or 
Quantum 534 controller to the controller’s flash RAM or PCMCIA memory card.

When the controller receives power, it first checks to see if a valid configuration is 
present in the data memory. If not, the contents of the flash RAM or PCMCIA 
memory card are re-loaded into the controller memory.

Flash RAM or PCMCIA memory card may be used as an alternative to the optional 
battery backup or an extra backup of the logic and configuration.

This function cannot be performed while the controller is running. You must stop the 
controller first.

Note: Do not attempt the transfer operation if the controller’s battery is low as the 
processor contents may be lost.
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Transferring the 
Controller’s 
Memory 
Contents to 
Controller Flash 
or PCMCIA 
Memory Card

 

Step Action

1 Right-click your project in the project navigation panel, and click Online 
Commands → Write → Transfer to Flash/EEPROM.
- or -
Click Controller → Transfer to Flash/EEPROM.
- or -
Click Transfer to Flash/EEPROM from the Write to Controller toolbar 
button list.

2 Click Internal Flash to transfer the current logic to flash memory.
- or -
Click PCMCIA to transfer the current logic to the PCMCIA memory card.

3 Compact controllers have enhanced options that may be set prior to transferring. 
Set the parameters for internal flash and PCMCIA settings.

Start PLC after download from EEPROM: Automatically starts the 
controller with the logic that was stored in flash memory or the PCMCIA card 
during a power failure.
Save state RAM: Saves the last state to flash memory or the PCMCIA card 
in the event of a power failure.

4 Type the number of registers to save in the 4xxxx registers to save field. The 
specified number of registers are saved to flash memory or the PCMCIA card in 
the event of a power failure.

5 Click Transfer to transfer the logic to flash memory or the PCMCIA card. You are 
prompted to stop the controller if it is running.
Note: Click Clear Flash to clear the logic stored in the flash memory or the 
PCMCIA card.

6 Click Stop if the controller is currently running.
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Starting and Stopping Controllers

Starting and 
Stopping a 
Controller

 

Step Action

1 Right-click your project in the project navigation panel, and click Online 
Commands → Start/Stop.
- or -
Click Controller → Start/Stop.
- or -
Click the Start Controller toolbar button.

2 For controllers that support it, you can select Optimization Mode. In the 
optimized mode, the ability to edit or show power flow is unavailable. You may 
have to stop the controller to make logic changes. The 685E and 785E 
controllers have a 2k buffer allowing editing during optimized mode. Once this 
buffer is full, no further changes can be made until the controller stops.

3 Click Start to start the controller.

4 The start/stop dialog box displays the following controller information:
Project Name
Processor Type
Communications Type and Address
Current State

5 Click Stop to stop the controller.
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PLC Status Viewer

Overview The status viewer monitors PLC status words. The PLC to be monitored is specified 
by the project selected. Multiple projects can be monitored at once and results in the 
word data grid are saved to the project. See p. 332 for more information about status 
words.

Opening the PLC 
Status Viewer

Double-click PLC Status in the project navigation panel.

- or -

Click Project → PLC Status.

- or -

Click the PLC Status toolbar button.

Checking the 
Value of a Word

In the PLC status window:

Logging Word 
Data

In the PLC status window:

Note: The words available are dependent on the PLC being monitored.

Step Action

1 Click Update current node.

2 Select the word from the status word navigation panel that you want to see the 
value of.
Note: Single bits are colored when set.

Step Action

1 Click Record selected nodes.

2 Select the check boxes beside the status word icons to select the word(s) that 
you want to log.

3 Click Start Logging.

4 Click Stop Logging to end the logging session.
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Working with 
Logged Word 
Data

After logging word data:

Step Action

1 Right-click  the logged data grid.

2 Click Delete to clear the selected word data from the logged word data grid.

3 Click Delete All to clear all word data from the logged word data grid.

4 Click View Bits to view the detailed word view and diagram of bits.

5 Click Print to print the logged word data.
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Analyze Device

Overview The analyze feature is very useful in diagnosing problems with your PLC that do not 
show up as part of typical online programming/commissioning. Analyze Device 
performs a checklist of predetermined tasks to find specific problems relating to an 
I/O sub-system's health and general PLC status. The analyze feature can pinpoint 
problems for maintenance staff to correct as well as keep an up-to-date knowledge 
base of maintenance records for future reference.

S901 Style 
Analyze

The S901 Analyze performs Stopcode Error, Controller Status, Battery Failed, 
Memory Protect, Single Sweep, Constant Sweep, S901/J200 Status, ASCII Error, 
Channel Communications Health, and Module Health checks. All potential problems 
are stored in a report.

S908 Style 
Analyze

The S908 Analyze performs Stopcode Error, Controller Status, Battery Failed, 
Memory Protect, Single Sweep, Constant Sweep, Hot Standby, DCP Present, ASCII 
Error Set, Remote I/O, S908 Error Set, Cable A Errors, Cable B Errors, Global 
Comm Health, Cable A Comm Health, Cable B Comm Health, Local Drop Health, 
Remote Drop Health, Remote Drop Cable A, Remote Drop Cable B, Drop 
Communications, and Module Health checks. All potential problems are stored in a 
report.

Understanding 
the Analyze PLC 
Output

Output graphics descriptions:

Viewing the 
Analyze Device 
Report

 

Graphic Description

This area passed, and no report entry has been made.

An entry has been made into the report signifying the state of the area.

A problem has been detected in the specific area. An entry in the report has 
been made.

Step Action

1 Double-click Analyze Device in the project navigation panel.
- or -
Click Project → Analyze Device.
- or -
Click the Analyze Device toolbar button.

2 Click the Report tab. (The Report window shows the date and time the problem 
was found and a brief description of the potential problem.)
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Configuration Extensions
At a Glance

Overview Configuration extensions are utilities that can be loaded into a controller. The 
Configuration extensions area contains several different hardware configuration 
extensions. These extensions are controller-specific. Each different extension has 
its own editor, and some of the more complex extensions have a wizard as well.

What's in this 
Chapter?

This chapter contains the following topics:

Topic Page

Configuration Extensions 122

Compact Phase II 124

Data Protect Extension 125

Quantum Hot Standby 126

I/O Scanner for Quantum Controllers (with NOE Cards) 128

I/O Scanner for Momentum Controllers 133

I/O Scanner Wizard 134

Peer Cop 136

Peer Cop Wizard 140

Profibus Extension 143

S980 Extension 145

SY/MAX Extension 146

TCP/IP Extension 147

Quantum VME Bus Extension 148

Quantum Security 149
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Configuration Extensions
Configuration Extensions

Overview Configuration extensions can be edited while the project is either online or offline. 
Online changes can only be made to a stopped controller. The configuration 
extension information is stored in the project and can be loaded at any time.

Available configuration extensions listed in the Active Extension panel:

Configuration Extension Description

Data Protect Prevents specific blocks of 0xxxx and 4xxxx references from 
being modified by general Modbus data write commands.

Peer Cop Allows you to configure data blocks to be transferred 
between controllers on a Modbus Plus network.

S980 Addresses Specifies the S980 station address.

Quantum Hot Standby Allows additional configuration of the Quantum Hot Standby 
setup.

Profibus Configures a Quantum controller for Profibus 
communications.

TCP/IP Configures controllers to connect to a TCP/IP network 
through a communication card.

SY/MAX Configures a Quantum controller for communication with SY/
MAX drops.

I/O Scanner Allows you to configure data blocks to be transferred 
between controllers on a TCP/IP network.

Compact Phase II This extension is only available for Phase II Compact PLCs.

Quantum VME Bus Configures a VME-424/X controller for communications with 
a VME network.

Quantum Security Allows additional security configuration of Quantum 140 CPU 
434 12A and 140 CPU 534 14A controllers. 

Note: Before setting config extensions, you must set the Configuration Extension 
Size (see p. 94) parameter in the configuration editor.
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Using the 
Configuration 
Extensions 
Utility

 

Step Action

1 Double-click Configurations Extensions in the project navigation panel.
- or -
Right-click Configurations Extensions in the project navigation panel, and 
click Open Editor.
- or -
Click Project → Configuration Extensions.
- or -
Click the Configurations Extensions toolbar button, and click Open Editor.

Result: The Configuration Extension window appears, showing only the 
extensions that are available for the active project.

2 To add a configuration extension, select the check box beside the extension 
icon.

3 To remove a configuration extension, clear the check box beside the extension 
icon.

4 To edit an extension, ensure that the extension’s associated check box is 
selected. Then, select the extension that you want to edit from the extension 
panel.
The status bar at the bottom of the Configuration Extension window shows the 
number of words used, total number of words available and any error or status 
messages as they may appear.

5 To save the changes that you made, close the Configuration Extensions window.
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Compact Phase II

Overview Compact Phase II extensions allow the programming of functions specific to the 
Compact Phase II controllers. This provides support for:

PLC based password access
Secure Data Area (SDA)
Comm 1 CTS/RTS delay time settings

Editing the 
Compact Phase II 
Extension

 

Note: If the Compact Phase II extension does not appear in the Active Extension 
panel, it is not a valid extension for the current controller type.

Step Action

1 Select the Compact Phase II check box in the Active Extension panel.

2 Enter a Secure Data Area value between 0 and 128 in the SDA Size (K Words) 
field. A zero value indicates the feature is unavailable.

3 Enter a value between 0 and 50 in the CTS Delay (x10 ms) field. A zero value 
indicates the feature is unavailable.
Note: This value is a factor of 10; if you enter 5, the PLC assumes you mean 50.

4 Enter a value between 0 and 50 in the RTS Delay (x10 ms) box. A zero value 
indicates the feature is unavailable.
Note: This value is a factor of 10; if you enter 5, the PLC assumes you mean 50.

5 Enter a password consisting of a maximum of 16 characters (A-Z, 0-9 and _) in 
the PLC Password field. The PLC password can only be changed while online. 
If the password is set to nothing, the PLC is not password protected.
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Data Protect Extension

Overview Data Protect is used to protect specific 0xxxx and 4xxxx references from being 
modified by Process Monitoring and Control software. Write access is allowed for all 
0xxxx and 4xxxx references within the specified block.

References outside the ranges specified are protected from general Modbus data 
write commands. By default, all 0xxxx and 4xxxx references are unprotected.

Editing the Data 
Protect 
Extension

 

Note: If the Data Protection extension does not appear in the Active Extension 
panel, it is not a valid extension for the current controller type.

Step Action

1 Select the Data Protect check box in the Active Extension panel.

2 Enter an address in the 0xxxx Starting Address field. Default is 0:0001.

3 Enter the number of references that are to be left unprotected in the 0xxxx 
Length field. ProWORX 32 shows the protected reference ranges in the 0xxxx 
Protected Ranges fields.
Example: Suppose you type a Starting Address value of 00017, and a Length of 
1024. The first protected range will be from 00001 (the first possible value) to 
00016 (the last value before the Starting Address value you entered).
There will then be an unprotected range from 00017 to 01040 (00017 + 1024). 
All references above 01041 are also protected.
If you enter a length that is too high (goes beyond the addresses configured for 
the controller), ProWORX 32 automatically sets the value to include all 
addresses above the Starting Address fields.

4 Enter an address in the 4xxxx Starting Address field. Default is 4:0001.

5 Enter the number of references that are to be left unprotected in the 4xxxx 
Length field. ProWORX 32 shows the protected reference ranges in the 4xxxx 
Protected Ranges fields.
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Quantum Hot Standby

Overview The Quantum Hot Standby extension allows additional configuration of the Quantum 
Hot Standby setup. This lets you set the type of state RAM transfer between the 
CHS 110 00 modules. It also lets you set the Initial Command Register and the Non-
Transfer Area. 

This extension is only available for version 2.x Quantum controllers that contain the 
CHS loadable (see p. 100) in the configuration.

Editing the 
Quantum Hot 
Standby 
Extension

 

Note: If the Quantum Hot Standby extension does not appear in the Active 
Extensions panel, it is not a valid extension for the current controller type.

Step Action

1 Select the Quantum Hot Standby check box in the Active Extension panel.

2 In the General tab, enter the 4xxxx address of the command register used to 
configure the hot standby system in the Command Register field. This register 
must be transferred every scan and cannot be in the non-transfer area.
The initial command register contains the settings that are loaded into the 
controller when it is started. If any changes need to be made while the controller 
is running, the command register must be used, and not the initial command 
register. Settings such as port address swapping, allowing an executive 
upgrade, setting the standby’s mode on a logic mismatch, setting the controller’s 
modes, and overriding the key switch can be changed from the command 
register.

3 Enter the starting address of the range of registers that are not to be transferred 
from the primary controller to the standby in the Non-Transfer Area Start 
Address field. This is commonly used to reduce scan time.

The first two registers are used in reverse transfer operations. These 
registers allow information to be passed from the standby to the primary 
controller.
The third register is the Status register, which stores the status of both 
controllers. This register provides information on how the hot standby system 
is operating, such as the power flow of the CHS instruction, position of the 
controller’s A/B switch, and whether there is a logic mismatch between 
controllers.
All registers following the third register are ignored (not transferred) during 
the scan.
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4 Enter the length of the non-transfer register range in the Non-Transfer Area 
Length field. This value can be from 1 through the total number of registers 
configured in the controller.

5 Click Show Command/Status Registers to view the command and status 
register contents in the Data Watch Window.

6 Select one of the following State RAM Transferred options:
Default (12K): All 0xxxx and 1xxxx registers (up to 8192 each) are 
transferred. 

If 10000 or fewer 3xxxx and 4xxxx (combined) registers are configured, 
then all are transferred.
If more than 10000 3xxxx and 4xxxx (combined) registers are configured, 
then (up to) 1000 3xxxx registers and all 4xxxx (up to a combined total of 
10000) are transferred.

Routine Only: All addresses defined in the routine transfer table are 
transferred every scan. There must be a minimum of 16 4xxxx registers to 
support the non-transfer area. The Routine Transfer Table is a range of 
discretes and registers that must be configured as a multiple of 16.
Routine and Extra: All addresses defined in the Routine Transfer Table and 
in the extra tables are transferred. The range of each extra table must be a 
multiple of 16. The extra tables can be transferred over multiple scans.
All State RAM: All RAM configured in the controller is transferred every scan.

7 Select an address in the table and enter a reference length.
For Routine Transfer Table address lengths, this must be a value between 16 
and the maximum configured size for that address.
For Extra Transfer Table address lengths, this must be a value between 16 
and the maximum configured size for that address exclusive of the range set 
in the corresponding Routine table.
Values must be a multiple of 16. The ranges defined are updated and 
displayed to the right on the tables as the values change.

8 Enter the number of scans (1-255) needed for the primary controller to transfer 
the extra transfer tables to the standby in the Scans to Transfer field.

9 Click the Initial Command Register tab.

10 Set the Swap Port (x) Addresses parameters to either Yes or No.

11 Set the Controller (x) Mode parameters to either Offline or Online.

12 Set the Standby Mode (on logic mismatch) to either Yes or No.

13 Set the Executive Upgrade Switch to either Enabled or Disabled.

14 Set the Keyswitch Override to either Enabled or Disabled.

Step Action
31003882 12/2006 127



Configuration Extensions
I/O Scanner for Quantum Controllers (with NOE Cards)

Overview The I/O Scanner extension provides data transfer between two or more controllers 
on a TCP/IP network. The I/O Scanner allows you to simultaneously configure up to 
128 communication transactions, depending on your controller. Because the TCP/
IP connection is established only once and remains connected during an entire 
session, this type of communication is very efficient.

I/O Scanner 
Wizard

ProWORX 32 includes a configuration wizard to step you through data transaction 
setup between a local device and a number of remote devices on a TCP/IP network. 
See p. 134 for more information.

Editing the I/O 
Scanner 
Extension

In the Active Extensions panel, select the I/O Scanner extension, then:

Note: If the I/O Scanner extension does not appear in the Active Extension panel, 
it is not a valid extension for the current controller type.

Step Action

1 Select the I/O Scanner check box in the Active Extension panel.

2 Select a card to edit from the Card Number list. There may be one, two, or six 
cards available to edit depending on the PLC type. Each card has an 
independent set of data values.

3 In the Local Device dialog box, enter an IP address in the IP Address field in 
the format (1-255).(1-255).(1-255).(1-255) This address should match the TCP/
IP extension for the selected card.

4 Enter a 1xxxx or 3xxxx address that will receive health information in the Health 
Block (1x/3x) field.

5 Enter the number (1-16) of the slot in the backplane the selected card inhabits in 
the Slot Number field. This value should match the value in the TCP/IP 
extension for the selected card.

6 Click the Device Control field.
Result: An address edit box appears to the right.
Enter a valid address, which must be either a 3x or 4x address and within the 
project’s configured range. The specified address appears in the Address Used 
table, if visible.

7 Select the Enable Device Control check box. When you select the check box, 
the Device Control Block field is enabled. When you clear the check box, the 
Device Control Block field is disabled.
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Bit Display Editor  

8 Click Show Registers.
Result: A Data Watch Window launches, which displays the health registers and 
the device control registers.
Click the left or right arrow underneath Current Page to switch between health 
registers and device control registers.
On the Health Registers page, you will see one of the following, depending on 
the address you entered in the Health Block field in step 3.

(8) 3x registers, which hold 128 health bits for each of the 128 possible 
transactions. These registers are editable in any Radix, but default to 
Decimal.
(128) 1x discretes, which hold 128 health bits for each of the 128 possible 
transactions. These registers are editable in any Radix, but default to Binary.

On the Device Control Registers page, you will see one of the following, 
depending on the address you entered in the Health Block field in step 3.

(8) 3x or 4x registers, which hold 128 health bits for each of the 128 possible 
transactions. These registers are editable in any Radix, but default to Binary. 
Click the ... button to open the Bit Display editor.

9 On the Device Control Registers page, double click a data cell to edit the data.
Result: The data edit box appears, and you can edit in whichever radix is defined 
for that row.
Press Enter to accept or Esc to cancel the edit.

10 Double click a radix cell to edit the data.
Result: The radix drop-down list appears, and you can select any new radix in 
the list.
Press Enter to accept or Esc to cancel the edit. The data value will reflect the 
new radix.

11 Click the ... button to launch the Bit Display editor.

Step Action

Step Action

1 Double-click a bit to edit the data. The hex and decimal data values will change 
to reflect the new value.

2 Or, click the list to the right of the bit you wish to edit. Select the desired setting. 
The associated bit will change to reflect the new setting.

3 Click OK to accept the new value, or click Cancel to ignore the new value and 
close the Bit Display editor.
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Select 
Transaction 
Dialog Box

 

Remote Device 
Dialog Box

Step Action

1 The Select Transaction field displays up to 128 (64 for M1E PLCs (see p. 133)) 
transactions.

A transaction that is not configured is denoted by a red X.
A partially configured transaction is denoted by a yellow exclamation mark.
A configured transaction is denoted by a green check mark.

2 To configure a transaction, right-click anywhere in the transaction list and click 
Add Transaction. Transactions are configured in order, so, if you have three 
transactions and click Add Transaction, the fourth transaction can be 
configured.

3 To clear the configuration of the last transaction in the list, right-click anywhere 
in the transaction list and click Delete Transaction, or press Delete.

Step Action

1 Enter the IP address of the remote device that you are communicating with in the 
IP Address field.

2 Enter the value of the destination Unit ID in the Unit ID field. This is an identifier 
for a pair of transactions (specifically Link Client/Server transactions). The 
transaction pair must have matching Unit IDs.
Example: A single Server Write that sends data to the matching Client Reads in 
a remote device. All Client Read transactions accept the data sent from the 
single Server Write transaction as long as the Unit IDs match.

3 Enter a millisecond value representing the length of time to wait before repeating 
the transaction in the Repetition Rate (0-50k) field. A value of 0 indicates the 
quickest possible rate.

4 Enter a millisecond value representing the length of time to wait for a reply for 
each transaction in the Health Timeout (0-50k) field.
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Transaction 
Dialog Box

Step Action

1 Select one of the following from the Function list.
Read: A unilateral read in which a local device reads data from a remote 
device.
Write: A unilateral write in which a local device writes data to a remote device.
Read/Write A unilateral read/write in which a local device reads data from 
and writes data to a remote device.
Link Client Read: A paired function type in which a local device responds to 
a write transaction from a remote device which must have a matching server 
write.
Link Client Write: A paired function type in which a local device writes to a 
remote device which must have a matching server read.
Link Client Read/Write: A paired function type in which a local device reads 
and writes data to and from a remote device which must have a matching 
server read and write.
Link Server Read: A paired function type in which a local device initiates a 
read from a remote device. The remote device must have a matching client 
write.
Link Server Write: A paired function type in which a local device writes to a 
remote device. The remote device must have a matching client read.
Link Server Read/Write: A paired function type in which a local device reads 
and writes data to and from a remote device which must have a matching 
client read/write.

Note: For unilateral function types, no intervention is required for the remote 
devices. They respond to any Read or Write without the need to set up an I/O 
Scanner transaction. Linked function types require two complementary 
transactions, one in each device.

2 Select one of the following from the Fallback Value list.
Zero: Resets the data values for the selected transaction to zero in the event 
of a power failure.
Hold Last: Retains the last data values for the selected transaction and make 
them available at restart in the event of a power failure.
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Read From 
Remote Dialog 
Box

 

Write To Remote 
Dialog Box

 

Step Action

1 Enter the local data address receiving data from the remote controller in the To 
field.

2 Enter the remote address where the read data is coming from in the From field.

3 Enter the number of sequential registers to read in the Length field. Up to 125 
registers are allowed.

Step Action

1 Enter the local data address that sends data to the remote controller in the From 
field.

2 Enter the remote address where the write data is going to in the To field.

3 Enter the number of sequential addresses to write in the Length field. Up to 100 
registers are allowed.
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I/O Scanner for Momentum Controllers

Editing the I/O 
Scanner 
Extension

The I/O Scanner configuration dialog box for M1 Ethernet controllers has the same 
functions as the dialog box for Quantum controllers (with NOE cards) (see p. 128) 
with the following 2 differences.

For M1 Ethernet controllers:
1. In the Local Device dialog box, the fourth field is Diagnostic Block, which 

functions the same way as Device Control (see p. 128) for NOE.
2. In the Local Device dialog box, the fifth field is Enable Diagnostic Block, which 

functions the same way as Enable Device Control (see p. 128) for NOE.

Data Watch 
Windows - Health 
and Diagnostic 
Registers

When you click Show Registers, the Health Registers page (page 1) (see p. 128) 
appears exactly as it does for Quantum controllers with NOE cards. However, the 
Diagnostic Registers page (page 2) appears differently for M1 Ethernet 
controllers.

Follow the steps below to edit the diagnostic registers.

Note: The Diagnostic Registers page in M1 Ethernet controllers displays 128-word 
length tables, unlike that in the Quantum controllers, which displays 8-word length 
tables.

Step Action

1 Double-click a data cell to edit the data.
Result: A list appears from which you can select any value.
Press Enter to accept or Esc to cancel the edit.
Note: The data values are read only for an NOE card. Changing this value will 
not change the way the corresponding NOE operates, which may simply reset 
the value back to its correct state.

2 Double-click a radix cell to edit the data.
Result: A list appears from which you can select any radix.
Press Enter to accept or Esc to cancel the edit. The data value will reflect the 
new radix.
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I/O Scanner Wizard

Overview The wizard operates independently of the offline/online mode. All changes are made 
to offline projects with an option to modify online devices as well. TCP/IP 
communications are required only when modifying online devices.

Using the I/O 
Scanner Wizard

 

Ensure online devices are stopped.
Online devices may be running! You must stop them before you modify their 
contents. Before you stop a device, ensure that it is safe to do so. The devices 
restart once the operation is complete. Modifications to the devices’ content cannot 
be undone.

Failure to follow this instruction can result in injury or equipment damage.

CAUTION

Step Action

1 Click the I/O Scanner Wizard button in the Active Extension panel.

2 Read the on-screen instructions, and click Next.

3 Clicking one of the following to set the transaction type.
Direct - Creates a single transaction in the local device. Data is transferred regardless of the 
programming of the remote device. This option is simpler than Link Client/Server, but could pose more 
risk as the target device needs no additional program to verify its operation.
Link Client/Server - Creates a pair of matching transactions, one in each device. The server makes a 
request from a client, which then responds to that request. This is a safer option than Direct transactions, 
but is more complex to set up and maintain.

Click Next.

4 Enter an IP address in the Local Device IP Address field in the standard IP format (1-255).(1-255).(1-
255).(1-255).
If you are using a Quantum PLC, select the slot that the NOE (or similar Ethernet adapter) card resides 
in from the Head Number list.

Click Next.

5 To properly use the I/O Scanner extension, you must define target PLCs with which to communicate. These 
target PLCs are called remote devices.

Click Add to add a remote device.
Click Remove to remove a remote device.

At least one remote device must be defined before proceeding.
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Finishing the I/O 
Scanner Wizard

 

6 If you click Add to add a remote device:
Click Browse to select a project. Select a project from the Remote Device/Database list.
Enter the IP address of the PLC for the remote device’s project in the Select an IP Address field.
If you are using a Quantum PLC, select the slot that the NOE (or similar Ethernet adapter) card resides 
in from the What slot in the remote rack is this device mounted in list.

Click Next to return to the remote device summary screen.

7 Repeat the above step until all desired remote devices have been added.
Click Next when you have finished adding remote devices to the I/O Scanner extension.

8 To transfer data from one device to another a transaction is required. Existing transactions cannot be 
modified using the I/O Scanner wizard and are disabled. Up to 128 transactions may be created, except if 
you are using the M1E PLCs, then only 64 transactions can be supported.

Click Add to add a new transaction.
Click Edit to edit a transaction created by the I/O Scanner wizard.
Click Remove to remove a transaction created by the I/O Scanner wizard.

9 After clicking Add, you are prompted to select a remote device. Click a remote device from the list, and 
click Next.
Now you can configure the new transaction.

First, select a function from the list.
Second, enter 4xxxx addresses into the From and To fields.
Third, enter numeric values in the Number of Registers field in the Read from Remote Device and 
Write to Remote Device areas.

Click Next when you have finished editing the transaction.
(To see descriptions of the functions and fields, see p. 128.)

10 The transaction summary screen displays a summary of all new transactions to be written to the local device 
as well as the various selected remote devices. Ensure the transactions are correct, and click Next.
Note: Clicking Next proceeds with the modifications, which cannot be undone once completed.
Note: Only offline databases are modified in this step.

11 Click Update Online Devices to update the physical devices defined as remote devices by the wizard. This 
does not update the local device, which must be done once the configuration extension editor is closed and 
all changes are saved.
Click Next.

Step Action

Step Action

1 Click View Log File to view a log of all changes made to the local and remote 
devices. This file (ScannerWizard.log) may be saved and printed as needed.

2 Click Finish to close the wizard.
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Peer Cop

Overview The Peer Cop extension provides data transfer between two or more controllers on 
a peer-to-peer network, as well as linking multiple networks using the S985 
communication card. Peer Cop configures data blocks to be continuously 
transferred (once per scan) between nodes on a Modbus Plus network. Data can be 
broadcast to all nodes on a single link (Global I/O) or between specific Modbus Plus 
nodes on a link (Specific I/O).

A maximum of 32 data registers or 512 (for example, 32*16) I/O points can be 
transferred to or read from a controller at a time. Peer Cop is supported by the A145 
and all E-Series, Momentum, and Quantum controllers equipped with NOM Ethernet 
adapters. Up to three Links of the Peer Cop can be configured and edited.

Peer Cop Wizard ProWORX 32 includes a configuration wizard (see p. 140) to help you set your Peer 
Cop extensions.

Editing the Peer 
Cop Extension

 

Note: If the Peer Cop extension does not appear in the Active Extension panel, it 
is not a valid extension for the current controller type.

Note: The Peer Cop wizard only applies to link 1.

Step Action

1 Select the Peer Cop check box in the Active Extension panel. 

2 The Peer Cop extension can be configured for up to three links. When you add 
a link you will have access to the 64 possible devices on another peer-to-peer 
network.

Link 1 is the internal link; all devices on the local Modbus Plus network can 
be accessed from Link 1.
Links 2 and 3 are remote links through S985 cards.

3 Click Add Link to add a link.
Click Clear Link to clear the configuration of a link.
Click Delete Link to delete a link.
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Global Input/
Output

Global I/O is one of two communication methods used by the Peer Cop extension 
(the other is Specific I/O). Global I/O is a broadcast communication method where 
a message is broadcast (made available) to all controllers on the Modbus Plus 
network. Global I/O data transfers do not require an acknowledgment from the 
receiving controller, so there is no immediate overhead placed on the receiving 
controller.

Editing Global 
Inputs

Global Input is used to receive global data from any device on a Modbus Plus 
network. One entry (line) is available for each device (1 through 64). Each device’s 
global data can also be received in pieces determined by Subfields.

4 To configure a link, set its Head Number, Time-out value, and Last Value 
parameters.
For link 2 or 3, select a head number (1 through 16) from the Link x Head 
Number list. Head Number specifies the head number on a Quantum rack. If you 
are using a Quantum controller, you have the option of editing the head number 
for the second or third link. The first link is internal; therefore, it cannot be edited.

5 Select a value from the Timeout (ms) list. Time-out specifies the health time-out 
interval. The default value is 500ms. This value specifies the minimum time 
period a Peer Cop configured communication must fail before the associated 
health bit is cleared. Valid time-out values range from 20ms to 2 seconds. If you 
type a value too big, the value truncates to a multiple of 20. For example, 230 
truncates to 220 (it is not rounded up to 240).

6 Click Clear or Hold from the Last Value list. Last Value specifies whether or not 
to hold the last value. When set to Hold, the input data area associated with an 
unhealthy transfer is left in its previous state (i.e. the last value with a health of 
OK).

Step Action

Note: Click View Data to view the register data of any global input/output or 
specific input/output. The Data Watch window opens, displaying the relevant data.

Step Action

1 Click Global Input in the Links panel.

2 Double-click an input in the Global Input list.
Result: The global input properties grid appears.

3 In the Index field, enter the starting point (1 through 32) of the broadcast data to 
read.

4 In the Start field, enter the destination for the received data (i.e., where the 
received data is to be stored).
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Editing Global 
Input Subfields

Each device’s global data can also be received in sections determined by Subfields. 
You can define a subfield for each block of the broadcast data that you want the 
controller to receive while ignoring the remainder.

Editing Global 
Outputs

Global Output broadcasts the specified range of discretes or registers to the devices 
on the Modbus Plus network. Each device used to access the data must also be 
configured to accept Global Input from the broadcasting device (1-32).

Specific Input/
Output

Specific I/O is one of two communication methods used by the Peer Cop extension 
(the other is Global I/O). Specific I/O uses a one-to-one communication method, and 
requires an acknowledgment from the receiving device, which creates a certain 
amount of overhead. When using Specific I/O, the destination controller must accept 
the entire block of data from the source controller. This means that the Index value 
used in Global I/O is not necessary.

5 In the Length field, enter the number of words (1 to 32) to read forwards from 
the Index value.
Example: Suppose the source controller is broadcasting 10 words of data using 
the Global Output function, but the receiving controller only uses words 3 to 7. 
Type an Index value of 3 and a Length of 5.
Note: The length value plus the index value must be less than or equal to 33.

6 Select either BIN (default) or BCD from the Type list.

Step Action

Step Action

1 Click View Subfields.

2 Click a subfield from the Global Inputs Subfields list to edit its properties. 
(Subfields have the same properties as inputs.)

3 Click Return when you are finished editing the subfield’s properties to return to 
the list of global inputs.

Step Action

1 Click Global Output in the Links panel.

2 Double-click an output in the Global Output list.
Result: The global output properties grid appears.

3 In the Start field, enter the destination for the received data (i.e., where the 
received data is to be stored).

4 In the Length field, enter the length (1-32) of the address range (i.e., the number 
of registers to broadcast).

5 Select either BIN (default) or BCD from the Type list.
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Specific I/O allows you to configure multiple defined data blocks for transmission to 
specific devices on the Modbus Plus network. The device receiving the data must 
be configured for Specific Input from the broadcast device. The length (in words) of 
the specific input (configured in the destination controller) must be identical in length 
to the specific output (configured in the source controller). The input data, however, 
can be stored in any type of reference desired. That is, five words of 4xxxx data can 
be stored in five words of 0xxxx memory area.

Editing Specific 
Inputs

 

Editing Specific 
Outputs

Select the Specific Output icon in the Links panel, then:

Note: Click View Data to view the register data of any global input/output or 
specific input/output. The Data Watch window opens, displaying the relevant data.

Step Action

1 Click Specific Input in the Links panel.

2 Double-click an input in the Specific Input list.
Results: The specific input properties grid appears.

3 In the Start field, enter the starting address of the block of data to be placed from 
the source controller.

4 In the Length field, enter the number of words (1 to 32) to be received from the 
source controller.

5 Select either BIN (default) or BCD from the Type list.

Step Action

1 Click Specific Output in the Links panel.

2 Click an output from the Specific Output list.
Result: The specific output properties grid appears.

3 In the Start field, enter the starting address for the block of data to be sent to the 
destination controller.

4 In the Length field, enter the number of words (1 to 32) to be sent to the 
destination controller.

5 Select either BIN (default) or BCD from the Type list.
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Peer Cop Wizard

Overview The Peer Cop Wizard guides you through transaction setup between a local device 
and a number of remote devices on a Modbus Plus network.

The wizard operates independently of the offline/online mode. All changes are made 
to offline projects with an option to modify online devices as well. Modbus Plus 
communications are required only when modifying online devices.

Using the Peer 
Cop Wizard

 

Ensure online devices are stopped.
Online devices may be running! You must stop them before you modify their 
contents. Before you stop a device, ensure that it is safe to do so. The devices 
restart once the operation is complete. Modifications to the devices’ content cannot 
be undone.

Failure to follow this instruction can result in injury or equipment damage.

Step Action

1 Click the Peer Cop Wizard button in the Active Extension panel.

2 Read the on-line instructions, and click Next.

3 Enter a MB+ address (01-64).(00-64).(00-64).(00-64) in the Local Device MB+ 
Address field.
Click Next.

4 Define target PLCs for the PLC to communicate with by adding remote devices to 
the Remote Device Summary list.

Click Add to add a remote device and its corresponding project.
Click Remove to delete a remote device from the list.

5 If you click Add to add a remote device:
Click Browse to select a project. Click a project from the list or click Browse to 
select a project in another directory. When you have selected a project, click OK.
Enter a MB+ address in the Select MB+ Address for this Device field.
Click Next.

Note: The Modbus Plus routing paths for the local device and all remote devices 
must match. Only the last non-zero address value may be different. All proceeding 
values must be the same because peer cop transactions cannot pass across 
Modbus Plus bridges or multiplexers.

CAUTION
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6 The Specific Transactions List dialog box appears. The Specific Transaction List 
provides a list of all specific point-to-point transactions. To transfer data from one 
device to another, a transaction is required. Existing transactions cannot be 
modified using the Peer Cop Wizard and are disabled. Up to 64 read and 64 write 
transactions may exist.

Click Add to add a new transaction.
Click Edit to edit a transaction created by the wizard.
Click Remove to remove a transaction created by the wizard.

7 If you clicked Add to add a new specific transaction, the Specific Transaction dialog 
box appears, allowing you to configure the transaction.

Select Read or Write from the Function list. Read requests data from the 
remote device, and Write sends data to the remote device.
In the From field, enter the 4xxxx address where the data comes from. The 
address is from the remote device for a read function and from the local device 
for a write function. 
In the To field, enter a 4xxxx address where the data is sent to. The address is 
from the local device for a read function and from a remote device for a write 
function.
In the Word Length field, enter the number of consecutive registers to transfer 
(1 through 32).

Click Next when you have finished configuring the specific transaction.

8 The Global Transactions List lists all of the global device-to-device transactions. 
Existing transactions cannot be modified using the Peer Cop Wizard and are 
disabled.

Click Add to add a new global transaction.
Click Edit to edit a global transaction created by the wizard.
Click Remove to remove a global transaction created by the wizard.

9 If you clicked Add to add a new global transaction, the Global Transaction screen 
appears, allowing you to configure the transaction.

Select Read or Write from the Function list. Read requests data from the 
remote device, and Write sends data to the remote device.
Enter the 4xxxx address where the data comes from in the From field. The 
address is from the remote device for a read function and from the local device 
for a write function. 
Enter a 4xxxx address where the data is sent to in the To field. The address is 
from the local device for a read function and from a remote device for a write 
function.
Enter the number of consecutive registers to transfer (1 through 32) in the Word 
Length field.

Click Next when you have finished configuring the global transaction.

Step Action
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Finishing the 
Peer Cop Wizard

 

10 The summary of transactions screen displays all of the new transactions created by 
the wizard.
These transactions are written to the local device as well as the various remote 
devices when you click Next.
To overwrite any transactions in the remote device that would interfere with the new 
one, select the Overwrite Existing Remote Transactions check box.
Note: Clicking Next proceeds with the modifications, which cannot be undone once 
completed.
Note: Only offline databases are modified in this step.

11 Click Update Online Devices to update the physical devices defined as remote 
devices by the wizard. This does not update the local device, which must be 
updated after the configuration extension editor is closed and all changes are 
saved.
Click Next.

Step Action

Step Action

1 Click View Log File to view all the changes made to the local and remote devices. 
This file (PeerWizard.log) may be saved or printed as needed.

2 Click Finish to close the wizard.
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Profibus Extension

Overview The Profibus configuration extension allows you to configure Profibus I/O in a 
ProWORX project. The extension has 2 major functions:

importing a Profibus station from an exported .CNF file created with the SYCon 
software package
editing the I/O parameters for the Profibus I/O using the Profibus configuration 
extension

Editing the 
Profibus 
Extension

 

Note: If the Profibus extension does not appear in the Active Extension panel, it is 
not a valid extension for the current controller type.

Step Action

1 Click Profibus in the Active Extension panel.

2 To begin importing an existing .CNF file, click Import .CNF. 
Note:

For a standard slave (modular/compact), the maximum is 16 (bytes or words 
depending on the type of the slave/slot).
For specific slaves (modular/compact), the maximum is 64 (bytes or words 
depending on the type of the slave/slot).

These maximums are Profibus standard maximums, not ProWORX 32 specific (i.e., 
Concept or any other software should have the same maximums with regard to 
Profibus.).
Note:  If current extensions include an active Profibus extension, the screen will show 

how many words are used in this extension.
Note: Importing a.CNF file will overwrite all of your existing settings.

3 You will be warned that any existing Profibus configurations will be cleared.
Click Yes to continue.
Click No to cancel.

After import, the Profibus extension enters Edit Mode. This mode allows you to configure 
the Profibus I/O parameters.

4 In Edit Mode, select an item in the Device Tree (upper, left-hand side of the screen) to 
display its parameters.
Three different devices may be available:

Master
Slave
Modules

5 The Device field displays the device’s name, bus address, and ID. 

6 The Master Parameters window displays the I/O and diagnostic settings. You can edit 
all values in this window except Baud Rate. Valid ranges are indicated in the labels. 
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Further Editing in 
the Profibus 
Extension

You can edit the Profibus settings again if:
You imported the associated .CNF file into your project using ProWORX 32, 
Version 2.0 or later.
You are using a project as described above to edit in offline mode.
You are using a project as described above to edit in online or combined mode 
with the correct controller.

You cannot edit the Profibus settings again if:
If you did not import a .CNF file using ProWORX 32, Version 2.0 or later.
You are using a project in direct to online mode.
If you connect to a controller that does not have Profibus data matching the 
selected project.

Setting the 
Presets

 

Note: You can only edit the addresses, address types, and diagnostic information 
for the imported modules. The modules (master and slaves) are fixed, and can only 
be defined by importing a .CNF file. The modules cannot be edited using 
ProWORX 32. Importing a .CNF file will overwrite any existing settings for the 
selected card.

Step Action

1 Click Set Presets to display a Presets frame, which allows you to select a 
starting address for all I/O and diagnostic addresses. All I/O settings will be 
cleared by this operation. 

2 In the Presets frame, select a starting address for each address type.
Note: Diagnostic settings are always either Boolean or Unsigned 8-bit integers. 
Only 3x addresses are allowed.
Note: I/O settings may include discrete addresses for Boolean settings and 
register addresses for all others. Type allowed depends on the length and 
whether this device uses bytes or words. Lengths cannot be changed.

3 Select the check box to preset addresses of the associated type.
Clear the check box to leave the address unchanged.

4 Click Preset to assign addresses to all Profibus I/O and diagnostic settings for 
all slaves and modules. 

5 Click Close to close the Presets frame and return to the Profibus edit screens. 
Closing the configuration extensions after editing will automatically generate a 
valid Profibus extension. 
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S980 Extension

Overview The S980 Configuration Extension stores the S980 station address. This address is 
then used as part of the S980’s mismatch detection mechanism; when the controller 
is powered up, the S980 checks to see if it has been moved to a different 984.

Editing the S980 
Extension

 

Note: If the S980 extension does not appear in the Active Extensions panel, it is 
not a valid extension for the current controller type.

Step Action

1 Click S980 Address in the Active Extension panel.

2 Enter up to a 12-digit hex number representing the S980 address in the Address 
field.
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SY/MAX Extension

Overview The SY/MAX configuration extension allows you to properly access and configure 
up to six SY/MAX RIO cards. This extension is only available when using Quantum 
controllers, revision 2 or later.

Editing the SY/
MAX Extension

 

Note: If the SY/MAX extension does not appear in the Active Extension panel, it is 
not a valid extension for the current controller type.

Step Action

1 Click SY/MAX in the Active Extension panel.

2 Select a card (1-6) from the Card list.

3 In the Module Drop Number field, enter a I/O drop number (-1 through 99). Set 
to -1 if the drop is not defined.

4 In the Backplane Slot field, enter the number of the slot (0 through 16) that the 
RIO card inhabits. Set to 0 to remove a module.

5 In the Retry Count field, enter a retry number (1 through 255).

6 In the Timeout field, enter a timeout value (1ms through 65535ms).
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TCP/IP Extension

Overview Before your controller can connect to a TCP/IP network, you must install and set up 
the TCP/IP configuration extension. This extension lets the controller recognize its 
TCP/IP communication card. For more information about configuring TCP/IP 
communications, see p. 88.

Editing the TCP/
IP Extension

 

Note: If the TCP/IP extension does not appear in the Active Extension panel, it is 
not a valid extension for the current controller type.

Step Action

1 Click TCP/IP in the Active Extension panel.

2 Select a card (1-6) from the Card list.
Note: Different controllers support different numbers of communications cards:

Quantum 113, Rev. 2 and 213 Rev. 2 controllers support two cards.
Quantum 424, Rev. 2 supports up to six cards.
M1E Momentum controllers only support one card and the Head Number is 
fixed at one.

3 Select a head number (1 through 16) from the Head Number list.

4 Enter an IP address (1-255).(1-255).(1-255).(1-255) in the IP Address, Subnet 
Mask, and Gateway IP fields. 0.0.0.0 indicates an undefined address.

5 Select either Ethernet II or IEEE 802.3 from the Framing Type list.

6 Select either Extension or BOOTP Server from the IP Address Selection list.
Extension - Upon power up, the PLC reads its TCP/IP addressing 
information from this extension.
BOOTP - Upon power up, the PLC requires a BOOTP server to supply TCP/
IP addressing information.
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Quantum VME Bus Extension

Overview The VME Bus extension lets a VME-424/X controller control data transfers between 
devices on a master/slave Quantum network. In a master/slave protocol, one device 
(the master) has control over other devices (slaves). As the network runs, each 
element can lose and gain master status, based on negotiations with other members 
of the network.

Editing the VME 
Bus Extension

 

Note: If the VME Bus extension does not appear in the Active Extension panel, it 
is not a valid extension for the current controller type.

Step Action

1 Click VME Bus in the Active Extension panel.

2 In the Slave Interrupt Level field, enter the appropriate value. Boards on a VME 
Bus can send and respond to messages on seven interrupt levels, numbered 
from 1 to 7. This field determines which interrupt level the board uses when it’s 
acting as a slave.

3 In the Status ID field, enter a value between 1 and 255. When the VME controller 
receives an interrupt while acting as a slave, this is the value it sends.

4 In the Master Arbitration Type list, select an appropriate value for master 
arbitration type. This field determines how the controller will operate. Valid 
settings are Not System Controller, Primary Mode (PRI) or Round Robin Mode 
(RRS).

5 In the Master Release Mode list, select an appropriate value for master release 
mode. This field determines when a board acting as a master relinquishes its 
master status. Valid settings are Release on Request (ROR), Release When 
Done (RWD), Release On Clear (ROC), or Bus Capture and Hold (BCAP). The 
proper setting depends on how your Quantum network is configured.

6 In the Master Bus Request Level list, select the appropriate value for master 
VME Bus request level. This field determines what priority the board has when 
trying to acquire master status. It can range from BR0 (the lowest) to BR3 (the 
highest).

7 For each interrupt level from Interrupt 1 to Interrupt 7, select whether it should 
be Enabled or Disabled. These fields will only have an effect when the VME acts 
as a master. If an interrupt level is:

Enabled: The controller responds to any messages sent on that interrupt.
Disabled: The controller ignores them.
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Quantum Security

Overview The Quantum Security configuration extension allows additional security 
configuration in Quantum 140 CPU 434 12A and 140 CPU 534 14A controllers. The 
security and password extensions are used with 21 CFR Part 11 regulations issued 
by the U.S. Food and Drug Administration.

Editing the 
Quantum 
Security 
Extension

 

Step Action

1 Click Quantum Security in the Active Extension panel.

2 In the Auto Logout list, select a time interval of 5, 10, 15, 20, 30, 45, 60, 75 or 
90 minutes. Auto Logout forces the PLC to log out the current user after a 
specified time of inactivity.

3 Select the Disable All writes from NOE/NOM cards check box to force the PLC 
to ignore any attempt to write to it from the NOE or NOM card. Ethernet writes 
are thereby disabled.

4 Select the Disable All writes from CPU Modbus ports check box to force the 
PLC to ignore any attempt to write to it from an onboard Modbus port.

5 Select the Enable Modbus+ Write Restrictions check box to force the PLC to 
ignore any attempt to write to it from an onboard Modbus Plus ports.

6 In the Enter New MB+ Address field, enter any exceptions to Modbus Plus write 
restrictions.

7 Click Add to add a Modbus Plus address to the exception list.
Click Delete to delete the selected Modbus Plus address from the exception 
list.
Click Clear to delete all Modbus Plus exception addresses except for local 
address (1.0.0.0.0) which cannot be deleted.

8 Click any of the Password fields in the PLC Password section to edit the 
password. Passwords are 16 alphanumeric characters and are not case 
sensitive. Both passwords must match for a new password to be accepted.
Note: The PLC Password section is available only if you are online with a PLC. 
If no password is set, Old Password is not available.
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Using the Logic Editor
At a Glance

Overview The logic editor is used to view and/or edit ladder logic in offline, online or emulation 
mode. In offline mode, network logic is loaded into the logic editor from the database 
when it is opened. In online mode, network logic is read from the controller one 
network at a time. In emulation, mode the power flow is simulated using the network 
logic loaded from the project.

What's in this 
Chapter?

This chapter contains the following topics:
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Mathematical Functions in Equation Networks 190
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Using the Logic Editor
Logic Editor Overview

Overview The logic editor is used to enter logic elements, display input/output data, and add 
descriptors and force discretes.

The logic editor shows project ladder logic in either offline, online, combined, or 
emulation mode. In offline mode, network logic is loaded into the logic editor from 
the project when the editor is opened. In online and combined modes, network logic 
is read from the PLC one network at a time. During idle states of online mode, 
networks around the currently displayed network may be cached for faster access 
to the networks.

The logic editor is made up of four panels.

Panel Description

Network Navigator 
Panel

The Network Navigator panel (tree) is used to navigate through 
networks and segments. To display or hide the Network Navigator 
panel, right-click in the logic editor, and click View → Navigation Tree.

Logic Editor Panel The logic panel contains the view of the logic contained in the currently 
viewed network. The title of the logic panel contains the current 
network, maximum network and the page title for the network. In online 
and emulation modes, power flow will be drawn per cell based on the 
properties of the logic editor.
The cursor tracks several features:

instruction help placed in the Tracking Help window
tracking documentation for the current address in the 
documentation editor
data for the current network

Instructions Panel The instructions panel contains a list of all available instructions for the 
current project. New instructions are entered by dragging from the 
Instructions Panel and dropping into the Logic Panel. The list of 
instructions is alphabetically sorted. To display or hide the Instructions 
panel, right-click in the logic editor, and click View → Instruction List.

Properties Panel The Properties panel contains information about the current cell the 
cursor is on. Depending on the type of cell, the Properties panel will 
contain a 1, 2, or 3 high instruction. For a blank cell, the Properties 
panel contains only the name property. To display or hide the 
Properties panel, right-click in the logic editor, and click View → 
Properties.

Note:  
The instructions, properties and network panels can be opened or closed:

Right-click in the logic editor, and click View → Instruction List.
Right-click in the logic editor, and click View → Properties.
Right-click in the logic editor, and click View → Navigation Tree.
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Logic Editor Properties

Customizing the 
Logic Editor 
Display

The logic properties dialog box tells ProWORX 32 how to display each cell in a 
network. To open the logic properties dialog box:

Logic Editor 
Display 
Properties

In the logic editor properties window:

Step Action

1 Right-click in the logic editor, and click Logic Properties.
- or -
Right-click Logic → Properties in the project navigation panel.
- or -
Click View → Properties.

2 Configure the logic editor properties (see p. 153) as desired.

3 Click OK to save and apply changes.

Property Description

View 1-4 The View 1-4 buttons allow Ladder Logic editor display to accommodate different views for users and 
for printing.
Ladder Logic display fields in View 1 have default settings. Fields in Views 2-4 are initially set to clear
The View 1 settings are the parameters used to print the Ladder Logic
The four view icon resides on the standard toolbar; clicking the icon cycles between the four views.

Color 
Configuration

The color of the descriptor, symbol, data, back reference, cursor background, cursor foreground, logic 
background, logic foreground, and power flow are user-defined. Click the color box beside the text and 
select a color from the color dialog box.
To set the colors to their defaults, click Default. Clicking Default also sets the power flow line width 
to three.

Power Flow 
Line Width

In Emulation or Online mode, the power line shows the flow of power. You can adjust the width of this 
line from 1 to 6.

Display 
Settings

Up to seven lines are available for each element: five lines above the instruction and two below it. For 
each line, select one of the following:

Clear - This line is not displayed.
Address - The address associated with the cell is displayed.
Descriptor (1 - 9) - Descriptors specified in the documentation editor are displayed.
Symbol (1,2) - Symbols specified in the documentation editor are displayed.
Data - The addresses data is displayed.
Back Ref - Back referencing information is displayed.
Blank - This line is blank.
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Always Fit 7 
Rows x 11 
Cols

Select the check box to always see the full grid of instructions in the window. If the check box is 
cleared, the cells will be displayed at full size, and you will have to scroll to see the entire network.

Show Coils in 
Solve Column

Select the check box to see the coils where they are solved by the controller. If the check box is 
cleared, the coils will always be displayed in the 11th column attached to the solve column by dots.

Multi Function 
Naming

When you select the check box, function identifier constants are replaced with four-letter descriptions 
of the function operation.

Confirm 
Overwrites

You are prompted to confirm each time you overwrite an existing ladder logic instruction with a new 
one. This security feature is useful when working online.

Multi 
Instruction 
Insert

When you select the check box, you can add as many instructions as you want without specifying an 
associated address.

Confirm 
Deletes

You are prompted to confirm each time you try to delete an instruction from ladder logic. Use this 
function to protect your ladder logic, especially while working online.

Use Insert/
Delete Key 
Menus

When you select the check box, you can access the Insert menu by pressing Insert. Likewise, when 
you select the check box, you can access the Delete menu by pressing Delete. When you clear the 
check box, these keys operate normally, and the menus are only accessible from the Edit menu.

Show Cross 
Reference 
Tips

When you select the check box, a tool tip will be visible showing the cross reference information for 
the address that your cursor is hovered over. The tool tip is in the format network.row.instruction.

ISA Symbols When you select the check box, the use of ISA symbols is enabled in the logic view.

Auto Fill 
Address Type

When you select the check box, the address type is automatically entered in any coil where there is a 
known, defined address type.

Online 
Multiple 
Undo/Redo 
Enabled

When you select the check box, you can reverse or reapply as many as 10 actions. Can only be 
applied to the network that you are currently working on. See p. 160 for more information.

State Flow When you select the check box, you can see the state of each contact or coil immediately, without 
having to use the Data Watch Window. Instruction is highlighted if it solves true, regardless of whether 
instructions upstream are passing power.

Online 
Update Rate

Adjusts how fast ProWORX 32 polls the controller for information when online and running. The faster 
the update rate, the more accurate the data displayed. But, as the update rate is increased, the 
performance of the software is reduced.

Property Description
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Hotkey Template

Overview The hotkey template is used to select the type of hotkey support that you wish to use. 
The following tables list the supported hotkeys for ProWORX 32, Modsoft, 
ProWORXPLUS, and ProWORX NxT.

Changing the 
Hotkey Template

 

ProWORX 32 
Hotkey Listing

ProWORX 32 generic hotkeys:

Step Action

1 Right-click Workspace and click Properties.
- or -
Right-click your project and click Properties.
- or -
Click View → Properties.

2 Click the Logic tab.

3 In the Hotkey Template list, click the template you want to use.
ProWORX 32
ProWORXPlus
Modsoft
NxT

4 Click OK.

Hotkey Operation

F1 Specific help for current topic

Ctrl+N New project

Ctrl+S Save project

Ctrl+Z Undo

Ctrl+X Cut

Ctrl+C Copy

Ctrl+V Paste

Ctrl+F Find (search)

Ctrl+H Replace

Ctrl+G Go to

Ctrl+P Print

Ctrl+Alt+I Print preview

Ctrl+F2 Documentation editor
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ProWORX 32 logic editor specific hotkeys:

Modsoft Hotkey 
Listing

 

Alt+F1 Instruction help

Alt+F2 Address used

Alt+F4 Exit ProWORX 32

Shift+F2 Tracking help

Hotkey Operation

Alt+R Open register editor

Alt+left mouse click Move entire logic block to another network location

Ctrl+left mouse click Copy address from one logic block to another

Ctrl+Home Go to first network of segment

Ctrl+End Go to last network of segment

Ctrl+E Enable discrete

Ctrl+D Force discrete off

Ctrl+Q Force discrete on

= Insert horizontal short

+ Insert vertical short

- Clear vertical short

Ins Insert popup menu (if insert/delete key menu property is on)

Del Delete popup menu (if insert/delete key menu property is on)

Hotkey Operation

Hotkey Operation ProWORX 32 Equivalent

Alt+F2 Invoke RDE Data Watch Window

Alt+F3 Copy Block copy

Alt+F4 Delete

Alt+F5 Paste Block paste

Alt+F6 Offset Replace

Alt+F7 Search

Alt+A Append network Insert previous network

Alt+B Retrace

Alt+D Delete network

Alt+I Insert network before Insert previous network

Alt+L Latched coil
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ProWORXPLUS 
Hotkey Listing

 

Alt+M Retentive coil

Alt+N Negative transitional

Alt+P Positive transitional

Alt+T Trace Locate coil

Alt+V Vertical short

Alt+Z DX-Zoom Register editor

Ctrl+Page Up Previous segment

Ctrl+Page Down Next segment

Ctrl+Home Go to first network of segment

Ctrl+End Go to last network of segment

Ctrl+F8 Configuration

Hotkey Operation ProWORX 32 Equivalent

Hotkey Operation ProWORX 32 Equivalent

Alt+A Address used

Alt+C Coil rebuild (offline), coil column (online)

Alt+G Global addressing Replace

Alt+H Help

Alt+J Jump to mark

Alt+L Log book

Alt+O Locate coil

Alt+R Register editor Register editor

Alt+S Search

Alt+T Trace (online)

Alt+U Undo

Alt+X Mark location and exit

Alt+Z Retrace

Ctrl+D Network display setup Logic properties

Ctrl+T Terminal block search

Ctrl+U Unlink all macros
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ProWORX NxT 
Hotkey Listing

Hotkey Operation

Ctrl+Home Go to first network of segment

Ctrl+Page Up Go to previous network of segment

Ctrl+End Go to last network of segment

Ctrl+Page Down Go to next network of segment

Ctrl+R Register editor 
Note: This hotkey is context sensitive. It displays the contents for the 
currently selected instruction or the Data Watch Window if no instruction 
is selected.

Ctrl+G Go To dialog box

Ctrl+M Mark location

Ctrl+L Local coil (when on a 0x address)

Ctrl+E Enable Discrete

Ctrl+D Force Discrete Off

Ctrl+Q Force Discrete On

Shift++ Insert vertical short

Shift+| Insert vertical short

= Insert horizontal short

- Delete vertical short

+ Insert vertical short
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Using the Logic Editor

Overview The level to which you can edit in the logic editor is set in the client security settings 
(see p. 22).

Opening the 
Logic Editor

Double-click Logic in the project navigation panel.

- or -

Right-click Logic in the project navigation panel, and click Open Editor.

- or -

Click Project → Logic.

- or -

Click the Logic toolbar button.

Undoing and 
Redoing Edits

Use the undo/redo feature to reverse or reapply up to 10 actions.

To Undo/
Redo an Edit

 

Note: The undo/redo feature works in the logic editor and traffic cop (see p. 194) 
only.

Note: You can only undo or redo one logic block at a time. You cannot select 
multiple logic blocks simultaneously and click Edit → Undo or Edit → Redo. If you 
try, an error message stating Nothing to Undo appears. 

Note: If you receive the message Undo information not recognized, clearing 
undo/redo information, a possible cause could be that the register ranges, which 
are set for the PRWX loadable, are being overwritten by the Traffic Cop, Peer Cop, 
MSTR, or other instruction addresses that are already used. Search for address 
conflicts with the Used Address (see p. 75) feature.

Step Action

1 Right-click in the logic editor, and click Edit → Undo or Edit → Redo.
- or -
Click Edit → Undo or Edit → Redo from the main menu.
- or -
Click the Edit or Redo toolbar buttons.
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Undoing/
Redoing Online

While working online or in combined mode, the undo/redo feature only works when:

The Online Multiple Undo/Redo Enabled (see p. 153) check box is selected in the 
logic properties dialog box.
The PRWX MSL loadable is added to your controller and is in the logic.
You use a running controller that supports this feature.

Online undo/redo is supported by the following controllers:

Adding the 
PRWX MSL 
Loadable

 

2 Select Edit → Undo or Edit → Redo. The Undo/Redo Stack dialog box appears.

3 In the list, click the starting point of the actions you wish to redo/undo. The rows 
(actions) above the selected action are also selected.

4 Click OK to undo or redo the selected actions.

Step Action

984-685E 984-AT4 Compact A120 Series

984-785E All Quantums Compact TSX

984-785L 984-VM4 Atrium

Step Action

1 Ensure that the Online Multiple Undo/Redo Enabled (see p. 153) check box is 
selected in the logic properties dialog box.

2 Attach to a valid controller. The PRWX Loadable dialog box appears.

3 In the Command field, type an unused register to be used by ProWORX 32 to 
control the loadable, or you can click Used to find one.

4 In the Table field, type an unused register of a starting range (i.e., 4xxxx to 
4xxxx+150) to be used by ProWORX 32 to transfer data into the loadable.

5 The Function field has the name of the function.
The Length field provides the length of the table.

These values cannot be changed.

6 In the Add the PRWX instruction to network number field, type a value 
between one and the maximum number of networks in the device. This number 
represents the network location to be created and where the PRWX instruction 
will be placed. Up to 5000 networks can be defined.

7 Click OK to add the PRWX instruction to your project’s logic.
- or -
Click Cancel to cancel adding the PRWX instruction.
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Working with Networks

Overview A ladder logic network contains a 7x11 celled grid. Network logic is solved from left-
to-right, top-to-bottom.

Inserting 
Networks

 

Moving 
Networks

You can move or copy networks within or between segments and within or between 
projects by using the standard Cut, Copy, and Paste functions. These functions can 
be selected by right-clicking the Network Navigator panel or by clicking the 
respective toolbar buttons.

Deleting 
Networks

 

Note: You can tailor your screen for viewing purposes by using the Zoom Out, 
Zoom In, and Full Screen toolbar buttons.

Step Action

1 To insert a network into a blank segment, right-click in the Network Navigator 
panel and click Insert Network.

2 To insert a network after the current network, right click in the logic editor, and 
click Insert → Next Network.

3 To insert a network previous to the current network, right-click in the logic editor, 
and click Insert → Previous Network.

Step Action

1 In the Network Navigator panel, click the network you wish to delete.

2 Right-click in the Network Navigator panel, and click Delete Network.
- or -
Right-click in the logic editor, and click Delete → Network.

Result: The selected network is deleted, and any remaining networks are shifted 
up one network.
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Working with 
Network Rows 
and Columns

 

Initializing Logic  

Step Action

1 To insert a row or column, right-click in the logic editor, and click Insert → Row 
or Insert → Column. You can only insert a row or column if it does not make the 
network invalid.

Inserting a column shifts existing columns to the right.
Inserting a row shifts existing rows down.

2 To delete a row or column, right-click in the logic editor, and click Delete → Row 
or Delete → Column. You can only delete a row or column if it does not make 
the network invalid.

Deleting a column shifts existing columns to the left.
Deleting a row shifts existing rows up.

Note: Delete → Row and Delete → Column only deletes empty rows. You must 
delete all elements from the row or column before you can delete the row or 
column. To do this, highlight the row or column, right-click in the logic editor, and 
click Delete → Element.

Step Action

1 To initialize logic (delete all existing logic and networks from the current project), 
right-click in the logic editor, and click Initialize Project Logic.
The Initialize Project Logic dialog box opens, asking if you want to continue. 
Click Yes or No.
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Instructions

Overview The instructions panel contains all available logic instructions. Click an instruction to 
drag and drop it into the logic editor.

Press Alt+F1 for specific instruction help.

Displaying the 
Instruction List

Right-click in the logic editor, and click View → Instruction List.

Adding an 
Instruction to a 
Network

Click the instruction you wish to add, and drag-and-drop it to any point in logic.

- or -

Click an empty cell, then click an instruction toolbar button to add an instruction.

Moving 
Instructions

You can move or copy instructions within or between networks and within or 
between projects by using the standard Cut, Copy, and Paste functions. These 
functions can be selected by right-clicking Edit in the logic editor or by clicking the 
respective toolbar buttons.

Finding 
Instructions

 

Deleting an 
Instruction from 
a Network

Click the instruction you want to delete from the network, and press Delete.

- or -

Right-click the instruction you want to delete from the network, and click Delete → 
Element.

Step Action

1 Set the logic editor cursor to the bottom node of the instruction that you want to 
search for.

2 Right-click in the logic editor, and click Search → Instruction Search.
Example: To find all ADD instructions in logic, set your cursor to the bottom node 
of an ADD instruction anywhere in the logic. Right-click in the logic editor, and 
click Search → Instruction Search.

3 Results: All instructions found are listed in the logic tab of the Search panel in 
the format InstructionName.Network.Row.Column.

4 To go to an instruction in the logic editor, double-click the desired instruction in 
the Search panel.
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Configuring an 
Instruction

 

Instruction 
Properties

 

Step Action

1 In the Properties panel, click the property you wish to configure.

2 Enter an appropriate value for each field (see below).

3 Press Enter to update the instruction’s properties.

Property Description

Top Type Top node address type

Top Offset Top node address

Mid Type Middle node address type

Mid Offset Middle node address

Bottom Type Bottom node address type

Bottom Offset Bottom node address

Name Instruction name
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Working with Addresses

Editing 
Addresses in 
Ladder Logic

 

Using Symbolic 
Addressing

To use symbolic addressing in the logic editor, see p. 64.

Finding 
Addresses in 
Ladder Logic

In the logic editor:

Step Action

1 To edit a single address, double-click the cell that contains the address you want 
to edit. Type the new address in the cell, and press Enter to save the changes.
- or -
You can also change the address for a specific cell by editing the Type and 
Offset fields in the Properties panel.

2 To edit a batch of addresses across networks, right-click in the logic editor, and 
click Search → Replace (Ctrl+H).

3 Enter the address to replace in the Find What field and the address that is to 
replace it in the Replace With field
Click Replace.
Results: The Replace dialog box opens.

4 Click Find Next to find the next instance of the address.
Click Replace to replace the address.
Click Replace All to replace addresses.

Note: For more information on searches, particularly using the step search and 
stay functions, see p. 71.

Step Action

1 To find a specific address, right-click in the logic editor, and click Search → Find 
(Ctrl+F).

2 Enter the address you want to search for in the Find What field.

3 Click Find to find the address in logic.

4 To find all like addresses in ladder logic, highlight a cell that contains the address 
that you want to search for.

5 Right-click Search → Address Search.
Example: To find all 10001 addresses in logic, highlight a cell containing the 
address 10001, and right-click Search → Address Search.
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Tracking Ladder 
Logic Addresses 
in the Data Watch 
Window

 

Disabling and 
Forcing 
Discretes

You can force a discrete to the On or Off state. This removes control of the discrete 
from logic; it remains in the fixed state until the force is removed. Enabling a discrete 
removes the Disabled On or Disabled Off, placing control of the discrete back in 
logic.

Using Addresses 
from the 
Documentation 
Editor

 

6 Results: All addresses found are listed in the Search Results window in the 
format InstructionName.Network.Row.Column.

7 To go to an address in the logic editor, double-click the desired address in the 
Search panel.

Step Action

Step Action

1 To track the address at the cursor:
Right-click Data → Add Watch.
- or -
Right-click Data → Track → Address.

2 To track all addresses in an instruction, right-click Data → Track → Instruction.

3 To track all addresses in a network, right-click Data → Track → Network.

4 To track all discrete addresses in a network, right-click Data → Track → 
Discretes.

Step Action

1 To force discretes on in a network, right-click Data → Disable On (Ctrl+Q).

2 To force discretes off in a network, right-click Data → Disable Off (Ctrl+D).

3 To return control of a discrete’s state back to logic, right-click Data → Enable 
(Ctrl+E).

Step Action

1 Click the Summary button in the documentation editor.

2 Click an address in the Reference field, and drag and drop it into any instruction 
in logic or any address property in the Properties panel.
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Configurable Mnemonics

Overview In ProWORX 32, all instruction mnemonics are configurable, so you can use 
mnemonics you are already familiar with.

Editing a 
Mnemonic

 

Mnemonics 
Listing

Mnemonic descriptions:

Step Action

1 Right-click your project in the project navigation panel, and click Properties.
- or -
Right-click Workspace, and click Properties.
- or -
Click View → Properties.

2 Click the mnemonic you wish to edit, and click Edit.

3 Type in the new mnemonic.

4 Click outside of the field or press Enter to save changes.
Note: If you try to type an existing mnemonic, ProWORX 32 reverts to the old 
mnemonic.

5 Click OK.

Mnemonic Description

NO -] [- normally open

NC -]\[- normally closed

PTC -]P[- off to on

NTC -]N[- on to off

VTO | OPEN vertical open

VTS | SHRT vertical short

HSH -SHRT horizontal short

CNR -()- normal coil

CR -(L)- latched coil

SKP SKP skip function

UCT UCTR up counter

DCT DCTR down counter

T1 T1.0 timer (seconds)

T0 T0.1 timer (tenths)

T. T.01 timer (hundredths)
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ADD ADD addition

SUB SUB subtraction

MUL MULT multiplication

DIV DIV division

RT R->T register to table

TR T->R table to register

TT T->T table to table

BLK BLKM block move

FIN FIN first-in

FOU FOUT first-out

SRC SRCH table search

STA STAT system status

AND AND logical and

OR OR inclusive or

CMP CMPR logical compare

SEN SENS logical bit sense

MBI MBIT logical bit modify

COM COMP logical complement

XOR XOR exclusive or

BRO BROT logical bit rotate

Mnemonic Description
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ISA Symbols

Overview If the ISA Symbol Name field in the project is set up to support discrete addresses, 
the network editor draws the ISA symbol instead of the ladder logic instruction.

Attaching an ISA 
Symbol to a 
Discrete Device

 

ISA Symbol 
Reference

ISA Symbols:

Step Action

1 Select a discrete device in the logic editor.

2 Enter an ISA symbol name in the ISA Symbol field in the documentation editor.

Symbol Diagram Symbol Diagram

CRNC PBNC

CRNO PBNO

FLSNC PRSNC

FLSNO PRSNO

FSNC PSNC

FSNO PSNO
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LSNC SOL

LSNO TASN

LTG TASNC

LTR TGSN

HORN TGSNO

Symbol Diagram Symbol Diagram
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Diagnostic Trace

Overview The Diagnostic Trace feature is used to find dependencies of a particular output coil 
(0xxxx). A search is performed to find the destination point. Then each network is 
searched to find dependencies of the output address. Each network is then 
searched to find dependencies of these dependencies.

Why Use 
Diagnostic 
Trace?

Use Diagnostic Trace to isolate problems relating to a specific output. For instance, 
if an output is off when it should be on, the Diagnostic Trace will search through logic 
to determine which addresses affect its state.

Using Diagnostic 
Trace

From the right-click menu in the logic panel:

Step Action

1 In the logic editor, highlight the address you wish to trace, and right-click Search 
→ Diagnostic Trace.

2 To move to an address’ cross reference, select the cross reference from the 
address list. The logic editor moves to the selected network, row, and column.
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Analyzing 
Diagnostic Trace 
Results

The Diagnostic Trace window shows the output address on the right side of the 
window.

The column to the left is all the dependencies of the output address.
The next column is all the dependencies of the dependencies.

Each address object within the trace contains a list of cross references for the 
address.

The address object includes the network number, row, and block type. For multi-
node blocks, an S or D is placed before the block type to indicate source or 
destination. For example, 1.3 S(BLKM). This indicates the address object in network 
number one, row three, and the source node of the block move instruction.

If there is no block type indicator, that means that the address object is a coil 
instruction; for example, (1.2), where one is the network number and 2 is the row.

If you click one of these cross references in the drop-down list, the logic editor moves 
to that network, row and column. The address objects are also colored to quickly find 
a problem. A check of the address state as well as instruction type is performed to 
determine the correct color of the address object.

Address color scheme:

Color Description

Red This address is likely to be the source of the problem.

Yellow This address could be related to the problem.

Green This address is not likely to be the source of the problem.

Note: To update the ladder logic cross references, select Update Cross 
References from the logic editor right-click menu.
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Sweep (Online Only)

Overview The Sweep function lets you solve logic for a set number of scans or solve logic 
continuously with a constant time between scans.

Constant Sweep 
Mode

The Constant Sweep mode sets the controller to scan and solve logic and update I/
O continuously, but with a constant time interval between scans.

If the actual scan time is less than the imposed scan time, the controller waits for the 
imposed scan time to elapse before performing the next scan. If the actual scan time 
is more than the imposed scan time, the controller finishes the scan, then continues 
on with the next scan. This lets you slow the scan time to when debugging logic, so 
that the controller doesn’t solve logic too quickly for you to catch errors.

Performing a 
Constant Sweep

 

Single Sweep

Single Sweep mode sets the controller to scan and solve logic and update I/O for a 
set number of scans only. When the sweep is finished, the controller stops solving 
logic and updating I/O, and waits until you manually trigger the sweep.

Step Action

1 Right-click in the Network Navigator panel, and click Sweep.

2 In the Sweep Mode field, click the Constant Sweep button.

3 In the Time field, enter the target time (in 10s of milliseconds) for each scan.

4 In the Register (4xxxx) field, enter a 4xxxx register to hold the target time value. 
The actual time taken for each scan is placed in the next register, so a total of 
two registers are used.

5 Click OK.

Single sweep will stop PLC without setting outputs to a predefined state.
Invoking single sweep will stop a running PLC after a set number of scans. The 
outputs are frozen in their last state of the last scan. Be sure it is appropriate to 
stop the process without setting outputs to a predefined state.

Failure to follow this instruction can result in death, serious injury, or 
equipment damage.

WARNING
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Performing a 
Single Sweep

 

Step Action

1 Right-click in the Network Navigator panel, and click Sweep.

2 In the Sweep Mode field, click the Single Sweep button.

3 In the Time field, enter the target time (in 10s of milliseconds) for each scan.
Note: If the actual scan takes less time than the target scan time, the controller 
waits for the target scan time to elapse before performing the next scan. If the 
actual scan takes more time than the target scan time, the controller finishes the 
scan, then continues on with the next scan. This lets you force the scan time to 
a higher rate when debugging logic that the controller may solve too quickly to 
otherwise catch.

4 In the Scans field, enter the number of scans (1-15) to be performed during the 
sweep.

5 Click OK.

6 When you are ready to perform the sweep, right-click in the Network Navigator 
panel, and click Sweep.

7 Click one of the following buttons:
Invoke: Select to start the sweep.
Trigger: Select to set a trigger for the sweep.
Turn Off: Select to shut off the sweep.

8 Click OK.
Result: The controller performs the scans (unless you selected Turn Off), then 
stops solving logic with all outputs frozen in their last state.
You can then browse register contents and perform other diagnostics using this 
process.
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Setting Bookmarks in Logic

Overview You can set bookmarks in your network logic so you can quickly return to a cell or 
series of cells. The Mark and Goto Mark functions allow quick viewing of non-
consecutive areas of logic. By marking multiple cell locations on different networks, 
you can use the mark table to quickly jump between the marked locations.

Setting a Mark in 
Logic

 

Going to a 
Marked Cell

 

Deleting a 
Bookmark

 

Setting a Mark 
Using Step 
Search

You can also set a Mark in logic using the Step Search (see p. 71) function.

Step Action

1 Right-click the cell in the logic editor that you wish to mark.

2 Click Search → Mark.
Result: The cell is added to the Bookmark Table.

Step Action

1 Right-click in the logic editor.

2 Click Search → Goto Mark.
Result: The Goto Mark dialog box opens.

3 Click the mark you wish to go to, and click Goto.

Step Action

1 Right-click in the logic editor.

2 Click Search → Goto Mark.
Result: The Goto Mark dialog box opens.

3 Click the mark you wish to delete, and click Delete.
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Hardware Clock

Overview Many controllers have a built-in time of day clock. You can set these clocks if the 
controller's starting register is configured in the configuration editor (see p. 94), you 
have the necessary rights, and the controller is running.

Configuring the 
Hardware Clock

 

Hardware Clock 
Registers

The time of day clock requires eight 4xxxx registers in your controller:

Step Action

1 Right-click in the Network Navigator panel, and click Hardware Clock.
- or -
Click Controller → Set Hardware Clock.
Note: If you choose this means to open the Hardware Clock, the logic editor 
must be open. Otherwise, the Hardware Clock option will not be available in 
the Controller menu.

2 In the First Day of Week list, click the day the controller will use as the first day 
of the week.

3 Do one of the following:
To synchronize the controller’s date and time with your computer, click Auto 
Set.
In the Controller Date field, type the date in mm-dd-yy format. In the 
Controller Time field, type the time in hh-mm-ss format.

4 Click OK.

Register Content

4xxxx Controller Information. From the left:
Bit 1: Set Clock Values
Bit 2: Read Clock Values
Bit 3: Done
Bit 4: Errors

4xxxx + 1 Day of week (from 1 to 7)

4xxxx + 2 Month

4xxxx + 3 Day

4xxxx + 4 Year

4xxxx + 5 Hour (in 24-hour format)

4xxxx + 6 Minutes

4xxxx + 7 Seconds
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Segment Scheduler

Overview The Segment Scheduler governs when each segment of logic is solved and controls 
which I/O drops are updated after each segment is solved.

The number of segments in the project is set in the configuration editor. By default, 
the segments are solved in numerical order (segment one first, segment two next, 
and so on).

Using the 
Segment 
Scheduler

 

Step Action

1 Right-click in the Network Navigator panel, and click Segment Scheduler.

2 Click the Control Input field, and select an input from the list.
Continuous: Sets the segment in this row to be solved every scan.
Set Control: Sets the segment to be solved only when a discrete address is 
in a specific state. If you select Set Control, you must also:

Type the discrete address in the Address field, which controls whether the 
segment in this row is to be solved.
Select whether the segment in this row is to be solved when the control 
discrete is On or Off.

Watchdog Timer Reset: Inserts a Watchdog Timer.

3 Click the Drop In field, and select the input drop associated with the segment in 
this row during the solve from the list.

4 Click the Drop Out field, and select the output drop associated with the segment 
in this row during the solve from the list.
Note: For S901 projects/controllers, the Drop In is replaced with Channel In and 
Drop Out is replaced with Channel Out.

5 Click OK.
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Equation Network Structure

Overview An equation network provides an easy way to program complex math functions, with 
values stored in register locations. Equations in an equation network are presented 
in a regular, left-to-right format, technically known as infix notation. You program 
equation networks and set its enable contact and output coil(s) in the Equation 
Network Editor.

Equation networks were introduced in Quantum Rev. 2 controllers; not all controllers 
support equation networks. The easiest way to see if your controller supports 
equation networks is by trying to create a new one; if your controller doesn’t support 
it, the equation network option on the right-click Insert menu won’t be available.

Creating an 
Equation 
Network

 

Using the 
Equation 
Network

 

Note: Controllers do not allow blank equation networks. Since ProWORX 32 allows 
blank equation networks, please note that they will not be saved to the controller.

Step Action

1 In the Network Navigator panel, click the network where you want to insert the 
equation network.

2 Right-click in the logic editor, and click Insert → Equation Network. An equation 
network occupies a whole network, regardless of the contents of the equation 
network.

Step Action

1 Enter the equation.

2 In the Properties panel, click the Input Type field, and select an input type from 
the list.

3 In the Input Offset field, enter the input reference.

4 Set the register address for the output coils. You can enter either the direct 
address (in X:Y numeric format) or a symbolic address (see p. 64). You can also 
insert addresses from the Symbols panel, Used Register Address table, and the 
Descriptor Summary. See below for coil descriptions.

5 To enter an equation into the network:
Click the ellipsis box in the Equation field.
- or -
Double-click anywhere in the Equation Network Editor.
178 31003882 12/2006



Using the Logic Editor
Coil Descriptions Enter a 0x reference. 

Error Coil 
Messages

 

Setting up an 
Enable Contact

An equation network’s enable contact, when set, activates the equation network. If 
an enable contact passes current, the equation network will be solved. You change 
settings for the enable contact in the Enable Editor display.

To select a type for the enable contact, select the symbol of the enable contact that 
corresponds with your chosen type. An enable contact can be a normally-open 
contact, normally-closed contact, horizontal short, or a horizontal open.

To select a register address for the enable contact, in the Enable Contact address 
field, type the direct address (in X:Y numeric format) or symbolic address (see p. 64) 
for the enable contact coil. This field is only available if the enable contact type is a 
normally-open or normally closed contact.

Coil Description

Solved OK Solved OK is set when the equation is being solved without errors.

< Coil Result < 0 is set when the equation result is less than zero.

= Coil Result = 0 is set when the equation result is equal to zero.

> Coil Result > 0 is set when the equation result is greater than zero.

Error Coil The error coil is set when errors have occurred while solving the 
equation. While online, if the error coil receives power, an error 
message will appear under the coil describing the error (see p. 179).

Note: If you don’t want to use a particular output coil, leave the address for that coil 
blank (or erase one already typed in). That coil will not be included in the equation 
network.

Error Message Meaning

Invalid operation An internal error generated by the math coprocessor.

Overflow A value is too large to be represented in its specified data type.

Underflow A number is too small to be represented in FP format (for floating point 
data only)

Divide by 0 The variable, constant, or result of a function directly to the right of a / 
operator has a value of zero.

Invalid operation 
with boolean data

Occurs when a boolean value is entered in an argument to a function.
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Equation 
Network Content

The content of the equation network is in the form:

result = algebraic expression

where the

Equation 
Network Size

An equation network can contain a maximum of 81 words, which are used according 
to the following rules:

result is a variable contained in 1 or 2 4x registers. It may be a signed 
or unsigned 16-bit short integer, a signed or unsigned 32-bit 
long integer, or a floating point number.

algebraic expression is a syntactically correct construction of variable and/or constant 
data, standard algebraic operators, and/or functions. 
Parentheses can be used to define the order in which the 
expression is evaluated and indicate arguments to functions 
within the expression.

Each... Consumes....

enabling input 1 word

normally open or normally closed contact 1 word

horizontal short used as input no words

output coil 1 word

16-bit register and/or discrete reference 1 word

opertaor in the equation window 1 word

function in the equation window 1 word

short integer 1 word

floating point or long constant 2 words

open/closed parenthetical pair 2 words
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Mathematical Equations in Equation Networks

Equation Format Equation elements appear in specific formats. Operations and functions each have 
their own format. Also, for each value, you must specify what kind of value it is 
(register address, constant or symbol) and its data type (signed integer, unsigned 
integer, etc.).

Equation Values 
and Data Types

Each value can refer to a constant, register address or symbol. The Equation 
Network Editor determines which data type the value is, based on the following 
format.

The actual data type of a value is determined by its suffix, as shown in the following 
table:

Typically, you’d first indicate the register address where the calculated result is to be 
stored, followed by an equal sign (the assignment operator), followed by the 
calculation itself. For example:

40001 = 40002U + COS(40003UL) * #+1.35E-4F / ’HEIGHT’L

40002U is an address of a 16-bit unsigned integer.
COS(40003UL) calculates the cosine of a long (32-bit) unsigned integer value 
stored at address 40003.
#+1.35E-4F is the floating point value of 0.000145, given in exponential notation.
’HEIGHT’L is a symbol of the name HEIGHT, representing the address of a long 
(32-bit) signed integer.
40001 = indicates that the result of the calculation is to be stored in register 
address 40001 as a 16-bit signed integer.

Format Meaning Example

Default (no # sign or single quotes Register address 40001

Prefixed by # Constant #123

Enclosed in single quotes Symbol ‘HEIGHT’

Suffix Data Type Applies to

B Boolean (binary) Constants, 1x, or 0x

U 16-bit unsigned short integer Constants, 3x, or 4x

S Signed short integer Constants, 3x, or 4x

L 32-bit signed long integer Constants, 3x, or 4x

UL 32-bit unsigned long integer Constants, 3x, or 4x

F 32-bit floating point number Constants, 3x, or 4x
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Everything to the right of the assignment operator also constitutes an expression. 
An expression is any part of an equation that can be evaluated to a single value. This 
can be a single constant or register address, or a complete mathematical operation. 
For example, #35 is an expression, as are LOG(#10) and 40002U + COS(40003UL). 
Complex expressions can contain other expressions within them, as in #3 * (40002U 
+ COS(40003UL)). For the most part, any operator or function can be performed on 
any expression, no matter how complex.

Variable Data Variable data within an equation network can be in 0x and 1x discrete references 
and in 3x and 4x registers.

Note: It is good programming practice to enclose all expressions in parentheses, 
even when they’re not actually needed. This makes the equation easier to read and 
ensures that operations in an equation are solved in the correct order.

Data Type Variable Type Words 
Consumed

Registers 
Consumed

Boolean 0x or 1x One N/A

Unsigned 16-bit variable 3x or 4x One One

Signed 16-bit variable 3x or 4x One One

Unsigned long (32-bit) variable 3x or 4x One Two

Signed long (32-bit) variable 3x or 4x One Two

Floating point variable 3x or 4x One Two

Note: When contiguous 3x or 4x registers are used for 32-bit long integers, the 
value still consumes only one word in the equation network.

Note: When 3x or 4x registers are used for a floating point number, the value 
requires one word for complete definition.
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Entering Variable 
Data in an 
Equation 
Network

When entering a 0x or 1x references as a discrete variable in an equation network, 
the reference is assumed to be boolean, and you do not need to append the suffix 
B to the reference. Thus, the entires 000010 and 000010B are equivalent.

No other suffixes are legal with a 0x or 1x reference.

When you enter a 3x or 4x register in an equation network, the following rules apply:

Constant Data Constants can also be used to specify data in an equation network. Long (32-bit) 
constants and floating point constants always require two words. The least 
significant byte (LSB) is always in the first of the two words. Both words must have 
the same data type.

If you enter a register . . then . . 

without a suffix, it is assumed to represent a signed 16-bit integer variable. 
You do not need to append the suffix S to the reference. Thus 
the entries 400023 and 400023S are equivalent.

with the suffix U (e.g., 
300004U),

you indicate that a single register containing an unsigned 16-
bit integer variable is used.

with the suffix L, you indicate that two contiguous registers containing a signed 
32-bit long integer variable are used (e.g., 400012L implies 
that register 400013 is also used).

with the suffix UL, you indicate that two contiguous registers containing an 
unsigned 32-bit long integer variable are used (e.g., 
300006UL imples that register 300007 is also used).

with the suffix F, you indicate that two contiguous registers containing a 
floating point variable are used (e.g., 400101F implies that 
register 400102 is also used).

Note: You cannot append a 3x or 4x register with the suffix B.

Data Type Words Consumed Valid Range of Values

Boolean One 0, 1

Signed 16-bit constant One -32,768 ... +32,767

Unsigned 16-bit constant One 0 ... 65,535

Signed long (32-bit) constant Two -2 x 109 ... +2 x 109

Unsigned long (32-bit) constant Two 0 ... 4,294,967,295

Floating point constant Two 8.43 x 1037 ≤ |x| ≤ 3.402 x 1038
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Entering 
Constant Data in 
an Equation 
Network

A constant is prefaced with a # sign and appended with a data type suffix (see 
p. 181). All constant values are in decimal format. Hexadecimal values are not 
allowed in ProWORX.

If you enter a constant in an equation network without a suffix, it is assumed to a 
signed short integer. For example, the entries #-3574 and #-3574S are equivalent.

A boolean constant must have the suffix B. The only two valid boolean constants are 
#0B and #1B. No other values are legal boolean constants.

Exponential 
Notation

Floating point numbers are normally specified in exponential notation, as in:

+1.34E-4

This represents 1.35 times 10 to the -4th power, or 1.35 times 0.0001. Thus, we 
would shift the decimal place four places to the left to get 0.000135. The -4 part is 
called the exponent (note the preceding E) and can be a positive or negative 
number.

In the Equation Network Editor, you must also indicate:

That these numbers are constants; and
Their data types. For example, integers or floating point numbers.

The default data type is unsigned 16-bit integer. So, since the above value is a 
fraction (and therefore must be a floating point number), it would have to appear as 
#+1.35E-4F.

With no data type suffix, numbers in exponential notation are assumed to be 
integers. For example, #+1.35E+2 represents the unsigned 16-bit integer value 135. 
Exponential notation is particularly useful for very large integers.
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Mathematical Operations in Equation Networks

Mathematical 
Operations

The following table lists the mathematical operations you can include in your 
equation:

Type Operator Result

Assignment operator
The assignment operator = is used to 
assign a storage place for the results 
of the equation. All equations will use 
the assignment operator. The format 
is:
ADDRESS = EXPRESSION
Where ADDRESS is a valid register 
address and EXPRESSION is a valid 
value or expression assigned to the 
address.

= Assignment

Unary operator
Unary means single, so unary 
operators are used on only one value. 
The unary operator is placed just 
before the value or expression to 
which it is applied. For example, -
(30002) returns -1 times the number 
stored at address 30002.

- Negation. The result is -1 times the 
value.

~ Ones complement. This works on the 
binary representation of a value: all 1s 
are changed to 0s and vice versa.

Exponentiation operator
Takes values to a specified power. 
40001**3 returns the (integer) value 
stored at 40001, taken to the third 
power.

** Exponentiation

Arithmetic operator
These require two values, one before 
and one after the operator. These 
values can be any valid expression. 
For example, #4 * 40003 results in 
four multiplied by the value stored at 
address 40003.

* Multiplication

/ Division

+ Addition

- Subtraction
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Bitwise operator
Bitwise operators work on binary 
(base 2) representations of values.
 

In the case of AND, OR and XOR, 
the computer applies the operator 
to each digit in the two values: 010 
XOR 011 (2 XOR 3 in decimal 
numbers) results in 001 (1 in 
decimal).
In the case of shifting operators, 
the computer shifts all digits in the 
binary representation of the 
number the given number of 
places to the left or right. Digits on 
one side of the number are lost, 
and zeros fill in the blanks on the 
other side. For example, for 8-bit 
numbers, 77 << 2 means 
01001101 shifted left two digits. 
The binary result is 00110100, or 
52 decimal.

& AND. The single bit result of an AND 
operation is only true (1) if both bits are 
set to 1.

| OR. The single bit result of an OR 
operation is true (1) if either bit is set to 
1. The result is false (0) only if both bits 
are set to 0.

^ XOR. Short for Exclusive OR. The 
single bit result of an XOR operation is 
false (0) if both bits are the same, true 
(1) otherwise.

<< Left Shift. The result of 40001<<#2 is 
the binary representation of the 
number stored at 40001 shifted left two 
(#2) places. Zeros are added on the 
right to fill in the gap.

>> Right Shift. The result of 40001>>#2 is 
the binary representation of the 
number stored at 40001 shifted right 
two (#2) places. Zeros are added on 
the left to fill in the gap.

Relational operator
These operators perform a 
comparison between two values or 
expressions. The result is always true 
(1) or false (0). For example, #35 <= 
#42 evaluates to 1 (true). Relational 
operators are used in Conditional 
expressions.

< Less than.

<= Less than or equal to.

= Equal to.

<> Not equal to.

=> Greater than or equal to.

> Greater than.

Conditional operator
See below for details.

?: Used in conditional expression.

Parentheses
Used to set precedence in solving 
equations. To make sure certain 
operations are solved before others, 
enclose those operations in 
parentheses.

()

Type Operator Result
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How an Equation 
Network 
Resolves an 
Equation

An equation network calculates its result in one of two ways, depending on the 
operator types used in the expression.

Single Expression

Evaluate a single expression and execute it by copying the derived value to the 
result register.

Conditional Expression

Evaluate the validity of the first of three arguments in a conditional expression and 
execute it by copying the value from either the second or third argument in the 
conditional expression to the result register.

If the expression being evaluated contains only some combination of unary, 
exponentiation, mathematical, and/or logical bitwise operators, it is treated as a 
single argument and is solved via single expression. For example, in the equation

400001 = (#16 ** #2 - #5) * #7

the square of 16 (256( minus 5 (251) is multiplied by 7, and the result (1,757) is 
copied to register 400001.

If you use one or more of the six relational operators shown in the previous table, 
you create the first of three arguments that comprise a conditional expression. The 
conditional operators must be used to create then/else arguments in the expression, 
and conditional expression is used to execute the result. For example, in the 
equation

400001 = 400002 >= #100 ? 300001 : 300002

the value in register 400002 is evaluated to see if it is greater than or equal to 100. 
This is the first argument in the conditional expression. If the value is greater than or 
equal to 100, the second argument is executed and the value in register 300001 is 
copied to register 400001. It is less than 100, the third argument is executed and the 
value in register 300002 is copied to register 400001.
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Operator 
Precedence

In a string of data types and operators, the order or precedence in the expression 
determines the order in which operations will be evaluated. Review the following 
examples:

Using 
Parentheses in 
an Equation 
Network 
Expression

You can alter the order in which an expression is evaluated by enclosing portions of 
the expression in parentheses. Parenthetical portions of the expressions are 
evaluated before portions outside the parentheses. Notice how the following 
expressions are evaluated with and without parentheses:

400001 = 300001F ** 300002F * 300003 + 300004 & 300005 > 300006 ? 300007 : 300008
The operations in the first argument of the conditional expression are evaluated from left to right in the order they 
appear. First, the value in register 300001 is raised to the power of the value in register 300002, then multiplied by 
the value in register 300003. That result is added to the value in register 300004, then logically ANDed with the value 
in register 300005 and compared with the value in register 300006.
If the > comparison is true, the second argument in the conditional expression is executed, and the value in register 
300007 is copied to register 400001. If the > comparison is false, the third argument in the conditional expression is 
executed and the value in register 300008 is copied to register 400001.

400001 = 300002U > 300003 & 300004U + 300005F * 300006F ** 300007 ? 300008 : 300009
Operator precedence forces the opposite effect on the first argument of the conditional expression.
Here the first operation to be evaluated is the exponentiation of the value in register 300006 by the value in register 
300007, followed by multiplication by the value in register 300005, then adition with the value in register 300004, then 
logically ANDing the result with the value in register 300003, and finally comparing teh result with the value in register 
300002.
If the > comparison is true, the second argument in the conditional expression is executed, and the value in register 
300008 is copied to register 400001. If the > comparison is false, the third argument in the conditional expression is 
executed, and the value in register 300009 is copied to register 400001.
When operators of equal precedence appear in an expression, they are generally evaluated in the order form from 
left to right and top to bottom in the equation network.

400001 = 300001U < 300002U | 300004U & 300001U + 300003U ? 300004 : 300005
This expression is evaluated by the precedence
300001U < ( ( 300002U | 300004U ) & ( 300001U + 300003U ) ) ? 300005 : 300006
where the sum of the values in registers 300001 and 300003 is ANDed with the logical OR of the values in registers 
300002 and 300004.

400001 = 300001U < ( 300002U | 300004U & 300001U ) + 300003U ? 300004 : 300005
This expression is evaluted by ORing the values in registers 300002 and 300004, then ANDing the result with the 
value in register 300001, and finally adding the value in register 300003.
188 31003882 12/2006



Using the Logic Editor
Nested 
Parentheses

When multiple levels of parenthetical data are nested in an expression, the most 
deeply nested parenthetical data is evaluated first. An equation network permits up 
to 10 nested levels of parentheses in an expression.

For example, the order in which the second expression above  is evaluated can be 
seen more clearly when parentheses are used.

300002U > ( 300003U & ( 300004U + ( 300005U * ( 300006F ** 300007F ) ) ) ) ? 
300008 : 300009

Entering 
Parentheses in 
an Equation 
Network

Equation network will echo back to you the expression as you enter it. It does not 
prevent you from entering additional levels of parentheses even when they may not 
be necessary to make the expression syntactically correct. For example, in the 
expression

( ( ( ( 300004U + 300005U ) ) ) ) / 300006U

equation network maintains the four nested level of parentheses in the expression 
even when only one set of parentheses may be needed.

Each pair of open and closed parentheses consumes two words in the equation 
network.

Note: The expression must have an equal and balanced number of open and 
closed parentheses in order to compile properly. If it does not, a compiler error will 
be generated and the equation network will not function.
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Mathematical Functions in Equation Networks

Mathematical 
Functions

The following table lists the pre-defined math functions you can include in your 
equation. Each of these functions takes one argument enclosed in brackets 
following the function name. The argument can be any valid value or expression. For 
example, COS(#35+40001) returns the cosine of 35 plus the number stored at 
address 40001. In this table, X refers to a function’s argument (as in COS(X)).

Entering 
Functions in an 
Equation 
Network

A function must be entered with its argument in the following form in the equation 
network expression:

function name ( argument ) 

where the function name is one of those listed in the table above and the argument 
is entered in parentheses immediately after the function name. The argument may 
be entered as:

one or more unary operations
one or more exponential operations
one or more multiplication/division operations
oneo or more addition/subtraction operations
one or more logical operations
one or more relational operations

Function Description

ABS(S) Absolute value of X (i.e. negative numbers become positive).

ARCCOS(X) Arc cosine of X radians.

ARCSIN(X) Arc sine of X radians.

ARCTAN(X) Arc tangent of X radians.

COS(X) Cosine of X radians.

COSD(X) Cosine of X degrees.

EXP(X) Calculates e (approximately 2.7182818) to the Xth power.

FIX(X) Converts floating point number X to an integer.

FLOAT(X) Converts integer X to a floating point number.

LN(X) Natural (base e) logarithm of X.

LOG(X) Common (base 10) logarithm of X.

SIN(X) Sine of X radians.

SIND(X) Sine of X degrees.

SQRT(X) Square root of X.

TAN(X) Tangent of X radians.

TAND(X) Tangent of X degrees.
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any legal combination of the above operations

For example, if you want to calculate the absolute value of the sine of the number in 
FP register 400025 and place the result in FP register 400015, enter the following in 
the equation network:

400015F = ABS (SIN (400025F))

See p. 185 for more details about these operations.

Limits on the 
Argument to a 
Function

The argument to a function in an equation network is resolved to a floating ponit (FP) 
number. The FP value must be in the following range, depending on the type of 
function.

Function Argument Range

ABS FP value -3.402823 x 1038 ... +3.402823 x 1038

ARCCOS FP value -1.00000 ... +1.00000

ARCSIN FP value -1.00000 ... +1.00000

ARCTAN FP value -3.402823 x 1038 ... +3.402823 x 1038

COS FP value -3.402823 x 1038 ... +3.402823 x 1038

COSD FP value -3.224671 x 104  ... +3.224671 x 104

EXP FP value -87.33655 ... +88.72284

FIX FP value -2.147484 x 109 ... +2.147484 x 109

FLOAT FP value -3.402823 x 1038 ... +3.402823 x 1038

LN FP value 0 ... 3.402823 x 1038

LOG FP value 0 ... 3.402823 x 1038

SIN FP value -3.402823 x 1038 ... +3.402823 x 1038

SIND FP value -1.724705 x 104 ... +1.724705 x 104

SQRT FP value 0 ... 3.402823 x 1038

TAN FP value -3.402823 x 1038 ... +3.402823 x 1038, not p/
2 x n (where n is an integer value)

TAND FP value -1.351511 x 104 ... +1.351511 x 104, not 90 
x n (where n is an integer value)
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Using the Traffic Cop
At a Glance

Overview The Traffic Cop is used to visualize and configure I/O stations (drops). Each I/O 
series (Quantum, Momentum, SY/MAX, Compact A120, Compact TSX 800, 800, 
200-500, DCP, S901, 900, Micro, Micro 984) has the same look and feel, although 
some series have different I/O structures.

What's in this 
Chapter?

This chapter contains the following topics:

Topic Page

Traffic Cop Overview 194

Working with Drops and Racks 196

Working with Slots 200

Online Module Status 203

I/O Drawing Generator 204

Materials List 206
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Using the Traffic Cop
Traffic Cop Overview

Overview The Traffic Cop is used to visualize and configure I/O stations (drops). Each I/O 
series (Quantum, Momentum, SY/MAX, Compact A120, Compact TSX 800, 800, 
200-500, DCP, S901, 900, Micro, Micro 984) has the same look and feel, although 
some series have different I/O structures. 

Navigation Panel The navigation panel shows a text-based representation of the Traffic Cop. The 
panel is enabled regardless of which I/O station is selected. The panel provides a 
hierarchical view of configured drops, racks and slots. Navigate through the panel to 
select a drop or rack to view or to edit its configuration in the Drop or Slot Properties 
panel. Use the panel view to insert, delete, and move any of the drops, racks, or 
slots.

Visual 
Representation

The visual representation of the I/O system consists of three views:

Drop View - Visual representation of all racks and slots within the selected I/O 
drop. Click any slot to jump to the rack view that contains the selected slot.
Rack View - Visual representation of all slots within the selected rack. Click any 
slot to access that slot's properties in the Slot Properties panel.
Overview - Visual representation of the Momentum Traffic Cop. This shows only 
the current branch of I/O. If a new card can be programmed, the last shown card 
is labelled AVAILABLE.

Opening the 
Traffic Cop

Double-click Traffic Cop in the project navigation panel.

- or -

Right-click Traffic Cop in the project navigation panel, and click Open Editor.

- or -

Click Project → Traffic Cop → Open.

- or -

Click the Traffic Cop toolbar button.
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Initializing the 
Traffic Cop

In the Traffic Cop navigation panel:

Step Action

1 In the Traffic Cop navigation panel, right-click the I/O station you wish to 
initialize.

2 Click Initialize.

Loss of I/O Configuration Data
Reconfigure Traffic Cop prior to placing PLC into run mode.

Failure to follow this instruction can result in injury or equipment damage.

CAUTION
31003882 12/2006 195



Using the Traffic Cop
Working with Drops and Racks

Drop Properties 
Panel

The drop properties panel, in the lower right side of the Traffic Cop editor, lists user-
editable and calculated properties pertaining to the selected drop.

In the Traffic Cop navigation panel, click the drop you want to work with. Available 
drop properties are:

Working with 
Drops

The following functions are available when you right-click a drop in the Traffic Cop 
navigation panel.

You can edit the currently selected drop at any time by editing properties in the Drop 
properties panel.

Property To Edit...

Hold-up Time Enter a hold-up time value (3 - 65,535).

Rack (1-x) Select a rack from the rack list. (X represents the number of racks 
available.)

ASCII Port Enter an ASCII port value.

Input Points Read only - number of input bits used within the selected drop.

Output Points Read only - number of output bits used within the selected drop.

Status Register Enter a 3xxxx address (holds the status information for the drop).

Read Only Select TRUE or FALSE from the available drop mode list.

Note: Not all properties are available for all drops, i.e., a Quantum drop will not 
have an ASCII Port property.

Function Action Comment

To insert a drop: Click Insert Drop. Inserts a drop above the selected drop and 
moves existing drops down.

To clear a drop: Click Clear Drop. Clears all racks from the selected drop.

To delete a drop: Click Delete Drop. Deletes the currently selected drop, and 
moves the remaining drops up.
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Working with 
Racks

The following functions are available when you right-click a rack in the Traffic Cop 
navigation panel.

 

You can edit the currently selected rack at any time by editing the rack property in 
the Drop properties panel.

Using Cut/Copy/
Paste/Undo/
Redo

All items in the Traffic Cop (heads, drops, racks, and slots) can be cut, copied and 
pasted. Also, items can be cut, copied, or pasted between different projects’ Traffic 
Cops. 

The following functions are available when you right-click in the Traffic Cop 
navigation panel.

Cut - Removes the currently selected item (including documentation) from the 
Traffic Cop into a buffer.
Copy - Copies the currently selected item (including documentation) from the 
Traffic Cop into a buffer.
Paste - Inserts the buffered item (including documentation) into the currently 
selected slot/rack/drop/head.
Note: A slot copy can only be pasted into a slot, if the user attempts to paste the 
slot onto a drop the paste will be ignored. This holds true for any item that is 
pasted. The I/O series of the paste must match or it is ignored.
Paste Special - The same as paste, but new available addresses are 
automatically assigned to any slot that is pasted.
Undo - Undoes your last action. The last 10 actions are stored.
Redo - Redoes the last undo.

Function Action Comment

To insert a rack: Click Insert Rack. Inserts a rack above the selected rack and 
moves existing racks down.

To clear a rack: Click Clear Rack. Clears all slots from the selected rack.

To delete a rack: Click Delete Rack. Deletes the currently selected rack and 
moves remaining racks up.

Note: If you undo 10 actions, you can redo 10 actions. However, if you undo 10 
actions, redo 5 of them and insert another card, you can no longer redo any action 
until you perform more undos.

Note: After you perform an undo or a redo, you must save your project before you 
rebuild the address used tables so that the tables will be accurate.
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Export/Import 
Traffic Cop

The Export Traffic Cop feature allows you to transfer a Traffic Cop to another 
project. Import Traffic Cop enables you to bring a Traffic Cop into your project.

Module Menu The Module menu allows you to organize Traffic Cop cards by type.

Step Action

1 Right-click in the Traffic Cop navigation panel.

2 Click Export Traffic Cop or Import Traffic Cop.

3 A dialog box appears that allows you to navigate to the appropriate source .mdb 
file for import or export.

4 Select the .mdb file for import or export, and click Save.

5 Upon completion of import or export, the message Export completed 
successfully or Import completed successfully appears in the Message 
Central window.

Step Action

1 Right-click in the Traffic Cop navigation panel.

2 Click Module Menu.

3 Click the arrow in the Module Menu dialog box, and click one of the following 
module categories. Some module categories are not available for all modules

All
Analog Input
Analog Output
Discrete Input
Discrete Output
I/O Network Adapter
Intelligent
LAN Adapter
Miscellaneous Adapter
Motion
Counter
Power
I/O Adapter

4 The Module Menu dialog box displays a list of modules based on your selection 
in the step 3.

5 Click a slot in your rack in the Traffic Cop navigation panel.

6 Double-click a module in the Module Menu dialog box.
Result: The selected module now appears in the slot in your rack.

7 The selected module now appears in the slot in your rack.
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Auto Configure 
(Momentum/
Compact Only)

The auto configure tool polls the controller to see what modules are in the rack. This 
function then displays the modules in a report form. You can use the report form to 
configure your controller, which saves you time because you don’t have to access 
each slot and configure each controller manually.

Auto configure is available only online in a stopped Momentum or Compact 
controller.

Step Action

1 Right-click in the Traffic Cop navigation panel.

2 Click Auto Configure.
Result: The Automatic Traffic Cop Configuration dialog box appears.

3 The Automatic Traffic Cop Configuration dialog box summarizes a list of 
modules that are detected. Modify the addresses, if necessary.

4 Click OK to accept the auto configuration.
Result: The new Traffic Cop will be programmed automatically.
- or -
Click Cancel to reject the auto configuration.
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Using the Traffic Cop
Working with Slots

Slot Properties 
Panel

The slot properties panel, in the lower center of the Traffic Cop editor, lists user-
editable and calculated properties pertaining to the selected slot.

In the Traffic Cop navigation panel, click the slot you want to work with. Available 
slot properties are:

Property To Edit...

Module Select a module.

Description Read only - description of the selected card.

Input Reference Enter an address type. Only valid entries are accepted.

Input Data Mode Select a data mode (BIN or BCD) from the data mode list.

Output Reference Enter an address type. Only valid entries are accepted.

Output Data Mode Select a data mode (BIN or BCD) from the data mode list.

Data Length Enter the data length.

Power Rating Read only - power rating of the selected card.

Bus Module Count Read only - number of modules a bus module contains.

Bypass Local Bus Select TRUE or FALSE from the bypass local bus list.

Bypass remote Select TRUE or FALSE from the bypass remote list.

Card Config Displays hex parameter data. To edit, click Browse.

Note: Not all properties are available for all slots, i.e., a discrete card will not have 
an Output Data Mode property.
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Working with 
Slots

The following functions are available when you right-click a slot in the Traffic Cop 
navigation panel.

Launching the 
AS-I Device List

To launch the device list for the EIA921-00 AS-I interface module:

Function Action Comment

To insert a slot: Click Insert. Inserts a slot above the selected slot and 
moves existing slots down.
Note: If you leave the Slot Properties panel 
without selecting a module while in a 
Momentum Traffic Cop, the insert will be 
cancelled.

To edit a slot: Click Edit. You can edit the currently selected slot at any 
time by editing properties in the Slot 
Properties panel.

To clear a slot: Click Clear. Clears the card from the selected slot.

To delete a slot: Click Delete. Deletes the currently selected slot and 
moves remaining slots up.

To drag and drop a 
slot:

Click the slot and drag 
and drop it into its new 
position.

You can use drag and drop in drop view or in 
rack view. Additional options for drag and 
drop include:

Ctrl + dragging will copy the slot, 
incrementing the addresses.
Shift + dragging will copy the slot, 
keeping the addresses.

Note: Drag and drop is available for all I/O 
series except Momentum.

Step Action

1 In the slot properties panel, click Card Status.

2 Select Click to View AS-I Device List in the list. Then, click the ellipsis button.

3 The AS-I Device List dialog box launches.
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Editing the AS-I 
Device List

When the AS-I Device List opens, all initial data for all slaves are filled and available. 
The first row is highlighted by default. The addresses correspond to the addresses 
defined for the card in the Traffic Cop. The remaining data values must match those 
found in the Card Config dialog box.

Step Action

1 To edit a slave, double-click any field, or click any field then click Edit. The edit 
panel opens with the correct initial data.
The editable fields are:

Projected Slave List: Select Slave Not In LPS or Slave In LPS from the list.
Slave Profile (ID.IO): Select 0- F (in hex format).
Slave Parameter Data: Select 0- F (in hex format).

Click OK to save the settings for the selected slave to the Traffic Cop.
Click Cancel if you do not want to save the settings for the selected slave to the 
Traffic Cop.

2 Click Terminal to open the Data Watch Window, which displays the terminal block 
for the EIA921-00 card.

3 Click Card Config. A confirmation message appears if you have made changes.
Click No to return to the AS-I Device List.
Click Yes to accept the changes, close the AS-I Device List, and open the Card 
Config dialog box.

Note: If you made no changes, the AS-I Device List will close, and the Card Config 
dialog box opens.

4 Click OK to save the current settings to the Traffic Cop.
Click Cancel if you do not want to save the current settings to the Traffic Cop.
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Online Module Status

PLC Status/
Traffic Cop 
Functionality 
Matrix

Functionality Matrix:

Module Status 
Icon Reference

Online Stopped - Module Recognition:

Online Running - Module Health:

Adding a Missing 
Slot

From the traffic cop navigation panel:

PLC Status

Online Running Online Stopped Offline

Traffic Cop 
Functionality

Read-Only Yes No No

PLC Status 
Update Method

Automatically 
every 3 seconds

Automatically every 
5 seconds

N/A

Online Health Yes No N/A

Online Module 
Recognition

No Yes N/A

Data Committed 
Method

N/A Controller is 
updated after user 
verification

Project is 
automatically 
updated

Icon Description

, , 
Indicates that an associated slot is incorrect or missing.

Indicates a slot that is missing or not configured.

Indicates that an incorrect slot has been added to the traffic cop.

Icon Description

Indicates an unhealthy slot.

Step Action

1
Double-click the slot  that you want to add.
Result: The correct slot will be selected in the Module property list in the slot 
properties panel.

2 Press Enter to accept the selected slot.

3 Configure the remaining properties of the selected slot.
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I/O Drawing Generator

Overview The I/O Drawing Generator creates CAD (Computer-Assisted Design) drawings of 
800, Micro, Quantum and A120 Traffic Cop series cards. The drawings are saved in 
.DXF format, which is supported by most CAD programs. See p. 359 for more 
information on creating I/O drawings.

Setting up the I/O 
Drawing 
Generator

 

Step Action

1 Right-click your project in the project navigation panel, and click Properties.
- or -
Right-click Workspace, and click Properties.
- or -
Click View → Properties.

2 Click the I/O Drawing Generator tab.

3 Select the Overwrite Existing Drawings check box to discard the existing 
drawings and save the new ones in their place.

4 Default directories are listed for the Symbol (see p. 361), Master (see p. 362), 
Intermediate (see Intermediate Drawings, p. 360), and Final (see p. 360) I/O 
drawings.

If you do not want to use these default directories, create folders where you 
want to save the drawings.
Then, click the ellipsis (...) button in the Directories field, and navigate to the 
folder you created to save the drawings.
Click the folder, and click Open.
Follow the above two steps for each file type.

Result: The I/O drawings created reside in the selected path in a subdirectory that 
has the same name as the project from which the drawings are created.

5 This property determines how ProWORX 32 handles a missing master drawing 
while the I/O drawings are being created. Click one of the following buttons in the 
Master Drawings field.

Ignore Missing Drawings
Break on Missing Drawings
Notify of Missing Drawings

Click OK.
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Using the I/O 
Drawing 
Generator

In the project navigation panel:

Step Action

1 I/O drawings are generated in a two-step process:
Intermediate: These drawings are used as a working step. Generating a series 
of intermediate drawings as you go can save time when it comes to generating 
the final drawings.
Final: These drawings are generated based on the corresponding intermediate 
drawings.

2 To generate an intermediate drawing:
Right-click Traffic Cop, and click I/O Drawing Generator → Intermediate 
Drawings.
- or -
Click Utilities → I/O Drawing Generator → Intermediate Drawings.

3 To generate a final drawing:
Right-click Traffic Cop, and click I/O Drawing Generator → Final Drawings.
- or -
Click Utilities → I/O Drawing Generator → Final Drawings.

4 To generate both intermediate and final drawings:
Right-click Traffic Cop, and click I/O Drawing Generator → Both Drawings.
- or -
Click Utilities → I/O Drawing Generator → Both Drawings.
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Materials List

Overview When you have finished configuring the I/O area of your system, you may want to 
know what materials are required to create the hardware system as configured. The 
material list function creates a list of all required materials (as configured) and their 
associated part numbers.

When you first launch the materials list, it will generate a list of materials required by 
the selected project. The materials list will be created from the project, if offline, or 
from the controller, if online. When you launch the materials list a second time, the 
data will be read from the project rather than generated. You can add prices and 
comments to existing materials and add new materials. The materials list can then 
be printed or saved to HTML, MS Excel, or MS Word.

Using the 
Materials List

 

Note: The materials list utility makes some assumptions about cabling that should 
be checked and modified before printing.

Step Action

1 Right-click Traffic Cop in the project navigation panel, and click Materials 
List.

2 Enter up to six lines of text in the Header field. This text will be displayed at the 
top of the printed materials list.

3 Add or edit materials in the grid. All fields are editable except Total, which is 
calculated.

4 To regenerate a material list from the controller or project, right-click the 
materials grid, and click Generate.

5 To inset a row at the current cursor position, right-click the materials grid, and 
click Insert.

6 To clear the currently selected row, right-click the materials grid, and click Clear.

7 To delete the currently selected row and shuffle the remaining rows up, right-
click the materials grid, and click Delete.

8 To save the materials list to another format, right-click the materials grid, and 
click Save As.

9 To print out the materials list, right-click the materials grid, and click Print.

10 Close the materials list to save the changes.
206 31003882 12/2006



Using the Traffic Cop
Recommended 
Cable Part 
Numbers

 

1 97-5951-000  RG-11/U Coax Cable 1000 ft. reel: This is the recommended cable for 
use as trunk cable. It can also be used for drop cabling although it is recommended to 
use the less expensive 97-5750-000  RG-6/U Coax Cable 1000 ft. reel for drop 
cabling. RG-6/U can also be used for trunk cabling if the cable run is less than 5000 ft., 
but is not recommended. If it is used, then 52-0488-000 RG-6/U BNC Connectors are 
used in place of 52-0401-000  RG-11/U F Connectors. For cable runs 8000 ft. up to 
15000 ft., CATV cable should be used, but is not supplied by Modicon.

2 AS-W801-012  I/O Signal Cable 12 ft. 
This also comes in 6 ft. -006 and 1.5 ft. -002 lengths.

3 AS-W804-012  I/O Power Cable to rack with power 12ft. 
This also comes in 5 ft. -005 and 1.5 ft. -002 lengths.

4 AS-W802-012  I/O Power Cable to rack no power 12 ft.
This is interchangeable with AS-W808-002/-005/-008  Light-weight cable in 1.5, 5, or 
8 ft. lengths.
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Using the Data Watch Window
At a Glance

Overview The Data Watch Window is used to view and edit register data values for the 
selected project. The project can be online, offline, or in emulation. Live, real time 
data may be viewed or edited within the Data Watch Window. The data values may 
be displayed in a number of ways depending on which Data Watch view is active. 
Several views are available including a generic Register Editor, a Data Watch/Edit 
window, a Spreadsheet view, a Trend view, an Instruction view for specific 
instructions, a Terminal Block view for specific I/O cards, and a mini-HMI view. If the 
preferences are selected, data for Traffic Cop and Network Logic elements are 
tracked automatically. Data values may also be logged. These values are saved into 
an external file for future use. Preferences and properties of the Data Watch Window 
are saved in the project.
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Using the Data Watch Window
What's in this 
Chapter?

This chapter contains the following topics:

Topic Page

Data Watch Window Overview 211

Properties 215

Viewing and Recording Data 218

Triggers and Clamps 219

HMI 221

Trend 225

Track Logic Editor 228

Track Traffic Cop 229

Instruction Editor / Terminal Block Editor 230

Instruction / Terminal Block Editor Display Scripts 231

Display Script Variables 232

Display Script Functions 233

Register Editor 237

PID Tuner 238

Drum Summary 241

Importing and Exporting Data Watch Window Data 243
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Using the Data Watch Window
Data Watch Window Overview

Overview The watch window is the primary Data Watch Window. You can select any valid 
address for the current device, and view the data for that address. Up to 100 
addresses of any type may be entered and tracked. The data may be edited at any 
time. Register values may be changed and discrete values may be enabled or 
forced on or off. Addresses are automatically saved on exit and reloaded on entry.

Any register data may be viewed or edited with any selected radix type. Available 
radices are Decimal, Hex, Binary, ASCII, signed integer, BCD, 32-bit floating point 
or 32-bit integer. The bottom status bar will display various information including 
status messages, logging information, running/stopped state, trigger info, and 
clamping info.

Opening the Data 
Watch Window

 

Adding 
Addresses to 
Track in the Data 
Watch Window

 

Clearing 
Addresses

Right-click in the Data Watch Window, and click Clear. All addresses are cleared.

Step Action

1 Expand Data Editors in the project navigation panel.

2 Double-click Data Watch Window.
- or -
Right-click Data Watch Window, and click Open Data Watch Window.

Step Action

1 In the Data Watch Window, double-click or press Enter in the first available 
Address cell.

2 Enter a valid address in the Address cell.

3 Press Enter to insert the address or Esc to cancel the entry.
Result: The Data and Radix fields are automatically populated if the address 
exists in the project. You can edit the data or radix of an address by double-
clicking on the cell you want to change.
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Loading 
Addresses and 
Data from a Log 
File

 

Filling the Data 
Watch Window 
with Addresses

 

Setting the Radix 
for Multiple 
Addresses

 

Deleting 
Addresses

In the Data Watch Window, right-click the addresses you want to delete, and click 
Delete Addresses or press Delete.

Step Action Result

1 Right click in the Data Watch Window, and 
click Load LOG file.

The Datawatch Log dialog box opens.

2 Navigate to a log file, select the file, and 
click Open.

All addresses from the file are added 
to the Data Watch Window.

Step Action Result

1 Right-click in the Data Watch 
Window, and click Fill 
Addresses.

The Add Addresses dialog box opens.

2 Enter an address in the 
Starting Address field.

This is the first in a range of addresses to be added 
to the Data Watch Window.

3 Enter a numeric value (1 
through 100) in the Number 
of Addresses field.

This is the length of the range of addresses to be 
added to the Data Watch Window.

4 Click OK. Addresses specified are added at the current grid 
location. Existing addresses may be overwritten.

Step Action

1 Right-click the radix you want to change, and click Set Radix.
Result: The Set Radices dialog box opens.

2 Select a radix from the list.

3 Click OK.
Result: All selected radices are updated to the specified radix.
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Jumping to a 
Specific Address

 

Copying Data 
Values from One 
Range of 
Addresses to 
Another

 

Moving Data 
Values from One 
Range of 
Address to 
Another

 

Step Action

1 Right-click in the Data Watch Window, and click Goto Address.
Result: The Goto Address dialog box opens.

2 Enter an address in the Select an Address to find field.

3 Click OK.
Result: The specified address is selected in the Data Watch Window.

Step Action Result

1 Right-click in the Data Watch Window, 
and click Data Utilities → Copy Data.

The Data Utilities dialog box opens.

2 Enter an address in the Start Address 
field.

The value of this address is the first in 
the range to be copied.

3 Enter an address in the End Address 
field.

The value of this address is the last in 
the range to be copied.

4 Enter an address in the Destination 
Address field.

The value of this address is the first to be 
copied to in the sequential range of 
addresses specified.

5 Click OK. Values are copied.

Step Action Result

1 Right-click in the Data Watch Window, 
and click Data Utilities → Move Data.

The Data Utilities dialog box opens.

2 Enter an address in the Start Address 
field.

The value of this address is the first in 
the range to be copied.

3 Enter an address in the End Address 
field.

The value of this address is the last in 
the range to be copied.

4 Enter an address in the Destination 
Address field.

The value of this address is the first to be 
moved to in the sequential range of 
addresses specified.

5 Click OK. Values are moved.
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Filling a Range of 
Addresses with a 
Data Value

 

Searching for a 
Data Value

 

Step Action Result

1 Right-click in the Data Watch Window, 
and click Data Utilities → Fill Data.

The Data Utilities dialog box opens.

2 Enter an address in the Start Address 
field.

The value of this address is the first in 
the range to be filled.

3 Enter an address in the End Address 
field.

The value of this address is the last in 
the range to be filled.

4 Enter a numeric value in the Data 
Value field.

This value is copied to all specified 
addresses.

5 Click OK. Address values are set to the specified 
value.

Step Action Result

1 Right-click in the Data Watch Window, 
and click Data Utilities → Search 
Data.

The Search Data dialog box opens.

2 Enter a numeric value in the Data 
Value field.

This is the value to be searched for.

3 Click OK. The address with the specified data 
value are selected in the Data Watch 
Window.
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Properties

Using the Data 
Watch Window 
Properties 
Dialog Box

 

Step Action

1 Right-click your project in the project navigation panel, and click Properties.
- or -
Right-click Workspace in the project navigation panel, and click Properties.
- or -
Right-click Logic in the project navigation panel, and click Properties.
- or -
Click View → Properties.
- or -
Expand Data Editors in the project navigation panel. Right-click one of the 
following:

Data Watch Window → Properties
Register Editor → Properties
PID Summary → Properties
Drum/ICMP Summary → Properties
HMI View → Properties

2 Click the Data Watch tab.

3 Edit the fields, which are described below, as necessary.
Click OK to save the changes and close the Properties dialog box.
- or -
Click Apply to save the changes and remain in the Properties dialog box.
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Multi Radix View When the Multi Radix View check box is selected, the Watch Window and the 
Register Editor are in multi radix view. A column is assigned for each selected radix 
(Hexadecimal, ASCII, Long, Binary, and/or Float) as well as one for Decimal. Each 
column displays the data value for the given address in the selected format. Radices 
cannot be edited.

When the Multi Radix View check box is cleared, the Watch Window and the 
Register Editor will be in single radix view. Only one radix will be viewable per 
address. Any radix can be changed.

 To change the view (single radix versus multi radix):

Sample Rate Specifies how often to poll the device for data. The faster the polling is, the more 
accurate the data is, but the client computer’s responses will become more sluggish. 
This rate also affects the rate that data points are logged. The minimum sample rate 
is one read every 60 minutes, and the maximum sample rate is one read every 25 
milliseconds.

To set the sample rate:

Step Action

1 In the Properties dialog box, select the Multi Radix View check box.

2 Select the radix check boxes you want to view.
Hex (Hexadecimal)
Bin (Binary)
Asc (ASCII)
Float
Long

3 Click OK to save the changes and close the Properties dialog box.
Click Apply to save the changes and remain in the Properties dialog box.

Note: This is a target sample rate. The actual sample rate may be slower than you 
specify due to a large amount of data being polled and the capabilities of your 
machine.

Step Action

1 In the Properties dialog box, move the Sample Rate slider to the right for a 
slower sample rate or to the left for a faster sample rate.

2 Click OK to save the changes and close the Properties dialog box.
Click Apply to save the changes and remain in the Properties dialog box.
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HMI Window 
Setup

For more information on editing this parameter, see p. 221.

Track Logic For more information on editing this parameter, see p. 228.

Track Traffic Cop For more information on editing this parameter, see p. 229.

Logging This value places a size limit on the Log file. Once the limit is reached, no further 
logging will be done. The limit is in megabytes.

To set the log file size limit:

Trending For more information on editing this parameter, see p. 225.

Step Action

1 Enter a numeric value (in megabytes) in the Maximum Log File Size field.

2 Click OK to save the changes and close the Properties dialog box.
Click Apply to save the changes and remain in the Properties dialog box.
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Viewing and Recording Data

Overview You can view either live data or previously recorded logged data in the Data Watch 
Window. Live data are the current data values in the PLC while in online or combined 
mode. Logged data represents previously recorded data stored in a .LOG file. You 
create .LOG files by recording live data from the Data Watch Window. 

Viewing a .LOG 
File

In the Data Watch Window:

Recording Data 
to a .LOG File

While in the Data Watch Window (in combined, online, or emulation mode):

Step Action

1 Right click in the Data Watch Window, and click Load LOG file.
- or -
Click the Live/Log toolbar button.

Result: The Datawatch Log dialog box opens.

2 Navigate to the appropriate file, and click Open.

3 The log file is loaded. 
Note: Once a log file is loaded, you are viewing logged data and NOT live data.

Step Action

1 In the Address fields, enter addresses that you want to track. 

2 Click the Record button on the Data Watch Window toolbar to begin recording 
data.
Result: The Datawatch Log dialog box opens.

3 Select a .LOG file to save the data. Once a .LOG file is selected, data recording 
begins.
Note: While data is being recorded, it is still live, and the user may continue to 
edit data as needed.
Note: A data record is created in the .LOG file when at least one data value 
changes. If no data values change, no data will be recorded.

4 Click the Pause toolbar button to pause recording data. No new data will be 
added to the LOG file even if the data is changing.
Click Pause again to resume recording.

5 Click the Stop toolbar button to cease recording data. You will now be viewing 
the data for the new .LOG file.

6 To return to viewing live data, close the .LOG file.
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Triggers and Clamps

Overview The Triggers/Clamps dialog box allows you to change the settings for triggers and 
clamps.

Trigger allows you to track the value of a specific address.
Clamps force all tracked data values inside or outside of a specified range.

Triggers Select the Enable Trigger check box to track the value of a specific address. When 
the data for this address reaches the specified value, the Data Watch Window 
begins tracking and/or logging values. The data is not tracked or logged until the 
condition is met.

When the Enable Trigger check box is cleared, the Data Watch Window 
automatically tracks and/or logs values.

Setting a Trigger  

Step Action

1 Double click Trigger or Clamps on the Data Watch Window status bar.

2 Select the Enable Trigger check box.

3 In the Address field, enter the address that you would like to track.

4 In the Repeat Options field:
Click Once Only to begin tracking only when the Start Condition is met. 
Tracking will continue indefinitely.
Click Continuous to start tracking/logging based on the values that you enter 
in the Start Condition and Stop Condition fields. 
Example: You can set the data logger to start recording when the value for 
register 40001 reaches 10 and stop recording if the value exceeds 20.

5 In the Start Condition field:
Click the <= or >= button.
Enter a numeric value in the State field

6 If you clicked the Continuous button in the Repeat Options field in step 4, 
select the Stop Condition check box, and enter a numeric value in the State 
field.

7 Click OK to save the changes.
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Clamps Select the Enable Clamps check box to force all tracked data values inside or 
outside the specified range. This affects the display only and does not affect the 
actual data values in the device. This also affects the data sent to the log file.

When the Enable Clamps check box is cleared, all data values are displayed as 
their actual data value.

Setting a Clamp  

Step Action

1 Double click Trigger or Clamps on the Data Watch Window status bar.

2 Select the Enable Clamps check box.

3 Enter a numeric value in the Low Clamp field.

4 Enter a numeric value in the High Clamp field.

5 Click the Capture Inside or Capture Outside button.

6 Click OK to save the changes.
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HMI

HMI Overview This view displays a simple human-machine graphical grid-based workspace. It 
allows data to be displayed, data values to be entered, discrete controls to be 
enacted, and basic animation to be visualized.

Each cell in the grid may have a series of pictures assigned to it. These pictures are 
selected based on the data value of an address assigned to the cell. Therefore, as 
the data changes, the pictures will change as well. Animated switches, gauges, 
meters, and similar graphics are available.

Setting the 
Background 
Color

 

Setting the Cell 
Size

Step Action

1 Click the Data Watch tab (see p. 215) in the Properties dialog box.

2 In the HMI Window Setup field, click the Background Color Select button.

3 Click a color from the Color dialog box.

4 Click OK to close the Color dialog box.

5 Click OK to save the changes and close the Properties dialog box.
- or -
Click Apply to save the changes and remain in the Properties dialog box.

Step Action

1 Click the Data Watch tab (see p. 215) in the Properties dialog box.

2 In the HMI Window Setup field, select the Fixed Cellsize check box.
Result: When you select this check box, the Width and Height fields are 
available, and you can manually select the cell size.

3 Enter a value (in pixels) from 1 to 240 in the Width field, or move the slider (lower 
value to the left; higher value to the right) to select a width.

4 Enter a value (in pixels) from 1 to 240 in the Height field, or move the slider 
(lower value to the left; higher value to the right) to select a height.

5 Click OK to save the changes and close the Properties dialog box.
- or -
Click Apply to save the changes and remain in the Properties dialog box.
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Creating Bitmap 
Files to 
Associate with 
Register Type 
Addresses 
(3x/4x)

Use Windows Explorer to:

Creating Bitmap 
Files to 
Associate with 
Discrete Type 
Addresses 
(0x/1x)

Discrete addresses may use any bitmap, regardless of name. 

Opening the HMI 
View

 

Editing Cell Data  

Step Action

1 Ensure all files you want to associate with a cell are in the same directory.

2 Ensure the files you want to associate with a cell are named sequentially.
Correct: Timer_1.bmp, Timer_2.bmp, Timer_3.bmp,... Timer_10.bmp
Incorrect: Timer.bmp, TTwo.bmp, TimerThree.bmp,... Time10.bmp
Tip: The easiest way to name bitmaps for use in the HMI is to use the 
BitmapName_#.bmp format.

Step Action

1 Expand Data Editors in the project navigation panel.

2 Double-click HMI View.
- or -
Right-click HMI View, and click HMI View.

Step Action

1 Right-click in the HMI panel, and click Edit Data.
Result: The Edit HMI Data dialog box opens.

2 Enter a value in the Picture list.
Result: This will update the value of the address associated with the picture.

3 Enter a value in the Monitor list.
Result: This will update the value of the address being monitored.

4 Click OK to save changes.
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Associating a 
Picture with an 
Address Value

 

 Follow the steps below after you entered an address to associate a picture with.

Step Action

1 Right-click in the HMI panel, and click Edit Cell.

2 Select the Picture Enabled check box.

3 Enter an address in the Address field.

4 Select from the Stretch Picture list how you want the pictures to be displayed.
None: Trims the bottom and right-side of the picture to fit.
Fit Cell: Makes the entire picture fit the cell.
Fit Width: Trims the bottom of the picture.
Fit Height: Trims the right-side of the picture.

5 Click OK to save changes.

If... Step Action

you have entered a 
discrete address 
(0xxxx or 1xxxx)

1 In the Off Picture field, click Browse, and select a bitmap 
(.bmp file) to view when the value of the selected address is 0 
(zero).

2 In the On Picture field, click Browse, and select a bitmap 
(.bmp file) to view when the value of the selected address is 
not 0 (zero).

3 Click OK to save changes.

you have entered 
an analog address 
(3xxxx or 4xxxx):

1 In the Picture field, click Browse, and select the first bitmap 
(.bmp) in a numbered sequence of bitmaps.

2 Enter numbers in the Actual Range fields. (These are the low 
and high data values you expect or know the address will 
hold.)

3 Enter a number in the # of Pictures field. (This number will be 
used to associate different sequentially named pictures with 
values from the selected address.)
Example: If you enter as an actual range the values 0 and 
999, then enter 10 in the # of Pictures field. Picture1.bmp 
(the picture you selected in step 1) will be associated with 
values 1 through 99, Picture2.bmp will be associated with 
values 100 through 199, etc.

4 Click OK to save changes.

Note: A maximum of 100 pictures may be associated with a cell.
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Adding a Caption 
to a Cell

 

Adding a Value 
to Monitor

 

Step Action

1 Right-click in the HMI panel, and click Edit Cell.

2 Select the Caption Enabled check box.

3 Enter the text you want displayed in the cell in the Caption field (maximum 20 
characters).

4 Click the Foreground button to select the text color. Select a color, and click OK.

5 In the Alignment list, click the positioning of the caption.
Top
Middle
Bottom

6 Click OK to save changes.

Step Action

1 Right-click in the HMI panel, and click Edit Cell.

2 Select the Data Monitor Enabled check box.

3 Enter an address in the Address field. (This address may be the same as or 
different than the address associated with the picture.)

4 Click the Foreground button to select the text color. Select a color, and click OK.

5 Enter numeric values in the Actual Range fields. (These are the low and high 
values you expect or know the address will hold.)

6 Enter numeric values in the Scale Range fields. (You can use the scale range 
to display a ratio value or an offset value for data analysis purposes. You can 
also set the Scale range to the same values as the Actual range to display raw 
data.)

7 In the Alignment list, click the positioning of the caption.
Top
Middle
Bottom

8 Click OK to save changes.
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Trend

Trend Overview This view does not allow editing of any on-screen information. It is for viewing data 
only. When active, this view will display a graphical line chart of data values. The 
time that the data was taken is displayed on the X axis. The data value is displayed 
on the Y axis as well as on the right hand legend. This is useful for tracking changes 
in data over time. There are several zoom and pan functions available.

Setting the Y-
Axis Values

 

Setting the 
Resolution Value

The resolution value is in milliseconds and defines the width of the X axis. This is the 
time window of the visible data.

Step Action

1 Click the Data Watch tab (see p. 215) in the Properties dialog box.

2 Select the Auto Y Axis Scale check box to have the Y axis automatically set 
and adjust to include all data points.
- or -
Enter a numeric value in the Y Axis Minimum and Y Axis Maximum fields 
to manually set the Y axis range.

3 Click OK to save the changes and close the Properties dialog box.
- or -
Click Apply to save the changes and remain in the Properties dialog box.

Step Action

1 Click the Data Watch tab (see p. 215) in the Properties dialog box.

2 Enter a numeric value in the Resolution field.

3 Click OK to save the changes and close the Properties dialog box.
- or -
Click Apply to save the changes and remain in the Properties dialog box.
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Setting the Alarm 
Values

The alarm values are a range of safe values. Any value that is outside of this range 
triggers an alarm state.

Setting the 
Setpoint Value

The setpoint value is a baseline value that can be used as a reference.

Setting the Trend 
Colors

 

Step Action

1 Click the Data Watch tab (see p. 215) in the Properties dialog box.

2 Enter a numeric value in the Lo Alarm and/or Hi Alarm fields.

3 Click OK to save the changes and close the Properties dialog box.
- or -
Click Apply to save the changes and remain in the Properties dialog box.

Step Action

1 Click the Data Watch tab (see p. 215) in the Properties dialog box.

2 Enter a numeric value in the Setpoint field.

3 Click OK to save the changes and close the Properties dialog box.
- or -
Click Apply to save the changes and remain in the Properties dialog box.

Step Action

1 Click the Data Watch tab (see p. 215) in the Properties dialog box.

2 Click one of the following trend elements from the Color Setup list.
Background
Foreground
Grid
Menu
Cursor

3 Click the Select button.

4 Click a color in the Color dialog box, and click OK.

5 Repeat steps 2 to 4 for all other trend elements.

6 Click OK to save the changes and close the Properties dialog box.
- or -
Click Apply to save the changes and remain in the Properties dialog box.
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Using the Trend 
Functionality

In the trend window:

Trend 
Functionality

 

Step Action

1 Select the Mode you want to use (Scroll-X, Zoom-X, Scroll-Y, Zoom-Y, Scroll-
XY, Zoom-XY, Cursor, or Zoom-Box).

2 Left-click the data point from which you want to work.

3 Hold-and-drag to manipulate the on-screen view of the data.

Mode Description of Functionality

Plot Default view. This is the setting used when viewing a live trend or logged 
data. If viewing live data, the trend automatically updates and scrolls. 
Selecting Plot also resets the view to the default by cancelling any scroll 
or zoom operations.

Scroll-X Drag the trend chart left or right to view trend data by time. Not available 
while viewing live data.

Zoom-X Compresses or expands the X (Time) axis. This allows for viewing more 
detail or more data points. Not available while viewing live data.

Scroll-Y Drag the trend chart up or down to view trend data that may be beyond the 
bounds of the current Y axis. Not available while viewing live data.

Zoom-Y Compresses or expands the Y (Value) axis. This allows for viewing more 
detail or more data points. Not available while viewing live data.

Scroll-XY This allows for scrolling of the X and Y axis simultaneously. Not available 
while viewing live data.

Zoom-XY This allows for zooming of the X and Y axis simultaneously. Not available 
while viewing live data.

Cursor Shows a cursor, the value of the data point and the time it was taken for a 
given trend line. Specific trend lines may be selected from the legend on 
the right. The cursor my be moved via the mouse, keys or navigation 
buttons. Not available while viewing live data.

Zoom-Box Use a selection box to zoom into a specific part of the trend. Not available 
while viewing live data.

View Selected 
Only Checkbox

When Checked, the trend only displays the plot of the address selected in 
the legend on the right. When cleared, all address plots are displayed. 
Only available in cursor mode with logged data.
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Track Logic Editor

Track Logic 
Editor

When you select the Track Logic check box in the Properties dialog box, the 
specified addresses in logic are automatically added to the Data Watch window and 
their values are tracked. When the cursor position in logic is changed, the previously 
tracked addresses are removed and a new set of addresses are tracked.

Select any of the check boxes below to track.
Network: All addresses and their values from the most recently selected network 
in the Logic Editor are displayed in the Watch Window.
Instructions: All addresses and their values that are associated with the most 
recently selected instruction are displayed in the Instruction Window.
Discrete: All addresses with discrete values associated with the most recently 
selected network in the logic editor are displayed in the Watch Window.
Address: The most recently selected address and its value is displayed in the 
Watch Window.

When the Track Logic and Track Traffic Cop check boxes are cleared, you must 
manually enter addresses in the Watch Window in order for them to be tracked.

Tracking Logic 
Editor 
Addresses in the 
Data Watch 
Window

 

Step Action

1 Click the Data Watch tab (see p. 215) in the Properties dialog box.

2 Select the Track Logic check box.

3 Click the option button (Network, Instruction, Discretes, or Address) that you 
want to track.

4 Click OK to save the changes and close the Properties dialog box.
- or -
Click Apply to save the changes and remain in the Properties dialog box.

5 Ensure that the Logic Editor and Data Watch Window are open.
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Track Traffic Cop

Track Traffic Cop When you select the Track Traffic Cop check box in the Properties dialog box, the 
specified addresses in the Traffic Cop are automatically added to the Data Watch 
window and their values are tracked. As the cursor position is changed in the Traffic 
Cop, the tracked addresses are also changed.

The traffic cop-related option that can be tracked is Track Slot. When you select this 
check box, the associated addresses of the card in the most recently selected slot 
are displayed in the Terminal Block Window.

When the Track Logic and Track Traffic Cop check boxes are cleared, you must 
manually enter addresses in the Watch Window in order for them to be tracked.

Tracking Traffic 
Cop Addresses 
in the Data Watch 
Window

In the Data Watch Window Properties dialog box:

Step Action

1 Click the Data Watch tab (see p. 215) in the Properties dialog box.

2 Select the Track Slot check box.

3 Click OK to save the changes and close the Properties dialog box.
- or -
Click Apply to save the changes and remain in the Properties dialog box.

4 Ensure that the Traffic Cop and Data Watch Window are open.
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Instruction Editor / Terminal Block Editor

Instruction 
Editor Overview

You can view the addresses and data of specific logic instructions using the 
instruction editor.

Additionally, the DRUM summary and the PID summary can activate the instruction 
editor for the DRUM or PID function selected in the summaries. Only the addresses 
referenced by the current instruction will be included.

The display is built with a user-defined VB script. These scripts are editable and may 
be used to modify the on-screen display.

Viewing an 
Instruction in the 
Instruction 
Editor

The instruction editor works with the logic editor. To view a certain instruction simply 
select the desired instruction in the logic editor, and the instruction will be displayed 
in the instruction editor

Terminal Block 
Editor Overview

You can view the addresses and data of specific I/O cards using the terminal block 
editor. Depending on property settings, you can view addresses and edit address 
values found in the currently selected item (rack or slot) in the Traffic Cop.

The display is built using a user-defined VB script. These scripts are editable and 
may be used to modify the on screen display in any way.

Viewing an I/O 
Card in the 
Terminal Block 
Editor

The terminal block editor works with the Traffic Cop. To view a certain card, simply 
select the desired card in the Traffic Cop, and the card will be displayed in the 
terminal block editor.
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Instruction / Terminal Block Editor Display Scripts

Display Scripts 
Overview

The instruction and terminal block views may be customized using specialized VB 
Script files (.ucs). A large variety of .ucs files are provided for common instructions 
and for some advanced I/O cards. All .ucs files use a standard set of functions that 
link into the PRWX32 data editor to provide the on screen elements needed. As well, 
all regular VB Script functions (such as FOR loops and IF statements) are available.

Creating a 
Display Script 
File

 

Naming a Display 
Script File

Rules and guidelines: 

Note: The script must follow standard VBS coding methods and rules.

Step Action

1 Open a blank script in a script editor (Notepad or Wordpad).

2 Enter the outline of the new script function as follows:
Sub FunctionName(TopAddr, MidAddr, BotAddr, TopLen, MidLen, 
BotLen, Page, Unused1, Unused2)  End Sub

3 Add functions to the script as needed.
Note: All functions must be prefixed by Call Editor.
Example: Call Editor.scAddGrid.

4 Save the script in the ProWORX\32\Scripts directory using the naming 
conventions described below.

Step Action

1 Script files must be saved with a .ucs extension.
Example: VMER.ucs

2 Instruction scripts must be saved using their machine name.
Example: Correct: MSTR.ucs, Incorrect: Master.ucs

3 Script file names cannot have spaces or punctuation in them.
Example: Correct: DAO84010.ucs, Incorrect: DAO 840 10.ucs, DAO-
840_10.ucs
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Display Script Variables

Variable 
Description 
Table

Variables used within the display script:

Variable Type Description

FunctionName NA The function name must be the same as the name of the 
instruction or I/O card it supports. E.g. For the ADD 
instruction, the function name would be ADD, and the 
script file name would be Add.ucs.

TopAddr String Instruction Editor: The address in the top node of the 
instruction.
Terminal Block Editor: For cards with input addresses 
only, the first input address. For cards with output 
addresses only, the first output address. For cards with 
both input and output addresses, the first input address.

MidAddr String Instruction Editor: The address in the second node of the 
instruction if second node exists.
Terminal Block Editor: First output address for cards 
containing both input and output addresses.

BotAddr String Instruction Editor: The address in the third node of the 
instruction if third node exists.
Terminal Block Editor: Empty.

TopLen Integer Instruction Editor: The number of implied addresses 
associated with the address in the top node.
Terminal Block Editor: Empty.

MidLen Integer Instruction Editor: The number of implied addresses 
associated with the address in the middle node.
Terminal Block Editor: Empty.

BotLen Integer Instruction Editor: The number of implied addresses 
associated with the address in the bottom node.
Terminal Block Editor: Empty.

Page Integer If a page control is specified in this script using 
scAddPages, this will give the page number to display.

Unused1, Unused2 Empty Reserved Values.

Note: All of these parameters will pass data into the script.
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Display Script Functions

Functions Used 
Within the 
Display Script

scAddGrid 
(Address, 
NumRows, 
VisibleRows)

This is the main function used to display data values. It is responsible for adding a 
grid of addresses along with their data values and radices. All radices will default to 
decimal. Grids are numbered starting at 1 in the order that they are added. This 
number is used as an ID for other functions such as scSetRowInfo.

scSetRowInfo 
(GridIndex, 
GridRow, 
TextString, 
Radix)

This function modifies the contents of a specific row in a specific grid. The 
Description and a specific Radix may be added with this function.

Note: All functions must be prefixed by Call Editor.
Example: Call Editor.scAddGrid

Note: All strings must be surrounded by quotes.
Example: Call Editor.scSetRowInfo(1, 1, "This is a string description", "Decimal")

Variable Type Variable Description

Address Integer The first address in a sequential list of addresses.

NumRows Integer The number of rows (and addresses) to display in this grid.

VisibleRows Integer This will limit the grid to showing only the number of rows 
specified. Additional rows will be accessible via scrolling.

Variable Type Variable Description

GridIndex Integer This is the grid's ID number. See scAddGrid.

GridRow Integer The row in this grid to modify. Valid rows start at 1 and go to the maximum 
number of rows this grid contains.

TextString String The description text to add.

Radix String The radix in which to display the data. Valid entries are:
Hexadecimal
Binary
ASCII
Float
Long
Signed
BCD
Decimal
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scGetText 
(TextIndex)

This function retrieves internal PRWX32 text strings. Usually, you should use a 
literal text string (Hello) instead of this function.

scGetData 
(Address as 
Variant)

This function retrieves a data value for a given address.

scAddBitDisplay 
(BitDisplayName
, GridNumber, 
GridRow, 
LineState, 
Editable)

This will add an ellipsis button to the specified grid on the specified row. This button 
activates a Bit Display dialog box that gives detailed bit descriptions and editing 
capabilities.

scAddBitInfo 
(BitDisplayName
, BitNumber, 
BitDescription)

This adds a bit description to the contents of a specified Bit Display created with 
scAddBitDisplay.

Variable Type Variable Description

TextIndex Integer The number of the internal text string you wish to 
retrieve.

Variable Type Variable Description

Address String  This is a string containing the address to get data for. All 
0x, 1x, 3x, 4x and 6x addresses are allowed.

Variable Type Variable Description

BitDisplayName String This is a name to be used to identify this particular display. A 
script may create numerous different bit displays.

GridNumber Integer This is the grid's ID number. See scAddGrid.

GridRow Integer The row in this grid to modify. Valid rows start at 1 and go to 
the maximum number of rows this grid contains.

LineState String A string of 16 numeric characters. The first character is the 
MSB. Each character may be one of:

0 - No Line
1 - Horizontal Stub
2 - Full Line
3 - End Stub

Editable Boolean Set to True to enable bit editing.
Set to False to make the display read-only.

Variable Type Variable Description

BitDisplayName String This is a name to be used to identify this particular 
display. See scAddBitDisplay.

BitNumber Integer The number from 1 to 16 of the bit to add the 
description to. 1 = LSB.

BitDescription String The description text to add.
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scAddBitE-
ditValue 
(BitDisplayName
, BitNumber, 
FirstBit, LastBit, 
Description, 
Value)

This creates a list for a specified bit in the specified Bit Display. This field may be 
used to set a block of bits to a specific pattern associated with a descriptive state. 
Only one list entry is added per call. Entries are added in sequential order.

scAddEquation 
(EquationStr, 
Var1, Var2, Var3, 
Var4, Var5)

This function will create a functional equation in a box. Up to five variables may be 
included.

scAddErrorField 
(GridNumber As 
Variant, GridRow 
As Variant)

This function will create an error box that displays an error message, which is visible 
only if an error condition is met. Conditions are specified using the scAddError-
FieldText function. Error conditions are a particular value contained in a particular 
register. A row in a grid defines this. Only one error field is allowed.

Variable Type Variable Description

BitDisplayName String This is a name to be used to identify this particular display. 
See scAddBitDisplay.

BitNumber Integer The number from 1 to 16 of the bit to add the description to. 1 
= LSB.

FirstBit Integer The first bit number in a sequence to be modified (MSB).

LastBit Integer The last bit number in a sequence to be modified (LSB).

BitDescription String The description of the list entry.

Value String The binary pattern to set the bits to.
Example: 110110

Variable Type Variable Description

EquationStr String A string containing the equation to display. Use "A", "B" 
through "E"" to denote a variable. Variables will be mapped 
to the data in a grid row.
Example: "A + B = C"

Var1 through Var5 String A string in the format "a,b,r" where a=Grid ID Number, 
b=Grid Row, r=Radix: "ILDF". The radix value specifies the 
radix in which to display the equation data (Integer, Long, 
Double, or Float). Double is not a normal radix. It builds a 
concatenation of 2 16-bit data values. These will be the 
data values that appear in the equation. Use "" for variables 
that are not used.

Variable Type Variable Description

GridNumber Integer This is the grid's ID number. See scAddGrid.

GridRow Integer The row in this grid to modify. Valid rows start at 1 and go to the 
maximum number of rows this grid contains.
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scAddError-
FieldText 
(DataValue As 
Variant, 
ErrorText As 
Variant)

This adds an error condition to an error field. Any number of conditions may be 
added. A condition is true is a data value equals the specified value.

scAddPages 
(NumPages)

This function adds a page selection control. Only one may be specified at a time. 
Pages are numbered sequentially starting at one. This is useful if an instruction has 
a large amount of information to display.

scAddPicklist 
(ListName, 
GridNumber, 
GridRow)

This will add a list box to a specified grid at a specified row. This list will allow the 
easy selection of specific data values for the associated address. Each pick list must 
be identified by giving it a name.

scAddToList 
(ListID, ListText, 
ListValue)

This will add a data value to a pick list created with scAddPickList.

scAddStaticText 
(TextString)

This will add a static block of text. This is useful for titles, instructions, or additional 
information not provided by any other means.

Variable Type Variable Description

DataValue Integer A value that corresponds to an error.

ErrorText String The error message to display.

Variable Type Variable Description

NumPages Integer The total number of pages to display.

Variable Type Variable Description

ListName String This is a name to be used to identify this particular pick 
list. A script may create numerous different pick lists.

GridNumber Integer This is the grid's ID number. See scAddGrid.

GridRow Integer The row in this grid to modify. Valid rows start at 1 and go 
to the maximum number of rows this grid contains.

Variable Type Variable Description

ListID String This is a name to be used to identify this particular pick list. See 
scAddPickList.

ListText String Text that will be appear in the list. Usually it describes the 
purpose of a data value.

ListValue Integer A data value that will be set if this list entry is selected.

Variable Type Variable Description

TextString TextString The text to display.
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Register Editor

Register Editor 
Overview

The register editor allows you to view and edit data for all available addresses. This 
includes all discretes as well as all input, holding, and extended registers.

Opening the 
Register Editor

 

Changing the 
Displayed 
Address Type

In the task bar of the Register Editor panel, click one of the buttons (0x, 1x, 3x, 4x, 
6x) to select an address type.

Displaying 
Extended 
Memory 
Addresses

 

Note: Addresses cannot be edited since they are specified by a project's 
configuration.

Step Action

1 Expand Data Editors in the project navigation panel.

2 Double-click Register Editor.
- or -
Right-click Register Editor, and click Register Editor.

Note: Extended memory addresses are defined by memory file.

Step Action

1 In the task bar of the Register Editor panel, click the 6x button.

2 Click the File list to select an extended memory file.
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PID Tuner

PID and PID2 
Blocks Overview

PID and PID2 blocks are software programming blocks that allow a process to be 
controlled with no changes or additions to hardware. PID stands for Proportional 
Integral Derivative. While the PID2 is a more advanced version of the PID, both 
operate in the same manner.

PID/PID2 Process 

The PID calculation compares a process variable (PV) with a desired control point 
called the set point (SP). The calculation uses the difference between the set point 
and the process variable to adjust the PID output value (OV), sometimes called the 
control variable. This output value is used to manipulate an input to the process so 
that, eventually, the measured process variable equals the desired set point.

PID Tuner 
Overview

The PID summary displays a list of all the PID and PID2 instructions in the logic of 
the current project. Each row in the grid gives the instruction name, its location in 
logic, and the addresses of key data values related to that PID block.

The currently selected row has an associated PID faceplate. This faceplate allows 
simple tuning of the selected PID block. You may invoke manual mode or adjust the 
setpoint value.

Process Output

Process

Process Input

PID 
Calculation

Output Value (OP)

Measurement

Set Point (SP)

Process Variable 
(PV)

Note: There may be a delay while a search is performed for PID instructions in 
logic.
238 31003882 12/2006



Using the Data Watch Window
Opening the PID 
Summary

 

Adjusting the 
Setpoint Value

 

Jumping to the 
Currently 
Selected PID 
Block in the 
Logic Editor

 

Editing PID Data  

Step Action

1 Expand Data Editors in the project navigation panel.

2 Double-click PID Summary.
- or -
Right-click PID Summary, and click PID Summary.

Step Action

1 In the PID Summary panel, click Adjust.

2 Click and drag the slider up to increase the setpoint and down to decrease the 
setpoint.

3 Press Enter to accept the changes.

Step Action

1 In the PID Summary panel, click the row of the PID or PID2 instruction that you 
want to jump to.

2 Click Goto.
Result: The logic editor opens, and the cursor is positioned on the selected PID 
block.

Step Action

1 In the PID Summary panel, click the row of the PID or PID2  you want to edit.

2 Click Tune.
Result: The instruction editor opens, containing the selected PID or PID2 
instruction. Here you may edit all data values related to the instruction.

3 Click the PID Summary tab to exit the instruction editor.
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Trending PID 
Data

 

Setting the PID 
Contact

 

Step Action

1 In the PID Summary panel, click the row of the PID or PID2  you want to trend.

2 Click Trend.
Result: The trend window opens, showing the trend data of the selected PID or 
PID2.

3 Click the PID Summary tab to exit the instruction editor.

Step Action

1 In the PID Summary panel, select the Force Input Contact check box.
Note: This overrides the contact setting by disabling the contact. Ensure that this 
does not result in any safety issues.

2 Click one of the following buttons.
Auto = on
Manual = off

The default contact setting is Auto. To toggle the contact, click the Auto/Manual 
button, which disables the contact immediately in front of the top node of this PID 
instruction and forces it on or off. The label on the button specifies the current 
state of the contact.
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Drum Summary

Drum Instruction 
Overview

The Drum instruction operates on a table of 4x registers containing data 
representing each step in a sequence. The number of registers associated with this 
step data table depends on the number of steps required in the sequence. You can 
pre-allocate registers to store data for each step in the sequence, thereby allowing 
you to add future sequencer steps without having to modify application logic.

Drum incorporates an output mask that allows you to selectively mask bits in the 
register data before writing it to coils. This is particularly useful when all physical 
sequencer outputs are not contiguous on the output module. Masked bits are not 
altered by the Drum instruction, and may be used by logic unrelated to the 
sequencer.

Drum Summary 
Overview

The Drum Summary displays a list of all the Drum, ICMP, and SCIF instructions in 
the logic of the current project. They are sorted by their top address. This address' 
data is known as its step value. All instructions with the same step value appear 
together on the right. All the step values that are available appear on the list to the 
left.

Each row shows the instruction name, its location in logic, and key data values 
related to that block. Steps Used, Machine ID, and Profile ID are all editable values.

Opening the 
Drum/ICMP 
Summary

 

Selecting a Step In the Drum Summary panel, select an address from the left panel. All applicable 
instructions referencing that address will be displayed.

Note: There may be a delay while a search is performed for Drum instructions in 
logic.

Step Action

1 Expand Data Editors in the project navigation panel.

2 Double-click Drum/ICMP Summary.
- or -
Right-click Drum/ICMP Summary, and click Drum/ICMP Summary.
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Editing Drum 
Summary Data

Editing 
Instruction 
Address Data 
Value

 

Step Action

1 In the Drum Summary panel, double-click the Steps Used, Machine ID, or 
Profile ID cell that you want to edit.

2 Enter a value in the cell.

3 Press Enter to save the changes or Esc to cancel the changes.

Step Action

1 In the Drum Summary panel, select the instruction you want to edit.

2 Click Sequencer.

3 In the instruction panel, double-click the Data cell that you want to edit.

4 Enter a value in the cell.

5 Press Enter to save the changes or Esc to cancel the changes.

6 Click the Drum Summary tab to exit the instruction panel.
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Importing and Exporting Data Watch Window Data

Overview Data watch window data can be imported or exported to or from a text file. This file 
may be modified with any text editor or spreadsheet program such as Notepad or 
Microsoft Excel.

Importing data watch window data is only available from the data watch window and 
register editor when in offline mode. Exporting data watch window data is available 
when in either online or offline mode.

Importing Data  

Step Action

1 Right-click in the Data Watch Window (see p. 211).

2 Click Data Utilities → Import Data.
Result: The Import From dialog box opens.

3 Navigate to a folder to select a file (.txt or .csv) to import.

4 Click Open.

5 Data from every address found in the Import file is imported regardless of which 
addresses are on the screen prior to the import. Any address in the Import file 
that is in the configured range of the Project being imported to will have its data 
imported. A progress bars displays the progress of the import.
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Exporting Data  

Data Formats Data watch window data import and export file formats:

Step Action

1 Right-click in the Data Watch Window (see p. 211).

2 Click Data Utilities → Export Data.
Result: The Export To dialog box opens.

3 Enter a new file name or navigate to a folder to select an existing file (.txt or .csv).

4 Click Open.

5 The data is exported as follows:
Data Watch Window (Offline): All addresses and data values currently shown 
in the data watch window are exported. If there are no addresses, nothing is 
exported.
Data Watch Window (Online): All addresses and data values currently shown 
in the data watch window are exported. If there are no addresses, nothing is 
exported. Note that the exported data is a snapshot of the data values in the 
PLC.
Register Editor (Offline): All addresses and data values for the selected 
address type are exported. For example, if the 4x type is selected, all 
configured 4x addresses and data will be exported.

File Format

.TXT - Tab Separated Variable text file. Address <tab> Data

.CSV - Comma Separated Variable text file. Address,Data
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Working with the ASCII Editor
ASCII Editor

Using the ASCII 
Editor

ASCII messages let your controller report information to you in plain language. Use 
them, for example, if you want to see a written alert on your screen every time a 
motor switches on or a printout every hour of how many items have passed by a 
counter.

Use the ASCII Message Editor to enter and edit the messages you want your 
controller or project to send.

Configuring 
ASCII Messages

Start by configuring your controller or project to use ASCII messages:

Note: Use the ASCII Read Block (READ) and ASCII Write Block (WRIT) in your 
ladder logic to send a message from a controller to your output device (such as a 
screen, printer, or disk drive).

Step Action

1 Confirm that your controller supports ASCII messages.

2 Double-click Configuration in the project navigation panel.
- or -
Right-click Configuration in the project navigation panel, and click Open Editor.
- or -
Click Project → Configuration.
- or -
Click the Configuration toolbar button.

3 Click the General (see p. 94) tab.

4 Configure the controller’s ASCII parameters (Total Messages, Message Words, 
and ASCII Ports).

5 Click the Ports (see p. 98) tab.

6 Ensure your ASCII ports are configured correctly.
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Opening the 
ASCII Editor

Click Project → ASCII Messages.

- or -

Click the ASCII Messages toolbar button.

Message List The message list panel contains all messages in the current project. Click a 
message to edit or preview it in the Editor/Preview panel.

Right-click in the Editor/Preview panel:

Editor / Preview 
Panel

The editor panel is a WYSIWYG message editor. Enter instructions into the editor 
by using either the toolbox buttons or the keyboard hot keys. The preview panel is 
a view-only preview display of the currently selected ASCII message. To toggle 
between the editor and preview panels, right-click the desired message and click 
Preview or Editor.

Note: A yellow message denotes a message that has too many words.

To... Function Result

Cut/copy/paste 
messages:

Click Cut, Copy, or Paste. The message is added to the 
windows clipboard and can be 
pasted into any other message.

Insert a message: Click Insert (Insert). Shuffles the messages up from 
the selected message.

Clear a message: Click Clear (Delete). Deletes all words from the 
selected message.

Delete a message: Click Delete (Shift+Delete). Deletes the selected message 
and moves messages up.

Initialize all 
messages:

Click Initialize. Clears all messages.

Note: Instructions placed after a carriage return will be ignored.

Note: Do not confuse blank cells with spaces. Blank cells will be removed when 
the message is saved.
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ASCII Editor 
Toolbox

To insert an item, either click the corresponding button or press the hotkey. Items 
are inserted at the cursor.

Tool Description Button Hot-Key

Text Box Up to 128 characters of text is displayed. T

Binary A placeholder for a binary field. Defined in 
ladder logic using a WRIT instruction.

B

Octal A placeholder for an octal field. Defined in 
ladder logic using a WRIT instruction.

O

Integer A placeholder for an integer field. Defined in 
ladder logic using a WRIT instruction.

I

Hexadecimal A placeholder for a hexadecimal field. Defined 
in ladder logic using a WRIT instruction.

H

Leading 0 
Integer

A placeholder for a leading 0 integer field. 
Defined in ladder logic using a WRIT 
instruction.

L

ASCII A placeholder for an ASCII field. Defined in 
ladder logic using a WRIT instruction.

A

Space Consecutive blank spaces are displayed. SPACE

Carriage 
Return

Moves cursor to the next line. ENTER

Repeat A repeat is denoted by a repeat start ({) and a 
repeat end (}). A repeat must have both a start 
and an end.

{ - Start
} - End

Control A control character is displayed. CTRL

Flush The message buffer contains a 256 byte data 
field. These bytes contain data values ranging 
from 00 to FF. The flush command clears all 
characters form the message buffer.

BACKSPACE

Flush Num 
Bytes

Removes from 1 through 255 bytes from the 
beginning of the message buffer.

N/A
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Tool Properties Each tool has specific properties that are editable using the properties panel. 
Changing a tool’s properties will automatically update the message editor and 
preview panels. 

Flush Inclusive Clears specific groups of data from 1 to 255 
times, or until a match is found. The terminator 
value determines how many times the buffer is 
flushed. The controller stops the buffer flushing 
when it finds a match for the terminating 
characters.

N/A

Flush 
Exclusive

Clears the buffer until a match is found for the 
terminating character pair. It does not flush the 
match characters. This uses two registers. The 
first register contains the type identifier and the 
second contains the hex values of the 
terminating pair. The hex values range from 
0000 to FFFF. The controller searches for this 
range in the buffer. If the second character of 
the match pair is not a null (00), then the next 
character in the buffer must be equal or the 
search continues. If the last character test is 
equal or null, the flush is performed up to but 
not including the matched terminators.

N/A

Tool Description Button Hot-Key
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Working with Macros
At a Glance

Overview When writing logic networks, you may find yourself reusing pieces of code again and 
again, changing addresses only for a few of the variables. In these cases, 
subroutines might not be suitable (example: when large numbers of variables are 
involved or when you want to reuse the same piece of code in different projects). 
What you’re looking for is a macro.

What's in this 
Chapter?

This chapter contains the following topics:

Topic Page

Macros 250

Using Macros in Logic 252
249



Macros
Macros

Overview Macros are generic pieces of logic networks you create with parameters instead of 
actual addresses. Macros are programmed offline in the logic editor. When you 
insert a macro in your main project, you map the parameters to real addresses. You 
can insert the same macro in several places with different sets of mapped addresses 
each time. The addresses change but the logic stays the same.

The main project retains its link to the inserted macros. This means ProWORX 32 
notices if you make changes to a macro and informs you when you view it in the logic 
editor.

Creating a Macro 
Project

To create a macro project:

Editing a Macro In general, you edit a macro with the same tools as a regular project. However, 
several ProWORX 32 functions are disabled when editing a macro project. Among 
them are:

Traffic Cop
Configuration Extensions
ASCII Functions
Extended Memory
PLC Status
I/O Drawing Generator
Analyze Device
Reading and Writing

Step Action

1 Create a new ProWORX 32 offline project by selecting File → New Project (see 
p. 42) from the ProWORX menu.

2 Navigate to the folder where you want to save the new project, enter the name 
of the new project in the File name field, and click Open.
Result: The New Project wizard opens.

3 Select the Use as a Macro checkbox 

4 Click Next to complete the remaining new project wizard steps.

5 Once you have created a macro project, it is denoted by the macro project icon. 
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Using Macro 
Parameters

While editing macro projects, you can assign macro parameters in place of register 
addresses or symbols. These are the addresses that will change for each insertion 
into the main project.

Macro parameters use this format: @txx

The t represents the type of address: 0 for 0xxxx, 1 for 1xxxx, 3 for 3xxxx and 4 
for 4xxxx.
The xx represents the parameter number, which can be from 1 to 50.

For example, a macro parameter of @304 would represent the fourth programmable 
address of the form 3xxxx. Note that @304 and @404 refer to different parameters 
and are mapped to totally different addresses.

You can have a total of 200 parameters in your macro project -- 50 for each address 
type.

To sort parameters in numerical order, click the column header.
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Using Macros in Logic

Adding Macro 
Projects to Logic

Insert macros into logic while working offline in the logic editor.

Removing Macro 
Projects from 
Logic

To remove a macro from a ProWORX 32 project:

To remove a macro completely from your hard drive:

Step Action

1 Take your project offline (see p. 49).

2 Open the logic editor (see p. 159).

3 Right-click in the logic editor, and click Insert → Macro.
Result: The Available Macros dialog box opens.

4 Select a macro from the list, and click OK.
Result: The Macro Parameters dialog box opens.

5 For each parameter, enter a Modicon address in the Address column.

6 When all the parameters have been mapped to Modicon addresses, click Insert. 
ProWORX 32 checks each address to ensure it’s valid for the macro parameter’s 
address type and range. If invalid addresses are found, you are returned to the 
Macro Parameters dialog box. Otherwise, the macro’s logic is inserted into your 
ProWORX 32 project and you are taken to the Macro Overview window.

Step Action

1 Select the macro you want to delete.

2 Right-click in the Network Navigator panel, and click Delete Macro.
Result: A confirmation dialog box opens.

3 Click Yes.
Result: The macro is removed from the project.

Note: Deleting a macro from a project doesn’t erase the macro file from your hard 
drive; it removes an inserted macro’s logic from your main logic.

Step Action

1 Follow steps 1 - 3 in the table above to remove the macro from your main logic.

2 Right-click the macro in the project navigation panel, and click Delete.
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Logic Editor 
Macro Display 
Overview

The Macro Overview display appears in the logic editor when you move the cursor onto 
an inserted macro. It also appears just after inserting a macro into a project. This 
display gives the macro’s file name, description (the Detailed Project Name as entered 
from the project properties), status, and a list of its parameters and the Modicon 
addresses or symbols to which they are mapped.

The macro status can be one of two things:

Macro has changed: The macro has been changed since it was inserted into the 
main logic network. You may want to update the inserted macro to reflect the 
changes made to the macro project it is linked to.
Macro not found: The macro project file either no longer exists or has been moved 
to a different directory.

Making Changes 
in Macros

If you make changes to a macro project after it has been inserted into a main logic 
network, you’ll have to update each copy of it within that logic network.

There may also be times when you want to make changes in logic to a single macro 
insertion without changing the original macro project. In this case, you’ll have to unlink 
that macro insertion. Unlinking a macro removes its connection to the original macro 
project; the logic in that macro insertion becomes part of the regular main project logic.

Once a macro insertion has been unlinked it cannot be re-linked. Changes made to the 
macro project will no longer be detected by the logic editor.

Updating a 
Macro in a 
Project

In the logic editor:

Unlinking a 
Macro from a 
Project

Note: Once you’ve unlinked a macro, you can’t re-link it.

Step Action

1 Move the cursor onto a macro that needs to be updated.
Result: The Macro Overview window opens, with a status that reads Macro Has 
Changed. (If the macro status reads Rec: xxx", where xxx is a series of numbers, 
then you don't need to update it.)

2 Right-click in the Network Navigator panel, and click Update Macro.
Result: The macro’s logic is reinserted into the logic network.

Step Action

1 In the logic editor, move the cursor onto the macro you want to unlink.
Result: The Macro Overview window opens.

2 Right-click in the Network Navigator panel, and click Unlink Macro.

3 To unlink all macros, right-click in the Network Navigator panel, and click Unlink All 
Macros.

4 Click Yes to confirm the unlink.
Result: The macro is unlinked and the Macro Overview window closes. You return to 
the logic editor.
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ProWORX 32 Utilities
At a Glance

Overview This chapter explains ProWORX 32 Utilities.

What's in this 
Chapter?

This chapter contains the following topics:

Topic Page

BM85 Configuration 256

BootP Utility 259

Compare Utility 262

I/O Drawing Viewer Utility 264

The Ping Utility 265

MBP Stat Utility 266

CodeGen Utility 268

Documentation Utilities 271

Global Replace 274
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Using ProWORX 32 Utilities
BM85 Configuration

Overview A BM85 Bridge Multiplexer allows you to connect up to four Modbus devices or 
networks of Modbus devices to a Modbus Plus network.

The BM85 Configuration utility is used to configure a BM85 device. BM85 
Configuration can be run as either a stand-alone application (BM85_Setup.exe in 
the ProWORX\32 directory) or as a utility in the utility menu.

Opening the 
BM85 
Configuration 
Utility

Click the Utilities tab in the project navigation panel, and double-click BM85 
Configuration.

- or -

Click Utilities → BM85 Configuration.

Working with the 
BM85 
Configuration 
Utility

In the BM85 Configuration dialog box:

Setting up the 
BM85

 

If you want to... Then...

Read current settings from the BM85, Click Read from MUX.

Write configuration settings to the BM85, Click Write to MUX.

Print configuration settings, Click Print.

Save configuration settings to .mux file, Click Save to File.

Step Action

1 In the BM85 Configuration dialog box, select a Communications Port from the 
Communications Port list.

2 In the File Name field, enter a path and file name, or click Browse to find a .mux 
file.

3 To create a new .mux file, click Browse, navigate to the folder in which you want 
the file to reside, and enter a file name (*.mux) in the File Name field. When 
asked if you want to create this file, click Yes. You can now edit the generic 
settings.

4 To retrieve and display the current settings of the BM85, click Read from MUX.
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Configuring the 
Modbus Ports of 
a BM85

Configure each of the BM85’s four ports by editing the parameters below:

Parameter Description

Port Type Selects the Modbus device that attaches to the port:
Master - Select for a master device, such as a PC
Slave - Select for a slave device, such as a PLC
Network - Select for a network of slave devices connected through a 
modem
X-Master - Select for a device in Silent Master mode

Address Sets the address of a slave device from 1 to 247. Only available when 
Port Type is Slave.

Baud Rate Sets the speed of data transmission in bits per second. The default is 
9600.

Stop Bits Sets the number of bits at the end of a packet which prepare the receiving 
device for the next packet. Either 1 or 2.

Parity Adds a check bit to a packet to make the number of binary ones always 
either odd (Odd Parity) or even (Even Parity). If Parity is set to None, the 
check bit is not added. The PC and controller must use the same parity. 
Default is None.

Data Mode Selects a communications mode for the port: RTU or ASCII. Default is 
RTU.

Priority Determines the order in which the BM85 checks the ports, with 1 being 
the highest priority and 4 the lowest. All ports must have different 
priorities.

Link Time-out Sets the maximum time in multiples of 100 milliseconds that the BM85 
waits for slave devices to respond to commands before it sends an error 
message.

Modem Booster Determines whether the BM85 maintains a dedicated connection to a 
slave device until it completes a command or transparently processes 
other network traffic while it waits. This option is not available unless the 
port type is set to Network. Note that this option should be set to No for 
ports attached to 584 controllers operating in SAFE84 Mode.
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Working with 
Routing Paths

In the BM85 Configuration dialog box:

Communicating 
with the BM85

If you are having trouble communicating with the BM85:

If you want to... Then...

Add a routing path, Select a table from the Table list and an address from the 
Address list. Enter a routing path in the Installed Routing 
Path field. Click Add.

Remove a routing path, Select a routing path from the Address list. Press Delete, or 
click Remove.

Step Action

1 Make sure the COM port selected is plugged into the BM85.

2 Make sure the port on the BM85 you are plugged into is in configure mode. Set 
MODBUS Port Configuration switches on the BM85 to CONFIGURE, PORT 1, 
9600 BAUD, NO PARITY, 1 STOP BIT (all off).
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BootP Utility

Overview ProWORX 32 supports the configuration of the IP Address of a Quantum NOE 
Ethernet adapter, an ENT module or a Momentum controller via an Ethernet 
network. The BootP utility lets you record and configure a device’s IP Address and, 
optionally, the Gateway IP Address and Sub network mask.

Opening the 
BootP Utility

Click the Utilities tab in the project navigation panel, and double-click BootP.

- or -

Click Utilities → BootP.

Using the BootP 
Utility

In the BootP dialog box:

BootP Listening When a BOOTP client such as a PLC requires an IP address, it broadcasts a request 
for an address across its Ethernet connection and through the TCP/IP network. It 
continues broadcasting these requests periodically until a reply is received or a set 
amount of time has passed. In the case where a PLC has a TCP/IP configuration 
extension active, the information in the extension may be used to configure an IP 
address if a BootP response is not received. The BootP utility listens for these IP 
address requests and responds accordingly. The response includes an IP address 
for the client. When the response is received, the client uses this new IP as its own 
and may then be accessed normally through the TCP/IP network.

Using BootP 
Listening

In the BootP dialog box: 

Step Action

1 To enable active pinging of devices in the list, select the Enable Active Device 
Ping check box.

2 To check if there is a device at the specified IP address, click Ping. If successful, 
the status field displays Device found at specified IP Address.

3 To exit the BootP utility, click Close.

Step Action

1 Click Start Listening to make the BootP utility listen for incoming IP requests. 
The BootP utility now responds to any BootP IP address requests coming from 
Modicon devices.

2 Click Stop Listening, and the BootP utility ignores any incoming requests.
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Automatically 
Checking IP 
Addresses

In the BootP dialog box, select the Enable Active Device Ping check box. This 
periodically pings each IP address in the list. The status of the device located at the 
address is reported back in the Status field.

Tip: Use Enable Active Device Ping when performing automatic BootP operations. 
Once a BootP operation is complete, the success of the operation is updated in the 
Status column in the list.

Using the Device 
List

In the BootP dialog box:

Device 
Parameters

BootP device parameter descriptions:

Step Action

1 To add a device to the BootP list, click New Device.

2 To remove a device from the BootP lists, select a device from the list and click 
Delete Device.

3 To configure a device in the BootP list, select a device from the list and enter the 
parameters in the available Device Info and Optional Parameters fields. For 
parameter descriptions, see p. 260.

4 To have the ability to write the Gateway address and the Subnet mask to the 
device, select the Write Optional Parameters check box. Otherwise, these 
parameters are unavailable.

Parameter Description

Device Displays the description of the associated row selected in the BootP 
Parameters table.

MAC Address A 12 digit hexadecimal number uniquely identifying an Ethernet device. A 
device's MAC address cannot be changed. The MAC Address is on a label 
(currently marked as IEEE GLOBAL ADDRESS) on each Schneider 
Ethernet device.

IP Address A logical 32-bit address used to identify a TCP/IP device. Each IP address 
has two parts: the network ID and the host ID. The network IP identifies all 
hosts (devices) that are on the same physical network. The host ID 
identifies a specific host on a network. Each computer that runs TCP/IP 
requires a unique IP address.
The IP Address may be available from or assigned by your network 
administrator.

Status The existing condition of the ping:
Device Found: ProWORX 32 has found a Schneider device with this 
MAC address and IP address
Device not found: ProWORX 32 could not find a Schneider device with 
this MAC address and this IP address.
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Subnet Mask Used to mask a portion of the IP address so that TCP/IP can distinguish 
the network ID from the host ID. TCP/IP hosts communicate by using the 
subnet mask to determine whether the destination host is located on a 
local or remote network.
The Subnet Mask may be available from or assigned by your network 
administrator.

Gateway For communication with a host on another network, an IP host must be 
configured with a route to the destination network. If a configured route is 
not found, the host uses the gateway to transmit the traffic to the 
destination host. The default gateway is where the IP sends packets that 
are destined for remote networks. If a default gateway is not specified, 
communications are limited to the local network.
The Gateway may be available from or assigned by your network 
administrator.

Parameter Description
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Compare Utility

Overview ProWORX 32’s Compare function finds differences in logic and configuration 
between a project and a controller, between two projects, or between two 
controllers. This utility ensures that your controllers are using the right logic, are 
configured properly, and a local project is the same as your operation’s master 
project.

The compare function examines any or all of these elements:

Opening the 
Compare Utility

Click the Utilities tab in the project navigation panel, and double-click Compare.

- or -

Click Utilities → Compare.

Using the 
Compare Utility

In the Compare Setup dialog box:

Networks Coils used - Up to four ranges, each range 1 - 1600

Controller Configuration Coil state - Up to four ranges, each range 1 - 1600

DX Instructions Input state - Up to four ranges, each range 1 - 256

Traffic Cop 3xxxx registers - Up to four ranges, each range 1 - 99

Segment Scheduler 4xxxx registers - Up to four ranges, each range 1 - 1800

ASCII Port Parameters Coil disable - Up to four ranges, each range 1 - 1600

ASCII Messages Input disable - Up to four ranges, each range 1 - 256

Step Action

1 To compare two projects:
Click the Browse button to the right of the Compare field, and select a project 
from the My Projects list in the Select Master Project dialog box or use the 
Browse button to locate a project not in the ProWORX 32 projects directory.
Click the Browse button to the right of the To field, and select a project from 
the My Projects list in the Select Compare Project dialog box or use the 
Browse button to locate a project not in the ProWORX 32 projects directory.
Clear both Online check boxes, and click OK.

2 To compare a project to a program installed in a controller, follow step 1, but 
select the online check box to the right of the To field.
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Using the 
Compare Report

 

3 To compare an element of a project, select the respective check box in the 
Compare Options field.

Networks
Controller Configuration
DX Instructions
Traffic Cop
Segment Scheduler
ASCII Port Parameters
ASCII Messages
Coil Used
Coil State
Input State
3xxxx Registers
4xxx Registers
Coil Disable
Input Disable

4 To compare all elements, click Toggle.

5 To view the master database’s existing compare report, click View Report.

6 To compare two controllers, follow step 1, but select both Online check boxes to 
the right of the Compare and To fields.

7 To run the compare, click OK.
NOTE: When comparing a project to a program installed in a controller, insure 
to put project in the compare field.

Step Action

Step Action

1 After clicking OK in the Compare Setup dialog box, the compare report opens in 
your default browser.

2
 - Elements match.

 - Element mismatch.

 - Element compare not applicable.

 - Element not compared.

3 For elements that are mismatched, click the text link to see mismatch element 
details.

4 To print the compare report, click File → Print from the compare index page.
To include the whole report, click Print all linked documents under the 
Options tab in the print dialog box, and then click Print.
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I/O Drawing Viewer Utility

Overview The drawings are in a .DXF format that is supported by most CAD programs. The I/
O Drawing Generator uses the master .DXF drawings to create I/O drawings based 
on the I/O Configuration and Documentation information. Once the final .DXF 
drawings are created, they can be imported using your CAD program. 

This dialog box displays the I/O drawing for the current card. It also allows you to 
print the displayed portion of the current .DXF drawing using the default Windows 
printer settings. Several options are available to allow you to view your drawings.

Pan allows you to scroll the view of the drawings displayed in much the same way 
as Autocad. Zoom allows you to zoom in on a selected section of the drawing. Zoom 
Out takes you back to display the complete .DXF drawing.

Opening the I/O 
Drawing Viewer 
Utility

Click the Utilities tab in the project navigation panel, and click I/O Drawing Viewer.

- or -

Click Utilities → I/O Drawing Viewer.

Using the I/O 
Drawing Viewer 
Utility

In the I/O Drawing Viewer dialog box:

Step Action

1 To pan across the drawing, click View → Pan, or click the Pans toolbar 
button.
Click the location you want to begin your pan view. Drag the cursor to another 
location in the drawing and release the mouse button. The view pans from the 
start location to your end location.

2 To zoom into the display, click View → Zoom In, or click the Zooms in 
toolbar button.
Click the start location where you want to begin your zoom. Drag your cursor 
to mark the area. A rectangle appears to define the section of drawing you 
want to zoom in on. Release the mouse button.

3 To zoom out of the display, click View → Zoom Out, or click the Zooms out 
toolbar button.

4 To select a different .DXF drawing, from the I/O Drawing Display window, 
click Open.
The File Open dialog box opens.
Select the .DXF to display, then click OK.

5 To print a drawing, from the I/O Draw Display window, click Print. The drawing 
prints to your default printer.

6 To save the I/O drawing in another format, click Save As.
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The Ping Utility

Overview Ping is a TCP/IP utility for testing a given IP address. The address is checked to see 
if a device exists for it. If the address exists, the ping is successful, and a round trip 
time (ms) is returned. If the ping fails, an error response will be given. This helps 
diagnose problems with the TCP/IP communications and determine a device's 
existence. Ping options are saved to the ProWORX.INI file.

Opening the Ping 
Utility

Click the Utilities tab in the project navigation panel, and double-click Ping.

- or -

Click Utilities → Ping.

Using the Ping 
Utility

In the Ping dialog box:

Step Action

1 Enter the IP address to ping in the IP Address to Ping field.

2 Click Ping to perform a ping.
Result: The status of the ping attempt is displayed in the Return Status field. If 
successful, the ping time is displayed in the Round Trip Time field.

3 Click Close to exit the Ping utility.
31003882 12/2006 265



Using ProWORX 32 Utilities
MBP Stat Utility

Opening the MBP 
Stat Utility

Click the Utilities tab in the project navigation panel, and double-click MBP Stat.

- or -

Click Utilities → MBP Stat.

Overview To access device status and diagnostic tools, right-click the device and select one 
of the following items.

Status and 
Diagnostic 
Tools

Tool Tabs Description

Bus Status (CTRL+B) Used to obtain network status of nodes on the network.

Active station 
table

Active nodes on the network are highlighted.
Note: The node that the cursor is on is not highlighted.

Token station 
table

Nodes on the network that are receiving and passing the 
token are highlighted. The Token Rotation Time and 
Token Pass Counter are also displayed.
Note: The node that the cursor is on is not highlighted.

Global data 
station table

Nodes that are sending global data to the selected node 
are flashing if the selected node is configured to receive 
global data from the nodes.

Network Statistics (CTRL+N) Obtain statistics for the node on which the cursor is 
located.

Personality Node information, such as type, address, version and 
communication state, is displayed.

Error counter Communication information and errors for the selected 
node are displayed.

Receive 
buffers

When the node selected is receiving specific input from 
other nodes on the network, the number of receive 
buffers in use is flashing.

Transactions The number of data transactions for the 8 data paths of 
the selected node:

DM - Data master
DS - Data slave
PM - Programming master
PS - Programming slave

Work-to-do The type of programming and/or data activity for the 8 
data paths of the selected node is displayed. A flashing 
square indicates data activity.
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To stop communications with the selected device, click Stop.

To begin communications with the selected device, click Start.

Read Global Data (CTRL+G) The global data being transmitted for the selected node 
is displayed. The data can be viewed in HEX, DEC 
signed or DEC unsigned format.

CPU status (CTRL+U) CPU firmware, hardware revisions, and crash codes are 
displayed. From here you can access the CPU Status 
words.

Adapter statistics (CTRL+A) CPU firmware, hardware revisions, and crash codes are 
displayed. From here you can access the CPU Status 
words.

Note: The Refresh slider allows you to set the rate at which the data is updated.

Status and 
Diagnostic 
Tools

Tool Tabs Description
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CodeGen Utility

Overview CodeGen is a utility that allows users to build databases from macros by using a 
script. To use CodeGen, first create a special .CGF batch file that specifies which 
macros to insert into your project.

CodeGen can be used with a program consisting entirely of macros. You can write 
several macros at once, create a .CGF script, then use CodeGen to insert the 
macros into your project. 

Opening the 
CodeGen Utility

Click Start → Programs → ProWORX 32 → CodeGen.

Result: The CODEGEN Macro Processing Utility dialog box opens.

Opening a 
CodeGen 
Database

To open a CodeGen access database:

Unintended Application Program Changes
When CodeGen runs a script file, it appends new macros to the end of the main 
logic database. Unintended application program changes can occur when 
expanding a macro multiple times or when halting the expansion of a macro 
(expanding only part).
Review your application program before placing a PLC intro run mode after 
expanding a macro, or halting the expansion of a macro.

Failure to follow this instruction can result in injury or equipment damage.

CAUTION

Step Action

1 In the CODEGEN Macro Processing Utility dialog box, click File → Open.

2 Navigate to the folder where your file is located, click the file, and click Open.
Note: The CodeGen database contains the list of macro projects as well as 
information, e.g. title, ProWORX 32 project, for each entry on the list.
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Creating .CGF 
Files with 
CodeGen 
Compiler

To create a .CGF file for CodeGen:

Step Action

1 Click Start → Programs → ProWORX 32 → CodeGen. 
The CODEGEN Macro Processing Utility dialog box opens.

2 To add an item to the CODEGEN Macro Processing Utility dialog box:
Right-click on a project in the ProWORX 32 Project column, then click Edit.
- or -
Click Project → Add.
Result: The Script Editor dialog box opens. 

3 In the Title field, type the title of your script. 

4 In the ProWORX 32 Project field, type the name of your project, or click Browse to locate 
your project. This is the project into which your macro/script will be inserted.

5 In the CodeGen Script File field, type the path and name of your script file, or click 
Browse to navigate to your file name.

6 Next, in the CGF Script editor, in the field where you view/edit the contents of the CGF 
script file, type your macro using the following format:
<Mode>
# MacroName PathToMacro
ParameterName Address
ParameterName Address
...
#MacroName PathToMacro
ParameterName Address
ParameterName Address
...

7 In the Notes field, type notes about your script.

8 Click OK to process the .CGF file.

9 If you need to make further changes to the .CGF file, click Project → Edit.
Result: You will return to the Script Editor, and can change any of the values in this 
screen.
Otherwise, proceed to the following step.

10 In the CODEGEN Macro Processing Utility dialog box, select the check box at the left side 
of an entry. When a check box is selected, the line will be processed when Start Build is 
activated.
Click Actions → Check all to select all of the check boxes at once so CodeGen runs all 
the scripts.
Click Actions → Uncheck all to clear all the check boxes.

11 Click the Start Build button (the arrow facing to the right)
- or -
Click Actions → Start Build to begin executing each task in the CODEGEN Macro 
Processing Utility dialog box.

12 To stop the build, click the Stop Build button (the square) on the toolbar.
If the build stops, a red X appears to the right of the check box where the build stopped.

13 The results are displayed in the Results field.
Note: The macro’s log file will be displayed in this field.
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Running 
CodeGen from a 
Command Line

To compile a macro and database without opening CodeGen:

1. Click Start → Run.
2. Click Browse to navigate to the CodeGen executable. Click the CodeGen.exe 

file, and click Open.
3. Using the default format below, type the path and file names of the macro 

configuration (.CFG) and the destination project (.PWX) files.
Codegen /cgf:c:\prwx32\<Filename>.cgf /
db:c:\prwx32\<projectname.pwx>
<Filename> contains the name of your .CGF file
<projectname.pwx> contains the full path and file name of your database.

4. Click OK. CodeGen appends the macros defined by the .CGF to the master 
project as a background task

.CGF Batch Files Below are the descriptions for the formats for a .CGF file:

Mode can be:

<Create New>: Clears the source database of all documentation and logic and 
inserts macros at the beginning of the logic.
<Overwrite>: Leaves the documentation for the source database, but the macro 
documentation can overwrite the source database’s documentation.
<Add To>: Leaves the documentation for the source database, but the macro 
documentation that matches the source is ignored.

Macroname: The file name of the macro that you want to insert.

PathToMacro: The path name to the macro database, including the back slash 
\character at the end of the path.

ParameterName: An identifier for the macro’s parameter. This can be either the 
parameter name (such as @001) or the symbol for it.

Address: The Modicon address that is substituted for the parameter preceding it on 
the same line.
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Documentation Utilities

Overview The documentation utility allows you to copy, move, and delete documentation 
records. Each operation (copy, move, and delete) is explained in detail below.

For all operations (copy, move, and delete), the following features apply:
Before clicking Start, make sure you fill in each required address field.

For the copy and move operations, fill in the Source Starting Address and 
the Source Ending Address fields. The Destination Ending Address field 
is calculated automatically.
For the delete operation, fill in the Source Starting Address and the Source 
Ending Address fields.

The addresses you enter in the respective fields must be within the address 
range specified in the CPU configuration.
The Source Starting Address and the Source Ending Address should be the 
same type address.
In the Options section, you can specify All or Partial documentation records. 
Some fields do not exist for specific address types; therefore, they are enabled or 
disabled depending on the addresses you enter.
Click Start to perform the required operations on the address ranges you 
specified.

Copy 
Documentation

To copy documentation:

Step Action

1 Click Edit → Documentation Utilities.

2 Click the Copy button.

3 In the Source Starting Address field, type the address from where you want to start 
copying records.

4 In the Source Ending Address field, type the address from where you want to end 
copying records.

5 In the Destination Starting Address field, type the address to where you want to 
copy the records.

6 Click Start.

Note: The Destination Ending Address is calculated automatically. To copy more than one 
record, type a different Source Ending Address.

Note: You can copy documentation from one type of database record to another. However, 
any field, which is not supported by both address types, will not copy.
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Move 
Documentation

To move documentation:

Documentation 
Options

The table below describes the allowable documentation features for different 
address types. For example, if you copy or move documentation from an 0x address 
type to a 3x address type, the Page Title, Long Comments, and ISA Symbol features 
do not copy or move.

Step Action

1 Click Edit → Documentation Utilities.

2 Click the Move button.

3 In the Source Starting Address field, type the address from where you want to 
start moving records.

4 In the Source Ending Address field, type the address from where you want to 
end moving records.

5 In the Destination Starting Address field, type the address to where you want 
to move the records.

6 Click Start.

Note: The Destination Ending Address is calculated automatically. To move more 
than one record, type a different Source Ending Address.

Note: You can move documentation from one type of database record to another. 
However, any field, which is not supported by both address types, will not move.

Address 
Type

Descriptors Short 
Comments

Long 
Comments

ISA 
Symbol

Page 
Title

Symbols HMI

0x, 1x yes yes yes yes yes yes yes

3x, 4x yes yes no no no yes yes

@x yes yes no no no no no

#x yes yes no no no yes yes

6x yes yes yes yes yes no no
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Delete 
Documentation

To delete documentation:

Step Action

1 Click Edit → Documentation Utilities.

2 Click the Delete button.

3 In the Source Starting Address field, type the address from where you want to 
start deleting records.

4 In the Source Ending Address field, type the address from where you want to 
end deleting records.

5 Click Start.
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Global Replace

Overview Global Replace lets you copy or move addresses (their descriptors and register 
contents) from a project database to the currently active project database.

Using Global 
Replace

 

Note:  
Global Replace is available only in offline mode.
Global Replace cannot be undone.
Global Replace will not work if the configuration editor is open.
The addresses you enter in the respective fields must be within the address range 
specified in the CPU configuration.
The Source Address Range → Start and the Source Address Range → End should 
be the same type address.

Step Action

1 Click Edit → Global Replace.
- or -
Click the Global Replace toolbar button.

2 In the Source Database field, click Browse to select a project from which you want to copy or move descriptors 
and register contents. This field defaults to the currently active project.

3 In the Source Address Range field:
Type the starting address of the block you want to copy/move in the Start field.
Type the ending address of the block you want to copy/move in the End field.

Note: Start and End addresses should be the same address type.
Note: 0xxxx, 1xxxx, 3xxxx, and 4xxxx registers can all be used as source addresses for an address copy/move. 
Each of these types of addresses can also have their descriptors copied or moved. If 4xxxx holding registers are 
specified, the register contents can also be copied or moved.

4 In the Destination Address Range field:
Type the starting addres of the block (in the current database) to be overwritten by the copy/move in the Start 
field.
The End field is calculated automatically, based upon the size of the block you specified in step 3.

Note: Start and End addresses should be the same address type.

5 Select the Replace Logic check box if you want to change the source addresses to the destination addresses 
in the ladder logic program.

In the Starting Network field, type the network number from which the address will be copied/moved.
In the  the Ending Network field, type the network number to which the addresses wil be copied/moved.

Note: By default, the starting network is the minimum network number, and the ending network is the maximum 
network number.

Finally, select the Step Replace check box to confirm every change to the ladder logic program. The check 
box is cleared by default. If not selected, all changes will ocur without confirmation.
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6 In the Options field, click one of the following options from the Documentation list.
Ignore: Does not transfer the documentation to the destination project.
Move: Transfers the documentation into the destination project and deletes it from the source project. The 
descriptors are deleted from the source project only when moving within the same project, i.e., the source 
and destination projects are the same.
Copy: Transfers the documentation into the destination project and retains it in the source project as well.

Note: The documentation consists of descriptors, and short and long comments.

7 In the Options field, click one of the following options from the Register Contents list. This field is disabled if it 
does not apply.

Ignore: Does not transfer the register contents to the active database.
Move: Transfers the register contents into the active database and deletes them from the source project. The 
register contents are deleted from the source project only when moving within the same project, i.e., the 
source and destination projects are the same.
Copy: Transfers the register contents into the active database and retains them in the source database as 
well.

8 In the Options field, click one of the following options from the Discrete States list.
Ignore: Does not transfer the discrete states to the destination project.
Move: Transfers the discrete states into the destination project and deletes them from the source project. 
The discrete states are deleted from the source project only when moving within the same project, i.e., the 
source and destination projects are the same.
Copy: Transfers the discrete states into the destination project and retains them in the source project as well.

9 In the Options field, click one of the following options from the Forced/Disabled list. This field is disabled if it 
does not apply. The field only applies when the source and destination addresses are 0x and/or 1x types.

Ignore: Does not transfer the forced/disabled discretes to the active database.
Move: Transfers the forced/disabled discretes into the active database and deletes them from the source 
database. The forced/disabled discretes are deleted from the source project only when moving within the 
same project, i.e., the source and destination projects are the same.
Copy: Transfers the forced/disabled discretes into the active database and retains them in the source 
database as well.

10 Click Start.

Step Action

Note: You can copy or move registers and discretes from one type of project to 
another. However, these fields will be available/unavailable depending on the 
combination of address types.
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ProWORX 32 Reporting
Reporting

Overview The ProWORX 32 reporting feature allows you to print many aspects of your project 
to a file or printer. Reporting can be used to extract information from your project into 
a printed document.

Ensuring Proper 
Monitor Settings

Printing documentation requires a monitor setting of 96 dpi to operate correctly. If 
you change the setting to 120 dpi, your networks will only print out approximately 6 
rows by 9 columns, instead of the full 7 rows by 11 columns. To ensure your monitor 
is set to 96 dpi, follow these steps.

Step Action

1 Click Start → Settings → Control Panel, and double-click Display.
- or -
Right-click on your desktop (with all windows minimized), and click 
Properties.

2 Click the Settings tab.

3 Click Advanced.

4 Click the General tab.

5 In the Display field, click Normal size (96 DPI) from the DPI setting list.

6 Click OK.

7 Click OK to close the Display Properties dialog box.
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Using the 
Printing Menu

 

Quick Picks In the Report Options field, select one of the following check boxes to include in 
your report.

Title Page
Table of Contents
Report Options

The list below these check boxes contain quick picks, which are pre-defined sets of 
reporting options. Click an option in the list, and the respective report options will be 
automatically selected. The options are as follows:

Step Action

1 To send the currently selected documentation to the printer:
Click File → Print.
- or -
Click the Print toolbar button.

2 To view the current report as it will be printed:
Click File → Print Preview.
- or -
Click the Print Preview toolbar button.

3 To edit the content and documentation that will make up the report:
Click File → Report Setup.
- or -
Click the Report Setup toolbar button.

Quick Pick Description

Turn off all options All report options are deselected.

Turn on all options All report options are selected.

All networks All settings within the Networks report option are selected.

Everything but networks All settings within all report options are selected except the 
Networks report option.

All documentation tables All settings within the Descriptor Ranges option and 
Documentation Tables options are selected.

All controller tables All settings within the Configuration Tables, Traffic Cop, 
Register Content Ranges, and Used Tables report options are 
selected.

All used tables All settings within the Used Tables report option are selected.

All mismatch tables All settings within the Mismatch Tables report option are 
selected.
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Reporting Setup

 

Customize Page 
Format

In the Report Setup dialog box: 

Step Action

1 Click File → Report Setup.
- or -
Click the Report Setup toolbar button.

2 Select the check boxes of the report options you want to include.
Customize Page Format
Networks
Descriptor Ranges
Documentation Tables
Configuration Tables
Traffic Cop
Register Content Ranges
Address Used Tables
Mismatch Tables

3 Set the parameters within each report option that you have selected.
(To see further details pertaining to each report option, see below.)

4 To select all parameters or deselect all parameters within a report option, click 
Toggle All.

5 Click Save Settings to save the current report options.

6 Click Print Preview to preview the report as it will be printed.

7 Click Close when you are finished setting the report options.
Click Yes to the ProWORX 32 dialog box prompting you to save changes.

Step Action

1 Select the Customize Page Format check box in the Report Options field.

2 In the Customize Page Format field, select the following check boxes if you 
want these options inluded in your report.

Page Title
Report Sections

Click Font to the right of both these check boxes to change the font.

3 In the Select field, click each of the buttons below to customize.
Left Page Header
Right Page Header
Title Page

When you click each button, a dialog box opens to the ProWORX → 32 → Bmp 
→ Report directory. Select a graphic to use for each element, and click Open. 
The selected graphic appears to the right of the respective button.
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Networks In the Report Setup dialog box:

Descriptor 
Ranges

In the Report Setup dialog box:

Documentation 
Tables

In the Report Setup dialog box:

Step Action

1 Select the Networks check box in the Report Options field.

2 In the Print Networks field, type All to print all networks in the current project.
In the Print Networks field, type None to print none of the networks in the 
current project.
In the Print Networks field, type a specific number or a range of numbers to 
print one network or a range of networks in the current project.

3 Select the One Network per Page check box if you want one network to print 
per page.

4 If you select One Network per Page, you can then select the following check 
boxes.

Network Long Comment: Prints long comments for the particular network.
Cross References: Prints all of the cross references that are associated with 
the particular network.

Select the All button or the Coil button to define the type of cross 
references you want to print.

Step Action

1 Select the Descriptor Ranges check box in the Report Options field.

2 Enter the range of descriptors to be printed for each address type. Valid entries 
include 1-100, None, and All.

3 Select the All Items check box to print all coils. This includes all items used in 
logic and items with descriptions.

4 Select the Items Used in Logic check box to print addresses used in logic.

5 Select the Items with Descriptions check box to print addresses that have 
descriptions.

Step Action

1 Select the Documentation Tables check box in the Report Options field.

2 Select any combination of the following documentation check boxes:
Log Book / Audit Trail
Symbol Table
Page Titles
Short Comments
Long Comments
Cross References
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Configuration 
Tables

In the Report Setup dialog box:

Traffic Cop In the Report Setup dialog box:

Register Content 
Ranges

In the Report Setup dialog box:

Step Action

1 Select the Configuration Tables check box in the Report Options field.

2 Select any combination of the following configuration tables check boxes:
Configuration
Segment Scheduler
ASCII Messages
Configurations Extensions

3 If you selected the Configuration Extensions check box, you can select any 
combination of the following check boxes:

Data Protect
S980 Address
Peer Cop
Profibus
Hot Standby
TCP/IP
I/O Scanner
SY/MAX
Compact TSX Phase 2
VME

Step Action

1 Select the Traffic Cop check box in the Report Options field.

2 Select any combination of the following traffic cop check boxes:
Drop Summary
Rack Overview
Slot Summary

3 If you selected the Slot Summary check box, you can select any combination of 
the following check boxes:

Descriptors
Symbols
Cross References
Short Comments

Step Action

1 Select the Register Content Ranges check box in the Report Options field.

2 Enter a range of register contents to print in the address (3xxxx, 4xxxx, and 
6xxxx (file 1 - 10)) fields. Valid entries include 1-100, None, and All.
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Address Used 
Tables

In the Report Setup dialog box:

Mismatch Tables In the Report Setup dialog box:

Color Printing In the Report Setup dialog box, select the Color Printing (using Logic Property 
colors) check box to print in color. If you clear the check box, the report will print in 
black and white.

Step Action

1 Select the Address Used Tables check box in the Report Options field.

2 Select the check boxes of the addresses you want to include in the report from: 
0xxxx, 1xxxx, 3xxxx, and 4xxxx.

3 Select the Disable References check box to include the addresses that have 
been disabled in logic.

Step Action

1 Select the Mismatch Tables check box in the Report Options field.

2 Under the Described But Not Used In Logic heading, select the check boxes 
of addresses that have descriptors, but are not used in logic, that you want to 
include in the report.

0xxxx
1xxxx
3xxxx
4xxxx

3 Under the Used In Logic But Not Described heading, select the check boxes 
of addresses that are used in logic, but do not have descriptors, that you want to 
include in the report.

0xxxx
1xxxx
3xxxx
4xxxx

Note: With color foregrounds and backgrounds set in the Logic Editor, the Network 
(report) printout may be difficult to read. To avoid illegible reports, uncheck the 
color printing checkbox in the Report Setup. This will cause the colors used in the 
Ladder Editor to be ignored and printed in black and white.
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ProWORX 32 Server
At a Glance

Overview The ProWORX 32 server (see p. 47) is the repository for projects, the center for 
security, and a hub for communications.

What's in this 
Chapter?

This chapter contains the following topics:

Topic Page

Using the ProWORX 32 Server 284

Audit Trail 293
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Using the ProWORX 32 Server

Logging in to the 
ProWORX 32 
Server

In the ProWORX client menu:

Logging out of 
the ProWORX 32 
Server

In the ProWORX server menu:

Using the 
ProWORX 32 
Server Toolbar

See p. 31 for more information on the ProWORX 32 server toolbar.

Using the 
ProWORX 32 
Server to Manage 
Projects

See p. 47 for more information on the project transactions that can occur between a 
ProWORX 32 client and server.

Setting the 
Server Port

 

Step Action

1 Click Server → Login.

2 In the Name field, enter the user name given to you by the system administrator.
The default name is Administrator.

3 In the Password field, enter your password.
The default password is Administrator.

4 Click Login.

Step Action

1 Click File → Logout.

2 Click File → Close to exit the ProWORX 32 Server.

Step Action

1 Click File → Set Server Port.

2 Select the communications type from either TCP/IP and/or Modbus Plus that the 
server uses to communicate with the clients.
Note: If you need to access projects, which are stored on the server, from the locally 
installed client, you must install a second Modbus Plus Adapter.

3 If you selected TCP/IP, enter the appropriate TCP/IP port number in the TCP/IP Port 
Number field.
284 31003882 12/2006



Using the ProWORX 32 Server
Setting the 
Project Folder

 

4 If you selected Modbus Plus, click either the All or the Selected button.
Click the All button if you want the server to automatically start using Modbus Plus 
adapters 0 and 1 (if installed).
Click the Selected button if you want to dedicate fewer than the number of installed 
adapters to serving clients.
Then, select an adapter in the Adapter List beneath the Selected button.

5 Click OK. To make the communications changes effective, you must restart the 
ProWORX 32 Server.

Step Action

Step Action

1 Click File → Set Projects Folder.

2 Type a new path in the New Path to Project Folder entry window or click the Browse 
button to browse for a new Projects Folder.

3 Check the 'Move existing projects to the new location’ checkbox.
This causes the ProWORX 32 software to move all the projects in the default or 
current projects directory to a new directory and delete the projects and the default or 
current projects directory from the ‘Server/Projects’ folder.

4 The default for the checkbox is checked. If the box is unchecked the existing projects 
will be copied to the new Server projects directory and all projects in the Server 
projects directory will be inaccessible. All moves will take effect when the Server is 
restarted.
There are several additional directories in the Server folder for ProWORX 32. The only 
directory that will be moved is the ‘Projects’ directory.
All the projects stored, via the Server, must be in the same directory.The Server must 
be restarted in order for the directory change to take place. Also, the projects will not 
get moved, until the Server is restarted. This insures that no one is connected to the 
Server and projects will not get moved without the user’s knowledge.
All files in the \Projects folder are moved to the new \Projects directory and the old 
\Projects folder is deleted. For example, if the directory moving from is 
C:\Server\Projects, and the destination directory selected is K:\PLC1, the projects will 
be moved to K:\PLC1\Projects. The \Projects folder is created because the Server 
expects the projects to be in a \Projects directory.
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Configuration 
Examples

The following examples represent suggestions for different types of configurations:

Working with 
Projects

 

Configuration Comment

Flexible Project 
Access

If you configure the server for both Modbus Plus and TCP/IP, then users can access projects 
from the plant floor via Modbus Plus or from the office via TCP/IP.

PLC Access for Users 
without Modbus Plus 
Adapters

For users without Modbus Plus adapters, the server can be configured to serve on TCP/IP. 
With a Modbus Plus adapter in the server, users can use the server as a gateway to the 
PLC’s on the Modbus Plus network attached to the server’s Modbus Plus adapter.

Simultaneous Users If you have two users going online simultaneously to several controllers, you may run out of 
paths with just a single Modbus Plus adapter in the server. Install a second Modbus Plus 
adapter in the server. Have one user use Adapter 0 in the communications setup for his 
projects, while another user configures her projects to use Adapter 1. 

Commissioning Commissioning can be greatly simplified if project members access all projects from one 
server. Temporarily install a server on a laptop computer in the area where work is being 
done. Let the server record changes and control access to projects. If a change is not working 
out, restore a PLC to a previous good version saved on the server. 

Bridge Connect two Modbus Plus adapters to the server. Connect each Modbus Plus adapter to a 
different Modbus Plus LAN. Users can attach to the server through one adapter and select 
the other adapter in the Communications Setup for their projects. This configuration allows 
users to bridge from one Modbus Plus LAN to another without the requirement for the usual 
BP85 bridge device.

Bridging beyond a, b, 
c, d, e

Place a server on LAN d at address e. Log into the server at Modbus Plus address a, b, c, d, 
e. When logged in through the server, your projects see the Modbus Plus network from the 
servers’s perspective. For example, LAN d could be connected to LAN x, which cold then be 
connected to LAN y with a Modbus Plus device z on it.
In Communications Setup, set the Modbus Plus path to be x, y, z. This will provide you with 
a much further reach than is otherwise possible with Modbus Plus.

Backups and Clients In this example, you have two Modbus Plus adapters in the server. You need to do server 
PLC backups and you want to support some users on Modbus Plus via the server. Have the 
users use adapter 0 for project/PLC data access, i.e., use adapter 0 in Communications 
Setup and log in at Modbus Plus address 0. On the server, select the check box for Modbus 
Plus and click the Selected button. Put a check mark beside adapter 0. This means that the 
server will only listen for clients on adapter 0, which will leave adapter 1 free for backups.
Next, set up the backup tasks on the server. The backup allows you to select 
communications options to override those in the project. Set the override for adapter 1. This 
helps ensure that the backups won’t be interrupted by a lack of access to the Modbus Plus 
network caused by a server servicing clients.

Step Action

1 Click the Projects tab.

2 Click a project in the project navigation panel.
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Manual Backup/
Compare

To perform a manual backup or compare: 

Scheduled 
Backup/
Compare

 

3 Click the Project Info tab to see the following display:
Project Name: a short project name
Project Status: checked out/locked status
Project Description: a detailed description of the project
Detailed Project Name: a longer, more descriptive project name
Client: the end-user of the project
Author: the author of the project
Controller Type
Controller Address: communications type and address

4 Click View Audit Trail (see p. 293) to view the transaction history of the project.

Step Action

Step Action

1 Click the Projects tab.

2 Click the Backup/Compare tab.

3 Click a project in the project navigation panel.

4 Click Backup Now to perform an immediate backup of the selected project.

5 Click Compare Now to compare the selected project to the configured 
controller.

6 Click View Latest Compare Results to view the most current compare results.

Step Action

1 Click the Projects tab.

2 Click the Backup/Compare tab.

3 Click a project in the project navigation panel.

4 Select the Backup check box.
Note: Select the Sync Backups and Compares check box to perform a backup, 
then a compare, to that backed-up version of the project

5 Click the Date/Time Wizard button to schedule a time for the backup.

6 Select the Compare check box.

7 Click the Date/Time Wizard button to schedule a time for the compare.
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Creating 
ProWORX 32 
Users

 

8 In the Master field, click one of the following buttons:
Compare Latest Version: the latest version of a project
Compare Previous Version: an earlier version of the project
If you clicked the Compare Previous Version button, click the ellipsis button 
to the right to open a selection dialog box. Select the previous version you 
want to compare, and click OK.

9 In the To field, click one of the following buttons:
Compare to PLC
Compare to File
If you clicked the Compare to File button, click the ellipsis button to the right 
to open a selection dialog box. Select the file you want to compare, and click 
OK.

10 In the Compare Options field, select one or more of the following check boxes 
to set up the compare options (see p. 262).

Networks
Controller Configuration
DX Instructions
Traffic Cop
Segment Scheduler
ASCII Port Parameters
ASCII Messages
Coil Used
Coil State
Input State
3xxxx Registers
4xxxx Registers
Coil Disable
Input Disable

11 Select the Override Communication Parameters check box if you want to 
override project communication parameters and the server is located on a 
different part of a Modbus Plus LAN.

12 Click OK to save your settings and close the dialog box.

Step Action

Step Action

1 Click the Users tab.

2 Click the Add User button.

3 In the Add User dialog box, enter the new user's name in the New User Name 
field.

4 Enter a distinct password in the Password field.
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Creating 
ProWORX 32 
User Groups

 

Working with 
ProWORX 32 
Users and User 
Groups

 

5 Reenter the password in the Re-enter Password field.

6 Click OK to save the new user and close the Add User dialog box.

7 To edit a user name or user password, click the user name in the left-hand 
Users panel, and click Edit User. Make the necessary changes, and click 
OK.
To delete a user, click the user name in the left-hand Users panel, and click 
Remove User.

Step Action

Step Action

1 Click the Users tab.

2 Click the Add Group button.

3 In the Group Rights dialog box, enter the name of the new group in the Group 
Name field.

4 Select Rights for the group.

5 Click OK save the new group and close the Group Rights dialog box.

6 To edit a user group or group rights, click the user group in the middle User 
Groups panel, and click Edit Group Rights (see User Rights, p. 290). Make 
the necessary changes, and click OK.
To delete a user group, click the user group in the middle User Groups panel, 
and click Remove Group.

Step Action

1 Click the Users tab.

2 To add a user to a user group:
Click a user group from the middle User Groups panel.
Click a user name in the left-hand Users panel.
Click the Add user to group button.

3 To remove a user from a user group:
Click a user name in the middle User Groups panel.
Click the Remove user from group button.
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User Rights To associate rights with users, follow the steps below.

User rights descriptions:

Step Action

1 Click the user group, for which you want to associate rights, in the middle User 
Groups panel, and click Edit Group Rights.

2 Select or clear any of the check boxes, defined in the table below.
Click the Check All button to select all check boxes.
Click the Uncheck All button to clear all check boxes.

3 Click OK to save changes and close the dialog box.

User Rights Descriptions

Enabled Functionality

Controller Configuration The ability to change the controller configuration, or change 
controller type.

Traffic Cop The ability to edit in the traffic cop.

Communications The ability to change the communications setup including the 
controller’s address.

Logic Editor The ability to edit logic.

Forcing The ability to force contacts and coils. This feature is allowed 
without online editing enabled.

Insert The ability to insert cells, rows, columns, and networks.

Delete The ability to delete cells, rows, columns, and networks.

Sweep The ability to enter sweep mode.

Data Editors The ability to enter any of the data editors, If deselected, the 
user is unable to change register data.

Extended Memory The ability to edit extended memory registers.

Protected Registers The ability to edit protected registers.

Configuration Extensions The ability to edit the configuration extensions.

ASCII Editor The ability to edit the ASCII messages.

Documentation The ability to change any of the documentation.

PLC Communication Settings

Read The ability to read from the controller.

Write The ability to write to the controller.

Start/Stop The ability to start or stop the controller.

Online Editing The ability to make any changes when the project mode is 
online or combined.

Server Access Settings
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Current Status The Activity tab, while in View Current mode, displays project communications 
information, and is divided into Communications Activity and Backup/Compare 
Results.

The Communications Activity section displays the following fields.
User: the client currently logged in to the ProWORX Server
Transfer Type: the type of transfer being performed (data or file)
Description

File: the file name and lock status
Data: the data type

Progress
File: a progress number or Done
Data the number of packets transferred

The Backup/Compare Results section displays the following fields.
Project: the project on which the backup/compare operation was performed
Action: either backup or compare
Date/Time: date and time of the backup/compare operation
Result: results of the backup/compare operation

Click View Activity Log to switch to the Activity Log viewer.

Activity Log The Activity tab, while in View Activity Log mode, displays a list of operations that 
have been performed via the server. These operations may have been performed 
on the server itself or an attached client.

The log shows:
the time an operation was performed
the user who performed the operation
the activity that was performed
additional information

The log is called ServerActivityLog.txt, and can be found in the ProWORX → 32 → 
Server installation folder.

Each time you start the server, a new file is created. Old files are saved and archived 
with a new name, which includes a time stamp of when the log was archived, in the 
ProWORX → 32 → Server → Logs installation folder.

Clear Audit Trails The ability to remove all audit trail and logbook entries.

Get Projects The ability to get projects from the server.

Put Projects The ability to put projects to the server.

Add/Edit Users/Groups The ability to add user groups.

Delete Users/Groups The ability to delete user groups.

User Rights Descriptions
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You can manually view or edit a log file using any text editor or spreadsheet 
application.

Click View Current Status to switch to the Current Status view.
Click Refresh to refresh the displayed log if new activity has occurred.

Related 
Documents

The Related Documents tab displays all related documents for all projects. It lists all 
files other than projects that are stored on the server. Related Documents displays 
the following fields:

Document Name: the selected document name in full
Document Status: the lock status of the document
Plant Layout Section: displays the lock status of the Plant Layout configuration 
file

Deleting Projects

Undo Checkout

Undo Checkout 
for 
PlantLayout.INI

Step Action

1 Click the Projects tab.

2 Right-click the project you want to delete.

3 Click Delete Project.

Step Action

1 Click the Projects tab.

2 Right-click the project you want to undo checkout.

3 Click Undo Checkout.

Step Action

1 Click the Related Documents tab.

2 Click the Undo Checkout button in the Plant Layout section.
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Audit Trail

Overview The audit trail keeps a record of project transactions between the ProWORX 32 
client and ProWORX 32 server. Each transaction is stored as an entry in the audit 
trail. Audit trail comments can be added to each record when putting a project to the 
server.

Using the Audit 
Trail

 

Step Action

1 Click the Projects tab.

2 Click the Project Info tab.

3 Click a transaction from the list in the project navigation panel to view a specific 
transaction's information.

4 Click the View Audit Trail button.

5 The transaction's information:
User: who made the changes to the current transactions
Date and Time: when the transaction was completed
Changes Made: ProWORX 32 areas that were changed from the previous to 
current transaction
User Comments: any notes or comments that the user has entered when 
putting the project to the server

You can also navigate through the transactions by clicking the standard 
navigation buttons at the top of the window.

6 Click the view tree button to hide or view the navigation panel.

7 Click Print to print the current audit trail.

8 Click the Clear Audit Trail button to clear all transaction audit trails.

9 Click Close when you are finished.
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Schneider Alliances
At a Glance

Overview Schneider Alliances is a third-party utility used by Schneider Alliances partners to 
add or modify I/O cards.

What's in this 
Chapter?

This chapter contains the following topics:

Topic Page

Using the Schneider Alliances Tool 296

Using the Script Editor 300

Using Script Editor Controls 302
295



Schneider Alliances
Using the Schneider Alliances Tool

Opening 
Schneider 
Alliances

In Windows Explorer, open the Schneider_Alliances.exe file located in the 
ProWORX → 32 installation folder.

Adding an I/O 
Module

In the Schneider Alliances dialog box:

Editing an I/O 
Module

In the Schneider Alliances dialog box:

Editing an I/O 
Module 
Parameter

While adding or editing an I/O module:

Step Action

1 In the I/O series list, select an I/O system.

2 Click Add.
Result: Certain default values are entered in the parameter list.

3 Edit the parameters to match the card you are adding.

4 Click Update to save the new data, or click Cancel to remove the new data and 
start over.

Step Action

1 In the I/O series list, select an I/O system.

2 In the Module list, select an existing card.
Result: The current card data is entered in the parameters list.

3 Click Edit.

4 Edit the parameters (see p. 296) you wish to update (see below).

5 Click Update to save the new data, or click Cancel to undo the changes you 
have made.

Step Action

1 Press Enter or click the Value column of the desired parameter.
Result: The selected parameter is now be editable.

2 Type a valid value or select a value from the list. (Some parameters require that 
you click the ellipsis box for further configuration.)

3 Press Enter to accept the new parameter, or press Esc to cancel the change.
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Deleting an I/O 
Module

In the Schneider Alliances dialog box:

Importing an I/O 
Module

In the Schneider Alliances dialog box:

Exporting an I/O 
Module

In the Schneider Alliances dialog box:

Step Action

1 Click Delete.
Result: The Schneider Alliances Delete dialog box opens.

2 In the Delete Options field, click one of the following buttons:
All: Allows the users to delete all modules.
I/O series: Allows the user to delete a specific series.
Modules: Allows the user to delete a specific module.

3 If you click I/O Series, select a series from the list.

4 If you click Modules, select a module from the list.
Note: Only user-defined modules can be deleted; no modules from the main 
traffic cop database can be removed.

5 Click OK to delete the selected modules. 

Step Action

1 Click Import.
Result: The Schneider Alliances Import dialog box opens.

2 In the Import Options field, click one of the following buttons to import modules 
from a Schneider Alliances Export file (.SAF):

Prompt to overwrite existing modules
Overwrite existing modules
Ignore existing modules

Note: The .SAF file will contain modules and any corresponding existing scripts 
or bitmaps.

3 Click OK.

Step Action

1 Click Export.
Result: The Schneider Alliance Export dialog box opens.

2 In the Export Type field, click one of the following buttons:
All: Allows the users to export all modules.
I/O series: Allows the user to export a specific series.
Modules: Allows the user to export a specific module.

3 If you select I/O Series, select an I/O series from the list.

4 If you select Modules, select a module from the list.
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Using the MCS 
Simple 2 Editor

 This parameter is only editable for Quantum, SY/MAX, and Compact I/O series (not 
available for 800, A120, or Momentum I/O series).

Using the Default 
Parameter Data 
Editor

 This parameter is only editable for Quantum, SY/MAX, Momentum, and Compact 
I/O series (not available for 800 or A120 I/O series).

5 In the E-Mail Options field, click one of the following buttons:
Do not e-mail
E-mail to Schneider Electric: Uses the default e-mail client to send the file 
to a predetermined Modicon e-mail address.
E-mail to other: Brings up the e-mail client with all fields filled in except the 
recipient.

6 Click OK.

Step Action

Step Action

1 In the MCS Simple 2 field, click the ellipsis button.

2 Double-click 1 or 0 to toggle a bit.

3 Click Save to save changes back to the main grid, or click Cancel to return to 
the main grid without updating any changes.

Step Action

1 In the Default Parameter Data field, click the ellipsis button.
Result: The Data Values dialog box opens. It shows the current number of rows 
in the Number of Parameters Used parameter and the current value in the 
Default Parameter Data parameter.

2 To edit the contents of a row, double-click the cell you want to edit, and enter a 
Hex value. Use the following functions to further edit the parameter

Function Action Comment

3 Click Add. A blank cell is added to the end of the grid.

4 Click Remove. The currently selected row is deleted, and the cells 
below are shuffled up.

5 Click Move Up. The contents of the currently selected cell are moved 
up one cell.

6 Click Move Down. The contents of the currently selected cell are moved 
down one cell.
298 31003882 12/2006



Schneider Alliances
I/O Card 
Parameters

The parameters displayed in the Name column of the Schneider Alliances dialog box 
depends on the I/O series you select.

Parameter Description

Card ID Hex Value. The Unique Modicon ID for each card of an I/O series.

INTERBUS ID Hex Value. The INTERBUS S ID of a card.

Drop Allowed Momentum Only. Defines whether or not a Momentum CPU supports a non-local, 
INTERBUS S drop.

Card Description Description of the currently selected I/O card. This is used throughout ProWORX 32 to 
pick, edit, and add I/O cards. Maximum ten characters.

Medium Description Text description displayed in the Traffic Cop when editing slot properties of a card.

Long Description A more detailed description of the card.

Power The amount of power used by the card in the rack.

Power (+5) Number of mA used by card at this power rating.

Power (+4.3) Number of mA used by card at this power rating.

Power (-5) Number of mA used by card at this power rating.

Number of Parameters Used The number of Card config parameters that are used by default.

Default Number of 
Parameters

The available number of parameter words by default.

In Bytes The number of input bytes used by the card.

Out Bytes The number of output bytes used by the card.

In Bytes (IBus) Momentum Only. Defines the number of input bytes for an INTERBUS card.

Out Bytes (IBus) Momentum Only. Defines the number of output bytes for an INTERBUS card.

Module Type Defines the type of card. Discrete, Analog, or Analog with no discretes allowed.

Doc Only Certain cards are not programmed into the controller memory, but are still displayed in 
the traffic cop. These cards are documentation only cards.

MCS Simple 1 Type of hardware module.

MCS Simple 2 Defines behavior of card.
See: Using the MCS Simple 2 editor.

Default Parameter Data The value of the card config words by default.

Rack View Bitmap The bitmap displayed in the Traffic Cop rack View.

Drop View Bitmap The bitmap displayed in the Traffic Cop in Drop view.

Extra Bus Info Momentum Only. One word that defines extra information for an INTERBUS Drop.

Script Data The WYSIWYG card config editor.
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Using the Script Editor

Overview Schneider Alliances Script Editor is a WYSIWYG property-based editor used to 
create card configuration scripts. The VB Script file used by ProWORX 32 to display 
card configuration is automatically created by the card configuration editor. These 
scripts are used by ProWORX 32 to configure optional card parameters in the traffic 
cop.

Adding a Control 
to the Grid

In the script editor dialog box:

Common 
Properties

 

Step Action

1 Click a control in the ToolBox panel to add it to the grid.

2 Set the properties for the control.
Tip: To most effectively set your control, select the controls container in the 
Container property first. This will move the control onto the desired frame.

3 Move the control by clicking the control’s center selection handle and dragging 
the control to the desired location.

4 Resize the control by clicking and dragging the control's perimeter selection 
handles to the desired size.

Property Description

Left The left-most part of the control in twips.
Note: For reference, there are 1440 twips per inch.

Top The topmost part of the control in twips.

Width The width of the control in twips.

Height The height of the control in twips.

Caption The text display related to the control.

Container The container is the object to which the control is anchored.
Note: You can anchor a control to either the form (pbEditor) or to any frame. 
When a control is anchored to a frame, the control’s positional variables (Left 
and Top) are relative to the anchor, not to the form.

StartBit The first bit in a range of bits to edit.

EndBit The last bit in a range of bits to edit.

Word The word number you want to edit.
Note: To add a control whose data value has no consequence to a word, set 
the Word property to 0. The word list is 1-base.

Event This is a portion of script that will execute when the value of the control is 
changed.
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Using the Event 
Editor Dialog

The event of a control is executed when the data value of the control changes. The 
event script allows you to enter VB script code to manipulate controls. The event 
script editor will do minor error checking for syntax mistakes. The grid has a unique 
initialize function, which is executed when the form is opened. You can hide controls 
using the .visible property, enable and disable controls using the .enabled property, 
and perform other standard VB functions.

 

Editing 
Parameter Data - 
Card Config 
Words Using 
Controls

In the properties panel:

Editing Card 
Config Word 
Data Example

Word ones current value is 10101010 - 10101010 (43690 decimal). A control’s 
properties are set as follows:

Word = 1
StartBit = 9
Word = 16
Data value of the control = 15

When the card config dialog is saved, word ones new value is 10101010 - 00001111 
(43535 decimal). Notice, bits 9 through 15 (00001111) are equal to 15 which is what 
the properties had specified.

Step Action

1 Click the ellipsis button in the Event property of a control.

2 Enter VB script code into the event window.

3 When finished, click OK to return to the script editor. Certain errors will be 
caught by the event script editor, and there will be an error message if any errors 
exist. Certain errors will not be detected by the editor though, and the I/O card’s 
script will not be functional in the traffic cop.
To cancel your changes and return to the script editor, click Cancel.

Step Action Comment

1 Select the control that will be 
used to edit a word.

Valid controls are: option buttons, check boxes, 
data edit boxes, and combo boxes.

2 Select a word from the list in 
the Word property.

The word numbers correspond with the Default 
Parameter Data words. 1 is the first word, 2 is 
the second word, and so on.

3 Enter a bit number into the 
StartBit property.

This is the first bit in a range of bits to be edited. 
Valid bit numbers are 1 through 16.

4 Enter a bit number into the 
StartBit property.

This is the last bit in a range of bits to be edited. 
Valid bit numbers are 1 through 16.
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Using Script Editor Controls

Frame Frames are used to enclose and group related controls. Scripts allow multiple layers 
of frames to be added on top of each other. After a frame has been added to a grid 
or previous frame, any of the available controls can be contained by (anchored to) 
that frame.

Option Button Option buttons are used on the grid or on a frame to display a limited set of options. 
Only one option button in a container can be selected at a time.

Control-specific properties:

Check Box Check boxes are used on the grid or on a frame to display either/or options.

Control-specific properties:

Label Most often used as a label for a combo box or a data edit box control, labels can be 
used for on-screen instructions, as well as further detail or descriptions.

Combo Box The combo box is used when there are a set number of selections you want the user 
to be able to choose from. Each item in the list has a corresponding data value.

Control-specific properties:

Property Description

Data The value that the bits are set to if the option button is clicked.

Property Description

DataChecked The value that the bits are set to if the check box is selected.

DataUnchecked The value that the bits are set to if the check box is cleared.

Property Description

List The list property provides an ellipsis button, which, when clicked, opens up a 
combo box configuration. The combo box allows you to enter the contents and 
related values of the items in the list.
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Creating a List 
for the Combo 
Box

In the combo box configuration:

Data Edit Box Data edit boxes are used on the grid or a frame to allow the user to enter any valid 
value. Valid values are determined by the radix that is set for the data edit box. For 
example, if Binary is selected in the radix property, only ones and zeros are valid 
data, and the value can only have a length of 16 characters.

Control-specific properties:

Command The command button is seldom used, but can be very useful for batch processes. 
For example, you can have a button that will select or clear a group of check boxes 
or a button that would clear all fields in a group.

Time State 
Properties

The time state property control is different from other controls in that it is a toggle 
edit combo box. It is used to edit parameters of cards that are actually not passed 
as data words. Namely, when editing the time-out state of a card, you would use a 
time state list to set the parameter to User Defined or Last Value.

Function Action

1 To add an item to the list, click Add.

2 To edit the Combo List Item and Item Data fields, double-click the cell.

3 To move the item within the list, click Move Up and Move Down.

4 To remove an item, click Remove.

5 To save the items and data and return to the script editor, click OK.
To cancel changes and return to the script editor, click Cancel.

Property Description

Radix The mode of the edit box. Available options are Decimal, Binary, Hexadecimal, 
ASCII, and Long.
Notes:

All radices are have a 16-bit limit except Long, which has a 32-bit limit.
A Long data type will overwrite the word that is selected in the Word property 
of the data edit box as well as the next word in the order that they are set in 
the Default Parameter Data property of the I/O card.
It is not recommended that you put a long data value in the last word. If the 
last word is selected in the Word property, the Long data value will be 
truncated and put into the last word. This may alter the results you expected 
significantly.
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What's in this 
Appendix?

The appendix contains the following chapters:
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A I/O Cards 307
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E Building and Modifying I/O Drawings 359
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I/O Cards
At a Glance

Overview This appendix lists the I/O cards supported by ProWORX 32 for the following I/O 
series.

What's in this 
Chapter?

This chapter contains the following topics:

Topic Page

800 308

A120 311

Compact TSX 313

Micro 315

Momentum M1 and INTERBUS 316

Quantum 317

SY/MAX 320
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I/O Cards
800

800 Series Cards I/O cards supported (in alphabetical order):

Card Description Card Description

B802-008 115 VAC 8 Point Output 
Module

B872-002 4-20 mA,1-5V 4 Channel 
Analog Output

B803-008 115 VAC 8 Point Input Module B872-011 Selectable 4 Channel Voltage 
Output

B804 16 Point Output Module B872-100 4-20mA 4 Channel Current 
Output Module

B804-016 115 VAC 16 Point Output 
Module

B872-200 Selectable 4 Channel Voltage 
Output

B804-116 115 VAC 16 Point Output 
Module

B873-001 4-20mA,1-5V 4 Channel 
Analog Input

B805-016 115 VAC 16 Point Input 
Module

B873-002 4-20mA,1-5V 4 Channel 
Analog Input

B806 32 Point Output Module B873-011 -10 V to 10 V 4 Channel Analog 
Input

B806-032 115 VAC 32 Point Output 
Module

B873-012 -10 V to 10 V 4 Channel Analog 
Input

B806-124 24 VAC 32 Point Output 
Module

B873-200 V/A, Thermo, RTD, Strain 
Gauge Input

B807 32 Point Input Module B875-001 4-20mA, 1-5V 8 Channel 
Analog Input

B807-032 115 VAC 32 Point Input 
Module

B875-002 4-20mA, 1-5V 8 Channel 
Analog Input

B807-132 115 VAC 32 Point Input 
Module

B875-011 -10 V to 10 V 8 Channel Analog 
Input

B808-016 230 VAC 16 Point Output 
Module

B875-012 -10 V to 10 V 8 Channel Analog 
Input

B809-016 230 VAC 16 Point Input 
Module

B875-101 Fast selectable 8 Channel 
Analog Input

B810-008 115 VAC 8 Isolated Output 
Module

B875-102 Fast selectable 8 Channel 
Analog Input

B814 8 Point Output Module B875-111 Select. 8 channel Differential 
Input

B814-001 NO Power Relay 8 Point 
Output Module

B875-200 V/A, Thermo, RTD, Strain 
Gauge Input
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I/O Cards
B814-002 NC Power Relay 8 Point 
Output Module

B877-111 Select. 16 channel Single 
Ended Input

B814-108 NO/NC Power Relay 8 Point 
Output Module

B881 Input/Output Module

B817 16 Point Isolated Input Module B881-001 24 VDC 16 Point Latched Input 
(TrueHigh)

B817-116 115 VAC 16 Point Isolated 
Input Module

B881-108 115 VAC 8 Point Protected 
Output Module

B817-216 230 VAC 16 Point Isolated 
Input Module

B881-508 125 VDC 8 Point True High 
Output Module

B818-032 24 VDC 32 Point Output (True 
High)

B818-032 24 VDC Diagnostic Output 
Module

B819-032 230 VAC 32 Point Input 
Module

B882-239 0-30 kHz 2 High Speed Up-
Counter Module

B820-008 10-60 VDC 8 Point Output 
(True High)

B883 Input/Output Module

B821 8 Point Input Module B883-001 0-50 kHz 2 High Speed Up/
Down Counter

B821-008 10-60 VDC 8 Point Input (True 
High)

B883-101 4 kHz CAM ABS Encoder 
Input,8 Disc Out

B821-108 10-60 VDC 8 Point Input (True 
High)

B883-111 1 kHz CAM with Velocity 
compensation

B824-016 24 VDC 16 Point Output (True 
High)

B883-200 10 Thermocouple Input 
Module

B825-016 24 VDC 16 Point Input (True 
High)

B883-201 8 RTD Input Module

B826-032 24 VDC 32 Point Output (True 
High)

B884-002 2 Loop, PID Control Module

B827-032 24 VDC 32 Point Input (True 
High)

B885 Main Module

B828-016 5V TTL 16 Point Output B885-002 ASCII/BASIC Module

B829-116 5V TTL 16 Input (Fast 
Response)

B885-100 Motion Module

B832-016 24 VDC 16 Point Output (True 
Low)

B885-110 Motion Module

B833-016 24 VDC 16 Point Input (True 
Low)

B886-000 High Speed Logic Solver

Card Description Card Description
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I/O Cards
B836-016 12-250 VDC 16 Point Output 
Module

B887-000 12 Register Bidirectional

B837-016 24 VAC/DC 16 Point Input 
(True High)

B888-100 Datalogic CM1000 AutoID 
Interface

B838-032 24 VDC 32 Point Output (True 
High)

D908-110 Distributed Control Single

B840-108 NO/NC Reed Relay 8 Point 
Output Module

D908-120 Distributed Control Dual

B842-008 NO/NC Reed Relay 8 Point 
Output Module

J890-001 RIO Single

B846 Analog MUX Module J890-002 RIO Redundant

B846-001 Analog MUX (16 voltage to 
one output)

J892-001 RIO ASCII Single

B846-002 Analog MUX (16 current to 
one output)

J892-002 RIO ASCII Redundant

B849-016 48 VAC/DC 16 Point Input 
Module

P800-003 Power Supply

B853-016 115 VAC/125 VDC 16 Input 
(True High)

P802-001 Power Supply

B855-016 12 VDC 16 Point Input (Intr. 
Safe)

P810-000 Power Supply

B862-001 4 Channel Register Output 
(TTL Level)

P830-000 Power Supply

B863 4 Channel Register Input P840-000 Power Supply

B863-001 4 Channel Register Input (TTL 
Level)

P884-001 Power Supply

B863-032 4 Channel Register Input (TTL 
Level)

P890-000 Power Supply

B864-001 8 Channel Register Output 
(TTL Level)

P892-000 Power Supply

B865-001 8 Channel Register Input (TTL 
Level)

S908-110 RIO Processor Single

B868-001 8 Channel Register Output 
(TTL Level)

S908-120 RIO Processor Dual

B869-001 8 Channel Register Input (TTL 
Level)

S911-800 Hot Standby Module

B872 4 Channel Analog Output

Card Description Card Description
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I/O Cards
A120

A120 Series 
Cards

I/O cards supported (in alphabetical order):

Card Description Card Description

ADU 204 4 Channel Register Input (+/-
0.5V)

DEP 208 230 VAC 8 Point Input Module

ADU 205 4 Channel Register Input (+/-
10V)

DEP 209 120 VAC 8 Point Input Module

ADU 206 4 Channel Register Input DEP 210 115 VAC 8 Point Input Module

ADU 211 8 Channel Analog Input 
Module

DEP 211 115 VAC 8 Point Input Module

ADU 212 8 Channel Analog Input 
Module

DEP 214 12-60 VDC 16 Point Input 
Module

ADU 214 4 Channel Multi Range A/D 
Input

DEP 215 5 VDC TTL 16 Point Input 
Module

ADU 216 8 Channel Thermocouple DEP 216 24 VDC 16 Point Input Module

CM900 Auto Interface DEP 217 24 VDC 16 Point Input Module

DAO 216 24 VDC 16 Point Output 
Module

DEP 218 115 VAC 16 Point Input 
Module

DAP 204 24 VDC 4 Point Relay (NO) 
Module

DEP 220 Fast 24 VDC 16 Point Input 
Module

DAP 208 24 VDC 8 Point Relay (NO) 
Module

DEP 257 110 VDC 16 Point Input 
Module

DAP 209 120 VAC 8 Point Output 
Module

DEP 296 60 VDC 16 Point Isolated Input 
Module

DAP 210 24-230 VAC 8 Point Output 
Module

DEP 297 48 VDC 16 Point Isolated Input 
Module

DAP 212 24 VDC 8 Point Input/4 Point 
Output

M7251 Programmable Limit Switch

DAP 216 24 VDC 16 Point Output 
Module

M7350 Resolver Decoder Function 
Module

DAP 217 5-24 VDC 16 Point Output 
Module

MOT 201 1 Slot 1 Axis Motion Control 
Module Encoder

DAP 218 24-240 VAC 16 Point Output 
Module

MOT 202 2 Slot 1 Axis Motion Control 
Module Resolver & Encoder

DAP 220-
250

24 VDC 8 Point Input/Output 
Module

P120 000 Power Supply
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I/O Cards
DAP 252 LowTemp 24 VDC 8 Point 
Input/4 Point Output

P120 125 Power Supply

DAP 253 LowTemp 110VDC 8 Point 
Input/4 Point Output

VIC 200 4 High Speed Pulse or 4 VRC 
Inputs

DAP 292 60 VDC 8 Point Input/4 Point 
Output

VIC 205 4 High Speed Pulse or 4 5V 
TTL Inputs

DAU 202 2 Channel Register Output (+/
-10V)

VIC 212 4 High Speed Pulse or 12 VDC 
Inputs

DAU 204 4 Channel Analog Output, 
Opto-Isolation

VIC 224 4 High Speed Pulse or 24 VDC 
Inputs

DAU 208 8 Channel Register Output (+/
-10V)

ZAE 201 High speed Counter/Positioner 
(2 Relay)

DEO 216 24 VDC 16 Point Input Module ZAE 204 4 Channel High speed 
Counter/Positioner

Card Description Card Description
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I/O Cards
Compact TSX

Compact TSX 
Series Cards

I/O cards supported (in alphabetical order):

Card Description Card Description

ADU 204 4 Channel Register Input (+/-
0.5V)

DAU 202 2 Channel Register Output (+/-
10V)

ADU 205 4 Channel Register Input (+/-
10V)

DAU 204 4 Channel Analog Output, 
Opto-Isolation

ADU 206 4 Channel Register Input DAU 208 8 Channel Register Output (+/-
10V)

ADU 210 4 Channel Analog Input 
Module

DEO 216 24 VDC 16 Point Input Module

ADU 211 8 Channel Analog Input 
Module

DEP 208 230 VAC 8 Point Input Module

ADU 212 8 Channel Analog Input 
Module

DEP 209 120 VAC 8 Point Input Module

ADU 214 4 Channel Multi Range A/D 
Input

DEP 210 115 VAC 8 Point Input Module

ADU 216 8 Channel Thermocouple DEP 211 115 VAC 8 Point Input Module

ADU 257 8 Channel Thermocouple DEP 214 12-60 VDC 16 Point Input 
Module

BKF 202 Interbus S Slave DEP 215 5 VDC TTL 16 Point Input 
Module

BKF201-16 16 Word Interbus S Master DEP 216 24 VDC 16 Point Input Module

BKF201-64 64 Word Interbus S Master DEP 217 24 VDC 16 Point Input Module

DAO 216 24 VDC 16 Point Output 
Module

DEP 218 115 VAC 16 Point Input 
Module

DAP 204 24 VDC 4 Point Relay (NO) 
Module

DEP 220 Fast 24 VDC 16 Point Input 
Module

DAP 208 24 VDC 8 Point Relay (NO) 
Module

DEP 257 110 VDC 16 Point Input 
Module

DAP 209 120 VAC 8 Point Output 
Module

DEP 296 60 VDC 16 Point Isolated Input 
Module

DAP 210 24-230 VAC 8 Point Output 
Module

DEP 297 48 VDC 16 Point Isolated Input 
Module

DAP 211 120 VAC 4 Point Output 
Module

KOS260-64 Universal Communications 
Module
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I/O Cards
DAP 212 24 VDC 8 Point Input/4 Point 
Output

MOT 201 1 Slot 1 Axis Motion Control 
Module Encoder

DAP 216 24 VDC 16 Point Output 
Module

MOT 202 2 Slot 1 Axis Motion Control 
Module Resolver & Encoder

DAP 217 5-24 VDC 16 Point Output 
Module

P120 000 Power Supply

DAP 218 24-240 VAC 16 Point Output 
Module

P120 125 Power Supply

DAP 220-
250

24 VDC 8 Point Input/Output 
Module

VIC 200 4 High Speed Pulse or 4 VRC 
Inputs

DAP 252 LowTemp 24 VDC 8 Point 
Input/4 Point Output

VIC 205 4 High Speed Pulse or 4 5V 
TTL Inputs

DAP 253 LowTemp 110VDC 8 Point 
Input/4 Point Output

VIC 212 4 High Speed Pulse or 12 VDC 
Inputs

DAP 292 60 VDC 8 Point Input/4 Point 
Output

VIC 224 4 High Speed Pulse or 24 VDC 
Inputs

FRQ 204 Frequency and Speed 
Measurement

ZAE 201 High speed Counter/Positioner 
(2 Relay)

KOS260-24 Universal Communications 
Module

ZAE 204 4 Channel High speed 
Counter/Positioner

Card Description Card Description
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I/O Cards
Micro

Micro Series 
Cards

I/O cards supported (in alphabetical order):

Card Description Card Description

MIC128 16 IN, 12 Relay OUT 24V DC MIC140 8 Bit Counter/Interrupt Input

MIC129 16 IN, 8 Relay OUT 24V DC MIC141 4 IN, 2 OUT 12 Bit 0-10V

MIC130 16 IN, 4 Relay OUT 24V DC MIC142 4 IN, 2 OUT 12 Bit 1-5V

MIC131 16 IN, 8 Triac 4 Relay OUT 
115V

MIC143 4 IN, 2 OUT 12 Bit +10V

MIC132 16 IN, 8 Triac OUT 115V MIC144 4 IN, 2 OUT 15 Bit 0-10V

MIC133 16 IN, 4 Relay OUT 115V MIC145 4 IN, 2 OUT 14 Bit 1-5V

MIC134 16 IN, 8 Triac 4 Relay OUT 
230V

MIC146 4 IN, 2 OUT 10V

MIC135 16 IN, 8 Triac OUT 230V MIC147 16 Bit Timer/Count Value

MIC136 16 IN, 4 Relay OUT 230V MIC148 1 Word IN, 1 Word OUT

MIC137 16 IN, 12 FET OUT 24V DC MIC149 2 Words IN, 2 Words OUT

MIC138 16 IN, 8 FET OUT 24V DC MIC150 4 Words IN, 4 Words OUT

MIC139 16 IN, 4 FET OUT 24V DC MIC151 8 Words IN, 8 Words OUT
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I/O Cards
Momentum M1 and INTERBUS

Momentum 
Series Cards

I/O cards supported (in alphabetical order):

Card Description Card Description

AAI030-00 8 Channel Differential Input AEC920-00 High Speed Counter 50khz

AAI140-00 16 Channel single ended Input AMM090-0x 24 VDC 4 In / 2 Out 
Bidirectional

AAI520-40 4 Channel RTD/Thermocouple ANM050-10 Seriplex Interface

AAO120-00 4 Analog Output 0-20mA ANR120-90 Bi-directional Analog (6 in/4 
out) with 24 VDC (8 in/8 out) 
discrete

AAO921-00 4 Analog Output 4-10mA ARM370-30 24 VDC 10 In / 8 Out Relay

ADI340-00 24 VDC 16 Point I/P Module ATV058-00 Single Phase Drive

ADI350-00 24 VDC 32 Point I/P Module BAI036-00 8 Channel Analog I/P Module

ADI540-50 120 VAC 16 Point I/P Module BAM096-00 4 I/P / 2 O/P Analog Module

ADI740-50 230 VAC 16 Point I/P Module BAO126-00 4 Channel Analog O/P Module

ADM350-1x 24 VDC 16 In / 16 Out BDI346-00 24 VDC 16 Point I/P Module

ADM370-10 24 VDC 16 In / 8 Out BDI356-00 24 VDC 32 Point I/P Module

ADM390-10 24 VDC 16 In / 16 Out BDI546-50 120 VAC 16 Point I/P Module

ADM390-30 24 VDC 10 In / 8 Out Relay BDI746-50 230 VAC 16 Point I/P Module

ADM540-80 120 VAC 6 In / 3 Out Bi-Dir BDM346-00 24 VDC 16 In / 16 Out

ADM690-50 115 VAC 10 In / 8 Out BDM346-30 8 In / 8 Out Relay

ADO340-00 24 VDC 16 Point O/P Module BDO346-00 24 VDC 16 Point O/P Module

ADO350-00 24 VDC 32 Point O/P Module BDO356-00 24 VDC 32 Point O/P Module

ADO530-50 115 VAC 8 Point O/P Module BDO946-50 115 to 230 VAC 16 Point O/P

ADO540-50 115 VAC 16 Point O/P Module BNO671-00 BUS Module

ADO730-50 24 VAC 8 Point O/P Module IBUS-xxxx Generic INTERBUS S 
Modules

ADO740-50 230 VAC 16 Point O/P Module ISP001-0x ISP Weighing Module
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I/O Cards
Quantum

Quantum Series 
Cards

I/O cards supported (in alphabetical order):

Card Description Card Description

ACI030-00 Analog 8 Channel Unipolar 
Input

DDI841-00 10-60 VDC 16 Input Module

ACI040-00 16 Channel Analog Current 
Module

DDI853-00 10-60 VDC 32 Input Module

ACI050-00 32 Channel Analog Current In DDM390-00 16/8 Bidirectional 24 VDC

ACI051-00 32 Channel Analog Voltage/
Current

DDM690-00 125 VDC 4 Input/4 Output 
HPO Module

ACI052-00 32 Channel Analog Voltage/
Current

DDO153-10 5 VDC 4x8 Output Module

ACO020-00 4-20 mA Analog Output 
Module

DDO353-00 24 VDC 32 Output Module

ACO130-00 8 Channel Output Module DDO353-01 24 VDC 32 Point Output 
Module

AII330-00 I. S. 8 Channel Analog Input DDO353-10 24 VDC True Low 32 Output 
Module

AII330-10 I. S. 8 Channel Analog Input 
Current

DDO364-00 24 VDC True High 96 Output 
Module

AIO330-00 I. S. Analog Output DDO843-00 10-60 VDC 16 Output

AMM090-0x Analog In/Out 4Ch/2Ch DDO885-00 125 VDC 12 Point O/P Module

ARI030-10 8 Channel RTD DEVNET-08 64 Register Devicenet 
Scanner

ATI030-00 8 Channel Thermocouple DEVNET-32 16 Register Devicenet 
Scanner

AUI040-00 16 Channel Universal Input 
Module

DII330-00 I. S. Digital Input

AVI030-00 8 Channel Bipolar, Analog 
Input

DIO330-00 I. S. Digital Output

AVI050-00 32 Channel Analog Voltage In DRA840-00 16 Output Relay

AVO020-00 Analog Voltage Output Module DRC830-00 8 Output ISO Relay

CHS110-00 Hot Standby DSI353-00 24 VDC 32 Point Input Module

CPS-111 115/230V AC Power Supply 
3A

DVO853-00 10-30 VDC Verified Output 
Module

CPS114 115/230V AC Power Supply 
8A

EHC105-00 High Speed Counter 5 
Channel
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I/O Cards
CPS124 115/230V AC Power Supply 
RED 8A

EHC202-00 High Speed Counter

CPS-211 24 V DC Power Supply 3A EHC204-00 High Speed Counter 4 
Channel

CPS-214 24 V DC Power Supply 8A EHC208-00 High Speed Counter 8 
Channel

CPS-224 24 V DC Power Supply RED 
8A

EIA921-00 1 Channel AS-1 Module 
Interface

CPS-414 48 V DC Power Supply SUM 
8A

ERT854-10 32 Point Smart Digital Input

CPS-424 48 V DC Power Supply RED 
8A

ESI062-10 2 Channel ASCII Interface

CPS-511 125V DC Power Supply 3A GPS100-00 IRIG-B Time Sync Interface

CPS-524 125V DC Power Supply 8A HLI340-00 Hi-Speed/Latch/Interrupt

CRA211-10 DIO Drop MB+ HRT100-00 HART Serial Communications 
Card

CRA211-20 DIO Drop MB+ I2T010-00 I2T 10 Input / 10 Output

CRA212-10 DIO Drop MB+ I2T016-00 I2T 16 Input / 16 Output

CRA212-20 DIO Drop MB+ MCI186X Resolver Interface Module

CRA931-00 RIO Drop S908 MCI18X1X2 Single Turn Interface

CRA932-00 RIO Drop S908 MCI18X3X4 MultiTurn Resolver Interface

CRP811-00 Profibus DP Interface Module MMB102-00 Two axis motion with 
incremental

CRP931-00 RIO Head S908 MMB104-00 Four axis motion with 
incremental

CRP932-00 RIO Head S908 MMC120-0x 2-Axis Motion Control

DAI340-00 24 VAC ISO 16 Input Module MMD102-00 Two axis absolute motion

DAI353-00 24/48 VAC 32 Input Module MMD104-00 Four axis absolute motion

DAI440-00 48 VAC 2x8 Input Module MSB101-00 Motion Inc Enc

DAI453-00 48 VAC 32 Input Module MSC101-00 Motion Enc/Res

DAI540-00 115 VAC 16 Input Module 
Isolated

NOA611-00 Interbus-S Master Module

DAI543-00 2x8 115 VAC Input Module NOA611-10 Interbus-S Master with PCP

DAI553-00 115 VAC 32 Input Module NOE211-00 Ethernet TCP/IP Twisted Pair

DAI740-00 230 VAC 16 Input Module NOE251-00 Ethernet TCP/IP Fiber Optic

CPS-424 48 V DC Power Supply RED 
8A

NOE311-00 Ethernet SY/MAX Twisted Pair

Card Description Card Description
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I/O Cards
DAM390-00 16/8 Bidirectional 24 VAC NOE351-00 Ethernet SY/MAX Fiber Optic

DAM490-00 16/8 Bidirectional 48 VAC NOE511-00 Ethernet MMS Twisted Pair

DAM590-00 16/8 Bidirectional 120 VAC NOE551-00 Ethernet MMS Fiber Optic

DAO840-00 24-230 VAC 16 Output NOE771-00 Ethernet TCP/IP 10/100 
Megabit

DAO840-10 24-115 VAC 16 Output NOE771-10 Ethernet TCP/IP 10/100 
Megabit

DAO842-10 100-230 AC 16 Output Module NOL911-xx LonWorks Interface

DAO842-20 24-48 VAC 16 Output NOM212-10 MB+ Drop Interface Card

DAO853-00 24-230 VAC 4x8 Output NOM2xx-00 MB+ Drop Interface Card

DCF077-00 24 VDC Input Module NOP911-00 Profibus FMS Interface Module

DDI153-10 5 VDC 4x8 Input Module NWM100-00 Ethernet 10/100 Megabit

DDI353-00 24 VDC 32 Input Module QSPXM Seriplex Master

DDI353-10 24 VDC True Low 32 Input 
Module

QUCM-SE Programmable 
communications module

DDI364-00 24 VDC 6x12 Fast Input 
Module

SERX53-00 Sequence Of Events Recorder

DDI673-00 125 VDC 24 Point I/P Module XCP900-00 Battery Backup

Card Description Card Description
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I/O Cards
SY/MAX

SY/MAX Series 
Cards

I/O cards supported (in alphabetical order):

Card Description Card Description

CRM931-D1 Digital 2 Slot RIO Adapter RIM131 High Speed Counter Module

CRM931-D2 Digital 4 Slot RIO Adapter RIM144 Multiplexed BCD Input Module

CRM931-D4 Digital 8 Slot RIO Adapter RIM301 85-140 VAC 16 Input Module

DRM931-D8 Digital 16 Slot RIO Adapter RIM331 32-Function 24V DC Input

CRM931-
RG

Register RIO Adapter Module RIM361 16-Function 240V AC/DC Input

RDI116 16 Channel Input RIM731 64-Function 24V AC/DC Input

RDI132 32 Channel Input ROM121 4-Function Analog Output

RDI1xx Input Module ROM122 4-Function Isolated Output

RDO616 16 Channel Relay Output ROM131 Stepper Motor Controller 
Module

RDO732 32 Channel Relay Output ROM141 Multiplexed BCD Output 
Module

RDOxxx Relay Output ROM221 16-Function 120V AC Output

RIM101 16-Function 120V AC/DC 
Input

ROM271 16-Function 120V AC Relay 
Output

RIM121 4-Function Analog Input ROM421 35-140 VAC 16 Output Module

RIM123 8 Channel High Speed Analog 
Input

ROM431 16-Function 240V AC Output

RIM125 16-Function Analog Input ROM441 32-Function 24V DC Output

RIM126 8 Channel Analog/Thermo 
Input

ROM871 64-Function Relay Output

RIM127 12 Channel RTD Input Module SIM116 16 In Simulator
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Power Supplies
Power Supplies

Power Supplies  

Power Supply Source Voltage Type Bus 
Current

Maximum 
per Rack

CPS 111 00 115 ... 230 VAC Standalone 3A 1

CPS 114 x0 115 ... 230 VAC Standalone/summable 8A 2

CPS 114 20 120 ... 230 VAC Standalone 11A 2

Summable 10A

CPS 124 x0 115 ... 230 VAC Standalone/redundant 8A 3

CPS 124 20 120 ... 230 VAC Standalone/redundant 11A 3

Summable 10A

CPS 211 00 24 VDC Standalone 3A 1

CPS 214 00 24 VDC Standalone/summable 8A 2

CPS 224 00 24 VDC Standalone/redundant 8A 3

CPS 414 00 48 VDC Summable 8A 2

CPS 424 00 48 VDC Redundant 8A 3

CPS 511 xx 100 ... 150 VDC Standalone 3A 1

CPS 524 xx 125 VDC Standalone/redundant 8A 3
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Power Supplies
Compatibility 
Issues

With the exception of standalone models, power supplies with the same model 
number are always compatible when installed in the same backplane.

Do not mix different power supply models on the same backplane.
Do not mix DC input power supplies with their respective AC versions on the 
same backplane.
Do not use standalone (only) power supplies with any other power supply on the 
same backplane.

You can use a standalone or a summable power supply with a DIO drop, but you 
can not use a redundant power supply with the DIO drop.

The added power supply must not be included in the system I/O map.
The added power supply does not have to be the same type as the DIO adapter. 
You can use AC power supplies with DC type adapters. (The reverse is true too.)
DIO module current load with an added power supply is typically 200mA.

Redundancy 
Rules

 

Summable Rules (1) CPS 114 20 module is 11A in standalone
(2) CPS 114 20 modules are 20A in summable
(1) CPS 114 20 module + (1) CPS 114 10 module are 16A in summable

If you have... Then, the I/O power budget should be...

(2) CPS 124 20 modules 10A

(3) CPS 124 20 modules 20A

(1) CPS 124 20 module
+
(1) CPS 224 00 module
- or -
(1) CPS 424 00 module

8A

(1) CPS 124 20 module
+
(2) CPS 224 00 modules
- or -
(2) CPS 424 00 modules

16A

(2) CPS 124 20 modules
+
(1) CPS 224 00 module
- or -
(1) CPS 424 00 module

16A
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Troubleshooting
At a Glance

Overview This chapter includes various tools and resources for troubleshooting networks, 
ladder logic, I/O cards, etc. Contact customer support (see p. 24) if you require 
further information about I/O cards.

What's in this 
Chapter?

This chapter contains the following sections:

Section Topic Page

C.1 General Troubleshooting 324

C.2 Status Words for S901 and S908 332
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Troubleshooting
C.1 General Troubleshooting

At a Glance

Overview The troubleshooting tools help to reduce down time and improve your maintenance 
personnel's understanding of the controller installation.

What's in this 
Section?

This section contains the following topics:

Topic Page

Isolating Faults 325

Manual Procedure List 326

Modbus Plus 328

Stopcode Error Analysis 329
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Troubleshooting
Isolating Faults

Isolating Faults Faults can fit into one of four categories:

Fault Possible Causes/Fixes

Input/Output Faults This is the most common type of fault. It occurs when an open, 
short, or electrical or mechanical malfunction happens. Common 
locations for these faults are in the field devices and the wiring 
between the I/O module that interfaces to the field device.

Controller Faults These faults include a faulty controller or improper ladder logic. 
The Controller Manual Check helps isolate a faulty controller.

Communication Faults Modicon controllers communicate with the I/O sub system through 
remote I/O processor communication networks or within local 
drops on the Modbus subsystem. Faults occur when two pieces of 
hardware unexpectedly stop communicating or communications 
becomes unintelligible.

Invalid Command When the warning Command Not Valid Unless Logged In 
appears:

Ensure the cable is properly attached to the controller.
Ensure that the controller you're connected to isn't logged onto 
by another user.
Ensure you're using the correct cable.
Ensure the cable is connected to the correct controller port.

If the problem persists, contact Schneider Electric's customer 
support (see p. 24).
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Troubleshooting
Manual Procedure List

Procedure One Controller failed to power up with good AC supply and fuse OK:

Procedure Two To replace a 38x/48x fuse:

To replace a 68x/78x fuse:

Step Action

1 Ensure that the power supply jumper is correct on the slot mount controllers.

2 Check the input power select switch position is correct for supply voltage.

3 Check for loose crimps or screws at the power supply terminal strip.

4 Check fuses where relevant.

Step Action

1 Remove memory and executing cartridges.

2 Remove 9 screws that hold the side (1/4 inch nut driver).

3 Remove line cord cover screws and the plastic line cord cover.

4 Remove 2 line cord standoffs (3/16 inch nut driver).

5 Remove screws near battery compartment.

6 The front part of the controller can now separate from the circuit board. The fuse 
is located near the AC power connector.

7 Replace fuse with the same size and type.

Step Action

1 Remove 2 thumbscrews and 2 machine screws with start washers as shown on 
front view.

2 Remove small cover.

3 Remove 4 machine screws from rear cover and slide rear cover back 3 inches. 
(Exec pack cover may have to be removed from the right side).

4 Carefully slide the left side section toward the back expose the two fuses.

5 Replace blown fuses with the same type and size.
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Troubleshooting
To replace a P930/P933 fuse:

Procedure Three Failure to attach to a running controller:

Procedure Four If Modbus Plus is the chosen mode of communication, please ensure that the 
Modbus Plus driver software is installed. You may use the Modbus Plus diagnostic 
tools included with the driver suite. Check if the Modbus Plus active LED is flashing 
both at the interface card (PCI85 or SA85) and at the PLC. Normal indication is six 
times per second.

Step Action

1 Turn off the P930/P933 power supply.

2 Turn off the supply power to the power supply.

3 Remove the supply power line from the P930/P933 power terminal.

4 Loosen mounting screws on top and bottom of the front face of the P930/P933 
and slide the P930/P933 out of the chassis.

5 Replace fuse with on of the same type and size.

Step Action

1 Ensure that the proper cables and software are being used.

2 Are the communication parameters on the computer the same as those on the 
controller?

3 Check the cable attachment and pinout.

4 If Modbus Plus is being used then ensure the Modbus Plus driver is installed and 
the Modbus Plus active LED on the SA85 or PC85 card and the controller are 
flashing at six times a second. (The Modbus Plus Indicator normal operating 
state.)

5 If this is the first time this cable has been used then test the cable.
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Modbus Plus

Modbus Plus 
Communications 
for Concept Exec 
Loader

When using Modbus Plus communications and the interrupt is not 5C, you must add 
the following line to the modicon.ini file located in the Windows folder:

Under the heading: [Ports]

MBP0 (or MBP1) = interrupt 5D

Modbus Plus 
Indicator

On most Modbus Plus devices, a green LED flashes a repetitive pattern indicating 
the communication status of the node. The patterns are:

LED Pattern Description

Six flashes 
per second

Normal operating state. The node is successfully receiving and passing the 
token. All nodes in operation on the network should be flashing this pattern.

One flash per 
second

Node is offline after just being powered up or there is another node on the 
network with the same address (duplicate addresses are not allowed). The 
node remains in this state for five seconds, then attempts to go to its normal 
operating state.

Two flashes, 
then OFF for 
two seconds

Node is hearing the token being passed among other nodes, but is never 
receiving the token. Check the network link for an open or short circuit, or 
defective termination.

Three 
flashes, then 
OFF for 1.7 
seconds

Node is not hearing any other node. It is periodically claiming the token, but 
finding no other node to which to pass it to. Check the network link for an open 
or short circuit, or defective termination.

Four flashes, 
then OFF for 
1.4 seconds

Node has heard a valid message from another node that is using the same 
address as this node. The node remains offline in this state as long as it 
continues to hear the duplicate address. If the duplicate address is not heard 
for five seconds, the node then changes to the pattern of one flash every 
second.
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Stopcode Error Analysis

Stopcode Error 
Analysis

Bit/error reference:

Bit Error Description

0 (0001 Hex) Illegal Configuration Someone or something has probably been 
modifying controller memory and the configuration is 
not valid for this controller. The error may also be 
caused by a bad memory board or Executive pack or 
by inserting the wrong memory or executive into a 
controller.

1 (0002 Hex) 984 A/B/X and 584 - 
Backup Checksum 
Error

Information saved in a coil and register has been 
corrupted. In order to recover the corrupted 
information, the program must be reloaded. A bad 
memory board may also cause this error.

1 (0002 Hex) 984 -80 Series (984 
A/B/X - some 
PROMS) Discrete 
Disabled Error

Usually caused by trying to start the controller in the 
optimized mode with discrete points that are 
disabled.

2 (0004 Hex) Logic Checksum 
Error

The calculated user logic checksum does not agree 
with the stored checksum. It can be caused by an 
illegal change of memory or by a bad memory board. 
Try reloading the program. This error also occurs if 
the ASCII area has been loaded incorrectly. If 
reloading fails then try initializing the ASCII area. As 
a last resort try replacing the memory board.

3 (0008 Hex) Invalid Node Type This error usually occurs when loading the 
controller. It may be caused by loading or relocating 
a program from a machine supporting a DX 
instruction not supported or configured for in the 
target machine, i.e. relocating a program with an 
HSBY function block to a 984 not configured for an 
HSBY. It may also be caused by loading a program 
made on a 24 bit machine to a 16 bit machine i.e., 
specifying a constant greater than 999.
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4 (0010 Hex) S908 RIO Head 
Failure or Remote I/
O option failed

Causes:
A failed S908 RIO board (replace the board)
Illegal board configuration in the 984 (e.g., the 
wrong PROM pack)
Configuring for more than one drop and not 
attaching anything to the S908
Cards contained in the Traffic Cop that are not 
present in the field or cards in the field that 
mismatch with the Traffic Cop.
Powering up an intelligent I/O card (B984) at the 
same time as the 984
Attempting to start an HSBY system without the 
S908 cards interconnected.
Cycling power on the controller may be 
necessary to clear this error.

5 (0020 Hex) 984 A/B/X and 584 
CPU Diagnostic 
Failure

The CPU board is bad and should be replaced.

5 (0020 Hex) 984 -80 Series Bad 
Coil Used Table

The coils existing in the logic do not match those 
found in the used table.

6 (0040 Hex) Real Time Clock 
Failure

The CPU board is bad and should be replaced.

7 (0080 Hex) Watchdog Time 
Expired

This bit is usually set in conjunction with another. It 
often signals a Data transfer program that is too 
large. The logic is not being solved fast enough.

(0090 Hex) Real I/O Option 
Failed

Check that the S908 card is properly installed and 
that its ready light is on steady.

8 (0100 Hex) No EOL Detected or 
Bad Number of 
Segments

This error usually occurs when a startup is 
attempted after the incomplete loading of a program. 
Reload or try another program.
Note: You may receive this system error when you 
first configure the system, before you have 
programmed any logic. This is not a fatal error. The 
system cannot find the end of logic because there is 
no logic programmed from the primary to the 
standby state.

9 (0200 Hex) 984 A/B/X and 584 
State RAM Test 
Failure

The continuously running diagnostics have failed. 
Replace the RIO processor.

Bit Error Description
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9 (0200 Hex) 984 -80 Series Bad 
Power Down 
Checksum

Cycle the power on the controller to clear the error or 
Start Controller.

10 (0400 Hex) SON Did Not Start 
Segment

Improper programming from a programming device 
or software package is usually the cause of start-of-
node failure.

11 (0800 Hex) Bad Segment 
Scheduler Table

The Segment Scheduler has been programmed 
improperly.

12 (1000 Hex) Illegal Peripheral 
Intervention

This error is caused by an attempt to clear the 
System Stop State word. A programming device has 
altered memory in a non-authorized manner.

13 (2000 Hex) Dim Awareness The 984 has not been configured successfully. This 
bit can be set in conjunction with other flags.

14 (4000 Hex) 984B and 584 
Extended Memory 
Parity Error

This error indication pertains to the 984B or 
extended memory 584 only. Try reloading memory. 
If that fails to solve the problem, replace the memory 
board.

14 (4000 Hex) 984 -80 Series 
Traffic Cop Failure

Usually caused by configuring for more than one 
drop and not having an S908 remote I/O processor 
in the controller rack. This error can also be caused 
by too many points contained in the Traffic Cop (512 
inputs and 512 outputs allowed per drop), or by 
more cards in Traffic Cop than physically present 
(Micro 984).

15 (8000 Hex) Peripheral Port 
STOP

This simply indicates the PLC has stopped.

Bit Error Description
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C.2 Status Words for S901 and S908

At a Glance

Overview With both the S901 and S908 controllers, the first 11 status words are always found 
at absolute memory address 65-6F hex. Pointers determine the absolute memory 
locations of the remaining words. A pointer for the start of the status information is 
always located at address 6F hex.

What's in this 
Section?

This section contains the following topics:

Topic Page

ASCII Message Status 333

Cable A Errors 334

Cable B Errors 335

Communication Status 336

Controller State 338

Controller Status 339

EOL (End of Logic) Pointer 340

Global Errors 341

S911 Hot Standby Status (S908) 342

Local Drop Communications Errors (S908) 343

Machine Configuration 344

Module Health 345

Number of Segments 347

Status Word Pointer Table 348

RIO Time-out 349

Run/Load/Debug Status 350

S901/J200 Status 351

S908 Errors 352

Stopcode 353
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ASCII Message Status

Word 6D Hex 
(109 Decimal)

This word reflects the status of the ASCII message database. Bits set in this word 
indicate that errors occurred while creating or editing ASCII messages. 

1   2   3   4   5   6   7   8   9   10   11   12   13   14   15   16

Invalid message pointer

Message checksum error

Invalid message

Number of ASCII messages and number of messages
pointers do not match
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Cable A Errors

Cable A Errors Cable A is the main cable connecting the remote I/O processor to the remote I/O 
interface.

  

Status Word Description

173 The count of frame size errors and DMA overrun errors.
The high order byte represents a count of Cable A frame size errors. This 
indicates that the length of the data message was incorrect.
The low order byte represents a count of DMA receiver overrun counts. 
This indicates that the hardware had more data to send than was 
required.

174 The cable A LAN receiver error counter and the bad drop reception on cable 
A counter. This indicates a cable or noise problem to a drop. The Drop 
Communication Errors (173) should be examined to determine which drop is 
having problems.

175 The last received LAN error code for cable A. The LAN hardware detected 
an error in receiving a message.

1   2   3   4   5   6   7   8   9   10   11   12   13   14   15   16

1 = No end frame

1 = Short frame

1 = Overrun error

1 = Alignment error

1 = CRC error

1 = Received message OK
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Cable B Errors

Cable B Errors Cable B is the secondary or redundant cable connecting the remote I/O processor 
to the remote I/O Interface (optional redundant cables).

  

Status Word Description

176 The count of frame size errors and DMA overrun errors. 
The high order byte represents a count of Cable B frame size errors. This 
indicates that the length of the data message was incorrect.
The low order byte represents a count of DMA receiver overrun counts. 
This indicates that the hardware had more data to send than was 
required.

177 The cable B LAN receiver error counter and the bad drop reception on cable 
B counter. This indicates a cable or noise problem to a drop. The Drop 
Communication Errors (173) should be examined to determine which drop is 
having problems.

178 The last received LAN error code for cable B. The LAN hardware detected 
an error in receiving a message.

1   2   3   4   5   6   7   8   9   10   11   12   13   14   15   16

1 = No end frame

1 = Short frame

1 = Overrun error

1 = Alignment error

1 = CRC error

1 = Received message OK
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Communication Status

Communication 
Status 1/2 (S901)

The remote I/O communication status word 1 shows errors and normal operating 
indication of the indicated channel pair. Under normal operating conditions the lower 
byte should be counting and the upper portion of the byte should match the lower 
portion of the byte.

Any bits set in the upper byte indicates an error condition for the channel pair. Note 
that a disconnected channel pair or a channel pair that does not exist will set the 
function scheduled to 001 (restart - communication reset).

  

Function schedule:

Binary Number Description

000 Normal I/O

001 Restart (comm reset)

010 Restart (application reset)

100 Inhibit

1   2   3   4   5   6   7   8   9   10   11   12   13   14   15   16

1 = Current message not supported

1 = Response message count > transmitted byte count

1 = Response from remote interface not what expected

Function schedule

1 = Message from controller is queued

Current message frame # to drop

Cable ID: 0 = Cable 0, 1 = Cable 1

# of next expected frame from drop

1 = Current message not
accepted at drop
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Communication 
Status 2/2 (S901)

The remote I/O communication status word 2 shows errors and the retry count on 
lost communications. If communications is lost with the channel pair then the 
corresponding error bit will be set and the retry counter will increment. If the retry 
counter counts to maximum, then other indicators will be affected.

Module health will show as 0. If communication is re-established, this error count 
and error word is not cleared. The only way to clear this word is to cycle power on 
the controller or issue a start and stop command. 

1   2   3   4   5   6   7   8   9   10   11   12   13   14   15   16

Retry counter

1 = Command not supported by drop

1 = Invalid frame number

1 = Drop just powered up

1 = Address did not respond

1 = CRC error from address drop

1 = Character overrun error from addressed drop
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Controller State

S908 Controller - 
Word 65 Hex 
(101 Decimal)

The controller state word shows information pertaining to the state and size of the 
controller. A state is any condition, which is either set for the life of the controller (16-
bit vs. 24-bit) or set by external events (memory protect). The upper bits have no 
meaning for an 984/S908 or -80 -85 controllers. The AC power bit will always be on, 
or monitoring would not be possible. The down size flag indicates controllers with < 
4K logic memory. Some Micro 984 controllers show a 0 for battery failed. The 16-bit 
user logic bit indicates controllers that support 2048 references. (The 984B and the 
780/785 are 24-bit controllers.) 

S901 Controller - 
Word 65 Hex 
(101 Decimal)

The controller state word shows information pertaining to the state and size of the 
controller. A state is any condition that is either set for the life of the controller (16-
bit vs. 24-bit) or set by external events (memory protect). The AC power bit will 
always be on, or monitoring would not be possible. The down size flag indicates 
controllers with < 4K logic memory. The 16-bit user logic bit indicates controllers that 
support 2048 references. (The 984B and 584 level 4 are 24-bit controllers.)

1   2   3   4   5   6   7   8   9   10   11   12   13   14   15   16

1 = Battery failed

1 = Memory protect OFF

1 = Run light OFF

1 = AC power ON

1 = Single sweep invoked

1 = Constant sweep invoked

1 = 16-bit user logic (Max 2048
reference system

D0 Reserved

D1 Set offline mode

D2 Set data exchange active

D3 Operating mode
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Controller Status

S908 and S901 
Controllers - 
Word 67 
(103 Decimal)

The controller status words indicate certain statuses of the machine. A status is any 
condition which changes during the running of the controller, usually from an internal 
event.

Word 3 (4xxxx + 2) - General controller status: 

1   2   3   4   5   6   7   8   9   10   11   12   13   14   15   16

Single sweeps (00)
1 = Existing DIM AWARENESS

1 = Constant sweep time exceeded

1 = Start command pending

1 = First scan
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EOL (End of Logic) Pointer

Word 6B Hex 
(107 Decimal)

This location contains the end of logic pointer. The EOL pointer provides the 
hexadecimal address of the end of user logic. 

1   2   3   4   5   6   7   8   9   10   11   12   13   14   15   16

EOL pointer address
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Global Errors

Global Errors  

  

Status Word Description

179 The Global Communication Status. This word stores communications status 
for both cable A and cable B.

Cable A is the main cable connecting the remote I/O processor to the 
Remote I/O Interface.
Cable B is the optional secondary or redundant cable. The specific 
information stored is shown in the figure below.

180 Global Cumulative error counter for cable A.
High byte - Framing error count
Low byte - No response count

Errors counted here cause the error counters in cable A errors (168) to 
increment. 

181 Global Cumulative error counter for cable B.
High byte - Framing error count
Low byte - No response count

Errors counted here cause the error counters in cable B errors (169) to 
increment.

Note: It is possible for bits 2 and 3 to be 1 and bit 1 to be 0 cables (171).

1   2   3   4   5   6   7   8   9   10   11   12   13   14   15   16

Dropout counter Retry counter

0 = Cable B status error

0 = Cable A status error

0 = Communication health error
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S911 Hot Standby Status (S908)

Word 66 Hex 
(102 Decimal)

The hot standby status is valid if a redundancy system is present. It shows if the unit 
is reporting present and healthy and the word also indicates if the unit is the primary 
or secondary controller.

Word 4 (4xxxx + 3) - S911/R911 Hot Standby Status 

System State:

Binary Number Description

01 Offline

10 Primary

11 Secondary

1   2   3   4   5   6   7   8   9   10   11   12   13   14   15   16

S911/R911 present and healthy

0 = Controller set to A

1 = Controller set to B

0 = Controllers logic matches

1 = Controllers logic mismatches

Remote system state

Local system state
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Local Drop Communications Errors (S908)

Status Words 
182-184

Status words 182 to 184 show the status of the local drop communication errors 
(when a local drop is present). The first drop may or may not be a local drop 
depending upon the controller type being used.

  

Status Word Description

182 The overall health and retry counter for the local drop. If the MSB is not 1, 
then there are module health (166) errors on the local drop.

183 The ourbus error count for the local drop. If the count is incrementing then 
there are errors on the local drop. This may be caused by invalid information 
in the traffic cop, an unhealthy module in the local drop, or a mismatch 
between the traffic cop and the module that exists in a slot located in the local 
drop.

184 The ourbus retry count for the local drop. Under normal operating conditions, 
only the all modules healthy bit should be set.

1   2   3   4   5   6   7   8   9   10   11   12   13   14   15   16
1 = All modules healthy

Retry counter
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Machine Configuration

Word 61 Hex 
(97 Decimal)

This screen shows the options that are present for the attached controller. These 
options include remote  I/O (S908 processor), Modbus II, Hot Standby, distributed 
control processor (D908) and coprocessors. It also indicates whether or not the time 
of day option is available for this controller and the remote I/O adapter size. 

Note: Some versions of the S908 remote I/O processor only support 6 remote drops. 
A 1 indicates that an option is present.

  

1   2   3   4   5   6   7   8   9   10   11   12   13   14   15   16

0 = TOD present

0 = Small RIO (7 drops including 1 local)

1 = Large RIO (32 drops including 1 local)

1 = Copro 4 present

1 = Copro 3 present

1 = Copro 2 present

1 = Copro 1 present

1 = DCP present (-80), SA85 present (984 A/B)

1 = HSBY present

1 = Modbus II present

1 = Remote I/O present (RIO)
344 31003882 12/2006



Troubleshooting
Module Health

S908 Controller

Module health status information consists of up to 160 words. A single bit is used to 
represent the health status of a single module. A binary 1 means that the module is 
healthy. Each drop in the I/O sub system has five words allocated to contain I/O 
module status. Each of these five words contains the I/O module status of a single 
rack within the drop. The most significant bit (MSB) represents the status of the 
module in slot 1. Slot 2 module status is represented by the bit to the immediate right 
of the MSB.

A healthy I/O module must meet the following conditions:

The specified slot must be configured in the traffic cop.
The slot must contain the module specified in the traffic cop.
Valid communication must exist between the module and the interface. 
Valid communication must exist between the interface module and the controller. 

  

Incorrect Health Bit Status
On systems using J890/J892s with PROM revision 1000, slot 1 status will be the 
LSB. J890/J892s with PROM revisions greater than 1000 slot 1 status will be the 
MSB. Ensure your program uses the health bits consistent with the PROM 
revision.

Failure to follow this instruction can result in death, serious injury, or 
equipment damage.

Note: If a module is configured in the traffic cop and active, then the bit will be 1.

WARNING
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S901 Controller The I/O module health status information consists of words that represent the 
module health for channel pairs. Each word represents 2 channels. The words are 
also divided into input modules and output modules. A single bit is used to represent 
the health status of a single module.

If the slot is inhibited in the traffic cop, then the bit will be a 0. If the slot contains an 
input module, then the bit will be a 1. This will not be the case if the communication 
status word 2/2 (183) indicates an error.

If the slot contains an output module and if the active light is on, then this bit will be 
a 1. If the active light is off, then this bit will be a 0. It is common to set the status 
indicator for an output slot to toggle between 0 and 1 when active and healthy.

The upper byte contains the status of the lower channel number of the channel pair 
(for example, channel 1 for channel pair 1/2). The lower byte contains the status of 
the higher channel number of the channel pair. Each byte represents the status of 
slots 1 to 8 of the channel. The most significant bit of the channel represents slot 1 
and the least significant bit shows the status of slot 8.

Status Word #012: Drop # 01/01 Rack # 1/5 
346 31003882 12/2006



Troubleshooting
Number of Segments

Word 6A Hex 
(106 Decimal)

This word is confirmed during power up to be the number of I/O exchange nodes 
plus 1 (for end of logic). If this is not true then a stop code of 0100 would result. 
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Status Word Pointer Table

Description The address in 6F points to a table of pointers 76 words long. It is important to 
remember that this 76 word long table is a table of address pointers for the 75 word 
long system status area.
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RIO Time-out

Word 6C Hex 
(108 Decimal)

This word contains the remote I/O time-out constant and a bit that indicates if 
redundant cables are present.

Note: Cable A and cable B are used for remote I/O communications.
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Run/Load/Debug Status

Word 6E Hex 
(110 Decimal)

This word is a mode indicator for 984 controllers. The load mode is used for loading 
a program to the controller. The run mode indicates that the controller was started 
in the optimized mode (no editing allowed while running). The debug mode is the 
normal mode of operation for a controller. In this mode network editing is allowed 
while the controller is running.
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S901/J200 Status

Word 68 Hex 
(104 Decimal)

This word shows the status of the remote I/O processor. The upper 4 bits should be 
zero under normal operating conditions. An error indicates a failure in the remote 
I/O processor.

RIO error status:

Binary Number Description

000 RIO did not respond

001 No response on loopback

010 Failed loopback data check

011 Timeout while awaiting response

100 RIO did not accept all of message
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S908 Errors

S908 Errors This word is the S908 start error code. This word will always be 0000 in a running 
system. If an error does occur, the controller will not start and will generate a 
stopcode system error of 4000.

Number Description Number Description

1 Bad Traffic Cop Length 23 Bad Number of Input Bytes

2 Bad Remote I/O Link Number 25 Bad First Reference Number

3 Bad Number of Drops 26 Bad Second Reference Number

4 Bad Traffic Cop Checksum 27 No Input or Output Bytes

10 Bad Drop Descriptor Length 28 Discrete Not on 16 Bit Boundary

11 Bad I/O Drop Number 30 Unpaired Odd Output Module

12 Bad Drop Holdup Time 31 Unpaired Odd Input Module

13 Bad ASCII Port Number 32 Unmatched Odd Module 
Reference

14 Bad Number of Modules in Drop 33 1xxxx Reference After 3xxxx 
Register

15 Drop Already Configured 34 Dummy Module Reference 
Already Used

16 Port Already Configured 35 3xxxx Module Not a Dummy

17 More than 1024 Outputs 36 4xxxx Module Not a Dummy

18 More than 1024 Inputs 40 Dummy Then Real 1xxxx Module

20 Bad Module Slot Address 41 Real Then Dummy 1xxxx Module

21 Bad Module Rack Address 42 Dummy Then Real 3xxxx Module

22 Bad Number of Output Bytes 43 Real Then Dummy 3xxxx Module
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Stopcode

S908 Controller - 
Word 69 Hex 
(105 Decimal)

This word contains a stopcode that describes what kind of stop state (if any) that the 
machine has. A 1 in the most significant bit indicates that the controller is not 
running. Any other 1 bit indicates an error. It is possible to have multiple errors. For 
a detailed explanation of stopcodes, see p. 329.

S901 Controller - 
Word 69 Hex 
(105 Decimal)

This word contains a stopcode that describes what kind of stop state (if any) that the 
machine has. A 1 in the most significant bit indicates that the controller is not 
running. Any other 1 bit indicates an error. It is possible to have multiple errors. For 
a detailed explanation of stopcodes, see p. 329.
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Editing .DIF Files with 
Microsoft Excel
Editing .DIF files with Microsoft Excel

Overview When Excel imports a .dif file, it converts the controller addresses in the first column 
of the database into numerical values which ProWORX 32 cannot read. Excel also 
exchanges the rows and columns of the database in the .dif file’s header. Unless you 
correct these problems, an error appears when you try to import a .dif file back into 
ProWORX 32 after you have changed it in Microsoft Excel.

To use Excel to edit documentation, follow these seven steps.

Step One Set the size of your descriptor fields for Microsoft Excel.

Step Two Export your ProWORX 32 project as a .dif file.

Step Action

1 Right-click your project in the project navigation panel.

2 Click Properties.

3 Click the Documentation tab.

4 Enter 9 in the Total Number of Descriptor Lines field.

5 Click OK to save the changes.

Step Action

1 Right-click your project in the project navigation panel.

2 Click Export Documentation.

3 In the Select Destination File dialog box, navigate to the respective folder, and 
click a file name to enter in the File name field.

4 Click Open to export documentation.
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Step Three Open and edit the documentation in Microsoft Excel.

Step Four Convert the controller addresses from numbers to text.

Step Action

1 Open the .dif file in Microsoft Excel.
The number in Column A tells you what controller address the row describes. 
The letter in Column B tells you what information the next cells in the row 
contain:

D: Descriptors 1 through 9 in columns C through K
S: Short comments 1 through 4 in columns C through F
L: Long comment lookup number in column C
T: The page title in column C

2 Make your changes to the documentation.

Step Action

1 Find an unused column in the spreadsheet. This temporary column holds 
information during the conversion process.

2 In the first cell of the unused column, type: =TEXT(A1,"00000"). This formula 
converts the numerical value in cell A1 into a text value which ProWORX 32 can 
read. When you press Enter, the text value appears in the cell where you 
entered the formula.

3 Click the cell.

4 From the Excel menu, click Edit → Copy.

5 Select the temporary column by clicking its header.
Example: If you entered the TEXT formula into the first cell of column M, now 
select all of column M.

6 From the Excel menu, click Edit → Paste.
Result: This operation pastes the TEXT formula copied from the first cell of the 
temporary column into all the other cells in the column. Click Yes if a warning 
message appears telling you that the selection is too large to undo. The 
temporary column now contains the same values as column A, but formatted as 
text instead of numbers.

7 Click the entire temporary column again.

8 From the Excel menu, click Edit → Copy.

9 Click Column A.

10 From the Excel menu, click Edit → Paste Special, then click Values. The text 
values from your temporary column replace the numerical values in column A. 
Click Yes if a warning message appears telling you that the selection is too large 
to undo.

11 Click the entire temporary column.
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Editing .DIF Files with Microsoft Excel
Step Five Export the Microsoft Excel spreadsheet as a .dif file.

Step Six Correct the rows and columns in the .dif header.

Step Seven Import the documentation back into ProWORX 32.

12 From the Excel menu, click Edit → Clear, then click All. The values in your 
temporary column disappear. Click Yes if a warning message appears telling 
you that the selection is too large to undo.

Step Action

Step Action

1 Save the edited database as a .dif file.

Step Action

1 Open the .dif file with a text editor (Notepad or Wordpad).

2 Switch the VECTORS and TUPLES values in the header of the .dif file.

3 Save the edited database as an ASCII .dif file.

Step Action

1 Right-click your project in the project navigation panel.

2 Click Import Documentation → Append or Overlay or Create New.

3 In the Select Documentation File dialog box, navigate to the respective folder, 
and click the .dif file containing the changed documentation.

4 Click Open.
Result: The documentation of the current project is updated.
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Building and Modifying 
I/O Drawings
Building and Modifying I/O Drawings

Overview The I/O Generator is used to create CAD drawings of 800, Micro, Quantum, and 
A120 cards based on your project’s Traffic Cop data. The drawings are in a .dxf 
format that is supported by most CAD programs. In some cases, a drawing may 
need to be modified to fit your application. In other cases, there is no supplied 
drawing for a new or custom I/O card. You may use an existing I/O drawing template 
and modify it to suit your needs. The following information will help you to design 
your own custom I/O drawings.

Set Drawing 
Parameters

The Drawing Parameters option is used to set the paths where the CAD program, 
and Master drawings and created (intermediate and final) drawings will reside. A 
controller prefix is set here, which will become the first two characters of the 
drawings that are created. An Overwrite Existing drawings option is set here to allow 
or disallow existing drawings to be replaced. If a small change is made to the Traffic 
Cop or documentation, it is faster to delete the affected drawings and set this option 
to No. The Drawing Parameter window is always displayed before drawing 
generation to confirm that the proper parameters are set.
359



I/O Drawings
Intermediate 
Drawings

The Intermediate Drawings option is used to create drawings that are specific to the 
Traffic Cop in the selected database. The appropriate Master .dxf drawing is 
modified by placing drop, rack, and slot references into replaceable text strings.

800, Compact, and Micro series drawings are saved with a new name in the form 
CCDDRS.dxf, where

CC is the controller prefix.
DD is the drop (01 to 32).
R is the rack (1 to 5).
S is the slot (1 to B).

Quantum series drawings are saved with a new name in the form CCHDDRS.dxf, 
where

CC is the controller prefix.
H is the head number (1 to h, representing head 0 to 16).
DD is the drop (01 to 64).
R is the rack (1 to 5).
S is the slot (1 to G, representing slot 1 to 16).

Once the intermediate .DXF drawings are created, they can be imported using your 
CAD program. If you use AutoCAD, you can automatically import these drawings by 
exiting to DOS, moving to your AutoCAD directory and, at the DOS prompt, entering 
ACAD nul CCint where CC is the controller prefix. This uses AutoCAD’s .scr file 
format.

These drawing can then be modified, resized, and combined. They may be renamed 
as long as: 

1. the first two characters (controller prefix) remain
2. the length does not exceed seven characters
3. the last character is not an F

This is because the Final Drawings will have the same name as the Intermediate 
drawings, with an F added to the end. If you edit your intermediate drawings, be sure 
to export them back to .dxf format so correct final drawings can be generated.

Final Drawings The Final Drawings option is used to create drawings that contain descriptors and 
field devices from the selected database. The Intermediate drawings are modified 
by replacing text strings with actual descriptors, short comments, database 
configuration, and field devices from this database. The drawing is then saved with 
a new name which is the name of the Intermediate drawing with an F added to the 
end.

Once the final .dxf drawing are created, they can be imported using your CAD 
program. If you are using AutoCAD, you can automatically import these drawings as 
described in the Intermediate Drawings section.
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Using Symbols 
in Drawings

The files included with the program include a number of symbol diagrams that can 
be incorporated into your CAD drawings. They are placed into the drawings via a 
reference code in the appropriate descriptor record.

Each code must be prefixed with a $ (dollar sign). More than one symbol code can 
be entered into the descriptor records. Each symbol code (one per descriptor line) 
represents a field device and is ordered by occurrence.

Example: To include a push button (normally open) as part of the wiring diagram for 
input 10004, you can enter the descriptor editor from logic or the I/O configurator, 
then enter the symbol code into the descriptor record (you would enter $PBNO into 
the descriptor record).

The following table lists the available symbols.

LTR light red

LTG light green

PBNO push button normally open

PBNC push button normally closed

CRNO coil relay normally open

CRNC coil relay normally closed

HORN horn or siren

LSNO limit switch normally open

LSNC limit switch normally closed

FSNC level switch normally closed

FSNO level switch normally open

PRSNO proximity switch normally open

PRSNC proximity switch normally closed

PSNC pressure switch normally closed

PSNO pressure switch normally open

TASNO temperature switch normally open

TASNC temperature switch normally closed

FLSNO flow switch normally open

FLSNC flow switch normally closed

SOL solenoid

TGSNO toggle switch normally open

TGSNC toggle switch normally closed
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AutoCAD 
Information - 
Master Drawings

Master drawings are drawings of each type of card. They have three layers defined:

1. 0
2. DUMMY
3. REPLACE

Layer 0 contains drawing elements that remain the same from Master drawing to 
Final drawing.

Layer DUMMY is not used at this time.

Layer REPLACE contains text that is replaced with other text that is unique to each 
database. Replaceable text begins and ends with a / (forward slash).

The following list contains examples of replaceable text. Note that the preceding 
letter denotes the point at which the replaceable text is manipulated: (I) is for the 
intermediate stage and (F) is for the final stage.

F /D1-101/ Descriptor #1 of the 1st input address

F /D2-R/ Descriptor #2 of the rack

F /D23-S/ Descriptors #2 and #3 of the slot

F /D123-S/ Descriptors #1, #2, and #3 of the drop

F /D23-O16/ Descriptors #2 and #3 of the 16th output address

I /A1-O02/ The actual address of the 2nd output address, e.g., 00018 or 
40004-02

F /A1-S/ The actual address of the slot, e.g., S0124 (Drop 01 Rack 2 
Slot 4)

F /N2-O13/ The 2nd line of the Short Comment field of the 13th output 
address

F /N12-S/ The 1st and 2nd lines of the Short Comment field of the slot

F /F1-I03/ Field device of the 3rd input address.
Field device is a descriptor prefixed with a $. (e.g., $PBNO 
field device is the 1st descriptor prefixed with a $, not 
necessarily descriptor 1).

I /HEAD/ The head number

I /DROP/ The drop number

I /RACK/ The rack number

I /SLOT/ The slot number

I /PLC/ The controller number assigned to this database

F /CLIENT/ The client field from the database configuration

F /PROJECT/ The project field from the database configuration

F /TITLE/ The title field from the database configuration

F /DATE/ The date

F /TIME/ The time
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The examples from the previous list cover possibilities. Any combination of 
descriptors, short comments, or field devices of the drop, rack, slot, input addresses, 
or output addresses can be included in a drawing. You can modify or create Master 
drawings with the following restrictions:

1. The name of the drawing should remain the same. Or, in the case of new 
drawings, the name must match the card number (e.g., 804-016.dxf)

2. No replaceable text can reside in a layer other than REPLACE.
3. Replaceable text string must not have a start point that touches any other drawing 

element

AutoCAD 
Information - 
Intermediate 
Drawings

Intermediate drawings are created from Master drawings, one for each slot with a 
card defined in the Traffic Cop and follows this format:

CCDDRS.DWG where:

CC= Controller Prefix (2 characters)

DD= Drop number (01-32)

R = Rack number (1-5)

S = Slot number (1-9, A, B)

In general, the replaceable text in the Master drawing will be modified to include the 
drop, rack, and slots (e.g., /D1-I01/ will become/D1-101-0123/ for Drop 0, Rack 2, 
Slot 3). Addresses are placed into the drawing at this time. The Intermediate 
drawings may be modified or combined, with the following restriction to the naming 
of drawings:

1. The first two characters of a name must be a controller prefix.
2. Names can not have more than seven characters.
3. Names must not have an F as the last character. This is because the Final 

drawings will use the same name appended with an F.

I /RANGE/ The range of addresses used in the card

I /RANGE2/ The 2nd range of addresses for bidirectional card

I /MASTDRAW/ The name of the Master Drawing

I /INTERDRAW/ The name of the Intermediate Drawing

F /FINALDRAW/ The name of the Final Drawing

I /LABEL-AA/

I /LABEL-N/ Neutral wire label

I /LABEL-X/ Hot wire label
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Using the LABEL 
Field

The LABEL replaceable text field is used for a labeling individual wires on an I/O 
drawing. There are three types of labels:

signal
hot
neutral

LABEL fields, like others used by ProWORX 32, are put into the Master drawings on 
the REPLACE layer.

Labels can be entered as:

The LABEL field for a signal wire produces a wire label in the following format.
MMDDRSSPPMM is the machine designation.
DD is the drop.
R is the rack.
SS is the slot.
PP is the I/O card point.
/LABEL-25/ in a drawing for a controller with a machine ID of AC with the I/O card 
in drop 21, rack 3, slot 7 appears in the final drawing as AC2130725.

The LABEL field for a hot or neutral wire produces a wire label in the following 
format.

MMWDDRSSMM is the machine designation.
W is the wire type (N for neutral, X for Hot).
DD is the drop.
R is the rack.
SS is the slot.
/LABEL-N/ in a drawing for a controller with a machine ID of AC with the I/O card 
in drop 21, rack 3, slot 7 appears in the final drawing as ACN21307.

Signal Wire /LABEL-AA/
where AA is a 2-digit number for the point on the card

Hot Wire /LABEL-X/

Neutral Wire /LABEL-N/
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address 1) On a communications network, the identifying number for a station such as a 
PLC.
2) In a computer’s or PLC’s memory, a location where data, usually a specific input 
or output value is stored.

address used 
table

A list of all I/O addresses in a controller, indicating which addresses are being used 
in ladder logic instructions and which are not.

analog Inputs (such as temperature) or outputs (such as motor speed) which can have a 
range of values. Compare with discrete.

ASCII American Standard Code for Information Interchange.
1) A way of encoding the standard text (the letters, numbers, etc. on your keyboard) 
your computer generates.
2) A data transmission mode for Modbus communications which sends and receives 
standard text. ASCII mode used 7 data bits while RTU mode uses 8.

ASCII message A text message transmitted or received by a programmable controller. These 
messages are sent to or from a terminal through an ASCII port.

assembly 
register

A register that accepts keyboard input for command and value entry in the network 
editor.

attaching to Also called selecting. Connecting your PC to a programmable controller so 
ProWORX 32 can read its ladder logic, traffic cop information, and configuration, 
and write changes back to it.

baud rate For serial communications, the speed (in bits per second) at which data is 
transmitted.

BCD Binary coded decimal.
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binary The base-two numbering system. It has two symbols: 1 (representing ‘on’) and 0 
(‘off’)

bit The smallest amount of information in binary: either a 1 or a 0.

bits per second 
(BPS)

The number of bits passed from one device to another in one second. Used to 
measure data transmission speed.

block A section of ladder logic which is defined while using the logic editor. This block can 
be copied, deleted, saved, moved, and loaded.

BM85 See bridge multiplexer.

BP85 See bridge plus.

bridge 
multiplexer

Allows you to connect up to four Modbus devices or networks of Modbus devices to 
a Modbus Plus network. Nodes on the Modbus Plus network can access slave 
devices connected to the BM85 Modbus ports.

bridge plus Links together two Modbus Plus networks.

byte A group of eight bits. A byte stores a value from 0 to 255.

cell A single location in ladder logic.

channel In an S901 I/O subsystem, a group of 128 inputs and 128 outputs assigned to a 
segment. The ladder logic in the segment usually controls all I/O operations of the 
corresponding channel.

characters per 
inch (CPI)

The number of characters a printer prints in one inch. (Also called horizontal pitch.)

checksum A calculation that sums a range of data and compares it to a pre-calculated value. 
This determines if the data is in error or has changed.

coaxial cable A round cable containing two conductors, one inside the other (separated by a 
insulator). The inner conductor transmits a signal while the outer conductor is a 
shield.

commentary The descriptors, short comments, long comments, and page titles within a project.

condition The state or value of the control discrete or analog. If the condition of the control’s 
address is true, the loopback stores a new value or triggers a new state in a 
destination range of addresses.
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control address The instruction address in the logic that is checked for a condition while the logic is 
being emulated and loopback is enabled.

controller An industrial control computer, also called a programmable logic controller or PLC.

CPS Characters per second.

cross-reference A list of the networks in which a particular address can be found.

current element The cell or ladder logic element being edited. The logic editor’s cursor is always on 
the current element.

current network The network being edited. The network displayed in the logic editor is always the 
current network.

cursor A bar or block which indicates a position on the screen. Generally, the cursor is 
located where something can be inserted or selected.

data bits The bits in a data package which carry a message, distinct from start bits, stop bits, 
and parity bits. Remote Terminal Unit mode (the Modbus default communication 
mode) sends eight data bits per package. ASCII mode sends seven data bits per 
package.

data contents A printout showing the data values in a ladder logic program.

data register A 4xxxx holding/output register.

data value The new state or value to be placed in a destination address range when the 
loopback control condition is true.

DCP drop ID# A distributed control processor drop address. It is equivalent to the drop number 
used by the DCP.

DCP-908 A distributed control processor providing intelligent bidirectional communication 
between a supervisory 984 controller and distributed 984 controllers.

decimal The base-ten number system. It consists of the symbols 0 through 9.

default A value automatically assigned by the computer in a software program. Usually, this 
value can be changed.

descriptor field One of up to nine text strings which are a short description of an address within a 
ladder logic program.
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descriptor 
record

All descriptors, short comments, the long comment number, and the page title for 
one address point.

descriptor table The table of addresses displayed on the screen in the descriptor module.

descriptor tables 
listing

A group of printouts which consist of tables of descriptors, a table of short 
comments, long comments, and mismatch tables.

descriptors A short description of an address within a ladder logic program. A number of 
descriptor fields.

destination The range of addresses to be driven when the loopback control condition is true.

device Any programmable unit (such as a PLC, numeric controller, or robot) or I/O card.

dim awareness The state of a PLC that contains no logic, configuration, or traffic cop information.

directory A group of files and/or subdirectories. A directory called the root directory is placed 
on each disk when it is formatted. Subdirectories can be created within the root 
directory and within other subdirectories. Files can be stored in a subdirectory or the 
root directory. In Windows, directories are often called folders.

disable To stop the programmable controller’s logic-solving mechanism from updating the 
state of a coil or updating the state of a discrete input. Also see force.

discrete Inputs (such as switches) or outputs (such as coils) that can only be on or off. 
Discrete inputs are usually held in 1xxxx registers. Compare with analog.

display A visual output device such as a monitor.

distributed I/O 
(DIO)

One of four major architectures for input/output systems (also see local I/O, remote 
I/O, and peer-to-peer communications). I/O that is installed away from the PLC 
over a wide area and communicates with it through a Modbus Plus network. One 
Quantum controller can support up to three distributed I/O networks, each with up to 
64 drops. The local rack houses a DIO processor for each network, which sets the 
network’s head number.

documentation A description of a controller’s memory, logic, and configuration. The descriptors, 
short comments, long comments, and page titles within a database.

documentation 
editor

The editor in which descriptors, short comments, long comments, and page titles 
can be entered and modified.

double 
[precision

A 32-bit format which uses two registers to store numerical values.
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drop A group of I/O cards physically connected together as an I/O network. A controller 
reads information from the drop, solves logic, then writes results to the drop in one 
segment of ladder logic. The Segment Scheduler controls the order in which drops 
are serviced.

duplicate coil An output coil address which has been assigned to more than one coil.

EEPROM Electrically erasable programmable read-only memory.

element A ladder logic instruction such as a coil, timer, or short.

enable To allow a PLC, based on the logic programmed into it, to update the state of a coil 
or input.

equation 
network

A special section of logic that lets the programmer solve regular mathematical 
equations within the network. Not supported by every controller.

exponential 
notation

A format for numbers based on powers of 10. For example, +1.35E-4 indicates 1.35 
multiplied by 10 to the power of -4 (i.e. with an exponent of -4), which works out to 
0.000135.

extended 
memory

Extra register memory available for some models of 984/584 controllers. It is 
accessed through the XMRD and XMWT functions.

extension The three letters after the period in a DOS file name, often used to indicate the file’s 
purpose.

file A collection of information stored on a disk. It can contain either a program or data.

file name The name of a file. ProWORX 32 uses DOS naming conventions: a file name can 
have up to eight characters, followed by a period and a three character extension.

force To change the state of a coil or a discrete input, overriding any actions in ladder 
logic. For example, if a coil is forced off, but the ladder logic is trying to turn it on, it 
will remain off.

function A ProWORX 32 command or operation.

global address 
change

An operation in the logic editor, which substitutes one address or a range of 
addresses for another or several others.
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head A collection of I/O drops tied to one CPU, DIO, or RIO processor. This term is 
specific to Modicon’s Quantum hardware.

hexadecimal A base 16 representation of an integer. It uses the symbols 0 through 9 and letters 
A through F.

I/O Input/output.

I/O configurator A PLC internal operation that maps logic element addresses to physical I/O cards. 
Also known as the traffic cop.

instruction One of the programmable controller’s instruction set.

ladder logic A relay-based programming language typically used in programmable logic 
controllers. So called because it looks vaguely like a ladder.

ladder logic 
documentation

Text information, notes, and other descriptions of the ladder logic.

ladder logic 
listing

A printout of a group of networks which make up a ladder logic program.

latch A coil, the state of which is backed up in memory.

lines per page The number of lines printed on a page when printing ladder logic listings.

load To retrieve data from a disk or other source.

loader A module that reads and writes ladder logic from a personal computer to a 
programmable controller or an industrial programming terminal. It also starts and 
stops a programmable controller from a personal computer.

local I/O One of four major architectures for input/output systems (also see distributed I/O, 
remote I/O, and peer-to-peer communications). The PLC and I/O modules 
communicate directly through wiring from the field. For Quantum controllers, local 
I/O allows a CPU, power supply, and from one through 14 I/O modules in a single 
backplane (up to 448 I/O points). Local I/O is limited to a single rack and is always 
head number 0. RIO and DIO processors are added in the local rack to extend the 
controller’s I/O system.

logic editor The editor in which you edit ladder logic.
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long comment A block of text which comment on an address within a ladder logic program. These 
are printed between the networks in the ladder listing.

LPI Lines per inch.

machine word 16 bits of data (two bytes). Also called a word.

macro Generic pieces of logic networks that can be inserted into main logic databases. See 
also macro parameter.

macro parameter A placeholder variable used in a macro. When inserted into a regular logic database, 
each macro parameter is mapped to a real register address.

master A networked device which controls the devices it connects to. Compare to slave.

memory The part of a computer or programmable controller which stores information for 
manipulation.

mismatch tables Two printouts which show the differences between two sets of data; for example, 
between descriptor records that have been entered for PLC addresses and 
addresses that have actually been used in a program.

mnemonic
(ne-mon-ik)

1) A memory aid.
2) A computer instruction with an abbreviated name that indicates its function. For 
example, BLKM is used for the block move instruction.

mnemonic 
assignments

A table in the configuration menu that lists the configuration of function key levels, 
prompts, and instruction mnemonics.

Modbus Modicon’s RS-232C master-slave serial communications protocol.

Modbus Plus Modicon’s high-speed, peer-to-peer, token-ring communications protocol.

modem Modulator/demodulator. A communications device that allows a computer to 
transmit information, usually over a standard telephone line.

module An input/output card.

motion control 
I/O drop

Usually, an I/O drop tied to an ICC410, 3220, or 3240 motion control system.
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network 1) A unit of ladder logic in a matrix of elements that is 11 columns wide and seven 
rows long. It is used to group a function’s ladder logic.
2) A chain of interconnected computers and/or programmable controllers which 
share data.

network 
comment

A descriptor record assigned to a network. Contains short comments, a long 
comment, a page title and descriptors.

network listing A printout of a group of networks of ladder logic which make up a program.

network logic A programmable controller control program or the representation of a programmable 
controller control program. It includes logic elements, networks, and register 
contents.

node A device that is connected to a network and is capable of communicating with other 
network devices, usually to send or receive I/O data.

not described 
mismatch table

A printout of those programmable controller addresses in a ladder logic program 
which do not have descriptor records.

offline When the computer is not connected to the programmable controller and works 
instead from a database.

online When the computer is connected to a programmable controller, working with it 
directly and in real time.

operator In mathematics (and in equation networks), a symbol or character that indicates a 
specific operation to be performed on one or more elements, called operands. In 
"3 + Y", the plus sign (+) is an operator that indicates addition between the two 
operands, "3" and "Y".

order of solve 1) The order in which segments are solved, as ordered by the segment scheduler.
2) The order in which elements are solved in a network.

page title A line of text which describes a page or group of pages in a ladder logic listing. 
Printed at the top of the page.

path The part of a file specification that indicates the drive and subdirectory the file is in.

PC Personal computer
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peer-to-peer One of four major architectures for input/output systems (also see distributed I/O, 
local I/O, and remote I/O). A protocol for networked devices in which any device 
can initiate data transfer.

power flow In logic, an instruction is highlighted if it solves true and passes power. All 
instructions upstream of it (to its left in the traffic cop display) must also be passing 
power.

preset The maximum value a timer or counter can have.

processor A programmable logic controller.

program For PLC’s, a set of ladder logic instructions contained in a set of ProWORX 32 files 
(a project).

programmable 
logic controller 
(PLC)

An industrial control computer, also known simply as a controller.

project A group of files sharing a common name (but different file extensions) where the 
ladder logic program and descriptor data for a controller is stored.

ProWORX 32 
function

A ProWORX 32 command or operation.

quick print A function that allows you to print a network to a printer, with or without 
documentation.

rack A collection of up to 16 I/O modules mounted in one back plane.

radix The base system of a value. The radix of decimal numbers is 10, the radix of binary 
numbers is 2 and the radix of hexadecimal numbers is 16. In ProWORX 32, the term 
radix sometimes refers to a value’s data type: binary, integer, floating point and so 
on.

random access 
memory (RAM)

Memory that holds programs while they are being executed.

read only 
memory (ROM)

Memory that is not erased by a power failure and that is programmed at the factory 
to hold vital information. This memory cannot be changed.
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remote I/O (RIO) One of four major architectures for input/output systems (also see distributed I/O, 
local I/O, and peer-to-peer communications). I/O that is installed away from the 
PLC and communicates with it though a high-performance, S908 coaxial cable 
network. For Quantum controllers, an interface device at each remote I/O drop 
communicates with an RIO processor in the PLC. The interface device sets the 
address of the drop. Each RIO processor supports up to 31 remote drops, each of 
which allows 64 input words and 64 output words.

remote terminal 
unit (RTU)

A data transmission mode used for Modbus communications. RTU uses 8 data bits.

reports listing A group of printouts which consist of hardware allocation, data usage, and data 
contents for a ladder logic program.

routing path The sequence of devices through which a message passes to reach its final 
destination.

RS-232 A popular standard for a serial data link connection.

run light A light on the front panel of a controller that is on while the controller is running.

save To store information on a disk.

scan delay You may not want the loopback function to immediately update the destination when 
a condition becomes true. By setting scan delay, you can set the number of scans 
for which the condition must remain true before the destination is updated.

search To locate a specified network element (or elements) in the ladder logic.

segment A group of I/O networks solved as a unit by the programmable controller. The 
Segment Scheduler controls the frequency of segment execution and order of I/O 
operations. Each segment controls two I/O channels in a 584 or 984/S901 
configuration, or one drop in a 984/S908 configuration.

serial port A 9- or 25- pin port used for serial communications (for example, Modbus).

short comment Up to four lines of text which comprise a comment about an address within a PLC 
ladder logic program. Typically printed beside output instructions in the ladder 
listing.

short comment 
field

One of up to four lines of text which comprise a comment about an address within a 
PLC network logic program. Typically printed beside output instructions, or below 
the network in the network listing.
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slave A networked device controlled by another device. Slave devices to not initiate data 
transactions. Compare with master.

slot The position of an I/O module in a rack.

state flow In logic, an instruction is highlighted if it solves true instead of only when it passes 
power (compare with power flow).

stop bits Bits used to indicate the end of transmission of a data item or frame.

subdirectory A directory within a directory.

sweep For a PLC, one cycle of scanning inputs, solving logic, and writing outputs.

TCP/IP A communication protocol for computers connected through an Ethernet or token 
ring network.

text A collection of ASCII characters.

timeout If communications fail, the program waits the specified number of seconds before 
trying to communicate again.

trace An operation in the network editor that locates a specified output coil in the network 
logic.

traffic cop A programmable controller’s internal configuration that maps logic element 
addresses to physical I/O cards.

used table A list of all I/O addresses in a controller, indicating which addresses are being used 
in instructions and which have not.

utility A computer program included in a software package, but run separately from the 
package’s main program.

word 16 bits of data (two bytes). Also called a machine word.
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Symbols
.CGF files

creating with codegen, 269
creating without codegen, 270

.csv, 67

.dbf, 67

.dif, 67
editing with MS Excel, 355

.doc, 67

.fil, 67

.fis, 67

.LOG file
recording data in data watch window, 
218
viewing in data watch window, 218

.mdb, 67

.tef, 67

.txt, 67

.xls, 67

Numerics
10-bit Modbus configurations, 84
38x/48x fuse, replacing

troubleshooting, 326
3x or 4x register

entering in mathematical equation, 183
61 hex (97 decimal)

machine configuration, 344
65 hex (101 decimal)

S901 controller, 338
S908 controller, 338
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66 hex (102 decimal)
hot standby status, 342

67 hex (103 decimal)
S908, S901 controllers, 339

68 hex (104 decimal)
S901/J200 status, 351

68x/78x fuse, replacing
troubleshooting, 326

69 hex (105 decimal), S901
stopcode, 353

69 hex (105 decimal), S908
stopcode, 353

6A hex (106 decimal)
number of segments, 347

6B hex (107 decimal)
end of logic pointer, 340

6C hex (108 decimal)
remote I/O time out, 349

6D hex (109 decimal), 333
6E hex (110 decimal)

run/load/debug status, 350
800 series

I/O cards, 308
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A
A120 series

I/O cards, 311
ABS, 190
activity log

server, 291
activity tab

server, activity log, 291
server, current status, 291

adding a control to the grid
I/O card script editor, 300

adding cell captions in HMI, 224
adding instruction solve support

in emulation mode, 58
adding instructions to networks

in logic editor, 163
adding macro projects to logic, 252
adding missing slot

traffic cop, 203
adding toolbars, 29
adding values to monitor in HMI, 224
address, 365

symbolic, 64
address used tables, 75

direct to online, 75
printing, 282

addresses
clearing in data watch window, 211
copying data values in data watch 
window, 213
deleting in data watch window, 212
disabling and forcing discretes, 166
displaying extended memory 
addresses, 237
editing in logic editor, 165
filling ranges with data values in data 
watch window, 214
finding in logic editor, 165
global replace, 274
jumping to, in data watch window, 213
loading in data watch window, 212
moving data values in data watch 
window, 213
multiple, setting radix in data watch 
378
window, 212
searching for data values in data watch 
window, 214
tracking in data watch window, 211
tracking in logic editor, 166
tracking logic in data watch window, 228

traffic cop, tracking in data watch 
window, 229
using from documentation editor, 166

adjusting scan time
emulation mode, 54

alarm values
setting, 226

algebraic expression
equation network, 180

analyzing device, 120
ARCCOS, 190
ARCSIN, 190
ARCTAN, 190
argument

equation network, 190
limits, 191

arithmetic operator, 185
ASCII

simple ports, 97
ASCII editor

configuring messages, 245
editor/preview window, 246
message list, 246
opening, 246
tools for editing, 247

AS-I device list
traffic cop, 201

assignment operator, 185
associating pictures in HMI, 223
audit trail

server, 293
authorization

moving, 21
wizard, 20

auto configure 
(Momentum/Compact only), 199
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AutoCAD
intermediate drawings, 363
master drawings, 362

B
backup/compare

server, manual, 287
server, scheduled, 287

baud, 365
bit/error reference, 329
bitmap files

discrete type address, 222
register type address, 222

bitwise operator, 185
BM85

communicating, 258
configuring, 256
configuring Modbus ports, 257
opening configuration utility, 256
working with routing paths, 258

bookmarks, 175
boolean, 182
BootP utility

automatically checking IP 
addresses, 260
listening, 259
opening, 259
using device list, 260

breakpoint
solving logic, 56

breakpoints
setting in emulation mode, 56

bridge, 87
bridge multiplexer

configuring, 256
building I/O drawings, 359
bypassing server

logging in, 16
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C
cable A errors, 334
cable B errors, 335
cables, recommended

traffic cop, 207
captions

adding cell, in HMI, 224
card config words

editing, 301
cell, 366
cell captions

adding in HMI, 224
cell data

editing in HMI, 222
cell size

setting in HMI, 221
checking word value

PLC status viewer, 118
checkout, undo

plant layout, 292
server, 292

clamps
setting in data watch window, 220

codegen
creating .CGF files, 269
opening database, 268
running from command line, 270

coil
equation network, 179
error messages, 179

color
setting background color in HMI, 221

combined mode
projects, 51

communicating with a BM85, 258
communication faults, 325
communication status

status words, 336
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communications
editing parameters, 80
Ethernet, 87
Modbus, 81
Modbus by modem, 82
Modbus Plus, 86
setting default communications type, 80
setting server port, 284
setup, 80
TCP/IP, 88
using the server, 80

compact phase II
configuration extensions, 124

Compact TSX series
I/O cards, 313

compare utility
opening, 262
using the compare report, 263

compare/backup
server, manual, 287
server, scheduled, 287

conditional expression
equation network, 187

conditional operator, 185
configuration

smart, 103
configuration examples

server, 286
configuration extensions

editing, 122, 124
editing data protect, 125
I/O scanner for Quantum controllers/
NOE cards, 128
I/O scanner wizard, 134
peer cop, 136
peer cop wizard, 140
Profibus, 143
Quantum hot standby, 126
Quantum security, 149
Quantum VME bus, 148
S980, 145
SY/MAX, 146
TCP/IP, 147
utility, 123

configuration tables
printing, 281
380
configuration, machine
word 61 hex (97 decimal), 344

configuring a BM85, 256
configuring a BM85's Modbus ports, 257
configuring controllers, 92

ASCII ports, 98
general tab parameters, 94
loadables, 99
Micro ports, 98
ports tab, 97
simple ASCII ports, 97

configuring hardware clock, 176
configuring instructions

in logic editor, 164
constant data

floating point, 183
long (32-bit), 183
LSB (least signifcant byte), 183
mathematical equation, 183

constant sweep, 173
control toolbar, 31
controller details, 44
controller faults, 325
controller, S901

status words, 338
controller, S908

status words, 338
controllers

comparing logic and configuration, 262
configuring, 92
configuring in DIM awareness, 93
initializing logic, 106
partial reading from, 107
partial writing to, 110
reading from, 107
start/stop, 117
status, 118
troubleshooting, 326
writing to, 109

controllers, S901 & S908
module health, 345

controls
script editor, 302

converting a ladder logic database, 45
copying data values of addresses

in data watch window, 213
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copying documentation, 271
COS, 190
COSD, 190
creating a new project, 42
creating display scripts

in instruction/terminal block editor, 231
creating equation network, 178
creating macro projects, 250
customer support, 24
customizing page format, 279
customizing toolbars, 29
cut/copy/paste

traffic cop, 197

D
data, 367

mathematical equation, 182
data protect

configuration extensions, 125
data values

emulation mode, 53
Data Watch Window

Clamps, 220
data watch window

clamps, 220
clearing addresses, 211
copying data values of addresses, 213
deleting addresses, 212
drum summary, 241
filling address range with data 
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values, 214
HMI, 221
importing/exporting, 243
instruction/terminal block editor, 230
jumping to addresses, 213
loading addresses, 212
log files, 217
M1 Ethernet controllers, 133
moving data values of addresses, 213
multiple addresses, setting radix, 212
PID blocks, 238
recording data to .LOG file, 218
register editor, 237
sample rate, 216
searching for data values, 214
tracking addresses, 166, 211
tracking logic editor addresses, 228
tracking traffic cop addresses, 229
trend, 225
triggers, 219
viewing .LOG file, 218

debug/load/run status
word 6E hex (110 decimal), 350

default address data values
emulation mode, 53

default parameter data editor, 298
deleting addresses

in data watch window, 212
deleting bookmarks, 175
deleting documentation, 273
deleting I/O cards, 297
deleting instructions

in logic editor, 163
deleting macro projects from logic, 252
deleting networks in logic editor, 161
deleting projects from the server, 292
descriptor ranges

printing, 280
descriptors

global replace, 274
device list

in BootP utility, 260
device status, 266
diagnostic tools, 266
diagnostic trace, 171
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DIM awareness
configuring controllers, 93

direct to online mode, 50
address used tables, 75

disabling and forcing discretes
in logic editor, 166

discrete reference
mathematical equation, 182

discrete states
global replace, 274

discrete type address
creating bitmap files, 222

display script
prefixes, 233

display scripts
creating, in instruction/terminal block 
editor, 231
naming, in instruction/terminal block 
editor, 231
scAddBitDisplay, 234
scAddBitEditValue, 235
scAddBitInfo, 234
scAddEquation, 235
scAddErrorField, 235
scAddErrorFieldText, 236
scAddGrid, 233
scAddPages, 236
scAddPickList, 236
scAddStaticText, 236
scAddToList, 236
scGetData, 234
scGetText, 234
scSetRowInfo, 233
variables, 232

displaying instructions
in logic editor, 163

documentation
global replace, 274
search, 71
382
documentation editor
adding symbols, 64
edit mode, 62
properties, 61
single-line mode, 63
summary mode, 63
symbol filter, 63
traffic cop mode, 63
using addresses, 166

documentation export, 66
documentation import, 66
documentation search results, 74
documentation tables

printing, 280
documentation utilities

copy, 271
delete, 273
move, 272

documents tab
in navigation panel, 38

drawing generator
I/O, 204

drawing viewer
opening, 264
using, 264

drawings
final, 204, 360
intermediate, 204, 360, 363
label field, 364
master, 204, 362
symbol, 204
symbols, 361

drops
traffic cop, 196

drum instruction, 241
drum summary

editing data, 242
editing instruction, 242
selecting a step, 241

DWW log toolbar, 31
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E
edit mode

documentation editor, 62
editing .dif files with MS Excel, 355
editing addresses

in logic editor, 165
editing card config words, 301
editing cell data in HMI, 222
editing configuration extensions, 122
editing data protect extensions, 125
editing drum summary data, 242
editing global input

peer cop extension, 137
editing global output

peer cop extension, 138
editing I/O scanner extension, 128
editing macros, 250
editing opcodes, 102
editing peer cop extension, 136
editing PID data, 239
editing Profibus extension, 143
editing Quantum hot standby 
extensions, 126
editing Quantum security extension, 149
editing Quantum VME bus extension, 148
editing S980 extension, 145
editing specific input

peer cop extension, 139
editing specific output

peer cop extension, 139
editing SY/MAX extension, 146
editing TCP/IP extension, 147
editor/preview window

ASCII editor, 246
EEPROM, 112, 369
EIA921-00

AS-I device list, traffic cop, 201
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emulation mode
adding instruction solve support, 58
adjusting scan time, 54
instructions supported, 57
projects, 51, 53
setting breakpoints, 56
setting default address data values, 53
setting instructions with loopback, 54
setting properties, 53
setting the solve mode, 55
starting, 55
stopping, 56

enable contact
horizontal open, 179
horizontal short, 179
normally closed, 179
normally open, 179

end of logic pointer
6B hex (107 decimal), 340

environment
setting properties, 26
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equation network
ABS, 190
algebraic expression, 180
ARCCOS, 190
ARCSIN, 190
ARCTAN, 190
argument, 190
argument limits, 191
arithmetic operator, 185
assignment operator, 185
bitwise operator, 185
conditional expression, 187
conditional operator, 185
content, 180
COS, 190
COSD, 190
creating, 178
enable contact, 179
entering function, 190
entering parentheses, 189
EXP, 190
exponentiation operator, 185
FIX, 190
FLOAT, 190
LN, 190
LOG, 190
mathematical, 181
mathematical function, 190
mathematical operation, 185
nested parentheses, 189
operator precedence, 188
output coil, 179
parentheses, 185, 188
relational operator, 185
result, 180
SIN, 190
SIND, 190
single expression, 187
size, 180
SQRT, 190
TAN, 190
TAND, 190
unary operator, 185
words consumed, 180

error/bit reference, 329
384
Ethernet
setting gateway parameters, 87

event editor dialog, 301
Exec Loader, 113
EXP, 190
exponential notation

mathematical equation, 184
exponentiation operator, 185
export

traffic cop, 198
exporting

data watch window data, 244
exporting documentation, 66
exporting I/O cards, 297
expression

equation network, 187
extended memory addresses

displaying, 237

F
faults, 325
file, 369
files

bitmap, discrete type address, 222
bitmap, register type address, 222
log files in data watch window, 217

filling address range with data values
in data watch window, 214

final drawings, 204, 360
find/replace (advanced search), 70
find/replace (simple search), 69
finding addresses

in logic editor, 165
mark button, 71
stay button, 71
step search, 71

finding instructions
in logic editor, 163

fit to screen
logic editor, 161

FIX, 190
flash RAM, 114
FLOAT, 190
floating point variable, 182
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folder
setting project, 285

forced/disabled discretes
global replace, 274

forcing and disabling discretes
in logic editor, 166

function
ABS, 190
ARCCOS, 190
ARCSIN, 190
ARCTAN, 190
argument, 190
argument limits, 191
COS, 190
COSD, 190
entering in equation network, 190
EXP, 190
FIX, 190
FLOAT, 190
LN, 190
LOG, 190
SIN, 190
SIND, 190
SQRT, 190
TAN, 190
TAND, 190

G
general tab parameters, 94
global, 369
global errors

status words, 341
global input/output

peer cop extension, 137
global replace, 274
goto, 71
graph functionality, 227
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H
hardware

requirements, 14
hardware clock, 176
head, 370
help, 24

ladder logic instructions, 163
HMI

adding cell captions, 224
adding values to monitor, 224
associating pictures, 223
creating bitmap files, discrete type 
address, 222
creating bitmap files, register type 
address, 222
data watch window, 221
editing cell data, 222
setting background color, 221
setting cell size, 221

horizontal open
equation network, 179

horizontal short
equation network, 179

hot standby
status words, 342

hotkeys
changing the template, 155
instructions help, 163
Modsoft, 156
ProWORX 32, 155
ProWORX 32 logic editor specific, 156
ProWORX NxT, 158
ProWORX PLUS, 157

I
I/O

drops, 196
opening the drawing viewer, 264
racks, 197
slots, 200
using the drawing viewer, 264

I/O card
viewing in terminal block editor, 230
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I/O card script editor
adding a control to the grid, 300
controls, 302
editing card config words, 301
using event editor dialog, 301

I/O cards
800 series, 308
A120 series, 311
adding, 296
Compact TSX series, 313
deleting, 297
editing parameters, 296
exporting, 297
importing, 297
Micro series, 315
Momentum M1 and INTERBUS 
series, 316
parameters, 299
Quantum, 317
script editor, 300
SY/MAX series, 320

I/O drawing generator, 204
building and modifying, 359
final drawings, 360
intermediate drawings, 360, 363
label field, 364
master drawings, AutoCAD, 362
symbols in drawings, 361

I/O scan search results, 73
I/O scanner extension

editing, 128
M1 Ethernet controller, 133
wizard, 134

import
traffic cop, 198

importing
data watch window data, 243

importing documentation, 66
importing I/O cards, 297
infix notation

equation network, 178
initializing controller logic, 106
initializing logic in logic editor, 162
initializing traffic cop, 195
input/output faults, 325
inserting macros in logic editor, 252
386
inserting networks in logic editor, 161

installing
MDac, 15
modifying/repairing previous 
installation, 15
ProWORX 32, 15

instruction
solving logic, 55

instruction editor, 230, 231
instruction toolbar, 31
instructions

adding in logic editor, 163
configuring in logic editor, 164
deleting in logic editor, 163
displaying in logic editor, 163
finding in logic editor, 163
moving in logic editor, 163
properties, 164
supported in emulation mode, 57

instructions help
hotkey, 163

INTERBUS, Momentum M1 series
I/O cards, 316

intermediate drawings, 204, 360
AutoCAD, 363

internal flash, 116
invalid commands, 325
IP address

pinging, 265
IP addresses

automatically check in BootP utility, 260
ISA symbols

attaching to discrete device, 169
isolating faults, 325
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J
jumping to addresses

in data watch window, 213

K
knowledge base, 77

adding records, 78
deleting records, 78
keywords, 77
printing, 78

L
label field

drawings, 364
ladder, 370
ladder logic

import into ProWORX 32, 45
initializing in a controller, 106
instructions, 163
networks, 161

ladder logic instructions
help, 163

LED indicator
Modbus Plus, 328

LN, 190
load/run/debug status

word 6E hex (110 decimal), 350
loadable

PRWX MSL, 160
loadables

copying, 100
deleting, 100
editing opcodes, 102
library wizard, 101
updating, 99

loading addresses
in data watch window, 212

local drop communication errors
status words 182-184, 343

LOG, 190
log files

setting in data watch window, 217
31003882 12/2006
logging in
as a non-administrator, 16
bypassing server, 16
with Modbus Plus, 18
with TCP/IP, 17

logging in to the server, 284
logging out, 19
logging out of the server, 284
logging word data

PLC status viewer, 118
logic

initializing in a controller, 106
solving by breakpoint, 56
solving by instruction, 55
solving by network, 55
solving by sweep, 55
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logic editor, 152
adding instructions, 163
adding symbols, 65
analyzing diagnostic trace, 172
attaching ISA symbols, 169
configuring instructions, 164
customizing display, 153
deleting bookmarks, 175
deleting instructions, 163
deleting networks, 161
disabling and forcing discretes, 166
display properties, 153
displaying instructions, 163
editing addresses, 165
equation network, 178
finding addresses, 165
finding instructions, 163
fit to screen, 161
hardware clock, 176
initializing logic, 162
inserting macros, 252
inserting networks, 161
moving instructions, 163
moving networks, 161
opening, 159
PRWX MSL loadable, 160
segment scheduler, 177
setting bookmarks, 175
sweep, 173
tracking addresses, 166
tracking addresses in data watch 
window, 228
undo/redo, 159
using diagnostic trace, 171
zoom in, 161
zoom out, 161

logic search results, 73
loopback

emulation mode, 54
LSB (least significant byte)

constant data, 183

M
M1 Ethernet controller

I/O scanner extension, 133
388
M1 Ethernet controllers
data watch window, 133

machine, 371
machine configuration

word 61 hex (97 decimal), 344
macros

creating projects, 250
editing, 250
parameters, 251
removing from logic, 252
unlinking from projects, 253
using in logic, 252

maintaining records of fixes, 77
managing projects, 47
manual backup/compare, 287
mark button

finding addresses, 71
master drawings, 204

AutoCAD, 362
materials list

traffic cop, 206
mathematical equation

constant data, 183
exponential notation, 184
values and data types, 181

mathematical function
ABS, 190
ARCCOS, 190
ARCSIN, 190
ARCTAN, 190
argument, 190
argument limits, 191
COS, 190
COSD, 190
entering in equation network, 190
equation network, 190
EXP, 190
FIX, 190
FLOAT, 190
LN, 190
LOG, 190
SIN, 190
SIND, 190
SQRT, 190
TAN, 190
TAND, 190
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mathematical operation
arithmetic operator, 185
assignment operator, 185
bitwise operator, 185
conditional operator, 185
equation network, 185
exponentiation operator, 185
parentheses, 185
relational operator, 185
unary operator, 185

MBP stat, 266
MCS simple 2 editor, 298
MDac

installing, 15
memory

displaying extended memory 
addresses, 237

message central, 28, 40
setting properties, 40

message list
ASCII editor, 246

Micro
flash RAM, 114

Micro series
I/O cards, 315

mismatch tables
printing, 282

mnemonics, 167
Modbus

10-bit configurations, 84
communications, 81
setting modem parameters, 83
setting parameters, 81

Modbus Plus
communications, 86
Concept exec loader, 
communications, 328
LED indicator, 328
setting parameters, 86

Modbus ports, 97
configuring a BM85, 257

Modbus to Ethernet bridge, 87
ModConnect

Schneider alliances, 296
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modem
communications, 82
types, 84

modifying I/O drawings, 359
modifying installation, 15
Modsoft

hotkeys, 156
module health

S901, S908 controllers, 345
module menu

traffic cop, 198
Momentum M1, INTERBUS series

I/O cards, 316
monitor mode, 27
moving authorization, 21
moving data values of addresses

in data watch window, 213
moving documentation, 272
moving instructions

in logic editor, 163
moving networks in logic editor, 161
moving toolbars, 29
multi radix view

changing the view (single vs. multi), 216
multiple addresses

setting radix in data watch window, 212
my computer tab

in navigation panel, 35

N
naming display scripts

in instruction/terminal block editor, 231
navigating traffic cop, 194
navigation panel

documents, 34
my computer, 34
my projects, 34
plant, 34
utilities, 34

nested parentheses
equation network, 189

NetScan network explorer, 89
network, 372

solving logic, 55
network explorer, 89
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networks
adding instructions, 163
configuring instructions, 164
deleting instructions, 163
deleting, in logic editor, 161
displaying instructions, 163
finding instructions, 163
initialzing logic, in logic editor, 162
inserting, in logic editor, 161
moving instructions, 163
moving, in logic editor, 161
printing, 280

NOE cards (in Quantum controllers)
I/O scanner, 128

non-administrator account
logging in, 16

normally closed contact
equation network, 179

normally open contact
equation network, 179

number of segments
word 6A hex (106 decimal), 347

O
offline, 372
offline mode

projects, 49
online control toolbar, 31
online mode

projects, 49
online module status

traffic cop, 203
opcodes

editing, 102
opening a codegen database, 268
operator precedence

equation network, 188
output coil

equation network, 179
output/input faults, 325
390
P
P930/P933 fuse, replacing

troubleshooting, 327
page, 372
page format

customizing, 279
parameters

macros, 251
parentheses

entering in equation network, 189
nested, 189
using in equation network, 188

partial reading from a controller, 107
partial writing to a controller, 110
paste/cut/copy

traffic cop, 197
PCMCIA, 116
peer cop extension

editing, 136
global input/output, 137

peer cop search results, 73
peer cop wizard, 140

PID blocks, 238
adjusting setpoint values, 239
editing data, 239
jumping to currently selected PID 
block, 239
setting contact, 240
trending data, 240

pinging, 265
pinging IP addresses

in BootP utility, 260
plant layout

feature descriptions, 36
undo checkout, 292

plant tab
in navigation panel, 36

PLC status viewer, 118
pointer table

status words, 348
port

setting server port, 284
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ports
ASCII, 98
Micro, 98
simple ASCII, 97

power supplies, 321
power up failure

troubleshooting, 326
precedence

equation network, 188
presets

setting, Profibus extension, 144
previous installation

modify/repair, 15
Profibus extension

editing, 143
setting presets, 144

program mode, 27
project

comparing logic and configuration, 262
setting folder, 285

projects
combined mode, 51
configuration wizard, 42
controller details, 44
creating, 42
deleting from the server, 292
direct to online mode, 50
emulation mode, 51, 53
managing, 47
offline mode, 49
online mode, 49
property descriptions, 52
selecting a communications mode, 44
selecting a controller, 43
setting properties, 51
working with on the server, 286

projects tab
in navigation panel, 34

properties
documentation editor, 61
setting environment parameters, 26

property descriptions
projects, 52

protected registers
setting, 68
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ProWORX NxT
hotkeys, 158

ProWORX PLUS
hotkeys, 157

ProWORX server, 47
PRWX MSL loadable, 160

Q
Quantum

I/O cards, 317
Quantum controllers (with NOE cards)

I/O scanner, 128
Quantum Hot Standby extensions

editing, 126
Quantum security extension

editing, 149
Quantum VME bus extension

editing, 148
quick, 373
quick picks

reporting, 278

R
rack, 373
racks

traffic cop, 197
Radix

Single Radix View, 216
radix

changing the view (single vs. multi), 216
setting in data watch window, for multiple 
addresses, 212

reading from a controller, 107
partial, 107

recommended, cabling
traffic cop, 207

recording data to .LOG file
in data watch window, 218

redo/undo
in logic editor, 159
traffic cop, 197

redundant power supplies, 321
register

printing, 281
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register contents
global replace, 274

register editor
changing displayed address type, 237
displaying extended memory 
addresses, 237

register type address
creating bitmap files, 222

registers consumed
mathematical equation, 182

related documents
server, 292

relational operator, 185
remote I/O

time out, 349
removing macros projects from logic, 252
removing ProWORX 32, 15
removing toolbars, 29
repairing installation, 15
replacing 38x/48x fuse

troubleshooting, 326
replacing 68x/78x fuse

troubleshooting, 326
replacing P930/P933 fuse

troubleshooting, 327
reporting

address used tables, 282
configuration tables, 281
customizing page format, 279
descriptor ranges, 280
documentation tables, 280
mismatch tables, 282
networks, 280
printing menu, 278
quick picks, 278
register content ranges, 281
traffic cop, 281

requirements
hardware, 14
software, 14

resolution values
setting, 225

result
equation network, 180

rights, user
server, 290
392
routing paths
BM85, 258

run/load/debug status
word 6E hex (110 decimal), 350

S
S901

analyzing, 120
S901 controller

status words, 338
S901, S908

status words, 332
S901, S908 controllers

module health, 345
S901/J200 status

status words, 351
word 68 hex (104 decimal), 351

S908
analyzing, 120
errors, 352

S908 controller
status words, 338

S911
hot standby status, 342

S980 extension
editing, 145

sample rate
setting in data watch window, 216

save, 374
scAddBitDisplay, 234
scAddBitEditValue, 235
scAddBitInfo, 234
scAddEquation, 235
scAddErrorField, 235
scAddErrorFieldText, 236
scAddGrid, 233
scAddPages, 236
scAddPickList, 236
scAddStaticText, 236
scAddToList, 236
scan time

adjusting in emulation mode, 54
scGetData, 234
scGetText, 234
scheduled backup/compare, 287
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Schneider alliances, 296
I/O card script editor, 300
opening, 296

script editor
adding a control to the grid, 300
controls, 302
editing card config words, 301
properties, 300
Schneider alliances, 300
using event editor dialog, 301

scripts
instruction/terminal block editor, 231
variables, 232

scSetRowInfo, 233
search, 69

documentation search results, 74
I/O scan search results, 73
logic search results, 73
peer cop search results, 73
traffic cop search results, 73
using documentation, 71
using find/replace (advanced), 70
using find/replace (simple), 69
using goto, 71
using search results panel, 72

searching for data values
in data watch window, 214

security
settings, 22
user rights, 23

security extension
editing, 149

segment scheduler, 177
segments, number of

word 6A hex (106 decimal), 347
selecting a communications mode, 44
selecting a controller, 43
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server, 47
activity log, 291
adding/editing/removing groups, 289
adding/editing/removing users, 288
adding/removing users from groups, 289
audit trail, 293
configuration examples, 286
current status, 291
deleting projects, 292
logging on, 284
logging out, 284
manual backup/compare, 287
related documents, 292
scheduled backup/compare, 287
setting port, 284
setting project folder, 285
undo checkout, 292
user rights, 290
working with projects, 286

setpoint values
setting, 226

setting alarm values, 226
setting bookmarks, 175
setting breakpoints

emulation mode, 56
setting clamps

in data watch window, 220
setting default address data values

emulation mode, 53
setting emulation properties, 53
setting instructions with loopback

emulation mode, 54
setting log files

in data watch window, 217
setting PID contact, 240
setting presents

Profibus extension, 144
setting project properties, 51
setting properties for message central, 40
setting protected registers, 68
setting resolution values, 225
setting sample rate

in data watch window, 216
setting security, 22
setting setpoint values, 226
393



Index
setting the solve mode
emulation mode, 55

setting triggers
in data watch window, 219

setting Y-axis values, 225
signed 16-bit variable, 182
signed long (32-bit) variable, 182
SIN, 190
SIND, 190
single expression

equation network, 187
Single Radix View, setting, 216
single sweep, 174
single-line mode

documentation editor, 63
slot

adding missing, in traffic cop, 203
slots

traffic cop, 200
smart configuration, 103
software

requirements, 14
software programming blocks

PID, 238
solve mode

setting in emulation mode, 55
solving logic

by breakpoint, 56
by instruction, 55
by network, 55
by sweep, 55

specific input/output
peer cop extension, 138

SQRT, 190
standalone power supplies, 321
standard toolbar, 31
starting a controller, 117
starting emulation, 55
status

PLC, 118
394
status words
ASCII messages, 333
cable A errors, 334
cable B errors, 335
communication status, 336
global errors, 341
hot standby, 342
local drop communication errors, 343
pointer table, 348
S901 controller, 338
S901, S908, 332
S901/J200, 351
S908 controller, 338

stay button
finding addresses, 71

step search
finding addresses, 71

stopcode
S901 controller, word 69 hex (105 
decimal), 353
S908 controller, word 69 hex (105 
decimal), 353

stopcode error, 329
stopping a controller, 117
stopping emulation, 56
summable power supplies, 321
summary mode

documentation editor, 63
support, 24
sweep

performing constant sweep, 173
performing single sweep, 174
solving logic, 55

SY/MAX extension
editing, 146

SY/MAX series
I/O cards, 320

symbol drawings, 204
symbol filter

documentation editor, 63
symbolic addressing, 64
symbols, 64

adding in logic editor, 65
adding to documentation editor, 64
ISA, attaching to discrete device, 169

symbols in drawings, 361
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T
TAN, 190
TAND, 190
TCP, 375
TCP/IP

setting parameters, 88
TCP/IP extension

editing, 147
technical support, 24
terminal block editor, 230

display scripts, 231
time out

remote I/O, 349
toolbars

adding, 29
control, 31
customizing, 29
DWW log, 31
instruction, 31
moving, 29
online control, 31
removing, 29
standard, 31

tracking addresses
in logic editor, 166

tracking help, 28, 39
tracking logic addresses

in data watch window, 228
traffic cop

adding missing slot, 203
AS-I device list, 201
auto configure 
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(Momentum/Compact only), 199
cut/copy/paste, 197
drop properties, 196
export/import, 198
initializing, 195
materials list, 206
module menu, 198
navigating, 194
online module status, 203
opening, 194
printing, 281
racks, 197
recommended cables, 207
slot properties, 200
tracking addresses in data watch 
window, 229
undo/redo, 197
visual representation, 194

traffic cop mode
documentation editor, 63

traffic cop search results, 73
transferring memory

EEPROM, 112
Exec Loader, 113
flash RAM, 114
PCMCIA, 116

trend
graph functionality, 227
setting alarm values, 226
setting resolution values, 225
setting setpoint values, 226
setting Y-axis values, 225

trending PID data, 240
triggers

setting in data watch window, 219
Troubleshooting, 323
troubleshooting

controllers, 326
isolating faults, 325
Modbus Plus, 328
replacing 38x/48x fuse, 326
replacing 68x/78x fuse, 326
replacing P930/P933 fuse, 327
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U
unary operator, 185
undo checkout

plant layout, 292
server, 292

undo/redo
in logic editor, 159
traffic cop, 197

uninstalling ProWORX 32, 15
unlinking macros from projects, 253
unsigned 16-bit variable, 182
unsigned long (32-bit) variable, 182
used, 375
used tables

printing, 282
user rights, 23

server, 290
using addresses

in documentation editor, 166
utilities tab

in navigation panel, 35

V
values and data types

mathematical equation, 181
variable data

mathematical equation, 182
viewing .LOG file

in data watch window, 218
viewing I/O card

in terminal block editor, 230
viewing traffic cop, 194
VME bus extension

editing, 148

W
word, 375

maximum in an equation network, 180
word 61 hex (97 decimal)

machine configuration, 344
word 65 hex (101 decimal)

S901 controller, 338
S908 controller, 338
396
word 66 hex (102 decimal)
hot standby status, 342

word 67 hex (103 decimal)
S908, S901 controllers, 339

word 68 hex (104 decimal)
S901/J200 status, 351

word 69 hex (105 decimal), S901
stopcode, 353

word 69 hex (105 decimal), S908
stopcode, 353

word 6A hex (106 decimal)
number of segments, 347

word 6B hex (107 decimal)
end of logic pointer, 340

word 6C hex (108 decimal)
remote I/O time out, 349

word 6D hex (109 decimal), 333
word 6E hex (110 decimal)

run/load/debug status, 350
words consumed

constant data, 183
mathematical equation, 182

working with logged word data
PLC status viewer, 119

writing to a controller, 109
partial, 110

Y
Y-axis values

setting, 225

Z
zoom in

logic editor, 161
zoom out

logic editor, 161
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